source: projects/specs/trunk/n/nepomuk-core/nepomuk-core-vl.spec @ 6725

Revision 6725, 3.2 KB checked in by Takemikaduchi, 12 years ago (diff)

KDE-4.9.0

Line 
1Name:          nepomuk-core
2Summary:       Nepomuk core utilities and libraries
3Summary(ja):   Nepomuk core ユーティリティーとライブラリ
4Version:       4.9.0
5Release:       1%{?_dist_release}
6
7License:       GPLv2,GPLv3,LGPLv2,LGPLv3
8Group:         User Interface/Desktops
9URL:           http://nepomuk.kde.org/
10
11Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
12
13BuildRoot:     %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires:  kdelibs-devel >= %{version}
16BuildRequires:  kdebase-workspace-devel >= %{version}
17BuildRequires:  soprano-devel >= 2.7.56
18BuildRequires:  strigi-devel >= 0.7.3
19
20Requires: %{name}-libs = %{version}-%{release}
21
22%description
23The core Nepomuk system contains of the central services like file indexing,
24file system monitoring, query, and of course storage, as well as the corresponding
25client libraries.
26
27
28%package devel
29Summary:  Developer files for %{name}
30Summary(ja): %{name} の開発用ファイル
31Group:    Development/Libraries
32Requires: %{name}-libs = %{version}-%{release}
33
34%description devel
35%{summary}.
36
37%description -l ja devel
38%{name} の開発用ファイルです.
39
40%package libs
41Summary: Runtime libraries for %{name}
42Summary(ja): %{name} のランタイムライブラリ
43Group:   System Environment/Libraries
44Requires: kdelibs4 >= %{version}
45Requires: kdepimlibs >= %{version}
46# cagibi is runtime dep, a dbus service
47Requires: cagibi
48
49%description libs
50%{summary}.
51
52%description -l ja libs
53%{name} のランタイムライブラリです.
54
55%prep
56%setup -q
57
58%build
59mkdir -p %{_target_platform}
60pushd %{_target_platform}
61%cmake \
62    -DCMAKE_BUILD_TYPE=release \
63    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
64    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
65    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
66    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
67    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
68    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
69    ..
70popd
71
72make %{?_smp_mflags} -C %{_target_platform}
73
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
79
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%posttrans
85update-desktop-database -q &> /dev/null ||:
86
87%postun
88if [ $1 -eq 0 ] ; then
89    update-desktop-database -q &> /dev/null ||:
90fi
91
92%post libs -p /sbin/ldconfig
93%postun libs -p /sbin/ldconfig
94
95
96%files
97%defattr(-,root,root,-)
98%{_bindir}/nepomuk-simpleresource-rcgen
99%{_bindir}/nepomukbackup
100%{_bindir}/nepomukindexer
101%{_bindir}/nepomukserver
102%{_bindir}/nepomukservicestub
103%{_libdir}/libkdeinit4_nepomukserver.so
104%{_datadir}/applications/kde4/nepomukbackup.desktop
105%{_datadir}/autostart/nepomukserver.desktop
106%{_datadir}/dbus-1/interfaces/*
107%{_datadir}/kde4/apps/*
108%{_datadir}/kde4/services/*
109%{_datadir}/kde4/servicetypes/*
110%{_datadir}/ontology/kde/
111
112%files devel
113%defattr(-,root,root,-)
114%{_includedir}/kde4/Nepomuk2
115%{_includedir}/kde4/nepomuk2
116%{_libdir}/libnepomukcore.so
117%{_libdir}/libnepomuksync.so
118%{_libdir}/cmake/NepomukCore
119
120%files libs
121%defattr(-,root,root,-)
122%{_libdir}/libnepomukcore.so.*
123%{_libdir}/libnepomuksync.so.*
124%{_libdir}/libnepomukcommon.so
125%{_libdir}/kde4/*.so
126
127
128%changelog
129* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
130- initial build
Note: See TracBrowser for help on using the repository browser.