source: projects/specs/trunk/n/ncurses/ncurses-vl.spec @ 12131

Revision 12131, 20.2 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%global revision 20190824
2
3Summary: A screen handling and optimization package.
4Summary(ja): スクリーンの操作と最適化を行うパッケージ
5Name: ncurses
6Version: 6.1
7%define includedirw %{_includedir}/ncursesw
8%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
9Release: 1%{?_dist_release}
10License: distributable
11Group: System Environment/Libraries
12URL: https://invisible-island.net/ncurses/ncurses.html
13Source0: https://invisible-mirror.net/archives/ncurses/current/ncurses-6.1-%{revision}.tgz
14Patch8: ncurses-config.patch
15Patch9: ncurses-libs.patch
16Patch11: ncurses-urxvt.patch
17Patch12: ncurses-kbs.patch
18
19Requires(post): /sbin/ldconfig
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: pkgconfig
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: daisuke
27
28%description
29The curses library routines are a terminal-independent method of
30updating character screens with reasonable optimization.  The ncurses
31(new curses) library is a freely distributable replacement for the
32discontinued 4.4 BSD classic curses library.
33
34
35%package devel
36Summary: The development files for applications which use ncurses.
37Summary(ja): ncurses を用いるアプリケーション開発用のファイル
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40Obsoletes: libtermcap-devel <= 2.0.8-46vl1
41Provides: libtermcap-devel = 2.0.8-47
42
43%description devel
44The header files and libraries for developing applications that use
45the ncurses CRT screen handling and optimization package.
46
47Install the ncurses-devel package if you want to develop applications
48which will use ncurses.
49
50Use the following compiler flags to build against the ncurses library:
51                                                                               
52-lncurses
53(compile and link against the regular ncurses library)
54                                                                               
55-I %{includedirw} -lncursesw
56(compile and link against the wide-character, UTF-8, library)
57
58
59%package c++-devel
60Summary: C++ bindings to ncurses
61Group: Development/Libraries
62Requires: %{name} = %{version}-%{release}
63Requires: %{name}-devel = %{version}-%{release}
64 
65%description c++-devel
66C++ bindings to ncurses
67
68
69%package -n compat32-%{name}
70Summary: A screen handling and optimization package.
71Summary(ja): スクリーンの操作と最適化を行うパッケージ
72Group: System Environment/Libraries
73Requires: %{name} = %{version}-%{release}
74
75%description -n compat32-%{name}
76The curses library routines are a terminal-independent method of
77updating character screens with reasonable optimization.  The ncurses
78(new curses) library is a freely distributable replacement for the
79discontinued 4.4 BSD classic curses library.
80
81
82%package -n compat32-%{name}-devel
83Summary: The development files for applications which use ncurses.
84Summary(ja): ncurses を用いるアプリケーション開発用のファイル
85Group: Development/Libraries
86Requires: compat32-%{name} = %{version}-%{release}
87Requires: %{name}-devel = %{version}-%{release}
88Obsoletes: compat32-libtermcap-devel <= 2.0.8-46vl1
89Provides: compat32-libtermcap-devel = 2.0.8-47
90
91%description -n compat32-%{name}-devel
92The header files and libraries for developing applications that use
93the ncurses CRT screen handling and optimization package.
94
95Install the ncurses-devel package if you want to develop applications
96which will use ncurses.
97
98Use the following compiler flags to build against the ncurses library:
99                                                                               
100-lncurses
101(compile and link against the regular ncurses library)
102                                                                               
103-I %{includedirw} -lncursesw
104(compile and link against the wide-character, UTF-8, library)
105
106
107%package -n compat32-%{name}-c++-devel
108Summary: C++ bindings to ncurses
109Group: System Environment/Libraries
110Requires: compat32-%{name} = %{version}-%{release}
111Requires: compat32-%{name}-devel = %{version}-%{release}
112Requires: %{name}-c++-devel = %{version}-%{release}
113 
114%description -n compat32-%{name}-c++-devel
115C++ bindings to ncurses
116
117
118%prep
119%setup -q -n %{name}-%{version}-%{revision}
120
121%patch8 -p1 -b .config
122%patch9 -p1 -b .libs
123%patch11 -p1 -b .urxvt
124%patch12 -p1 -b .kbs
125
126for f in ANNOUNCE; do
127    iconv -f iso8859-1 -t utf8 -o ${f}{_,} &&
128        touch -r ${f}{,_} && mv -f ${f}{_,}
129done
130
131%build
132%define rootdatadir /lib
133common_options=" \
134    --enable-colorfgbg \
135    --enable-hard-tabs \
136    --enable-overwrite \
137    --enable-pc-files \
138    --enable-xmc-glitch \
139    --disable-stripping \
140    --disable-wattr-macros \
141    --with-ospeed=unsigned \
142    --with-pkg-config-libdir=%{_libdir}/pkgconfig \
143    --with-shared \
144    --with-terminfo-dirs=%{_sysconfdir}/terminfo:%{_datadir}/terminfo:%{rootdatadir}/terminfo \
145    --with-termlib=tinfo \
146    --with-ticlib=tic \
147    --with-xterm-kbs=DEL \
148    --without-ada"
149abi5_options="--with-chtype=long"
150
151for abi in 5 6; do
152    for char in narrowc widec; do
153        mkdir $char$abi
154        pushd $char$abi
155        ln -s ../configure .
156
157        [ $abi = 6 -a $char = widec ] && progs=yes || progs=no
158
159        %configure $(
160            echo $common_options --with-abi-version=$abi
161            [ $abi = 5 ] && echo $abi5_options
162            [ $char = widec ] && echo --enable-widec
163            [ $progs = yes ] || echo --without-progs
164        )
165
166        make %{?_smp_mflags} libs
167        [ $progs = yes ] && make %{?_smp_mflags} -C progs
168
169        popd
170    done
171done
172
173
174%install
175rm -rf ${RPM_BUILD_ROOT}
176
177make -C narrowc5 DESTDIR=$RPM_BUILD_ROOT install.libs
178rm ${RPM_BUILD_ROOT}%{_libdir}/lib{tic,tinfo}.so.5*
179make -C widec5 DESTDIR=$RPM_BUILD_ROOT install.libs
180make -C narrowc6 DESTDIR=$RPM_BUILD_ROOT install.libs
181rm ${RPM_BUILD_ROOT}%{_libdir}/lib{tic,tinfo}.so.6*
182make -C widec6 DESTDIR=$RPM_BUILD_ROOT install.{libs,progs,data,includes,man}
183
184chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/lib*.so.*.*
185chmod 644 ${RPM_BUILD_ROOT}%{_libdir}/lib*.a
186
187# move lib{ncurses{,w},tinfo}.so.* to /lib*
188mkdir $RPM_BUILD_ROOT/%{_lib}
189mv $RPM_BUILD_ROOT%{_libdir}/lib{ncurses{,w},tinfo}.so.* $RPM_BUILD_ROOT/%{_lib}
190for l in $RPM_BUILD_ROOT%{_libdir}/lib{ncurses{,w},tinfo}.so; do
191    ln -sf $(echo %{_libdir} | \
192        sed 's,\(^/\|\)[^/][^/]*,..,g')/%{_lib}/$(readlink $l) $l
193done
194
195mkdir -p $RPM_BUILD_ROOT{%{rootdatadir},%{_sysconfdir}}/terminfo
196
197# move few basic terminfo entries to /lib
198baseterms=
199for termname in \
200        ansi dumb linux vt100 vt100-nav vt102 vt220 vt52
201do
202    for t in $(find $RPM_BUILD_ROOT%{_datadir}/terminfo \
203        -samefile $RPM_BUILD_ROOT%{_datadir}/terminfo/${termname::1}/$termname)
204    do
205        baseterms="$baseterms $(basename $t)"
206    done
207done
208for termname in $baseterms; do
209    termpath=terminfo/${termname::1}/$termname
210    mkdir $RPM_BUILD_ROOT%{rootdatadir}/terminfo/${termname::1} &> /dev/null || :
211    mv $RPM_BUILD_ROOT%{_datadir}/$termpath $RPM_BUILD_ROOT%{rootdatadir}/$termpath
212    ln -s $(dirname %{_datadir}/$termpath | \
213        sed 's,\(^/\|\)[^/][^/]*,..,g')%{rootdatadir}/$termpath \
214        $RPM_BUILD_ROOT%{_datadir}/$termpath
215done
216
217# prepare -base and -term file lists
218for termname in \
219    ansi dumb linux vt100 vt100-nav vt102 vt220 vt52 \
220    Eterm\* aterm bterm cons25 cygwin eterm\* gnome gnome-256color hurd jfbterm \
221    konsole konsole-256color mach\* mlterm mrxvt nsterm putty{,-256color} pcansi \
222    rxvt{,-\*} screen{,-\*color,.[^mlp]\*,.linux,.mlterm\*,.putty{,-256color},.mrxvt} \
223    st{,-\*color} sun teraterm teraterm2.3 tmux{,-\*} vte vte-256color vwmterm \
224    wsvt25\* xfce xterm xterm-\*
225do
226    for i in $RPM_BUILD_ROOT%{_datadir}/terminfo/?/$termname; do
227        for t in $(find $RPM_BUILD_ROOT%{_datadir}/terminfo -samefile $i); do
228            baseterms="$baseterms $(basename $t)"
229        done
230    done
231done 2> /dev/null
232for t in $baseterms; do
233    echo "%dir %{_datadir}/terminfo/${t::1}"
234    echo %{_datadir}/terminfo/${t::1}/$t
235done 2> /dev/null | sort -u > terms.base
236find $RPM_BUILD_ROOT%{_datadir}/terminfo \! -type d | \
237    sed "s|^$RPM_BUILD_ROOT||" | while read t
238do
239    echo "%dir $(dirname $t)"
240    echo $t
241done 2> /dev/null | sort -u | comm -2 -3 - terms.base > terms.term
242
243cat terms.base terms.term |sort -u > terms.all
244
245# can't replace directory with symlink (rpm bug), symlink all headers
246mkdir $RPM_BUILD_ROOT%{_includedir}/ncurses{,w}
247for l in $RPM_BUILD_ROOT%{_includedir}/*.h; do
248    ln -s ../$(basename $l) $RPM_BUILD_ROOT%{_includedir}/ncurses
249    ln -s ../$(basename $l) $RPM_BUILD_ROOT%{_includedir}/ncursesw
250done
251
252# don't require -ltinfo when linking with --no-add-needed
253for l in $RPM_BUILD_ROOT%{_libdir}/libncurses{,w}.so; do
254    soname=$(basename $(readlink $l))
255    rm -f $l
256    echo "INPUT($soname -ltinfo)" > $l
257done
258             
259rm -f $RPM_BUILD_ROOT%{_libdir}/libcurses{,w}.so
260echo "INPUT(-lncurses)" > $RPM_BUILD_ROOT%{_libdir}/libcurses.so
261echo "INPUT(-lncursesw)" > $RPM_BUILD_ROOT%{_libdir}/libcursesw.so
262
263echo "INPUT(-ltinfo)" > $RPM_BUILD_ROOT%{_libdir}/libtermcap.so
264
265rm -f ${RPM_BUILD_ROOT}%{_libdir}/terminfo
266#rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/{*_g,ncurses++*}.pc
267
268
269%post -p /sbin/ldconfig
270
271%postun -p /sbin/ldconfig
272
273%post -n compat32-%{name} -p /sbin/ldconfig
274
275%postun -n compat32-%{name} -p /sbin/ldconfig
276
277
278%files -f terms.all
279%defattr(-,root,root)
280%doc ANNOUNCE AUTHORS README TO-DO
281%{_bindir}/[cirt]*
282%{_mandir}/man1/*
283%{_mandir}/man5/*
284%{_mandir}/man7/*
285/%{_lib}/lib*.so.*
286%{_libdir}/lib*.so.*
287%dir %{_sysconfdir}/terminfo
288%{rootdatadir}/terminfo
289%{_datadir}/tabset
290%dir %{_datadir}/terminfo
291
292%files devel
293%defattr(-,root,root)
294%doc test
295%doc doc/html/hackguide.html
296%doc doc/html/ncurses-intro.html
297%doc c++/README*
298%{_bindir}/ncurses*-config
299%{_libdir}/lib*.so
300%{_libdir}/lib*.a
301 %dir %{_includedir}/ncurses
302%dir %{_includedir}/ncursesw
303%{_includedir}/ncurses/*.h
304%{_includedir}/ncursesw/*.h
305%{_includedir}/*.h
306%{_mandir}/man3/*
307%{_libdir}/pkgconfig/*.pc
308%exclude %{_libdir}/pkgconfig/ncurses++*.pc
309
310%files c++-devel
311%defattr(-,root,root)
312%doc c++/NEWS c++/PROBLEMS c++/README*
313%{_includedir}/ncurses/cursesapp.h
314%{_includedir}/ncurses/curses?.h
315%{_includedir}/ncurses/etip.h
316%{_libdir}/libncurses++.a
317%{_libdir}/libncurses++w.a
318%{_libdir}/pkgconfig/ncurses++*.pc
319
320%if %{build_compat32}
321%files -n compat32-%{name}
322%defattr(-,root,root)
323%attr(755,root,root) %{_libdir}/lib*.so.*
324/%{_lib}/lib*.so.*
325%{_libdir}/lib*.so.*
326
327
328%files -n compat32-%{name}-devel
329%defattr(-,root,root)
330%{_libdir}/lib*.so
331%{_libdir}/lib*.a
332%{_libdir}/pkgconfig/*.pc
333%exclude %{_libdir}/pkgconfig/ncurses++*.pc
334 
335
336%files -n compat32-%{name}-c++-devel
337%defattr(-,root,root)
338%{_libdir}/libncurses++.a
339%{_libdir}/libncurses++w.a
340%{_libdir}/pkgconfig/ncurses++*.pc
341%endif
342
343
344%clean
345rm -rf $RPM_BUILD_ROOT
346
347
348%changelog
349* Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.1-1
350- updated to 6.1 + 20190824.
351
352* Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.9-3
353- rebuild with VineSeed environment
354
355* Wed Dec 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9-2
356- don't require -ltinfo when linking with --no-add-needed
357
358* Fri Sep 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9-1
359- update to 5.9 + 20110716
360- update all patches
361- add pkgconfig file
362
363* Sun Mar 27 2011 IWAI, Masaharu <iwai@alib.jp> 5.6-5
364- build with new toolchain
365
366* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.6-4
367- rebuilt with new toolchain
368- add Requires(post,pre): /sbin/ldconfig
369
370* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 5.6-3
371- updated %%files section on compat32-* packages
372
373* Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.6-2
374- changed c++-devel Group to Development/Libraries
375- changelog of 5.6-1 is missing... seemed to be updated on Aug 10 2008
376
377* Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 5.4-0vl3
378- added compat32- packages for x86_64 architecture support
379
380* Mon May 17 2004 Tomoya TAKA <taka@vinelinux.org> 5.4-0vl2
381- add patch10 taken from fedora's 5.4-4
382
383* Sun May  9 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4-0vl1
384- new upstream release
385- remove obsolete patches
386
387* Mon Mar 22 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.3-9vl1
388- synced up with Fedora 5.3-9
389  - Thu Sep 11 2003 Adrian Havill <havill@redhat.com> 5.3-9
390  - remove not-so safe-sprintf configure option because the code does
391    not appear to be stable enough for some apps. (#103790)
392 
393  - Wed Aug 20 2003 Adrian Havill <havill@redhat.com> 5.3-8.1
394  - RHEL bump
395 
396  - Wed Aug 20 2003 Adrian Havill <havill@redhat.com> 5.3-8
397  - multilib patch (#91211)
398 
399  - Mon Aug 11 2003 Adrian Havill <havill@redhat.com> 5.3-7
400  - fixed the safe sprintf code that was enabled in the previous release
401    by the configure parameter. (#101486)
402 
403  - Mon Jun 16 2003 Elliot Lee <sopwith@redhat.com> 5.3-6.1
404  - Fix ac25 patch, make it easy to turn off GPM support
405 
406  - Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
407  - rebuilt
408 
409  - Thu May 22 2003 Adrian Havill <havill@redhat.com> 5.3-5
410  - added latest rollup patch with widec/UTF8 centric weekly (20030517)
411  - added --enable-widec to configure (#86311)
412    original work done by Mr. Sam <sam@email-scan.com>
413  - require sharutils (#86605)
414  - add gpm, xmc support
415  - add debug syms back into package
416  - updated autoconf/configure patch
417
418* Thu Mar 27 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.3-4vl1
419- synced Rawhide 5.3-4
420
421* Fri Feb 08 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-16vl2
422- revert to patch13 from 14 for XF86-4
423
424* Wed Feb 06 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-16vl1
425- synced Rawhide 5.2-16
426
427* Tue Aug 28 2001 Shoji Matsumoto <shom@vinelinux.org> 5.2-12vl2
428- patch 3 (xterm) disabled. this patch is for XF86-4???
429
430* Wed Aug 22 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-12vl1
431- added kon patch for Vine
432
433* Fri Jul 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.2-12
434- Sync terminfo with termcap 11.0.1-10
435
436* Sun Jun 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.2-11
437- Update to patchlevel 20010623, fixes some lynx issues
438 
439* Mon Jun 18 2001 Helge Deller <hdeller@redhat.de>
440- fixed tput -S segfaulting bug (#44669)
441- use _tmppath for BuildRoot:
442- Copyright -> License
443
444* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
445- Update to patchlevel 20010407
446
447* Tue Mar  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
448- Fix up some terminfo entries containing includes to
449  "/var/tmp/ncurses-root/something" (#30771)
450
451* Thu Feb 22 2001 Harald Hoyer <harald@redhat.de>
452- fixed rxvt backspace setting
453
454* Fri Feb  9 2001 Yukihiro Nakai <ynakai@redhat.com>
455- Update Japanese kterm patch
456
457* Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
458- Update
459- Add japanese patch from termcap
460- Fix ospeed handling
461
462* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
463- Add libcurses.a -> libncurses.a symlink (RFE #23023)
464
465* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
466- Use --with-ospeed='unsigned int'
467
468* Fri Nov 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
469- Fix alpha and ia64
470- Rebuild with gcc 2.96-64
471
472* Thu Nov  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
473- 5.2
474- Fix typo in man page (Bug #20205)
475- update the "screen" terminfo entries to the version supplied with
476  screen 3.9.8
477
478* Mon Oct  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
479- Update (fixes the "make menuconfig" bug introduced by the security fix)
480
481* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
482- Fix security problem (possible buffer overrun)
483
484* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
485- Add the bugfix patches from the ncurses maintainer
486
487* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
488- 5.1
489
490* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
491- automatic rebuild
492
493* Mon Jun  5 2000 Matt Wilson <msw@redhat.com>
494- *don't ship symlinks from lib*.so.5 to lib*.so.4!
495- use FHS macros
496
497* Fri Jun  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
498- rebuild for 7.0
499- /usr/share/man
500- update URL for patches
501- misc. fixes to spec file
502
503* Mon Mar 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
504- use the real library version number
505- update to 20000319
506
507* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
508- rebuild for sparc baud rates > 38400.
509
510* Fri Feb 18 2000 Preston Brown <pbrown@redhat.com>
511- xterm terminfo entries from XFree86 3.3.6
512- final round of xterm fixes, follow debian policy.
513
514* Sat Feb  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
515- strip libraries
516
517* Thu Feb  3 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
518- More xterm fixes (Bug #9087)
519
520* Thu Jan 27 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
521- More xterm fixes from Hans de Goede (Bug #8633)
522
523* Sat Jan 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
524- remove some broken symlinks (leftovers from libncurses.so.5)
525- Use %configure (Bug #8484)
526
527* Tue Jan 11 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
528- Add xterm patch from Hans de Goede <hans@highrise.nl>
529- Patch 20000108, this fixes a problem with a header file.
530
531* Wed Jan  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
532- Add 20000101 patch, hopefully finally fixing the xterm description
533
534* Wed Dec 22 1999 Cristian Gafton <gafton@redhat.com>
535- revert to the old major number - because the ABI is not changed (and we
536  should be handling the changes via symbol versioning anyway)
537
538* Fri Nov 12 1999 Bernhard Rosenkraenzer <bero@redhat.com>
539- Fix a typo in spec
540- Add the 19991006 patch, fixing some C++ STL compatibility problems.
541- get rid of profiling and debugging versions - we need to save space...
542
543* Thu Nov  4 1999 Bernhard Rosenkraenzer <bero@redhat.com>
544- 5.0
545- some spec cleanups to make updating easier
546- add links *.so.5 to *.so.4 - they are fully binary compatible.
547  (Why did they change the invocation number???)
548
549* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
550- make clean in the test dir - don't ship any binaries at all.
551
552* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
553- fixed stripping of test programs.
554
555* Sun Aug 29 1999 Preston Brown <pbrown@redhat.com>
556- removed 'flash' capability for xterm; see bug #2820 for details.
557
558* Fri Aug 27 1999 Cristian Gafton <gafton@redhat.com>
559- add the resetall script from Marc Merlin <marc@merlins.org>
560
561* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
562- added iris-ansi-net as alias for iris-ansi (bug #2561)
563
564* Fri Jul 30 1999 Michael K. Johnson <johnsonm@redhat.com>
565- added ncurses-intro.hmtl and hackguide.html to -devel package [bug #3929]
566
567* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
568- make sure ALL binaries are stripped (incl. test binaries)
569
570* Thu Mar 25 1999 Preston Brown <pbrown@redhat.com>
571- made xterm terminfo stuff MUCH better.
572
573* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
574- auto rebuild in the new build environment (release 16)
575
576* Sat Mar 13 1999 Cristian Gafton <gafton@redhat.com>
577- fixed header for C++ compiles
578
579* Fri Mar 12 1999 Jeff Johnson <jbj@redhat.com>
580- add terminfo entries for linux/linux-m on sparc (obsolete termfile_sparc).
581
582* Thu Feb 18 1999 Cristian Gafton <gafton@redhat.com>
583- updated patchset from original site
584
585* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
586- don't build the C++ demo code
587- update patch set to the current as of today (redid all the individual
588  patches in a single one)
589
590* Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
591- make sure to strip the binaries
592
593* Wed Sep 23 1998 Cristian Gafton <gafton@redhat.com>
594- added another zillion of patches. The spec file *is* ugly
595- defattr
596
597* Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
598- added lots of patches. This spec file is starting to look ugly
599
600* Wed Jul 01 1998 Alan Cox <alan@redhat.com>
601- Fix setuid trusting. Open termcap/info files as the real user.
602
603* Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
604- added terminfo entry for the poor guys using lat1 and/or lat-2 on their
605  consoles... Enjoy linux-lat ! Thanks, Erik !
606
607* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
608- new patch to get xterm-color and nxterm terminfo entries
609- aliased them to rxvt, as that seems to satisfy everybody
610
611* Sun Apr 12 1998 Cristian Gafton <gafton@redhat.com>
612- added %clean section
613
614* Tue Apr 07 1998 Cristian Gafton <gafton@redhat.com>
615- removed /usr/lib/terminfo symlink - we shouldn't need that
616
617* Mon Apr 06 1998 Cristian Gafton <gafton@redhat.com>
618- updated to 4.2 + patches
619- added BuildRoot
620
621* Sat Apr 04 1998 Cristian Gafton <gafton@redhat.com>
622- rebuilt with egcs on alpha
623
624* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
625- version 7 didn't rebuild properly on the Alpha somehow -- no real changes
626  are in this version
627
628* Tue Dec 09 1997 Erik Troan <ewt@redhat.com>
629- TIOCGWINSZ wasn't used properly
630
631* Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
632- built against glibc, linked shared libs against -lc
633
Note: See TracBrowser for help on using the repository browser.