source: projects/specs/trunk/n/ncpfs/ncpfs-vl.spec @ 521

Revision 521, 5.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Utilities for the ncpfs filesystem, a NetWare client for Linux.
2Name: ncpfs
3%define pversion 2.2.0.18
4Version: %{pversion}
5Release: 3vl1
6Copyright:  GPL
7Source: ftp://ftp.platan.vc.cvut.cz/pub/linux/ncpfs/ncpfs-%{version}/ncpfs-%{pversion}.tgz
8Group: Applications/System
9Requires: ipxutils
10Buildroot: %{_tmppath}/%{name}-%{version}-root
11
12%description
13Ncpfs is a filesystem which understands the Novell NetWare(TM) NCP
14protocol.  Functionally, NCP is used for NetWare the way NFS is used
15in the TCP/IP world.  For a Linux system to mount a NetWare
16filesystem, it needs a special mount program.  The ncpfs package
17contains such a mount program plus other tools for configuring and
18using the ncpfs filesystem.
19
20Install the ncpfs package if you need to use the ncpfs filesystem
21to use Novell NetWare files or services.
22
23%package -n ipxutils
24Summary: Tools for configuring and debugging IPX interfaces and networks.
25Group: Applications/System
26
27%description -n ipxutils
28The ipxutils package includes utilities for configuring and debugging
29IPX interfaces and networks under Linux. IPX is the low-level protocol
30used by Novell's NetWare file server system to transfer data.
31
32Install ipxutils if you need to configure IPX networking on your
33network.
34
35%prep
36%setup -q -n ncpfs-%{pversion}
37
38%build
39%configure --disable-pam --disable-function-sections
40make
41make -C ipxdump
42mv ipxdump/README ipxdump/README.ipxdump
43
44%install
45rm -rf $RPM_BUILD_ROOT
46
47mkdir -p $RPM_BUILD_ROOT/sbin
48mkdir -p $RPM_BUILD_ROOT/usr/sbin
49%makeinstall install-dev libsodir=$RPM_BUILD_ROOT/usr/lib
50
51# Move ipx_configure/ipx_internal_net to permit /usr from NFS
52for i in ipx_configure ipx_internal_net ipx_interface
53do
54        mv $RPM_BUILD_ROOT/usr/bin/$i $RPM_BUILD_ROOT/sbin/$i
55done
56
57install -m755 ipxdump/ipxdump ipxdump/ipxparse $RPM_BUILD_ROOT/usr/bin/
58
59# these could be SUID root, but it's a security hole
60chmod 755 $RPM_BUILD_ROOT/usr/bin/ncpmount $RPM_BUILD_ROOT/usr/bin/ncpumount
61ln -s mount.ncp $RPM_BUILD_ROOT/sbin/mount.ncpfs
62ln -s ../usr/bin/ncpmount $RPM_BUILD_ROOT/sbin/mount.ncp
63
64strip --strip-unneeded $RPM_BUILD_ROOT/usr/lib/libncp*.so.*
65
66# file list
67find $RPM_BUILD_ROOT -type f -or -type l | \
68        grep -v ipx | grep -v mount.ncp.8| \
69        sed -e "s|$RPM_BUILD_ROOT||g" | \
70        sed -e "s|/usr/bin/nwsfind|%attr(4755,root,root) /usr/bin/nwsfind|g" > rpm.files
71
72%post -p /sbin/ldconfig
73
74%postun -p /sbin/ldconfig
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78rm -f rpm.files
79
80%files -f rpm.files
81%defattr(-,root,root)
82%doc BUGS COPYING Changes FAQ README
83
84%files -n ipxutils
85%defattr(-,root,root)
86%doc ipx-1.0/COPYING ipx-1.0/README
87%doc ipxdump/README.ipxdump
88/sbin/ipx_*
89/usr/bin/ipx*
90%{_mandir}/man8/ipx*
91
92%changelog
93* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
94- 2.2.0.18-3vl1
95
96* Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
97- fix absolute symlink
98
99* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
100- automatic rebuild
101
102* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
103- update to 2.2.0.18
104
105* Mon May 22 2000 Bill Nottingham <notting@redhat.com>
106- simply link mount.ncp to ncpmount
107
108* Tue Apr 18 2000 Bill Nottingham <notting@redhat.com>
109- build on alpha
110
111* Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
112- fix handling of large keys (#10454)
113
114* Thu Feb  3 2000 BIll Nottingham <notting@redhat.com>
115- fix shared library
116
117* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
118- fix description
119
120* Tue Jan 11 2000 Bill Nottingham <notting@redhat.com>
121- update to 2.2.0.17
122
123* Thu Jul 15 1999 Bill Nottingham <notting@redhat.com>
124- add patch to update to 2.2.0.16.a (#4051)
125
126* Tue Jul  6 1999 Bill Nottingham <notting@redhat.com>
127- oops, left ipx_interface out of %files
128
129* Mon Jun 14 1999 Bill Nottingham <notting@redhat.com>
130- update to 2.2.0.16
131- fix mount.ncp USER arg
132
133* Thu May 13 1999 Bill Nottingham <notting@redhat.com>
134- update to 2.2.0.15
135
136* Tue May 11 1999 Bill Nottingham <notting@redhat.com>
137- update to 2.2.0.14
138- fix bug in slist/nwsfind
139- move ipxdump docs to the package that it's in...
140
141* Tue Apr  6 1999 Bill Nottingham <notting@redhat.com>
142- turn off setuid on nwsfind
143- move ipxutils to using ncpfs versioning for sanity reasons
144
145* Fri Mar 26 1999 Bill Nottingham <notting@redhat.com>
146- doesn't work on alpha, apparently
147- add a mount.ncp mount helper
148
149* Mon Mar 22 1999 Bill Nottingham <notting@redhat.com>
150- remove dangling symlink
151
152* Tue Feb 23 1999 Bill Nottingham <notting@redhat.com>
153- update to 2.2.0.12
154
155* Fri Jan 22 1999 Bill Nottingham <notting@redhat.com>
156- build for arm. Yuk.
157
158* Wed Dec  9 1998 Bill Nottingham <notting@redhat.com>
159- update to 2.2.0.11
160
161* Fri Sep 11 1998 Jeff Johnson <jbj@redhat.com>
162- update to 2.2.0.
163
164* Fri Jul 10 1998 Jeff Johnson <jbj@redhat.com>
165- exclusively i386 for now.
166
167* Tue Jul  7 1998 Jeff Johnson <jbj@redhat.com>
168- move ipx_configure/ipx_internal_net to /sbin to permit /usr from NFS.
169
170* Thu May 07 1998 Prospector System <bugs@redhat.com>
171- translations modified for de, fr, tr
172
173* Mon Apr 13 1998 Cristian Gafton <gafton@redhat.com>
174- manhattan rebuild
175- there is a new version out, 2.0.12, but it contains RSA crypto code, so
176  it's of no use for us. :-(
177- buildroot and spec file cleanup
178
179* Thu Dec 18 1997 Erik Troan <ewt@redhat.com>
180- uid_t, gid_t, mode_t fixes for glibc 2.0.5 and linux 2.0.x
181
182* Wed Oct 23 1997 Michael Fulbright <msf@redhat.com>
183- added a few file which were missing from the file list
184
185* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
186- updated to 2.0.11
187- massive hacking for glibc
188
189* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
190- nwrights program now included in package.
Note: See TracBrowser for help on using the repository browser.