source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 9520

Revision 9520, 31.4 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME 3.16.1

Line 
1%define glib2_version 2.44.0
2%define pango_version 1.36.3
3%define gtk3_version 3.16.0
4%define libxml2_version 2.9.1
5%define eog_version 3.16.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.16.0
8%define vine_menus_version 3.0
9%define startup_notification_version 0.10
10%define libexif_version 0.6.19
11%define tracker_version 1.4.0
12%define gobject_introspection_version 0.9.8
13
14Name:           nautilus
15Summary:        Nautilus is a file manager for GNOME
16Summary(ja):    Nautilus - GNOME ファイルマネージャ
17Version:        3.16.1
18Release:        1%{?_dist_release}
19License:        GPLv2+
20Group:          User Interface/Desktops
21URL:            http://www.gnome.org/projects/nautilus/
22
23Vendor:         Project Vine
24Distribution:   Vine Linux
25Packager:       Takemikaduchi
26
27Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.16/%{name}-%{version}.tar.xz
28
29# vine
30Patch102:       run_in_gnome.patch
31Patch2000:      nautilus-vine-settings.patch
32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
34Requires:       gamin
35Requires:       vine-menus >= %{vine_menus_version}
36Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
37Requires:       libexif >= %{libexif_version}
38Requires:       %{name}-libs = %{version}-%{release}
39
40BuildRequires:  intltool
41BuildRequires:  libtool >= 1.4.2-10
42BuildRequires:  automake, autoconf
43BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
44
45BuildRequires:  glib2-devel >= %{glib2_version}
46BuildRequires:  pango-devel >= %{pango_version}
47BuildRequires:  gtk3-devel >= %{gtk3_version}
48BuildRequires:  libxml2-devel >= %{libxml2_version}
49BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
50BuildRequires:  gamin-devel
51BuildRequires:  startup-notification-devel >= %{startup_notification_version}
52BuildRequires:  tracker-devel >= %{tracker_version}
53BuildRequires:  libexif-devel >= %{libexif_version}
54BuildRequires:  unique3-devel
55BuildRequires:  libnotify-devel
56BuildRequires:  libSM-devel
57BuildRequires:  exempi-devel
58BuildRequires:  tracker-devel
59BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
60BuildRequires:  gsettings-desktop-schemas
61
62Obsoletes:      nautilus-extras
63Obsoletes:      nautilus-suggested
64Obsoletes:      nautilus-mozilla < 2.0
65Obsoletes:      eel2 <= 2.24.1
66
67Provides:       eel2 <= 2.24.1
68
69
70%description
71Nautilus integrates access to files, applications, media,
72Internet-based resources and the Web. Nautilus delivers a dynamic and
73rich user experience. Nautilus is an free software project developed
74under the GNU General Public License and is a core component of the
75GNOME desktop project.
76
77%description -l ja
78Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
79リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
80豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
81のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
82プロジェクトのコア・コンポーネントです。
83
84
85%package        devel
86Summary:        Support for developing nautilus extensions
87Summary(ja):    Nautilus 拡張機能開発のためのサポート
88License:        LGPLv2+
89Group:          Development/Libraries
90Requires:       %{name}-libs = %{version}-%{release}
91Requires:       pkgconfig
92
93%description    devel
94This package provides libraries and header files needed
95for developing nautilus extensions.
96
97%description -l ja devel
98このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
99ヘッダファイルを提供します。
100
101
102%package        libs
103Summary:        Libraries for use in nautilus extentions
104Summary(ja):    Nautilus 拡張機能で利用するライブラリ
105Group:          System Environment/Libraries
106
107%description    libs
108This package provides libraries required by nautilus extention
109module.
110
111%description -l ja libs
112このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
113
114
115%package        docs
116Summary:        Documentation for %{name}
117Summary(ja):    %{name} 用のドキュメント
118Group:          Documentation
119BuildArch:      noarch
120
121%description    docs
122This package contains documentation for %{name}.
123
124
125%prep
126%setup -q -n %{name}-%{version}
127
128%patch102 -p1 -b .vine
129%patch2000 -p1 -b .vine
130
131%build
132gtkdocize
133libtoolize --force --copy
134autoreconf -f -i
135CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
136%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
137
138make %{?_smp_mflags}
139
140%install
141rm -rf $RPM_BUILD_ROOT
142
143make install DESTDIR=$RPM_BUILD_ROOT
144
145# make sure desktop files validate by ignoring sr@Latn
146perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
147# desktop-file-install can't handle empty OnlyShowIn correctly
148perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
149
150desktop-file-install --vendor gnome --delete-original       \
151  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
152  --add-only-show-in GNOME                                  \
153  $RPM_BUILD_ROOT%{_datadir}/applications/*
154
155find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
156
157%find_lang %name
158
159%clean
160rm -rf $RPM_BUILD_ROOT
161
162%postun
163if [ $1 -eq 0 ] ; then
164    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
165fi
166
167%posttrans
168glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
169
170%post libs -p /sbin/ldconfig
171%postun libs -p /sbin/ldconfig
172
173
174%files  -f %{name}.lang
175%defattr(-,root,root,-)
176%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
177%dir %{_libdir}/nautilus
178%dir %{_libdir}/nautilus/extensions-3.0
179%{_libdir}/nautilus/extensions-3.0/*.so
180%{_libexecdir}/nautilus-convert-metadata
181%{_datadir}/GConf/gsettings/nautilus.convert
182%{_datadir}/appdata/org.gnome.Nautilus.appdata.xml
183%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
184%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
185%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
186%{_datadir}/applications
187%{_bindir}/*
188%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
189%{_datadir}/glib-2.0/schemas/
190%{_mandir}/man1/*
191
192%files devel
193%defattr(-,root,root,-)
194%{_includedir}/nautilus
195%{_libdir}/pkgconfig/*
196%{_libdir}/*.so
197%{_datadir}/gir-1.0
198
199%files libs
200%defattr(-,root,root,-)
201%{_libdir}/*.so.*
202%{_libdir}/girepository-1.0/*.typelib
203
204%files docs
205%defattr(-,root,root,-)
206%{_datadir}/gtk-doc/html/libnautilus-extension/*
207
208
209%changelog
210* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
211- new upstream release
212
213* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
214- new upstream release
215- update Patch2000 (nautilus-vine-settings.patch)
216- create %%{name}-docs subpackage
217
218* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.2-2
219- moved libs subpackage to System Environment/Libraries Group
220
221* Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
222- new upstream release
223
224* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
225- new upstream release
226- remove Patch0 (nautilus-3.14.0-git20141015.patch)
227
228* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
229- new upstream release
230- add Patch0 (nautilus-3.14.0-git20141015.patch)
231
232* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
233- new upstream release
234
235* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
236- new upstream release
237
238* Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
239- new upstream release
240
241* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
242- new upstream release
243- add Patch2000 (nautilus-vine-settings.patch)
244
245* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
246- new upstream release
247
248* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
249- new upstream release
250
251* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
252- new upstream release
253
254* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
255- new upstream release
256
257* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
258- new upstream release
259
260* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
261- new upstream release
262- remove Patch0,7
263- add BuildRequires: exempi-devel, tracker-devel
264
265* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
266- add Patch0 (nautilus-3.4.2-ja.po.patch)
267
268* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
269- new upstream release
270
271* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
272- new upstream release
273
274* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
275- added patch102 to fix autostart in other desktop environments
276  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
277
278* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
279- new upstream release
280
281* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
282- new upstream release
283
284* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
285- new upstream release
286
287* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
288- new upstream release
289
290* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
291- new upstream release
292- drop Patch101
293- change BuildRequires: gtk3-devel instread of gtk2-devel
294- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
295- change BuildRequires: unique3-devel instread of unique-devel
296- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
297
298* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
299- fixed group of libs
300- add translation of summary and description.
301- add Vendor, Distribution and Packager tags.
302
303* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
304- new upstream release
305
306* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
307- new upstream release
308
309* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
310 - new upstream release
311
312* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
313- new upstream release
314- add BuildRequires: gobject-introspection-devel
315- remove BuildRequires: libgnomeui-devel
316- add configure option (--enable-introspection=yes)
317
318* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
319- rebuild with rpm-4.8.1 for pkg-config file
320
321* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
322- split nautilus extention libraries to -libs subpackage.
323
324* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
325- new upstream release
326
327* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
328- new upstream release
329- drop Patch100
330- add Patch101
331- add Obsoletes: eel2 <= 2.24.1
332- add Provides: eel2 <= 2.24.1
333
334* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
335- new upstream release
336- add BuildRequires: libSM-devel
337
338* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
339- removed Requires: eel2
340- added %%posttrans section
341
342* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
343- new upstream release
344
345* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
346- new upstream release
347
348* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
349- new upstream release
350
351* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
352- new upstream release
353- split -devel subpackage
354
355* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
356- new upstream release
357
358* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
359- patch6 needs autoreconf
360
361* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
362- new upstream release
363
364* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
365- new upstream release
366
367* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
368- new upstream release
369- added Requires: gvfs
370
371* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
372- new upstream release
373- added Patches from FC
374  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
375  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
376  - Fix a crash in the Properties dialog while changing owner (patch from head)
377  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
378  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
379
380* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
381- new upstream release
382- dropped Patch11-13 and added Patch7-9 from Fedora
383  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
384  - Add patch from upstream to get audio preview working again
385    (#332251)
386  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
387  - Fix a crash with small fonts (#242350)
388  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
389  - Backport fixes for async thumbnail loading from svn
390
391* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
392- run autoreconf for Patch11 changes
393
394* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
395- remove tracker dependancy, Patch13 detects tracker dynamically.
396
397* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
398- add Patch13 to support user-dirs
399
400* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
401- new upstream release
402- enable tracker support
403- add BuildRequires: tracker-devel, Requires: tracker
404
405* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
406- new upstream release
407
408* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
409- add BuildRequires: gamin-devel, Requires: gamin
410- remove fam dependency (replaced by gamin)
411
412* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
413- new upsteram release
414
415* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
416- really applied Patch110...
417
418* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
419- add Patch110 to fix corruption of help option message.
420
421* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
422- new upstream release
423
424* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
425- fix typo in ja.po
426
427* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
428- update ja.po to translate patch50 related message.
429
430* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
431- add Patch50 to show progressbar on umounting
432  (ubuntu patch in Bug 313639)
433
434* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
435- new upstream release
436
437* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
438- add Patch10 to avoid background rendering delay
439
440* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
441- new upstream release
442
443* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
444- add fix-non-UTF-8-encoding.patch (patch0)
445  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
446
447* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
448- new upstream release
449
450* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
451- new upstream release
452
453* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
454- new upstream release
455
456* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
457- new upstream release
458
459* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
460- rebuild
461
462* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
463- new upstream version
464
465* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
466- new upstream version
467
468* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
469- add vine patch to change some defaults.
470  - change default zoom sine
471  - set always_use_browser
472
473* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
474- new upstream release
475
476* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
477- add Patch110 to fix libegg(egg-recent-model.c)
478  save old umask value before create ".recently-used" file.
479 
480* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
481- change default desktop font to Sans 9 (from Sans 10)
482- add patch10 to build with gtk+-2.4
483
484* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
485- new upstream release
486
487* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
488- new upstream release
489
490* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
491- add backport patch from rawhide (Patch10)
492
493* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
494- modified vine patch
495  - change default zoom level to small
496  - change desktop font to Sans 10
497
498* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
499- new upstream release
500
501* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
502- add desktop icon patch from rawhide
503
504* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
505- remove obsolete ja.po
506
507* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
508- new upstream release
509
510* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
511- new upstream release
512
513* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
514- new upstream release
515
516* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
517- update ja.po
518
519* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
520- new upstream release
521
522* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
523- new upstream release
524
525* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
526- new upstream release
527
528* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
529- new upstream release
530
531* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
532- new upstream release
533
534* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
535- new upstream release
536
537* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
538- add nautilus-cd-burner patch
539
540* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
541- new upstream release
542
543* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
544- discard scrollkeeper outputs.
545- update PreReq tags.
546
547* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
548- change icon for nautilus-file-management-properties
549- update ja.po
550
551* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
552- update ja.po
553- add translation for .desktop files.
554
555* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
556- add Requires: vine-menus
557
558* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
559- new upstream release
560
561* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
562- remove redhatize patch
563
564* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
565- rebuild to remove unneeded dependancy.
566
567* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
568- build for Vine Linux
569
570* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
571- add explicit startup-notification dependency because build system is
572  dumb
573- 2.1.3
574
575* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
576- 2.1.2
577
578* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
579- 2.0.7
580- remove patches that are upstream
581
582* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
583- Add badhack to make weblinks on desktop work
584
585* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
586- fix #70667 assertion failures
587- fix triple click patch
588
589* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
590- don't activate on double click
591
592* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
593- put button press mask in triple-click patch, maybe it will work
594- remove html-hack patch as it does nothing useful
595
596* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
597- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
598  bogus bug reports
599- add hack for HTML mime type handling in a web browser, not
600  nautilus
601
602* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
603- Updated to 2.0.6. Removed the patches I put upstream.
604- Added patch that fixes #72410
605
606* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
607- Add a simple patch so that redhat-config-packages can disable
608  the new window behavior for mounted CDs behavior.
609
610* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
611- Add patch to fix bug #70667
612
613* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
614- remove mp3
615
616* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
617- ignore the "add_to_session" preference as it only broke stuff
618- pad the left margin a bit to cope with poor word wrapping
619
620* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
621- Update to 2.0.5, remove topleft icon patch
622
623* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
624- Add patch to fix the bug where desktop icons get
625  stuck in the top left corner on startup
626
627* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
628- 2.0.4
629
630* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
631- obsolete nautilus-mozilla < 2.0 #69839
632
633* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
634- add rhconfig patch to Bluecurve theme and disable sidebar by default
635
636* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
637- drop start here files, require redhat-menus that has them
638
639* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
640- 2.0.3
641
642* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
643- build for new eel2, gail
644
645* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
646- and add the libexec components, mumble
647
648* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
649- put the components in the file list, were moved upstream
650
651* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
652- 2.0.1
653
654* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
655- Relibtoolize to fix relink problems for solib components
656- Add LANG=en_US to %makeinstall as well
657- Back out previous change, force locale to en_US to prevent UTF-8 problems
658- Add workaround for intltool-merge bug on ia64
659
660* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
661- automated rebuild
662
663* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
664- 2.0.0
665- use desktop-file-install
666- require desktop-backgrounds-basic
667
668* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
669- add wacky hack in hopes of fixing the hang-on-login thing
670
671* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
672- add build requires on new gail
673- rebuild to try to lose broken libgailutil.so.13 dependency
674
675* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
676- rebuild in different environment
677
678* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
679- 1.1.19
680
681* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
682- rebuild in different environment
683
684* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
685- really remove nautilus-devel if we are going to obsolete it
686- don't require hwbrowser
687
688* Sun May 26 2002 Tim Powers <timp@redhat.com>
689- automated rebuild
690
691* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
692- rebuild in different environment
693
694* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
695- 1.1.17
696
697* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
698- 1.1.14
699
700* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
701- require eog
702- obsolete nautilus-devel
703- fix name of schemas file in post
704
705* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
706- Update to 1.1.13
707
708* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
709- put tree view in file list
710
711* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
712- nautilus for gnome 2
713- clean up the spec file and file list a bit
714
715* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
716- merge translations
717
718* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
719- Add patch to fix trash crash
720
721* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
722- fix for metadata tmp race
723- backport thumbnail speed fix and thumbnail inf. loop fix
724
725* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
726- add some fixes from CVS version, including one for #61819 and a couple segfaults
727
728* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
729- fix thumbnails for files with future timestamp, #56862
730
731* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
732- buildrequires intltool #60633
733- apply Alex's pixbuf cache patch to save a few megs #60581
734
735* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
736- drop Milan-specific features, including png10 and ac25 patches
737- copy in 1.0.5 help component to avoid large risky patch
738- remove .la files
739- drop mozilla from ia64 again
740- remove oaf file from nautilus-mozilla that was also in the base
741  package
742
743* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
744- enable mozilla support on ia64
745
746* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
747- require Mozilla 0.9.7
748- Add patch that puts mozilla profile startup before embedding is initialized
749
750* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
751- 1.0.6, require Mozilla 0.9.6
752
753* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
754- Update to 1.0.5
755
756* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
757- Fix handling of GnomeVFSFileInfo structure (#53315)
758
759* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
760- Change handling of names on unmount to fix #52325
761
762* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
763- put nautilus-help.desktop in file list; #53109
764
765* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
766- Add po files from sources.redhat.com
767
768* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
769- Add po files from sources.redhat.com
770
771* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
772- Added patch to fix the .directory issuer
773
774* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
775- I screwed up the build yesterday, so it didn't actually contain the
776  fixes mentioned. This build should contain them.
777
778* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
779- fix bug causing 32000 stats or so in large directories,
780  should speed things up somewhat
781- fix #52104 via gruesome kdesktop-detection hack and setting
782  window type hint on our desktop window
783- fix so Start Here icon displays in sidebar
784- don't load non-local .desktop files
785
786* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
787- make Programs icon into a link, to match the other .desktop files
788- own various directories #51164
789- web page titles in Japanese, #51709
790- tree defaults to only directories #51850
791
792* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
793- make start here icon work again
794- kill some warning spew, #51661
795- cache getpwnam() results to speed things up a bit
796
797* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
798- Fix problem with missing desktop starthere.desktop file
799- New snapshot from our branch, fixes:
800  - On upgrade, icons migrated from GNOME desktop are not properly lined up
801    (#51436)
802  - icons dropped on the desktop don't end up where dropped. (#51441)
803  - Nautilus shouldn't have fam monitor read-only windows. This
804    keeps CDROMS from being unmounted until you close all
805
806    nautilus windows pointing to them. (#51442)
807  - Warnings about 'cannot statfs...' when moving items to trash.
808- Use separate start-here.desktop for panel, since the one used
809  for the root window only works from Nautilus.
810
811* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
812- Changed starthere .desktop files to be links instead
813- of spawning a new nautilus. This makes start-here:
814- much faster.
815
816* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
817- Added hwbrowser dependency
818- New snapshot, fixes the mozilla-view submit form problem
819
820* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
821- Rebuild with new xml-i18n-tools
822- fix crash in creating new desktop files
823
824* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
825- Fix up DnD code some more
826
827* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
828- Sync our CVS version; fixes some MUSTFIX
829  (the one about drawing background on startup,
830   properly translate desktop files, etc.)
831
832* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
833- Fix 64bit cleanness issue
834- Fix NULL mimetype crash
835- Disable additional_text for .desktop files
836
837* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
838- Fix unmounting devices.
839
840* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
841- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
842- mimetype sniffing.
843
844* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
845- Remove the "don't run as root" warning.
846- Remove eazel from bookmarks
847- langified (again? did someone change it?)
848
849* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
850- Apply a patch that makes nautilus dnd reset work with the latest
851- eel release.
852
853* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
854- Build on ia64 without the mozilla component.
855
856* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
857- Fix crash-on-startup showstopper
858- Fix can't-find-images bug (this one was only showing up
859  when built with debug symbols, since it was an uninitialized memory
860  read)
861
862* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
863- sync new tarball from our CVS branch,
864  fixes some drag-and-drop, changes URI scheme names,
865  etc.
866
867* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
868- Add BuildRequires (#49539, 49537)
869- Fix %%post, %%postun (#49720)
870- Background efficiency improvements and hacks
871
872* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
873- Don't launch esd on each mouseover.
874
875* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
876- move first time druid patch into my "CVS outstanding" patch
877- try to really remove Help/Feedback
878- try to really fix Help/Community Support
879- try again to get Start Here in the Go menu
880- try again to get Start Here on the desktop
881- don't show file sizes for .desktop files
882
883* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
884- add newline to ends of .desktop files that were missing them
885
886* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
887- update to my latest 'cvs diff -u' (adds default
888  Start Here link, displays .directory name in sidebar)
889- include /etc/X11/* links (starthere, sysconfig, serverconfig)
890
891* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
892- Patch to remove firsttime druid and flash
893
894* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
895- add hacks for displaying desktop files
896- add hack to turn off the "unwriteable" emblem
897
898* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
899- added defattr to the files lists to be (-,root,root)
900- languified
901
902* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
903- Need to run autoheader too.
904
905* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
906- Make the fam dependency a real runtime dependency
907- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
908- Cleaned up specfile.
909
910* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
911- Change default background and rubberband color.
912- Use the sidebar tabs from the default theme
913- BuildDepend on fam-devel, depend on fam
914- Disable the eazel update pages in the first-time druid.
915- Remove the eazel logo from the first-time druid
916
917* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
918- 1.0.4, removes eazel services icon and wizard page
919- Eazel logo is still in startup wizard for now, needs fixing
920
921* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
922- fix group (s/Desktop/Desktops/) #47134
923- remove ammonite dependency
924
925* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
926- add a different default theme
927- clean up file list overspecificity a bit
928
929* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
930- move to a CVS snapshot of nautilus for now
931  (Darin is my hero for having distcheck work out of CVS)
932
933* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
934- clean up defaults a bit
935
936* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
937- New version
938
939* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
940- Added BuildRequires lines
941- Changed Source to point to ftp.gnome.org instead of just the tarball name
942- Moved %description sections closer to their %package sections
943- Moved %changelog to the end, where so that it's not in the way
944- Changed configure and make install options to allow moving of
945  libraries, includes, binaries more easily
946- Removed hard-coded paths (don't define %prefix or %docdir)
947- replace %{prefix}/bin with %{_bindir}
948- replace %{prefix}/share with %{_datadir}
949- replace %{prefix}/lib with %{_libdir}
950- replace %{prefix}/include with %{_includedir}
951
952* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
953- removed obsoletes from sub packages and added mozilla and trilobite
954subpackages
955
956* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
957- created this thing
Note: See TracBrowser for help on using the repository browser.