source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 9475

Revision 9475, 31.3 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME-3.16.0

Line 
1%define glib2_version 2.44.0
2%define pango_version 1.36.3
3%define gtk3_version 3.16.0
4%define libxml2_version 2.9.1
5%define eog_version 3.16.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.16.0
8%define vine_menus_version 3.0
9%define startup_notification_version 0.10
10%define libexif_version 0.6.19
11%define tracker_version 1.4.0
12%define gobject_introspection_version 0.9.8
13
14Name:           nautilus
15Summary:        Nautilus is a file manager for GNOME
16Summary(ja):    Nautilus - GNOME ファイルマネージャ
17Version:        3.16.0
18Release:        1%{?_dist_release}
19License:        GPLv2+
20Group:          User Interface/Desktops
21URL:            http://www.gnome.org/projects/nautilus/
22
23Vendor:         Project Vine
24Distribution:   Vine Linux
25Packager:       Takemikaduchi
26
27Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.16/%{name}-%{version}.tar.xz
28
29# vine
30Patch102:       run_in_gnome.patch
31Patch2000:      nautilus-vine-settings.patch
32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
34Requires:       gamin
35Requires:       vine-menus >= %{vine_menus_version}
36Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
37Requires:       libexif >= %{libexif_version}
38Requires:       %{name}-libs = %{version}-%{release}
39
40BuildRequires:  intltool
41BuildRequires:  libtool >= 1.4.2-10
42BuildRequires:  automake, autoconf
43BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
44
45BuildRequires:  glib2-devel >= %{glib2_version}
46BuildRequires:  pango-devel >= %{pango_version}
47BuildRequires:  gtk3-devel >= %{gtk3_version}
48BuildRequires:  libxml2-devel >= %{libxml2_version}
49BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
50BuildRequires:  gamin-devel
51BuildRequires:  startup-notification-devel >= %{startup_notification_version}
52BuildRequires:  tracker-devel >= %{tracker_version}
53BuildRequires:  libexif-devel >= %{libexif_version}
54BuildRequires:  unique3-devel
55BuildRequires:  libnotify-devel
56BuildRequires:  libSM-devel
57BuildRequires:  exempi-devel
58BuildRequires:  tracker-devel
59BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
60BuildRequires:  gsettings-desktop-schemas
61
62Obsoletes:      nautilus-extras
63Obsoletes:      nautilus-suggested
64Obsoletes:      nautilus-mozilla < 2.0
65Obsoletes:      eel2 <= 2.24.1
66
67Provides:       eel2 <= 2.24.1
68
69
70%description
71Nautilus integrates access to files, applications, media,
72Internet-based resources and the Web. Nautilus delivers a dynamic and
73rich user experience. Nautilus is an free software project developed
74under the GNU General Public License and is a core component of the
75GNOME desktop project.
76
77%description -l ja
78Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
79リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
80豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
81のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
82プロジェクトのコア・コンポーネントです。
83
84
85%package        devel
86Summary:        Support for developing nautilus extensions
87Summary(ja):    Nautilus 拡張機能開発のためのサポート
88License:        LGPLv2+
89Group:          Development/Libraries
90Requires:       %{name}-libs = %{version}-%{release}
91Requires:       pkgconfig
92
93%description    devel
94This package provides libraries and header files needed
95for developing nautilus extensions.
96
97%description -l ja devel
98このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
99ヘッダファイルを提供します。
100
101
102%package        libs
103Summary:        Libraries for use in nautilus extentions
104Summary(ja):    Nautilus 拡張機能で利用するライブラリ
105Group:          System Environment/Libraries
106
107%description    libs
108This package provides libraries required by nautilus extention
109module.
110
111%description -l ja libs
112このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
113
114
115%package        docs
116Summary:        Documentation for %{name}
117Summary(ja):    %{name} 用のドキュメント
118Group:          Documentation
119BuildArch:      noarch
120
121%description    docs
122This package contains documentation for %{name}.
123
124
125%prep
126%setup -q -n %{name}-%{version}
127
128%patch102 -p1 -b .vine
129%patch2000 -p1 -b .vine
130
131%build
132gtkdocize
133libtoolize --force --copy
134autoreconf -f -i
135CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
136%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
137
138make %{?_smp_mflags}
139
140%install
141rm -rf $RPM_BUILD_ROOT
142
143make install DESTDIR=$RPM_BUILD_ROOT
144
145# make sure desktop files validate by ignoring sr@Latn
146perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
147# desktop-file-install can't handle empty OnlyShowIn correctly
148perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
149
150desktop-file-install --vendor gnome --delete-original       \
151  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
152  --add-only-show-in GNOME                                  \
153  $RPM_BUILD_ROOT%{_datadir}/applications/*
154
155find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
156
157%find_lang %name
158
159%clean
160rm -rf $RPM_BUILD_ROOT
161
162%postun
163if [ $1 -eq 0 ] ; then
164    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
165fi
166
167%posttrans
168glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
169
170%post libs -p /sbin/ldconfig
171%postun libs -p /sbin/ldconfig
172
173
174%files  -f %{name}.lang
175%defattr(-,root,root,-)
176%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
177%dir %{_libdir}/nautilus
178%dir %{_libdir}/nautilus/extensions-3.0
179%{_libdir}/nautilus/extensions-3.0/*.so
180%{_libexecdir}/nautilus-convert-metadata
181%{_datadir}/GConf/gsettings/nautilus.convert
182%{_datadir}/appdata/org.gnome.Nautilus.appdata.xml
183%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
184%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
185%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
186%{_datadir}/applications
187%{_bindir}/*
188%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
189%{_datadir}/glib-2.0/schemas/
190%{_mandir}/man1/*
191
192%files devel
193%defattr(-,root,root,-)
194%{_includedir}/nautilus
195%{_libdir}/pkgconfig/*
196%{_libdir}/*.so
197%{_datadir}/gir-1.0
198
199%files libs
200%defattr(-,root,root,-)
201%{_libdir}/*.so.*
202%{_libdir}/girepository-1.0/*.typelib
203
204%files docs
205%defattr(-,root,root,-)
206%{_datadir}/gtk-doc/html/libnautilus-extension/*
207
208
209%changelog
210* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
211- new upstream release
212- update Patch2000 (nautilus-vine-settings.patch)
213- create %%{name}-docs subpackage
214
215* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.2-2
216- moved libs subpackage to System Environment/Libraries Group
217
218* Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
219- new upstream release
220
221* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
222- new upstream release
223- remove Patch0 (nautilus-3.14.0-git20141015.patch)
224
225* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
226- new upstream release
227- add Patch0 (nautilus-3.14.0-git20141015.patch)
228
229* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
230- new upstream release
231
232* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
233- new upstream release
234
235* Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
236- new upstream release
237
238* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
239- new upstream release
240- add Patch2000 (nautilus-vine-settings.patch)
241
242* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
243- new upstream release
244
245* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
246- new upstream release
247
248* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
249- new upstream release
250
251* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
252- new upstream release
253
254* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
255- new upstream release
256
257* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
258- new upstream release
259- remove Patch0,7
260- add BuildRequires: exempi-devel, tracker-devel
261
262* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
263- add Patch0 (nautilus-3.4.2-ja.po.patch)
264
265* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
266- new upstream release
267
268* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
269- new upstream release
270
271* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
272- added patch102 to fix autostart in other desktop environments
273  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
274
275* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
276- new upstream release
277
278* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
279- new upstream release
280
281* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
282- new upstream release
283
284* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
285- new upstream release
286
287* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
288- new upstream release
289- drop Patch101
290- change BuildRequires: gtk3-devel instread of gtk2-devel
291- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
292- change BuildRequires: unique3-devel instread of unique-devel
293- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
294
295* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
296- fixed group of libs
297- add translation of summary and description.
298- add Vendor, Distribution and Packager tags.
299
300* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
301- new upstream release
302
303* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
304- new upstream release
305
306* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
307 - new upstream release
308
309* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
310- new upstream release
311- add BuildRequires: gobject-introspection-devel
312- remove BuildRequires: libgnomeui-devel
313- add configure option (--enable-introspection=yes)
314
315* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
316- rebuild with rpm-4.8.1 for pkg-config file
317
318* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
319- split nautilus extention libraries to -libs subpackage.
320
321* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
322- new upstream release
323
324* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
325- new upstream release
326- drop Patch100
327- add Patch101
328- add Obsoletes: eel2 <= 2.24.1
329- add Provides: eel2 <= 2.24.1
330
331* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
332- new upstream release
333- add BuildRequires: libSM-devel
334
335* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
336- removed Requires: eel2
337- added %%posttrans section
338
339* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
340- new upstream release
341
342* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
343- new upstream release
344
345* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
346- new upstream release
347
348* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
349- new upstream release
350- split -devel subpackage
351
352* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
353- new upstream release
354
355* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
356- patch6 needs autoreconf
357
358* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
359- new upstream release
360
361* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
362- new upstream release
363
364* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
365- new upstream release
366- added Requires: gvfs
367
368* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
369- new upstream release
370- added Patches from FC
371  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
372  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
373  - Fix a crash in the Properties dialog while changing owner (patch from head)
374  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
375  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
376
377* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
378- new upstream release
379- dropped Patch11-13 and added Patch7-9 from Fedora
380  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
381  - Add patch from upstream to get audio preview working again
382    (#332251)
383  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
384  - Fix a crash with small fonts (#242350)
385  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
386  - Backport fixes for async thumbnail loading from svn
387
388* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
389- run autoreconf for Patch11 changes
390
391* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
392- remove tracker dependancy, Patch13 detects tracker dynamically.
393
394* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
395- add Patch13 to support user-dirs
396
397* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
398- new upstream release
399- enable tracker support
400- add BuildRequires: tracker-devel, Requires: tracker
401
402* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
403- new upstream release
404
405* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
406- add BuildRequires: gamin-devel, Requires: gamin
407- remove fam dependency (replaced by gamin)
408
409* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
410- new upsteram release
411
412* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
413- really applied Patch110...
414
415* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
416- add Patch110 to fix corruption of help option message.
417
418* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
419- new upstream release
420
421* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
422- fix typo in ja.po
423
424* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
425- update ja.po to translate patch50 related message.
426
427* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
428- add Patch50 to show progressbar on umounting
429  (ubuntu patch in Bug 313639)
430
431* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
432- new upstream release
433
434* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
435- add Patch10 to avoid background rendering delay
436
437* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
438- new upstream release
439
440* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
441- add fix-non-UTF-8-encoding.patch (patch0)
442  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
443
444* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
445- new upstream release
446
447* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
448- new upstream release
449
450* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
451- new upstream release
452
453* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
454- new upstream release
455
456* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
457- rebuild
458
459* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
460- new upstream version
461
462* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
463- new upstream version
464
465* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
466- add vine patch to change some defaults.
467  - change default zoom sine
468  - set always_use_browser
469
470* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
471- new upstream release
472
473* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
474- add Patch110 to fix libegg(egg-recent-model.c)
475  save old umask value before create ".recently-used" file.
476 
477* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
478- change default desktop font to Sans 9 (from Sans 10)
479- add patch10 to build with gtk+-2.4
480
481* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
482- new upstream release
483
484* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
485- new upstream release
486
487* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
488- add backport patch from rawhide (Patch10)
489
490* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
491- modified vine patch
492  - change default zoom level to small
493  - change desktop font to Sans 10
494
495* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
496- new upstream release
497
498* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
499- add desktop icon patch from rawhide
500
501* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
502- remove obsolete ja.po
503
504* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
505- new upstream release
506
507* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
508- new upstream release
509
510* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
511- new upstream release
512
513* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
514- update ja.po
515
516* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
517- new upstream release
518
519* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
520- new upstream release
521
522* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
523- new upstream release
524
525* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
526- new upstream release
527
528* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
529- new upstream release
530
531* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
532- new upstream release
533
534* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
535- add nautilus-cd-burner patch
536
537* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
538- new upstream release
539
540* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
541- discard scrollkeeper outputs.
542- update PreReq tags.
543
544* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
545- change icon for nautilus-file-management-properties
546- update ja.po
547
548* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
549- update ja.po
550- add translation for .desktop files.
551
552* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
553- add Requires: vine-menus
554
555* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
556- new upstream release
557
558* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
559- remove redhatize patch
560
561* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
562- rebuild to remove unneeded dependancy.
563
564* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
565- build for Vine Linux
566
567* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
568- add explicit startup-notification dependency because build system is
569  dumb
570- 2.1.3
571
572* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
573- 2.1.2
574
575* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
576- 2.0.7
577- remove patches that are upstream
578
579* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
580- Add badhack to make weblinks on desktop work
581
582* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
583- fix #70667 assertion failures
584- fix triple click patch
585
586* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
587- don't activate on double click
588
589* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
590- put button press mask in triple-click patch, maybe it will work
591- remove html-hack patch as it does nothing useful
592
593* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
594- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
595  bogus bug reports
596- add hack for HTML mime type handling in a web browser, not
597  nautilus
598
599* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
600- Updated to 2.0.6. Removed the patches I put upstream.
601- Added patch that fixes #72410
602
603* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
604- Add a simple patch so that redhat-config-packages can disable
605  the new window behavior for mounted CDs behavior.
606
607* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
608- Add patch to fix bug #70667
609
610* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
611- remove mp3
612
613* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
614- ignore the "add_to_session" preference as it only broke stuff
615- pad the left margin a bit to cope with poor word wrapping
616
617* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
618- Update to 2.0.5, remove topleft icon patch
619
620* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
621- Add patch to fix the bug where desktop icons get
622  stuck in the top left corner on startup
623
624* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
625- 2.0.4
626
627* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
628- obsolete nautilus-mozilla < 2.0 #69839
629
630* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
631- add rhconfig patch to Bluecurve theme and disable sidebar by default
632
633* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
634- drop start here files, require redhat-menus that has them
635
636* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
637- 2.0.3
638
639* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
640- build for new eel2, gail
641
642* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
643- and add the libexec components, mumble
644
645* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
646- put the components in the file list, were moved upstream
647
648* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
649- 2.0.1
650
651* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
652- Relibtoolize to fix relink problems for solib components
653- Add LANG=en_US to %makeinstall as well
654- Back out previous change, force locale to en_US to prevent UTF-8 problems
655- Add workaround for intltool-merge bug on ia64
656
657* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
658- automated rebuild
659
660* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
661- 2.0.0
662- use desktop-file-install
663- require desktop-backgrounds-basic
664
665* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
666- add wacky hack in hopes of fixing the hang-on-login thing
667
668* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
669- add build requires on new gail
670- rebuild to try to lose broken libgailutil.so.13 dependency
671
672* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
673- rebuild in different environment
674
675* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
676- 1.1.19
677
678* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
679- rebuild in different environment
680
681* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
682- really remove nautilus-devel if we are going to obsolete it
683- don't require hwbrowser
684
685* Sun May 26 2002 Tim Powers <timp@redhat.com>
686- automated rebuild
687
688* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
689- rebuild in different environment
690
691* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
692- 1.1.17
693
694* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
695- 1.1.14
696
697* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
698- require eog
699- obsolete nautilus-devel
700- fix name of schemas file in post
701
702* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
703- Update to 1.1.13
704
705* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
706- put tree view in file list
707
708* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
709- nautilus for gnome 2
710- clean up the spec file and file list a bit
711
712* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
713- merge translations
714
715* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
716- Add patch to fix trash crash
717
718* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
719- fix for metadata tmp race
720- backport thumbnail speed fix and thumbnail inf. loop fix
721
722* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
723- add some fixes from CVS version, including one for #61819 and a couple segfaults
724
725* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
726- fix thumbnails for files with future timestamp, #56862
727
728* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
729- buildrequires intltool #60633
730- apply Alex's pixbuf cache patch to save a few megs #60581
731
732* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
733- drop Milan-specific features, including png10 and ac25 patches
734- copy in 1.0.5 help component to avoid large risky patch
735- remove .la files
736- drop mozilla from ia64 again
737- remove oaf file from nautilus-mozilla that was also in the base
738  package
739
740* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
741- enable mozilla support on ia64
742
743* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
744- require Mozilla 0.9.7
745- Add patch that puts mozilla profile startup before embedding is initialized
746
747* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
748- 1.0.6, require Mozilla 0.9.6
749
750* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
751- Update to 1.0.5
752
753* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
754- Fix handling of GnomeVFSFileInfo structure (#53315)
755
756* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
757- Change handling of names on unmount to fix #52325
758
759* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
760- put nautilus-help.desktop in file list; #53109
761
762* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
763- Add po files from sources.redhat.com
764
765* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
766- Add po files from sources.redhat.com
767
768* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
769- Added patch to fix the .directory issuer
770
771* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
772- I screwed up the build yesterday, so it didn't actually contain the
773  fixes mentioned. This build should contain them.
774
775* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
776- fix bug causing 32000 stats or so in large directories,
777  should speed things up somewhat
778- fix #52104 via gruesome kdesktop-detection hack and setting
779  window type hint on our desktop window
780- fix so Start Here icon displays in sidebar
781- don't load non-local .desktop files
782
783* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
784- make Programs icon into a link, to match the other .desktop files
785- own various directories #51164
786- web page titles in Japanese, #51709
787- tree defaults to only directories #51850
788
789* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
790- make start here icon work again
791- kill some warning spew, #51661
792- cache getpwnam() results to speed things up a bit
793
794* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
795- Fix problem with missing desktop starthere.desktop file
796- New snapshot from our branch, fixes:
797  - On upgrade, icons migrated from GNOME desktop are not properly lined up
798    (#51436)
799  - icons dropped on the desktop don't end up where dropped. (#51441)
800  - Nautilus shouldn't have fam monitor read-only windows. This
801    keeps CDROMS from being unmounted until you close all
802
803    nautilus windows pointing to them. (#51442)
804  - Warnings about 'cannot statfs...' when moving items to trash.
805- Use separate start-here.desktop for panel, since the one used
806  for the root window only works from Nautilus.
807
808* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
809- Changed starthere .desktop files to be links instead
810- of spawning a new nautilus. This makes start-here:
811- much faster.
812
813* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
814- Added hwbrowser dependency
815- New snapshot, fixes the mozilla-view submit form problem
816
817* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
818- Rebuild with new xml-i18n-tools
819- fix crash in creating new desktop files
820
821* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
822- Fix up DnD code some more
823
824* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
825- Sync our CVS version; fixes some MUSTFIX
826  (the one about drawing background on startup,
827   properly translate desktop files, etc.)
828
829* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
830- Fix 64bit cleanness issue
831- Fix NULL mimetype crash
832- Disable additional_text for .desktop files
833
834* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
835- Fix unmounting devices.
836
837* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
838- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
839- mimetype sniffing.
840
841* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
842- Remove the "don't run as root" warning.
843- Remove eazel from bookmarks
844- langified (again? did someone change it?)
845
846* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
847- Apply a patch that makes nautilus dnd reset work with the latest
848- eel release.
849
850* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
851- Build on ia64 without the mozilla component.
852
853* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
854- Fix crash-on-startup showstopper
855- Fix can't-find-images bug (this one was only showing up
856  when built with debug symbols, since it was an uninitialized memory
857  read)
858
859* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
860- sync new tarball from our CVS branch,
861  fixes some drag-and-drop, changes URI scheme names,
862  etc.
863
864* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
865- Add BuildRequires (#49539, 49537)
866- Fix %%post, %%postun (#49720)
867- Background efficiency improvements and hacks
868
869* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
870- Don't launch esd on each mouseover.
871
872* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
873- move first time druid patch into my "CVS outstanding" patch
874- try to really remove Help/Feedback
875- try to really fix Help/Community Support
876- try again to get Start Here in the Go menu
877- try again to get Start Here on the desktop
878- don't show file sizes for .desktop files
879
880* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
881- add newline to ends of .desktop files that were missing them
882
883* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
884- update to my latest 'cvs diff -u' (adds default
885  Start Here link, displays .directory name in sidebar)
886- include /etc/X11/* links (starthere, sysconfig, serverconfig)
887
888* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
889- Patch to remove firsttime druid and flash
890
891* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
892- add hacks for displaying desktop files
893- add hack to turn off the "unwriteable" emblem
894
895* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
896- added defattr to the files lists to be (-,root,root)
897- languified
898
899* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
900- Need to run autoheader too.
901
902* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
903- Make the fam dependency a real runtime dependency
904- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
905- Cleaned up specfile.
906
907* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
908- Change default background and rubberband color.
909- Use the sidebar tabs from the default theme
910- BuildDepend on fam-devel, depend on fam
911- Disable the eazel update pages in the first-time druid.
912- Remove the eazel logo from the first-time druid
913
914* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
915- 1.0.4, removes eazel services icon and wizard page
916- Eazel logo is still in startup wizard for now, needs fixing
917
918* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
919- fix group (s/Desktop/Desktops/) #47134
920- remove ammonite dependency
921
922* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
923- add a different default theme
924- clean up file list overspecificity a bit
925
926* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
927- move to a CVS snapshot of nautilus for now
928  (Darin is my hero for having distcheck work out of CVS)
929
930* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
931- clean up defaults a bit
932
933* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
934- New version
935
936* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
937- Added BuildRequires lines
938- Changed Source to point to ftp.gnome.org instead of just the tarball name
939- Moved %description sections closer to their %package sections
940- Moved %changelog to the end, where so that it's not in the way
941- Changed configure and make install options to allow moving of
942  libraries, includes, binaries more easily
943- Removed hard-coded paths (don't define %prefix or %docdir)
944- replace %{prefix}/bin with %{_bindir}
945- replace %{prefix}/share with %{_datadir}
946- replace %{prefix}/lib with %{_libdir}
947- replace %{prefix}/include with %{_includedir}
948
949* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
950- removed obsoletes from sub packages and added mozilla and trilobite
951subpackages
952
953* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
954- created this thing
Note: See TracBrowser for help on using the repository browser.