source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 926

Revision 926, 27.5 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release (gnome packages)

Line 
1%define glib2_version 2.24.0
2%define pango_version 1.28.0
3%define gtk2_version 2.20.0
4%define libgnomeui_version 2.24.3
5%define libxml2_version 2.5.10
6%define eog_version 2.30.0
7%define desktop_file_utils_version 0.3
8%define gnome_desktop_version 2.30.0
9%define vine_menus_version 3.0
10%define gnome_menus_version 2.30.0
11%define gnome_vfs2_version 2.24.1
12%define startup_notification_version 0.5
13%define libexif_version 0.5.12
14%define gconf_version 2.28.0
15
16Name:           nautilus
17Summary:        Nautilus is a file manager for GNOME
18Summary(ja):    Nautilus - GNOME ファイルマネージャ
19Version:        2.30.1
20Release:        1%{?_dist_release}
21License:        GPLv2+
22Group:          User Interface/Desktops
23URL:            http://www.gnome.org/projects/nautilus/
24
25Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.28/%{name}-%{version}.tar.bz2
26
27# Some changes to default config
28Patch1:         nautilus-2.5.7-rhconfig.patch
29Patch3:         background-no-delay.patch
30
31# Why is this not upstream ?
32Patch6:         nautilus-2.23.5-dynamic-search.patch
33
34Patch7:         rtl-fix.patch
35
36# vine
37Patch100:       nautilus-2.8.2-vine.patch
38Patch101:       nautilus-2.30.0-vine.patch
39
40BuildRoot:      %{_tmppath}/%{name}-%{version}-root
41Requires:       gamin
42Requires:       vine-menus >= %{vine_menus_version}
43Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
44Requires:       libexif >= %{libexif_version}
45
46Requires(pre,preun,post): GConf2 >= %{gconf_version}
47Requires(post,postun): rarian-compat
48
49BuildRequires:  glib2-devel >= %{glib2_version}
50BuildRequires:  pango-devel >= %{pango_version}
51BuildRequires:  gtk2-devel >= %{gtk2_version}
52BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
53BuildRequires:  libxml2-devel >= %{libxml2_version}
54BuildRequires:  gnome-desktop-devel >= %{gnome_desktop_version}
55BuildRequires:  gamin-devel
56BuildRequires:  intltool
57BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
58BuildRequires:  libtool >= 1.4.2-10
59BuildRequires:  automake, autoconf
60BuildRequires:  startup-notification-devel >= %{startup_notification_version}
61#BuildRequires: tracker-devel >= %{tracker_version}
62BuildRequires:  libexif-devel  >= %{libexif_version}
63BuildRequires:  unique-devel
64BuildRequires:  libtool, autoconf
65BuildRequires:  libSM-devel
66
67Obsoletes:      nautilus-extras
68Obsoletes:      nautilus-suggested
69Obsoletes:      nautilus-mozilla < 2.0
70Obsoletes:      eel2 <= 2.24.1
71
72Provides:       eel2 <= 2.24.1
73
74
75%description
76Nautilus integrates access to files, applications, media,
77Internet-based resources and the Web. Nautilus delivers a dynamic and
78rich user experience. Nautilus is an free software project developed
79under the GNU General Public License and is a core component of the
80GNOME desktop project.
81
82%package devel
83Summary: Support for developing nautilus extensions
84License: LGPLv2+
85Group: Development/Libraries
86Requires: %{name} = %{version}-%{release}
87Requires: pkgconfig
88
89%description devel
90This package provides libraries and header files needed
91for developing nautilus extensions.
92
93%prep
94%setup -q -n %{name}-%{version}
95
96##patch3 -p1 -b .no-delay
97#%patch5 -p1 -b .selinux
98##patch6 -p1 -b .dynamic-search
99%patch7 -p1 -b .rtl-fix
100
101## %patch100 -p1 -b .vine
102%patch101 -p1 -b .vine
103
104%build
105gtkdocize
106libtoolize --force --copy
107autoreconf -f -i
108CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
109%configure --disable-more-warnings --disable-update-mimedb
110
111export tagname=CC
112LANG=en_US make LIBTOOL=/usr/bin/libtool %{?_smp_mflags}
113
114%install
115rm -rf $RPM_BUILD_ROOT
116
117export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
118export tagname=CC
119LANG=en_US %makeinstall LIBTOOL=/usr/bin/libtool
120unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
121
122## these are in desktop-backgrounds-basic
123## (uncomment when we patch the source to look in the right place)
124## /bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/nautilus/patterns
125
126# make sure desktop files validate by ignoring sr@Latn
127perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
128# desktop-file-install can't handle empty OnlyShowIn correctly
129perl -pi -e 's/OnlyShowIn=;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
130
131desktop-file-install --vendor gnome --delete-original       \
132  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
133  --add-only-show-in GNOME                                  \
134  $RPM_BUILD_ROOT%{_datadir}/applications/*
135
136perl -pi -e 's/OnlyShowIn=GNOME;/OnlyShowIn=;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
137
138rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{la,a}
139rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
140rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
141
142mkdir -p $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-2.0
143
144%find_lang %name
145
146%clean
147rm -rf $RPM_BUILD_ROOT
148
149%post
150/sbin/ldconfig
151touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
152export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
153gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
154
155%posttrans
156%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null ||:
157gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
158scrollkeeper-update > /dev/null 2>&1 || :
159
160%pre
161if [ "$1" -gt 1 ]; then
162    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
163    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
164fi
165
166%preun
167if [ "$1" -eq 0 ]; then
168    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
169    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
170fi
171
172%postun
173/sbin/ldconfig
174if [ $1 -eq 0 ] ; then
175    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
176    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
177    scrollkeeper-update > /dev/null 2>&1 || :
178fi
179
180%files  -f %{name}.lang
181%defattr(-,root,root)
182%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
183%{_libdir}/*.so.*
184%dir %{_libdir}/nautilus
185%dir %{_libdir}/nautilus/extensions-2.0
186%{_libexecdir}/nautilus-convert-metadata
187%{_datadir}/nautilus
188%{_datadir}/pixmaps
189%{_datadir}/applications
190%{_datadir}/mime/*
191%{_datadir}/icons/hicolor/*
192%{_bindir}/*
193%{_sysconfdir}/gconf/schemas/*
194%{_mandir}/man1/*
195
196%files devel
197%defattr(-, root, root)
198%{_includedir}/nautilus
199%{_libdir}/pkgconfig/*
200%{_libdir}/*.so
201%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
202
203
204%changelog
205* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
206- new upstream release
207
208* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
209- new upstream release
210- drop Patch100
211- add Patch101
212- add Obsoletes: eel2 <= 2.24.1
213- add Provides: eel2 <= 2.24.1
214
215* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
216- new upstream release
217- add BuildRequires: libSM-devel
218
219* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
220- removed Requires: eel2
221- added %%posttrans section
222
223* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
224- new upstream release
225
226* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
227- new upstream release
228
229* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
230- new upstream release
231
232* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
233- new upstream release
234- split -devel subpackage
235
236* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
237- new upstream release
238
239* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
240- patch6 needs autoreconf
241
242* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
243- new upstream release
244
245* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
246- new upstream release
247
248* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
249- new upstream release
250- added Requires: gvfs
251
252* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
253- new upstream release
254- added Patches from FC
255  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
256  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
257  - Fix a crash in the Properties dialog while changing owner (patch from head)
258  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
259  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
260
261* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
262- new upstream release
263- dropped Patch11-13 and added Patch7-9 from Fedora
264  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
265  - Add patch from upstream to get audio preview working again
266    (#332251)
267  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
268  - Fix a crash with small fonts (#242350)
269  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
270  - Backport fixes for async thumbnail loading from svn
271
272* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
273- run autoreconf for Patch11 changes
274
275* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
276- remove tracker dependancy, Patch13 detects tracker dynamically.
277
278* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
279- add Patch13 to support user-dirs
280
281* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
282- new upstream release
283- enable tracker support
284- add BuildRequires: tracker-devel, Requires: tracker
285
286* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
287- new upstream release
288
289* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
290- add BuildRequires: gamin-devel, Requires: gamin
291- remove fam dependency (replaced by gamin)
292
293* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
294- new upsteram release
295
296* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
297- really applied Patch110...
298
299* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
300- add Patch110 to fix corruption of help option message.
301
302* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
303- new upstream release
304
305* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
306- fix typo in ja.po
307
308* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
309- update ja.po to translate patch50 related message.
310
311* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
312- add Patch50 to show progressbar on umounting
313  (ubuntu patch in Bug 313639)
314
315* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
316- new upstream release
317
318* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
319- add Patch10 to avoid background rendering delay
320
321* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
322- new upstream release
323
324* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
325- add fix-non-UTF-8-encoding.patch (patch0)
326  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
327
328* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
329- new upstream release
330
331* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
332- new upstream release
333
334* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
335- new upstream release
336
337* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
338- new upstream release
339
340* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
341- rebuild
342
343* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
344- new upstream version
345
346* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
347- new upstream version
348
349* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
350- add vine patch to change some defaults.
351  - change default zoom sine
352  - set always_use_browser
353
354* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
355- new upstream release
356
357* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
358- add Patch110 to fix libegg(egg-recent-model.c)
359  save old umask value before create ".recently-used" file.
360 
361* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
362- change default desktop font to Sans 9 (from Sans 10)
363- add patch10 to build with gtk+-2.4
364
365* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
366- new upstream release
367
368* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
369- new upstream release
370
371* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
372- add backport patch from rawhide (Patch10)
373
374* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
375- modified vine patch
376  - change default zoom level to small
377  - change desktop font to Sans 10
378
379* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
380- new upstream release
381
382* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
383- add desktop icon patch from rawhide
384
385* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
386- remove obsolete ja.po
387
388* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
389- new upstream release
390
391* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
392- new upstream release
393
394* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
395- new upstream release
396
397* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
398- update ja.po
399
400* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
401- new upstream release
402
403* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
404- new upstream release
405
406* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
407- new upstream release
408
409* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
410- new upstream release
411
412* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
413- new upstream release
414
415* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
416- new upstream release
417
418* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
419- add nautilus-cd-burner patch
420
421* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
422- new upstream release
423
424* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
425- discard scrollkeeper outputs.
426- update PreReq tags.
427
428* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
429- change icon for nautilus-file-management-properties
430- update ja.po
431
432* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
433- update ja.po
434- add translation for .desktop files.
435
436* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
437- add Requires: vine-menus
438
439* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
440- new upstream release
441
442* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
443- remove redhatize patch
444
445* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
446- rebuild to remove unneeded dependancy.
447
448* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
449- build for Vine Linux
450
451* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
452- add explicit startup-notification dependency because build system is
453  dumb
454- 2.1.3
455
456* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
457- 2.1.2
458
459* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
460- 2.0.7
461- remove patches that are upstream
462
463* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
464- Add badhack to make weblinks on desktop work
465
466* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
467- fix #70667 assertion failures
468- fix triple click patch
469
470* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
471- don't activate on double click
472
473* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
474- put button press mask in triple-click patch, maybe it will work
475- remove html-hack patch as it does nothing useful
476
477* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
478- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
479  bogus bug reports
480- add hack for HTML mime type handling in a web browser, not
481  nautilus
482
483* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
484- Updated to 2.0.6. Removed the patches I put upstream.
485- Added patch that fixes #72410
486
487* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
488- Add a simple patch so that redhat-config-packages can disable
489  the new window behavior for mounted CDs behavior.
490
491* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
492- Add patch to fix bug #70667
493
494* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
495- remove mp3
496
497* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
498- ignore the "add_to_session" preference as it only broke stuff
499- pad the left margin a bit to cope with poor word wrapping
500
501* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
502- Update to 2.0.5, remove topleft icon patch
503
504* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
505- Add patch to fix the bug where desktop icons get
506  stuck in the top left corner on startup
507
508* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
509- 2.0.4
510
511* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
512- obsolete nautilus-mozilla < 2.0 #69839
513
514* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
515- add rhconfig patch to Bluecurve theme and disable sidebar by default
516
517* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
518- drop start here files, require redhat-menus that has them
519
520* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
521- 2.0.3
522
523* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
524- build for new eel2, gail
525
526* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
527- and add the libexec components, mumble
528
529* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
530- put the components in the file list, were moved upstream
531
532* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
533- 2.0.1
534
535* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
536- Relibtoolize to fix relink problems for solib components
537- Add LANG=en_US to %makeinstall as well
538- Back out previous change, force locale to en_US to prevent UTF-8 problems
539- Add workaround for intltool-merge bug on ia64
540
541* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
542- automated rebuild
543
544* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
545- 2.0.0
546- use desktop-file-install
547- require desktop-backgrounds-basic
548
549* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
550- add wacky hack in hopes of fixing the hang-on-login thing
551
552* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
553- add build requires on new gail
554- rebuild to try to lose broken libgailutil.so.13 dependency
555
556* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
557- rebuild in different environment
558
559* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
560- 1.1.19
561
562* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
563- rebuild in different environment
564
565* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
566- really remove nautilus-devel if we are going to obsolete it
567- don't require hwbrowser
568
569* Sun May 26 2002 Tim Powers <timp@redhat.com>
570- automated rebuild
571
572* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
573- rebuild in different environment
574
575* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
576- 1.1.17
577
578* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
579- 1.1.14
580
581* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
582- require eog
583- obsolete nautilus-devel
584- fix name of schemas file in post
585
586* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
587- Update to 1.1.13
588
589* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
590- put tree view in file list
591
592* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
593- nautilus for gnome 2
594- clean up the spec file and file list a bit
595
596* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
597- merge translations
598
599* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
600- Add patch to fix trash crash
601
602* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
603- fix for metadata tmp race
604- backport thumbnail speed fix and thumbnail inf. loop fix
605
606* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
607- add some fixes from CVS version, including one for #61819 and a couple segfaults
608
609* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
610- fix thumbnails for files with future timestamp, #56862
611
612* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
613- buildrequires intltool #60633
614- apply Alex's pixbuf cache patch to save a few megs #60581
615
616* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
617- drop Milan-specific features, including png10 and ac25 patches
618- copy in 1.0.5 help component to avoid large risky patch
619- remove .la files
620- drop mozilla from ia64 again
621- remove oaf file from nautilus-mozilla that was also in the base
622  package
623
624* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
625- enable mozilla support on ia64
626
627* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
628- require Mozilla 0.9.7
629- Add patch that puts mozilla profile startup before embedding is initialized
630
631* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
632- 1.0.6, require Mozilla 0.9.6
633
634* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
635- Update to 1.0.5
636
637* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
638- Fix handling of GnomeVFSFileInfo structure (#53315)
639
640* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
641- Change handling of names on unmount to fix #52325
642
643* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
644- put nautilus-help.desktop in file list; #53109
645
646* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
647- Add po files from sources.redhat.com
648
649* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
650- Add po files from sources.redhat.com
651
652* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
653- Added patch to fix the .directory issuer
654
655* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
656- I screwed up the build yesterday, so it didn't actually contain the
657  fixes mentioned. This build should contain them.
658
659* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
660- fix bug causing 32000 stats or so in large directories,
661  should speed things up somewhat
662- fix #52104 via gruesome kdesktop-detection hack and setting
663  window type hint on our desktop window
664- fix so Start Here icon displays in sidebar
665- don't load non-local .desktop files
666
667* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
668- make Programs icon into a link, to match the other .desktop files
669- own various directories #51164
670- web page titles in Japanese, #51709
671- tree defaults to only directories #51850
672
673* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
674- make start here icon work again
675- kill some warning spew, #51661
676- cache getpwnam() results to speed things up a bit
677
678* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
679- Fix problem with missing desktop starthere.desktop file
680- New snapshot from our branch, fixes:
681  - On upgrade, icons migrated from GNOME desktop are not properly lined up
682    (#51436)
683  - icons dropped on the desktop don't end up where dropped. (#51441)
684  - Nautilus shouldn't have fam monitor read-only windows. This
685    keeps CDROMS from being unmounted until you close all
686
687    nautilus windows pointing to them. (#51442)
688  - Warnings about 'cannot statfs...' when moving items to trash.
689- Use separate start-here.desktop for panel, since the one used
690  for the root window only works from Nautilus.
691
692* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
693- Changed starthere .desktop files to be links instead
694- of spawning a new nautilus. This makes start-here:
695- much faster.
696
697* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
698- Added hwbrowser dependency
699- New snapshot, fixes the mozilla-view submit form problem
700
701* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
702- Rebuild with new xml-i18n-tools
703- fix crash in creating new desktop files
704
705* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
706- Fix up DnD code some more
707
708* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
709- Sync our CVS version; fixes some MUSTFIX
710  (the one about drawing background on startup,
711   properly translate desktop files, etc.)
712
713* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
714- Fix 64bit cleanness issue
715- Fix NULL mimetype crash
716- Disable additional_text for .desktop files
717
718* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
719- Fix unmounting devices.
720
721* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
722- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
723- mimetype sniffing.
724
725* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
726- Remove the "don't run as root" warning.
727- Remove eazel from bookmarks
728- langified (again? did someone change it?)
729
730* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
731- Apply a patch that makes nautilus dnd reset work with the latest
732- eel release.
733
734* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
735- Build on ia64 without the mozilla component.
736
737* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
738- Fix crash-on-startup showstopper
739- Fix can't-find-images bug (this one was only showing up
740  when built with debug symbols, since it was an uninitialized memory
741  read)
742
743* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
744- sync new tarball from our CVS branch,
745  fixes some drag-and-drop, changes URI scheme names,
746  etc.
747
748* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
749- Add BuildRequires (#49539, 49537)
750- Fix %%post, %%postun (#49720)
751- Background efficiency improvements and hacks
752
753* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
754- Don't launch esd on each mouseover.
755
756* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
757- move first time druid patch into my "CVS outstanding" patch
758- try to really remove Help/Feedback
759- try to really fix Help/Community Support
760- try again to get Start Here in the Go menu
761- try again to get Start Here on the desktop
762- don't show file sizes for .desktop files
763
764* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
765- add newline to ends of .desktop files that were missing them
766
767* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
768- update to my latest 'cvs diff -u' (adds default
769  Start Here link, displays .directory name in sidebar)
770- include /etc/X11/* links (starthere, sysconfig, serverconfig)
771
772* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
773- Patch to remove firsttime druid and flash
774
775* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
776- add hacks for displaying desktop files
777- add hack to turn off the "unwriteable" emblem
778
779* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
780- added defattr to the files lists to be (-,root,root)
781- languified
782
783* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
784- Need to run autoheader too.
785
786* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
787- Make the fam dependency a real runtime dependency
788- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
789- Cleaned up specfile.
790
791* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
792- Change default background and rubberband color.
793- Use the sidebar tabs from the default theme
794- BuildDepend on fam-devel, depend on fam
795- Disable the eazel update pages in the first-time druid.
796- Remove the eazel logo from the first-time druid
797
798* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
799- 1.0.4, removes eazel services icon and wizard page
800- Eazel logo is still in startup wizard for now, needs fixing
801
802* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
803- fix group (s/Desktop/Desktops/) #47134
804- remove ammonite dependency
805
806* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
807- add a different default theme
808- clean up file list overspecificity a bit
809
810* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
811- move to a CVS snapshot of nautilus for now
812  (Darin is my hero for having distcheck work out of CVS)
813
814* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
815- clean up defaults a bit
816
817* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
818- New version
819
820* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
821- Added BuildRequires lines
822- Changed Source to point to ftp.gnome.org instead of just the tarball name
823- Moved %description sections closer to their %package sections
824- Moved %changelog to the end, where so that it's not in the way
825- Changed configure and make install options to allow moving of
826  libraries, includes, binaries more easily
827- Removed hard-coded paths (don't define %prefix or %docdir)
828- replace %{prefix}/bin with %{_bindir}
829- replace %{prefix}/share with %{_datadir}
830- replace %{prefix}/lib with %{_libdir}
831- replace %{prefix}/include with %{_includedir}
832
833* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
834- removed obsoletes from sub packages and added mozilla and trilobite
835subpackages
836
837* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
838- created this thing
Note: See TracBrowser for help on using the repository browser.