source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 9258

Revision 9258, 30.8 KB checked in by inagaki, 9 years ago (diff)

2015-01-13 Ryoichi INAGAKI <ryo1@…>

  • anjuta, nautilus: modified Group
  • openjpeg2: added Group


Line 
1%define glib2_version 2.42.0
2%define pango_version 1.36.3
3%define gtk3_version 3.14.0
4%define libxml2_version 2.9.1
5%define eog_version 3.14.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.14.0
8%define vine_menus_version 3.0
9%define startup_notification_version 0.10
10%define libexif_version 0.6.19
11%define tracker_version 1.0.0
12%define gobject_introspection_version 0.9.8
13
14Name:           nautilus
15Summary:        Nautilus is a file manager for GNOME
16Summary(ja):    Nautilus - GNOME ファイルマネージャ
17Version:        3.14.2
18Release:        2%{?_dist_release}
19License:        GPLv2+
20Group:          User Interface/Desktops
21URL:            http://www.gnome.org/projects/nautilus/
22
23Vendor:         Project Vine
24Distribution:   Vine Linux
25Packager:       Takemikaduchi
26
27Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.14/%{name}-%{version}.tar.xz
28
29# vine
30Patch102:       run_in_gnome.patch
31Patch2000:      nautilus-vine-settings.patch
32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
34Requires:       gamin
35Requires:       vine-menus >= %{vine_menus_version}
36Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
37Requires:       libexif >= %{libexif_version}
38Requires:       %{name}-libs = %{version}-%{release}
39
40BuildRequires:  intltool
41BuildRequires:  libtool >= 1.4.2-10
42BuildRequires:  automake, autoconf
43BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
44
45BuildRequires:  glib2-devel >= %{glib2_version}
46BuildRequires:  pango-devel >= %{pango_version}
47BuildRequires:  gtk3-devel >= %{gtk3_version}
48BuildRequires:  libxml2-devel >= %{libxml2_version}
49BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
50BuildRequires:  gamin-devel
51BuildRequires:  startup-notification-devel >= %{startup_notification_version}
52BuildRequires:  tracker-devel >= %{tracker_version}
53BuildRequires:  libexif-devel >= %{libexif_version}
54BuildRequires:  unique3-devel
55BuildRequires:  libnotify-devel
56BuildRequires:  libSM-devel
57BuildRequires:  exempi-devel
58BuildRequires:  tracker-devel
59BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
60BuildRequires:  gsettings-desktop-schemas
61
62Obsoletes:      nautilus-extras
63Obsoletes:      nautilus-suggested
64Obsoletes:      nautilus-mozilla < 2.0
65Obsoletes:      eel2 <= 2.24.1
66
67Provides:       eel2 <= 2.24.1
68
69
70%description
71Nautilus integrates access to files, applications, media,
72Internet-based resources and the Web. Nautilus delivers a dynamic and
73rich user experience. Nautilus is an free software project developed
74under the GNU General Public License and is a core component of the
75GNOME desktop project.
76
77%description -l ja
78Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
79リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
80豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
81のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
82プロジェクトのコア・コンポーネントです。
83
84%package devel
85Summary: Support for developing nautilus extensions
86Summary(ja): Nautilus 拡張機能開発のためのサポート
87License: LGPLv2+
88Group: Development/Libraries
89Requires: %{name}-libs = %{version}-%{release}
90Requires: pkgconfig
91
92%description devel
93This package provides libraries and header files needed
94for developing nautilus extensions.
95
96%description -l ja devel
97このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
98ヘッダファイルを提供します。
99
100%package libs
101Summary: Libraries for use in nautilus extentions
102Summary(ja): Nautilus 拡張機能で利用するライブラリ
103Group: System Environment/Libraries
104
105%description libs
106This package provides libraries required by nautilus extention
107module.
108
109%description -l ja libs
110このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
111
112%prep
113%setup -q -n %{name}-%{version}
114
115%patch102 -p1 -b .vine
116%patch2000 -p1 -b .vine
117
118%build
119gtkdocize
120libtoolize --force --copy
121autoreconf -f -i
122CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
123%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
124
125make %{?_smp_mflags}
126
127%install
128rm -rf $RPM_BUILD_ROOT
129
130make install DESTDIR=$RPM_BUILD_ROOT
131
132# make sure desktop files validate by ignoring sr@Latn
133perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
134# desktop-file-install can't handle empty OnlyShowIn correctly
135perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
136
137desktop-file-install --vendor gnome --delete-original       \
138  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
139  --add-only-show-in GNOME                                  \
140  $RPM_BUILD_ROOT%{_datadir}/applications/*
141
142find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
143
144%find_lang %name
145
146%clean
147rm -rf $RPM_BUILD_ROOT
148
149%postun
150if [ $1 -eq 0 ] ; then
151    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
152fi
153
154%posttrans
155update-mime-database %{_datadir}/mime &> /dev/null ||:
156glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
157
158%post libs -p /sbin/ldconfig
159%postun libs -p /sbin/ldconfig
160
161
162%files  -f %{name}.lang
163%defattr(-,root,root)
164%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
165%dir %{_libdir}/nautilus
166%dir %{_libdir}/nautilus/extensions-3.0
167%{_libdir}/nautilus/extensions-3.0/*.so
168%{_libexecdir}/nautilus-convert-metadata
169%{_datadir}/GConf/gsettings/nautilus.convert
170%{_datadir}/appdata/org.gnome.Nautilus.appdata.xml
171%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
172%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
173%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
174%{_datadir}/applications
175%{_datadir}/mime/*
176%{_bindir}/*
177%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
178%{_datadir}/glib-2.0/schemas/
179%{_mandir}/man1/*
180
181%files devel
182%defattr(-, root, root)
183%{_includedir}/nautilus
184%{_libdir}/pkgconfig/*
185%{_libdir}/*.so
186%{_datadir}/gir-1.0
187%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
188
189%files libs
190%defattr(-, root, root)
191%{_libdir}/*.so.*
192%{_libdir}/girepository-1.0/*.typelib
193
194
195%changelog
196* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.2-2
197- moved libs subpackage to System Environment/Libraries Group
198
199* Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
200- new upstream release
201
202* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
203- new upstream release
204- remove Patch0 (nautilus-3.14.0-git20141015.patch)
205
206* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
207- new upstream release
208- add Patch0 (nautilus-3.14.0-git20141015.patch)
209
210* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
211- new upstream release
212
213* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
214- new upstream release
215
216* Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
217- new upstream release
218
219* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
220- new upstream release
221- add Patch2000 (nautilus-vine-settings.patch)
222
223* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
224- new upstream release
225
226* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
227- new upstream release
228
229* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
230- new upstream release
231
232* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
233- new upstream release
234
235* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
236- new upstream release
237
238* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
239- new upstream release
240- remove Patch0,7
241- add BuildRequires: exempi-devel, tracker-devel
242
243* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
244- add Patch0 (nautilus-3.4.2-ja.po.patch)
245
246* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
247- new upstream release
248
249* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
250- new upstream release
251
252* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
253- added patch102 to fix autostart in other desktop environments
254  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
255
256* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
257- new upstream release
258
259* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
260- new upstream release
261
262* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
263- new upstream release
264
265* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
266- new upstream release
267
268* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
269- new upstream release
270- drop Patch101
271- change BuildRequires: gtk3-devel instread of gtk2-devel
272- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
273- change BuildRequires: unique3-devel instread of unique-devel
274- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
275
276* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
277- fixed group of libs
278- add translation of summary and description.
279- add Vendor, Distribution and Packager tags.
280
281* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
282- new upstream release
283
284* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
285- new upstream release
286
287* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
288 - new upstream release
289
290* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
291- new upstream release
292- add BuildRequires: gobject-introspection-devel
293- remove BuildRequires: libgnomeui-devel
294- add configure option (--enable-introspection=yes)
295
296* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
297- rebuild with rpm-4.8.1 for pkg-config file
298
299* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
300- split nautilus extention libraries to -libs subpackage.
301
302* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
303- new upstream release
304
305* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
306- new upstream release
307- drop Patch100
308- add Patch101
309- add Obsoletes: eel2 <= 2.24.1
310- add Provides: eel2 <= 2.24.1
311
312* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
313- new upstream release
314- add BuildRequires: libSM-devel
315
316* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
317- removed Requires: eel2
318- added %%posttrans section
319
320* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
321- new upstream release
322
323* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
324- new upstream release
325
326* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
327- new upstream release
328
329* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
330- new upstream release
331- split -devel subpackage
332
333* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
334- new upstream release
335
336* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
337- patch6 needs autoreconf
338
339* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
340- new upstream release
341
342* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
343- new upstream release
344
345* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
346- new upstream release
347- added Requires: gvfs
348
349* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
350- new upstream release
351- added Patches from FC
352  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
353  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
354  - Fix a crash in the Properties dialog while changing owner (patch from head)
355  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
356  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
357
358* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
359- new upstream release
360- dropped Patch11-13 and added Patch7-9 from Fedora
361  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
362  - Add patch from upstream to get audio preview working again
363    (#332251)
364  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
365  - Fix a crash with small fonts (#242350)
366  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
367  - Backport fixes for async thumbnail loading from svn
368
369* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
370- run autoreconf for Patch11 changes
371
372* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
373- remove tracker dependancy, Patch13 detects tracker dynamically.
374
375* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
376- add Patch13 to support user-dirs
377
378* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
379- new upstream release
380- enable tracker support
381- add BuildRequires: tracker-devel, Requires: tracker
382
383* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
384- new upstream release
385
386* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
387- add BuildRequires: gamin-devel, Requires: gamin
388- remove fam dependency (replaced by gamin)
389
390* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
391- new upsteram release
392
393* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
394- really applied Patch110...
395
396* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
397- add Patch110 to fix corruption of help option message.
398
399* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
400- new upstream release
401
402* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
403- fix typo in ja.po
404
405* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
406- update ja.po to translate patch50 related message.
407
408* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
409- add Patch50 to show progressbar on umounting
410  (ubuntu patch in Bug 313639)
411
412* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
413- new upstream release
414
415* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
416- add Patch10 to avoid background rendering delay
417
418* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
419- new upstream release
420
421* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
422- add fix-non-UTF-8-encoding.patch (patch0)
423  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
424
425* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
426- new upstream release
427
428* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
429- new upstream release
430
431* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
432- new upstream release
433
434* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
435- new upstream release
436
437* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
438- rebuild
439
440* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
441- new upstream version
442
443* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
444- new upstream version
445
446* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
447- add vine patch to change some defaults.
448  - change default zoom sine
449  - set always_use_browser
450
451* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
452- new upstream release
453
454* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
455- add Patch110 to fix libegg(egg-recent-model.c)
456  save old umask value before create ".recently-used" file.
457 
458* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
459- change default desktop font to Sans 9 (from Sans 10)
460- add patch10 to build with gtk+-2.4
461
462* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
463- new upstream release
464
465* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
466- new upstream release
467
468* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
469- add backport patch from rawhide (Patch10)
470
471* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
472- modified vine patch
473  - change default zoom level to small
474  - change desktop font to Sans 10
475
476* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
477- new upstream release
478
479* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
480- add desktop icon patch from rawhide
481
482* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
483- remove obsolete ja.po
484
485* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
486- new upstream release
487
488* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
489- new upstream release
490
491* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
492- new upstream release
493
494* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
495- update ja.po
496
497* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
498- new upstream release
499
500* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
501- new upstream release
502
503* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
504- new upstream release
505
506* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
507- new upstream release
508
509* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
510- new upstream release
511
512* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
513- new upstream release
514
515* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
516- add nautilus-cd-burner patch
517
518* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
519- new upstream release
520
521* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
522- discard scrollkeeper outputs.
523- update PreReq tags.
524
525* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
526- change icon for nautilus-file-management-properties
527- update ja.po
528
529* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
530- update ja.po
531- add translation for .desktop files.
532
533* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
534- add Requires: vine-menus
535
536* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
537- new upstream release
538
539* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
540- remove redhatize patch
541
542* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
543- rebuild to remove unneeded dependancy.
544
545* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
546- build for Vine Linux
547
548* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
549- add explicit startup-notification dependency because build system is
550  dumb
551- 2.1.3
552
553* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
554- 2.1.2
555
556* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
557- 2.0.7
558- remove patches that are upstream
559
560* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
561- Add badhack to make weblinks on desktop work
562
563* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
564- fix #70667 assertion failures
565- fix triple click patch
566
567* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
568- don't activate on double click
569
570* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
571- put button press mask in triple-click patch, maybe it will work
572- remove html-hack patch as it does nothing useful
573
574* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
575- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
576  bogus bug reports
577- add hack for HTML mime type handling in a web browser, not
578  nautilus
579
580* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
581- Updated to 2.0.6. Removed the patches I put upstream.
582- Added patch that fixes #72410
583
584* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
585- Add a simple patch so that redhat-config-packages can disable
586  the new window behavior for mounted CDs behavior.
587
588* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
589- Add patch to fix bug #70667
590
591* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
592- remove mp3
593
594* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
595- ignore the "add_to_session" preference as it only broke stuff
596- pad the left margin a bit to cope with poor word wrapping
597
598* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
599- Update to 2.0.5, remove topleft icon patch
600
601* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
602- Add patch to fix the bug where desktop icons get
603  stuck in the top left corner on startup
604
605* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
606- 2.0.4
607
608* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
609- obsolete nautilus-mozilla < 2.0 #69839
610
611* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
612- add rhconfig patch to Bluecurve theme and disable sidebar by default
613
614* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
615- drop start here files, require redhat-menus that has them
616
617* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
618- 2.0.3
619
620* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
621- build for new eel2, gail
622
623* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
624- and add the libexec components, mumble
625
626* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
627- put the components in the file list, were moved upstream
628
629* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
630- 2.0.1
631
632* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
633- Relibtoolize to fix relink problems for solib components
634- Add LANG=en_US to %makeinstall as well
635- Back out previous change, force locale to en_US to prevent UTF-8 problems
636- Add workaround for intltool-merge bug on ia64
637
638* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
639- automated rebuild
640
641* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
642- 2.0.0
643- use desktop-file-install
644- require desktop-backgrounds-basic
645
646* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
647- add wacky hack in hopes of fixing the hang-on-login thing
648
649* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
650- add build requires on new gail
651- rebuild to try to lose broken libgailutil.so.13 dependency
652
653* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
654- rebuild in different environment
655
656* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
657- 1.1.19
658
659* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
660- rebuild in different environment
661
662* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
663- really remove nautilus-devel if we are going to obsolete it
664- don't require hwbrowser
665
666* Sun May 26 2002 Tim Powers <timp@redhat.com>
667- automated rebuild
668
669* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
670- rebuild in different environment
671
672* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
673- 1.1.17
674
675* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
676- 1.1.14
677
678* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
679- require eog
680- obsolete nautilus-devel
681- fix name of schemas file in post
682
683* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
684- Update to 1.1.13
685
686* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
687- put tree view in file list
688
689* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
690- nautilus for gnome 2
691- clean up the spec file and file list a bit
692
693* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
694- merge translations
695
696* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
697- Add patch to fix trash crash
698
699* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
700- fix for metadata tmp race
701- backport thumbnail speed fix and thumbnail inf. loop fix
702
703* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
704- add some fixes from CVS version, including one for #61819 and a couple segfaults
705
706* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
707- fix thumbnails for files with future timestamp, #56862
708
709* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
710- buildrequires intltool #60633
711- apply Alex's pixbuf cache patch to save a few megs #60581
712
713* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
714- drop Milan-specific features, including png10 and ac25 patches
715- copy in 1.0.5 help component to avoid large risky patch
716- remove .la files
717- drop mozilla from ia64 again
718- remove oaf file from nautilus-mozilla that was also in the base
719  package
720
721* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
722- enable mozilla support on ia64
723
724* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
725- require Mozilla 0.9.7
726- Add patch that puts mozilla profile startup before embedding is initialized
727
728* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
729- 1.0.6, require Mozilla 0.9.6
730
731* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
732- Update to 1.0.5
733
734* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
735- Fix handling of GnomeVFSFileInfo structure (#53315)
736
737* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
738- Change handling of names on unmount to fix #52325
739
740* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
741- put nautilus-help.desktop in file list; #53109
742
743* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
744- Add po files from sources.redhat.com
745
746* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
747- Add po files from sources.redhat.com
748
749* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
750- Added patch to fix the .directory issuer
751
752* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
753- I screwed up the build yesterday, so it didn't actually contain the
754  fixes mentioned. This build should contain them.
755
756* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
757- fix bug causing 32000 stats or so in large directories,
758  should speed things up somewhat
759- fix #52104 via gruesome kdesktop-detection hack and setting
760  window type hint on our desktop window
761- fix so Start Here icon displays in sidebar
762- don't load non-local .desktop files
763
764* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
765- make Programs icon into a link, to match the other .desktop files
766- own various directories #51164
767- web page titles in Japanese, #51709
768- tree defaults to only directories #51850
769
770* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
771- make start here icon work again
772- kill some warning spew, #51661
773- cache getpwnam() results to speed things up a bit
774
775* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
776- Fix problem with missing desktop starthere.desktop file
777- New snapshot from our branch, fixes:
778  - On upgrade, icons migrated from GNOME desktop are not properly lined up
779    (#51436)
780  - icons dropped on the desktop don't end up where dropped. (#51441)
781  - Nautilus shouldn't have fam monitor read-only windows. This
782    keeps CDROMS from being unmounted until you close all
783
784    nautilus windows pointing to them. (#51442)
785  - Warnings about 'cannot statfs...' when moving items to trash.
786- Use separate start-here.desktop for panel, since the one used
787  for the root window only works from Nautilus.
788
789* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
790- Changed starthere .desktop files to be links instead
791- of spawning a new nautilus. This makes start-here:
792- much faster.
793
794* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
795- Added hwbrowser dependency
796- New snapshot, fixes the mozilla-view submit form problem
797
798* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
799- Rebuild with new xml-i18n-tools
800- fix crash in creating new desktop files
801
802* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
803- Fix up DnD code some more
804
805* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
806- Sync our CVS version; fixes some MUSTFIX
807  (the one about drawing background on startup,
808   properly translate desktop files, etc.)
809
810* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
811- Fix 64bit cleanness issue
812- Fix NULL mimetype crash
813- Disable additional_text for .desktop files
814
815* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
816- Fix unmounting devices.
817
818* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
819- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
820- mimetype sniffing.
821
822* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
823- Remove the "don't run as root" warning.
824- Remove eazel from bookmarks
825- langified (again? did someone change it?)
826
827* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
828- Apply a patch that makes nautilus dnd reset work with the latest
829- eel release.
830
831* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
832- Build on ia64 without the mozilla component.
833
834* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
835- Fix crash-on-startup showstopper
836- Fix can't-find-images bug (this one was only showing up
837  when built with debug symbols, since it was an uninitialized memory
838  read)
839
840* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
841- sync new tarball from our CVS branch,
842  fixes some drag-and-drop, changes URI scheme names,
843  etc.
844
845* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
846- Add BuildRequires (#49539, 49537)
847- Fix %%post, %%postun (#49720)
848- Background efficiency improvements and hacks
849
850* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
851- Don't launch esd on each mouseover.
852
853* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
854- move first time druid patch into my "CVS outstanding" patch
855- try to really remove Help/Feedback
856- try to really fix Help/Community Support
857- try again to get Start Here in the Go menu
858- try again to get Start Here on the desktop
859- don't show file sizes for .desktop files
860
861* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
862- add newline to ends of .desktop files that were missing them
863
864* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
865- update to my latest 'cvs diff -u' (adds default
866  Start Here link, displays .directory name in sidebar)
867- include /etc/X11/* links (starthere, sysconfig, serverconfig)
868
869* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
870- Patch to remove firsttime druid and flash
871
872* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
873- add hacks for displaying desktop files
874- add hack to turn off the "unwriteable" emblem
875
876* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
877- added defattr to the files lists to be (-,root,root)
878- languified
879
880* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
881- Need to run autoheader too.
882
883* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
884- Make the fam dependency a real runtime dependency
885- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
886- Cleaned up specfile.
887
888* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
889- Change default background and rubberband color.
890- Use the sidebar tabs from the default theme
891- BuildDepend on fam-devel, depend on fam
892- Disable the eazel update pages in the first-time druid.
893- Remove the eazel logo from the first-time druid
894
895* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
896- 1.0.4, removes eazel services icon and wizard page
897- Eazel logo is still in startup wizard for now, needs fixing
898
899* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
900- fix group (s/Desktop/Desktops/) #47134
901- remove ammonite dependency
902
903* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
904- add a different default theme
905- clean up file list overspecificity a bit
906
907* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
908- move to a CVS snapshot of nautilus for now
909  (Darin is my hero for having distcheck work out of CVS)
910
911* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
912- clean up defaults a bit
913
914* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
915- New version
916
917* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
918- Added BuildRequires lines
919- Changed Source to point to ftp.gnome.org instead of just the tarball name
920- Moved %description sections closer to their %package sections
921- Moved %changelog to the end, where so that it's not in the way
922- Changed configure and make install options to allow moving of
923  libraries, includes, binaries more easily
924- Removed hard-coded paths (don't define %prefix or %docdir)
925- replace %{prefix}/bin with %{_bindir}
926- replace %{prefix}/share with %{_datadir}
927- replace %{prefix}/lib with %{_libdir}
928- replace %{prefix}/include with %{_includedir}
929
930* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
931- removed obsoletes from sub packages and added mozilla and trilobite
932subpackages
933
934* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
935- created this thing
Note: See TracBrowser for help on using the repository browser.