source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 9119

Revision 9119, 30.7 KB checked in by Takemikaduchi, 9 years ago (diff)

lynx,ncftp,w3m: change location of desktop file
gsettings-desktop-schemas: change keybinding of switch-input-source
others: new upstream release

Line 
1%define glib2_version 2.42.0
2%define pango_version 1.36.3
3%define gtk3_version 3.14.0
4%define libxml2_version 2.9.1
5%define eog_version 3.14.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.14.0
8%define vine_menus_version 3.0
9%define startup_notification_version 0.10
10%define libexif_version 0.6.19
11%define tracker_version 1.0.0
12%define gobject_introspection_version 0.9.8
13
14Name:                   nautilus
15Summary:                Nautilus is a file manager for GNOME
16Summary(ja):    Nautilus - GNOME ファイルマネージャ
17Version:                3.14.2
18Release:                1%{?_dist_release}
19License:                GPLv2+
20Group:                  User Interface/Desktops
21URL:                    http://www.gnome.org/projects/nautilus/
22
23Vendor:                 Project Vine
24Distribution:   Vine Linux
25Packager:               Takemikaduchi
26
27Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.14/%{name}-%{version}.tar.xz
28
29# vine
30Patch102:       run_in_gnome.patch
31Patch2000:      nautilus-vine-settings.patch
32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
34Requires:       gamin
35Requires:       vine-menus >= %{vine_menus_version}
36Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
37Requires:       libexif >= %{libexif_version}
38Requires:       %{name}-libs = %{version}-%{release}
39
40BuildRequires:  intltool
41BuildRequires:  libtool >= 1.4.2-10
42BuildRequires:  automake, autoconf
43BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
44
45BuildRequires:  glib2-devel >= %{glib2_version}
46BuildRequires:  pango-devel >= %{pango_version}
47BuildRequires:  gtk3-devel >= %{gtk3_version}
48BuildRequires:  libxml2-devel >= %{libxml2_version}
49BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
50BuildRequires:  gamin-devel
51BuildRequires:  startup-notification-devel >= %{startup_notification_version}
52BuildRequires:  tracker-devel >= %{tracker_version}
53BuildRequires:  libexif-devel >= %{libexif_version}
54BuildRequires:  unique3-devel
55BuildRequires:  libnotify-devel
56BuildRequires:  libSM-devel
57BuildRequires:  exempi-devel
58BuildRequires:  tracker-devel
59BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
60BuildRequires:  gsettings-desktop-schemas
61
62Obsoletes:      nautilus-extras
63Obsoletes:      nautilus-suggested
64Obsoletes:      nautilus-mozilla < 2.0
65Obsoletes:      eel2 <= 2.24.1
66
67Provides:       eel2 <= 2.24.1
68
69
70%description
71Nautilus integrates access to files, applications, media,
72Internet-based resources and the Web. Nautilus delivers a dynamic and
73rich user experience. Nautilus is an free software project developed
74under the GNU General Public License and is a core component of the
75GNOME desktop project.
76
77%description -l ja
78Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
79リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
80豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
81のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
82プロジェクトのコア・コンポーネントです。
83
84%package devel
85Summary: Support for developing nautilus extensions
86Summary(ja): Nautilus 拡張機能開発のためのサポート
87License: LGPLv2+
88Group: Development/Libraries
89Requires: %{name}-libs = %{version}-%{release}
90Requires: pkgconfig
91
92%description devel
93This package provides libraries and header files needed
94for developing nautilus extensions.
95
96%description -l ja devel
97このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
98ヘッダファイルを提供します。
99
100%package libs
101Summary: Libraries for use in nautilus extentions
102Summary(ja): Nautilus 拡張機能で利用するライブラリ
103Group: User Interface/Desktops
104
105%description libs
106This package provides libraries required by nautilus extention
107module.
108
109%description -l ja libs
110このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
111
112%prep
113%setup -q -n %{name}-%{version}
114
115%patch102 -p1 -b .vine
116%patch2000 -p1 -b .vine
117
118%build
119gtkdocize
120libtoolize --force --copy
121autoreconf -f -i
122CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
123%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
124
125make %{?_smp_mflags}
126
127%install
128rm -rf $RPM_BUILD_ROOT
129
130make install DESTDIR=$RPM_BUILD_ROOT
131
132# make sure desktop files validate by ignoring sr@Latn
133perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
134# desktop-file-install can't handle empty OnlyShowIn correctly
135perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
136
137desktop-file-install --vendor gnome --delete-original       \
138  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
139  --add-only-show-in GNOME                                  \
140  $RPM_BUILD_ROOT%{_datadir}/applications/*
141
142find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
143
144%find_lang %name
145
146%clean
147rm -rf $RPM_BUILD_ROOT
148
149%postun
150if [ $1 -eq 0 ] ; then
151    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
152fi
153
154%posttrans
155update-mime-database %{_datadir}/mime &> /dev/null ||:
156glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
157
158%post libs -p /sbin/ldconfig
159%postun libs -p /sbin/ldconfig
160
161
162%files  -f %{name}.lang
163%defattr(-,root,root)
164%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
165%dir %{_libdir}/nautilus
166%dir %{_libdir}/nautilus/extensions-3.0
167%{_libdir}/nautilus/extensions-3.0/*.so
168%{_libexecdir}/nautilus-convert-metadata
169%{_datadir}/GConf/gsettings/nautilus.convert
170%{_datadir}/appdata/org.gnome.Nautilus.appdata.xml
171%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
172%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
173%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
174%{_datadir}/applications
175%{_datadir}/mime/*
176%{_bindir}/*
177%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
178%{_datadir}/glib-2.0/schemas/
179%{_mandir}/man1/*
180
181%files devel
182%defattr(-, root, root)
183%{_includedir}/nautilus
184%{_libdir}/pkgconfig/*
185%{_libdir}/*.so
186%{_datadir}/gir-1.0
187%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
188
189%files libs
190%defattr(-, root, root)
191%{_libdir}/*.so.*
192%{_libdir}/girepository-1.0/*.typelib
193
194
195%changelog
196* Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
197- new upstream release
198
199* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
200- new upstream release
201- remove Patch0 (nautilus-3.14.0-git20141015.patch)
202
203* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
204- new upstream release
205- add Patch0 (nautilus-3.14.0-git20141015.patch)
206
207* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
208- new upstream release
209
210* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
211- new upstream release
212
213* Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
214- new upstream release
215
216* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
217- new upstream release
218- add Patch2000 (nautilus-vine-settings.patch)
219
220* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
221- new upstream release
222
223* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
224- new upstream release
225
226* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
227- new upstream release
228
229* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
230- new upstream release
231
232* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
233- new upstream release
234
235* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
236- new upstream release
237- remove Patch0,7
238- add BuildRequires: exempi-devel, tracker-devel
239
240* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
241- add Patch0 (nautilus-3.4.2-ja.po.patch)
242
243* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
244- new upstream release
245
246* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
247- new upstream release
248
249* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
250- added patch102 to fix autostart in other desktop environments
251  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
252
253* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
254- new upstream release
255
256* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
257- new upstream release
258
259* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
260- new upstream release
261
262* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
263- new upstream release
264
265* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
266- new upstream release
267- drop Patch101
268- change BuildRequires: gtk3-devel instread of gtk2-devel
269- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
270- change BuildRequires: unique3-devel instread of unique-devel
271- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
272
273* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
274- fixed group of libs
275- add translation of summary and description.
276- add Vendor, Distribution and Packager tags.
277
278* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
279- new upstream release
280
281* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
282- new upstream release
283
284* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
285 - new upstream release
286
287* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
288- new upstream release
289- add BuildRequires: gobject-introspection-devel
290- remove BuildRequires: libgnomeui-devel
291- add configure option (--enable-introspection=yes)
292
293* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
294- rebuild with rpm-4.8.1 for pkg-config file
295
296* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
297- split nautilus extention libraries to -libs subpackage.
298
299* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
300- new upstream release
301
302* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
303- new upstream release
304- drop Patch100
305- add Patch101
306- add Obsoletes: eel2 <= 2.24.1
307- add Provides: eel2 <= 2.24.1
308
309* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
310- new upstream release
311- add BuildRequires: libSM-devel
312
313* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
314- removed Requires: eel2
315- added %%posttrans section
316
317* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
318- new upstream release
319
320* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
321- new upstream release
322
323* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
324- new upstream release
325
326* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
327- new upstream release
328- split -devel subpackage
329
330* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
331- new upstream release
332
333* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
334- patch6 needs autoreconf
335
336* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
337- new upstream release
338
339* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
340- new upstream release
341
342* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
343- new upstream release
344- added Requires: gvfs
345
346* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
347- new upstream release
348- added Patches from FC
349  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
350  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
351  - Fix a crash in the Properties dialog while changing owner (patch from head)
352  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
353  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
354
355* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
356- new upstream release
357- dropped Patch11-13 and added Patch7-9 from Fedora
358  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
359  - Add patch from upstream to get audio preview working again
360    (#332251)
361  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
362  - Fix a crash with small fonts (#242350)
363  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
364  - Backport fixes for async thumbnail loading from svn
365
366* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
367- run autoreconf for Patch11 changes
368
369* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
370- remove tracker dependancy, Patch13 detects tracker dynamically.
371
372* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
373- add Patch13 to support user-dirs
374
375* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
376- new upstream release
377- enable tracker support
378- add BuildRequires: tracker-devel, Requires: tracker
379
380* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
381- new upstream release
382
383* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
384- add BuildRequires: gamin-devel, Requires: gamin
385- remove fam dependency (replaced by gamin)
386
387* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
388- new upsteram release
389
390* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
391- really applied Patch110...
392
393* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
394- add Patch110 to fix corruption of help option message.
395
396* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
397- new upstream release
398
399* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
400- fix typo in ja.po
401
402* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
403- update ja.po to translate patch50 related message.
404
405* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
406- add Patch50 to show progressbar on umounting
407  (ubuntu patch in Bug 313639)
408
409* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
410- new upstream release
411
412* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
413- add Patch10 to avoid background rendering delay
414
415* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
416- new upstream release
417
418* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
419- add fix-non-UTF-8-encoding.patch (patch0)
420  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
421
422* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
423- new upstream release
424
425* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
426- new upstream release
427
428* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
429- new upstream release
430
431* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
432- new upstream release
433
434* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
435- rebuild
436
437* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
438- new upstream version
439
440* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
441- new upstream version
442
443* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
444- add vine patch to change some defaults.
445  - change default zoom sine
446  - set always_use_browser
447
448* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
449- new upstream release
450
451* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
452- add Patch110 to fix libegg(egg-recent-model.c)
453  save old umask value before create ".recently-used" file.
454 
455* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
456- change default desktop font to Sans 9 (from Sans 10)
457- add patch10 to build with gtk+-2.4
458
459* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
460- new upstream release
461
462* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
463- new upstream release
464
465* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
466- add backport patch from rawhide (Patch10)
467
468* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
469- modified vine patch
470  - change default zoom level to small
471  - change desktop font to Sans 10
472
473* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
474- new upstream release
475
476* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
477- add desktop icon patch from rawhide
478
479* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
480- remove obsolete ja.po
481
482* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
483- new upstream release
484
485* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
486- new upstream release
487
488* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
489- new upstream release
490
491* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
492- update ja.po
493
494* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
495- new upstream release
496
497* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
498- new upstream release
499
500* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
501- new upstream release
502
503* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
504- new upstream release
505
506* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
507- new upstream release
508
509* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
510- new upstream release
511
512* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
513- add nautilus-cd-burner patch
514
515* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
516- new upstream release
517
518* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
519- discard scrollkeeper outputs.
520- update PreReq tags.
521
522* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
523- change icon for nautilus-file-management-properties
524- update ja.po
525
526* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
527- update ja.po
528- add translation for .desktop files.
529
530* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
531- add Requires: vine-menus
532
533* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
534- new upstream release
535
536* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
537- remove redhatize patch
538
539* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
540- rebuild to remove unneeded dependancy.
541
542* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
543- build for Vine Linux
544
545* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
546- add explicit startup-notification dependency because build system is
547  dumb
548- 2.1.3
549
550* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
551- 2.1.2
552
553* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
554- 2.0.7
555- remove patches that are upstream
556
557* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
558- Add badhack to make weblinks on desktop work
559
560* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
561- fix #70667 assertion failures
562- fix triple click patch
563
564* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
565- don't activate on double click
566
567* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
568- put button press mask in triple-click patch, maybe it will work
569- remove html-hack patch as it does nothing useful
570
571* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
572- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
573  bogus bug reports
574- add hack for HTML mime type handling in a web browser, not
575  nautilus
576
577* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
578- Updated to 2.0.6. Removed the patches I put upstream.
579- Added patch that fixes #72410
580
581* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
582- Add a simple patch so that redhat-config-packages can disable
583  the new window behavior for mounted CDs behavior.
584
585* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
586- Add patch to fix bug #70667
587
588* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
589- remove mp3
590
591* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
592- ignore the "add_to_session" preference as it only broke stuff
593- pad the left margin a bit to cope with poor word wrapping
594
595* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
596- Update to 2.0.5, remove topleft icon patch
597
598* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
599- Add patch to fix the bug where desktop icons get
600  stuck in the top left corner on startup
601
602* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
603- 2.0.4
604
605* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
606- obsolete nautilus-mozilla < 2.0 #69839
607
608* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
609- add rhconfig patch to Bluecurve theme and disable sidebar by default
610
611* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
612- drop start here files, require redhat-menus that has them
613
614* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
615- 2.0.3
616
617* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
618- build for new eel2, gail
619
620* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
621- and add the libexec components, mumble
622
623* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
624- put the components in the file list, were moved upstream
625
626* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
627- 2.0.1
628
629* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
630- Relibtoolize to fix relink problems for solib components
631- Add LANG=en_US to %makeinstall as well
632- Back out previous change, force locale to en_US to prevent UTF-8 problems
633- Add workaround for intltool-merge bug on ia64
634
635* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
636- automated rebuild
637
638* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
639- 2.0.0
640- use desktop-file-install
641- require desktop-backgrounds-basic
642
643* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
644- add wacky hack in hopes of fixing the hang-on-login thing
645
646* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
647- add build requires on new gail
648- rebuild to try to lose broken libgailutil.so.13 dependency
649
650* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
651- rebuild in different environment
652
653* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
654- 1.1.19
655
656* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
657- rebuild in different environment
658
659* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
660- really remove nautilus-devel if we are going to obsolete it
661- don't require hwbrowser
662
663* Sun May 26 2002 Tim Powers <timp@redhat.com>
664- automated rebuild
665
666* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
667- rebuild in different environment
668
669* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
670- 1.1.17
671
672* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
673- 1.1.14
674
675* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
676- require eog
677- obsolete nautilus-devel
678- fix name of schemas file in post
679
680* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
681- Update to 1.1.13
682
683* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
684- put tree view in file list
685
686* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
687- nautilus for gnome 2
688- clean up the spec file and file list a bit
689
690* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
691- merge translations
692
693* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
694- Add patch to fix trash crash
695
696* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
697- fix for metadata tmp race
698- backport thumbnail speed fix and thumbnail inf. loop fix
699
700* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
701- add some fixes from CVS version, including one for #61819 and a couple segfaults
702
703* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
704- fix thumbnails for files with future timestamp, #56862
705
706* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
707- buildrequires intltool #60633
708- apply Alex's pixbuf cache patch to save a few megs #60581
709
710* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
711- drop Milan-specific features, including png10 and ac25 patches
712- copy in 1.0.5 help component to avoid large risky patch
713- remove .la files
714- drop mozilla from ia64 again
715- remove oaf file from nautilus-mozilla that was also in the base
716  package
717
718* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
719- enable mozilla support on ia64
720
721* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
722- require Mozilla 0.9.7
723- Add patch that puts mozilla profile startup before embedding is initialized
724
725* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
726- 1.0.6, require Mozilla 0.9.6
727
728* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
729- Update to 1.0.5
730
731* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
732- Fix handling of GnomeVFSFileInfo structure (#53315)
733
734* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
735- Change handling of names on unmount to fix #52325
736
737* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
738- put nautilus-help.desktop in file list; #53109
739
740* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
741- Add po files from sources.redhat.com
742
743* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
744- Add po files from sources.redhat.com
745
746* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
747- Added patch to fix the .directory issuer
748
749* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
750- I screwed up the build yesterday, so it didn't actually contain the
751  fixes mentioned. This build should contain them.
752
753* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
754- fix bug causing 32000 stats or so in large directories,
755  should speed things up somewhat
756- fix #52104 via gruesome kdesktop-detection hack and setting
757  window type hint on our desktop window
758- fix so Start Here icon displays in sidebar
759- don't load non-local .desktop files
760
761* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
762- make Programs icon into a link, to match the other .desktop files
763- own various directories #51164
764- web page titles in Japanese, #51709
765- tree defaults to only directories #51850
766
767* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
768- make start here icon work again
769- kill some warning spew, #51661
770- cache getpwnam() results to speed things up a bit
771
772* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
773- Fix problem with missing desktop starthere.desktop file
774- New snapshot from our branch, fixes:
775  - On upgrade, icons migrated from GNOME desktop are not properly lined up
776    (#51436)
777  - icons dropped on the desktop don't end up where dropped. (#51441)
778  - Nautilus shouldn't have fam monitor read-only windows. This
779    keeps CDROMS from being unmounted until you close all
780
781    nautilus windows pointing to them. (#51442)
782  - Warnings about 'cannot statfs...' when moving items to trash.
783- Use separate start-here.desktop for panel, since the one used
784  for the root window only works from Nautilus.
785
786* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
787- Changed starthere .desktop files to be links instead
788- of spawning a new nautilus. This makes start-here:
789- much faster.
790
791* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
792- Added hwbrowser dependency
793- New snapshot, fixes the mozilla-view submit form problem
794
795* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
796- Rebuild with new xml-i18n-tools
797- fix crash in creating new desktop files
798
799* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
800- Fix up DnD code some more
801
802* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
803- Sync our CVS version; fixes some MUSTFIX
804  (the one about drawing background on startup,
805   properly translate desktop files, etc.)
806
807* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
808- Fix 64bit cleanness issue
809- Fix NULL mimetype crash
810- Disable additional_text for .desktop files
811
812* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
813- Fix unmounting devices.
814
815* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
816- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
817- mimetype sniffing.
818
819* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
820- Remove the "don't run as root" warning.
821- Remove eazel from bookmarks
822- langified (again? did someone change it?)
823
824* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
825- Apply a patch that makes nautilus dnd reset work with the latest
826- eel release.
827
828* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
829- Build on ia64 without the mozilla component.
830
831* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
832- Fix crash-on-startup showstopper
833- Fix can't-find-images bug (this one was only showing up
834  when built with debug symbols, since it was an uninitialized memory
835  read)
836
837* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
838- sync new tarball from our CVS branch,
839  fixes some drag-and-drop, changes URI scheme names,
840  etc.
841
842* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
843- Add BuildRequires (#49539, 49537)
844- Fix %%post, %%postun (#49720)
845- Background efficiency improvements and hacks
846
847* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
848- Don't launch esd on each mouseover.
849
850* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
851- move first time druid patch into my "CVS outstanding" patch
852- try to really remove Help/Feedback
853- try to really fix Help/Community Support
854- try again to get Start Here in the Go menu
855- try again to get Start Here on the desktop
856- don't show file sizes for .desktop files
857
858* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
859- add newline to ends of .desktop files that were missing them
860
861* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
862- update to my latest 'cvs diff -u' (adds default
863  Start Here link, displays .directory name in sidebar)
864- include /etc/X11/* links (starthere, sysconfig, serverconfig)
865
866* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
867- Patch to remove firsttime druid and flash
868
869* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
870- add hacks for displaying desktop files
871- add hack to turn off the "unwriteable" emblem
872
873* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
874- added defattr to the files lists to be (-,root,root)
875- languified
876
877* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
878- Need to run autoheader too.
879
880* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
881- Make the fam dependency a real runtime dependency
882- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
883- Cleaned up specfile.
884
885* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
886- Change default background and rubberband color.
887- Use the sidebar tabs from the default theme
888- BuildDepend on fam-devel, depend on fam
889- Disable the eazel update pages in the first-time druid.
890- Remove the eazel logo from the first-time druid
891
892* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
893- 1.0.4, removes eazel services icon and wizard page
894- Eazel logo is still in startup wizard for now, needs fixing
895
896* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
897- fix group (s/Desktop/Desktops/) #47134
898- remove ammonite dependency
899
900* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
901- add a different default theme
902- clean up file list overspecificity a bit
903
904* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
905- move to a CVS snapshot of nautilus for now
906  (Darin is my hero for having distcheck work out of CVS)
907
908* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
909- clean up defaults a bit
910
911* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
912- New version
913
914* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
915- Added BuildRequires lines
916- Changed Source to point to ftp.gnome.org instead of just the tarball name
917- Moved %description sections closer to their %package sections
918- Moved %changelog to the end, where so that it's not in the way
919- Changed configure and make install options to allow moving of
920  libraries, includes, binaries more easily
921- Removed hard-coded paths (don't define %prefix or %docdir)
922- replace %{prefix}/bin with %{_bindir}
923- replace %{prefix}/share with %{_datadir}
924- replace %{prefix}/lib with %{_libdir}
925- replace %{prefix}/include with %{_includedir}
926
927* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
928- removed obsoletes from sub packages and added mozilla and trilobite
929subpackages
930
931* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
932- created this thing
Note: See TracBrowser for help on using the repository browser.