source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 7302

Revision 7302, 29.8 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1%define glib2_version 2.34.0
2%define pango_version 1.32.0
3%define gtk3_version 3.6.0
4%define libxml2_version 2.9.0
5%define eog_version 3.6.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.6.0
8%define vine_menus_version 3.0
9%define startup_notification_version 0.10
10%define libexif_version 0.6.19
11%define gconf_version 2.32.0
12%define gobject_introspection_version 0.9.8
13
14Name:                   nautilus
15Summary:                Nautilus is a file manager for GNOME
16Summary(ja):    Nautilus - GNOME ファイルマネージャ
17Version:                3.6.3
18Release:                1%{?_dist_release}
19License:                GPLv2+
20Group:                  User Interface/Desktops
21URL:                    http://www.gnome.org/projects/nautilus/
22
23Vendor:                 Project Vine
24Distribution:   Vine Linux
25Packager:               Takemikaduchi
26
27Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.6/%{name}-%{version}.tar.xz
28
29# Some changes to default config
30Patch1:         nautilus-2.5.7-rhconfig.patch
31
32# vine
33Patch102:       run_in_gnome.patch
34
35BuildRoot:      %{_tmppath}/%{name}-%{version}-root
36Requires:       gamin
37Requires:       vine-menus >= %{vine_menus_version}
38Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
39Requires:       libexif >= %{libexif_version}
40Requires:       %{name}-libs = %{version}-%{release}
41
42BuildRequires:  intltool
43BuildRequires:  libtool >= 1.4.2-10
44BuildRequires:  automake, autoconf
45BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
46
47BuildRequires:  glib2-devel >= %{glib2_version}
48BuildRequires:  pango-devel >= %{pango_version}
49BuildRequires:  gtk3-devel >= %{gtk3_version}
50BuildRequires:  libxml2-devel >= %{libxml2_version}
51BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
52BuildRequires:  gamin-devel
53BuildRequires:  startup-notification-devel >= %{startup_notification_version}
54#BuildRequires: tracker-devel
55BuildRequires:  libexif-devel  >= %{libexif_version}
56BuildRequires:  unique3-devel
57BuildRequires:  libnotify-devel
58BuildRequires:  libSM-devel
59BuildRequires:  exempi-devel
60BuildRequires:  tracker-devel
61BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
62BuildRequires:  gsettings-desktop-schemas
63
64Obsoletes:      nautilus-extras
65Obsoletes:      nautilus-suggested
66Obsoletes:      nautilus-mozilla < 2.0
67Obsoletes:      eel2 <= 2.24.1
68
69Provides:       eel2 <= 2.24.1
70
71
72%description
73Nautilus integrates access to files, applications, media,
74Internet-based resources and the Web. Nautilus delivers a dynamic and
75rich user experience. Nautilus is an free software project developed
76under the GNU General Public License and is a core component of the
77GNOME desktop project.
78
79%description -l ja
80Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
81リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
82豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
83のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
84プロジェクトのコア・コンポーネントです。
85
86%package devel
87Summary: Support for developing nautilus extensions
88Summary(ja): Nautilus 拡張機能開発のためのサポート
89License: LGPLv2+
90Group: Development/Libraries
91Requires: %{name}-libs = %{version}-%{release}
92Requires: pkgconfig
93
94%description devel
95This package provides libraries and header files needed
96for developing nautilus extensions.
97
98%description -l ja devel
99このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
100ヘッダファイルを提供します。
101
102%package libs
103Summary: Libraries for use in nautilus extentions
104Summary(ja): Nautilus 拡張機能で利用するライブラリ
105Group: User Interface/Desktops
106
107%description libs
108This package provides libraries required by nautilus extention
109module.
110
111%description -l ja libs
112このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
113
114%prep
115%setup -q -n %{name}-%{version}
116
117%patch102 -p1 -b .vine
118
119%build
120gtkdocize
121libtoolize --force --copy
122autoreconf -f -i
123CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
124%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
125
126make %{?_smp_mflags}
127
128%install
129rm -rf $RPM_BUILD_ROOT
130
131make install DESTDIR=$RPM_BUILD_ROOT
132
133# make sure desktop files validate by ignoring sr@Latn
134perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
135# desktop-file-install can't handle empty OnlyShowIn correctly
136perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
137
138desktop-file-install --vendor gnome --delete-original       \
139  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
140  --add-only-show-in GNOME                                  \
141  $RPM_BUILD_ROOT%{_datadir}/applications/*
142
143find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
144
145%find_lang %name
146
147%clean
148rm -rf $RPM_BUILD_ROOT
149
150%postun
151if [ $1 -eq 0 ] ; then
152    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
153fi
154
155%posttrans
156update-mime-database %{_datadir}/mime &> /dev/null ||:
157glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
158
159%post libs -p /sbin/ldconfig
160%postun libs -p /sbin/ldconfig
161
162
163%files  -f %{name}.lang
164%defattr(-,root,root)
165%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
166%dir %{_libdir}/nautilus
167%dir %{_libdir}/nautilus/extensions-3.0
168%{_libdir}/nautilus/extensions-3.0/*.so
169%{_libexecdir}/nautilus-convert-metadata
170%{_libexecdir}/nautilus-shell-search-provider
171%{_datadir}/GConf/gsettings/nautilus.convert
172%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
173%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
174%{_datadir}/dbus-1/services/org.gnome.Nautilus.SearchProvider.service
175%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
176%{_datadir}/nautilus
177%{_datadir}/applications
178%{_datadir}/mime/*
179%{_bindir}/*
180%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
181%{_datadir}/glib-2.0/schemas/
182%{_mandir}/man1/*
183
184%files devel
185%defattr(-, root, root)
186%{_includedir}/nautilus
187%{_libdir}/pkgconfig/*
188%{_libdir}/*.so
189%{_datadir}/gir-1.0
190%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
191
192%files libs
193%defattr(-, root, root)
194%{_libdir}/*.so.*
195%{_libdir}/girepository-1.0/*.typelib
196
197
198%changelog
199* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
200- new upstream release
201
202* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
203- new upstream release
204
205* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
206- new upstream release
207
208* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
209- new upstream release
210- remove Patch0,7
211- add BuildRequires: exempi-devel, tracker-devel
212
213* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
214- add Patch0 (nautilus-3.4.2-ja.po.patch)
215
216* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
217- new upstream release
218
219* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
220- new upstream release
221
222* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
223- added patch102 to fix autostart in other desktop environments
224  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
225
226* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
227- new upstream release
228
229* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
230- new upstream release
231
232* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
233- new upstream release
234
235* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
236- new upstream release
237
238* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
239- new upstream release
240- drop Patch101
241- change BuildRequires: gtk3-devel instread of gtk2-devel
242- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
243- change BuildRequires: unique3-devel instread of unique-devel
244- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
245
246* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
247- fixed group of libs
248- add translation of summary and description.
249- add Vendor, Distribution and Packager tags.
250
251* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
252- new upstream release
253
254* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
255- new upstream release
256
257* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
258 - new upstream release
259
260* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
261- new upstream release
262- add BuildRequires: gobject-introspection-devel
263- remove BuildRequires: libgnomeui-devel
264- add configure option (--enable-introspection=yes)
265
266* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
267- rebuild with rpm-4.8.1 for pkg-config file
268
269* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
270- split nautilus extention libraries to -libs subpackage.
271
272* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
273- new upstream release
274
275* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
276- new upstream release
277- drop Patch100
278- add Patch101
279- add Obsoletes: eel2 <= 2.24.1
280- add Provides: eel2 <= 2.24.1
281
282* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
283- new upstream release
284- add BuildRequires: libSM-devel
285
286* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
287- removed Requires: eel2
288- added %%posttrans section
289
290* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
291- new upstream release
292
293* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
294- new upstream release
295
296* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
297- new upstream release
298
299* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
300- new upstream release
301- split -devel subpackage
302
303* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
304- new upstream release
305
306* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
307- patch6 needs autoreconf
308
309* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
310- new upstream release
311
312* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
313- new upstream release
314
315* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
316- new upstream release
317- added Requires: gvfs
318
319* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
320- new upstream release
321- added Patches from FC
322  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
323  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
324  - Fix a crash in the Properties dialog while changing owner (patch from head)
325  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
326  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
327
328* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
329- new upstream release
330- dropped Patch11-13 and added Patch7-9 from Fedora
331  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
332  - Add patch from upstream to get audio preview working again
333    (#332251)
334  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
335  - Fix a crash with small fonts (#242350)
336  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
337  - Backport fixes for async thumbnail loading from svn
338
339* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
340- run autoreconf for Patch11 changes
341
342* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
343- remove tracker dependancy, Patch13 detects tracker dynamically.
344
345* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
346- add Patch13 to support user-dirs
347
348* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
349- new upstream release
350- enable tracker support
351- add BuildRequires: tracker-devel, Requires: tracker
352
353* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
354- new upstream release
355
356* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
357- add BuildRequires: gamin-devel, Requires: gamin
358- remove fam dependency (replaced by gamin)
359
360* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
361- new upsteram release
362
363* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
364- really applied Patch110...
365
366* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
367- add Patch110 to fix corruption of help option message.
368
369* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
370- new upstream release
371
372* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
373- fix typo in ja.po
374
375* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
376- update ja.po to translate patch50 related message.
377
378* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
379- add Patch50 to show progressbar on umounting
380  (ubuntu patch in Bug 313639)
381
382* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
383- new upstream release
384
385* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
386- add Patch10 to avoid background rendering delay
387
388* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
389- new upstream release
390
391* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
392- add fix-non-UTF-8-encoding.patch (patch0)
393  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
394
395* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
396- new upstream release
397
398* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
399- new upstream release
400
401* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
402- new upstream release
403
404* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
405- new upstream release
406
407* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
408- rebuild
409
410* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
411- new upstream version
412
413* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
414- new upstream version
415
416* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
417- add vine patch to change some defaults.
418  - change default zoom sine
419  - set always_use_browser
420
421* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
422- new upstream release
423
424* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
425- add Patch110 to fix libegg(egg-recent-model.c)
426  save old umask value before create ".recently-used" file.
427 
428* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
429- change default desktop font to Sans 9 (from Sans 10)
430- add patch10 to build with gtk+-2.4
431
432* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
433- new upstream release
434
435* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
436- new upstream release
437
438* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
439- add backport patch from rawhide (Patch10)
440
441* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
442- modified vine patch
443  - change default zoom level to small
444  - change desktop font to Sans 10
445
446* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
447- new upstream release
448
449* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
450- add desktop icon patch from rawhide
451
452* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
453- remove obsolete ja.po
454
455* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
456- new upstream release
457
458* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
459- new upstream release
460
461* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
462- new upstream release
463
464* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
465- update ja.po
466
467* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
468- new upstream release
469
470* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
471- new upstream release
472
473* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
474- new upstream release
475
476* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
477- new upstream release
478
479* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
480- new upstream release
481
482* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
483- new upstream release
484
485* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
486- add nautilus-cd-burner patch
487
488* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
489- new upstream release
490
491* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
492- discard scrollkeeper outputs.
493- update PreReq tags.
494
495* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
496- change icon for nautilus-file-management-properties
497- update ja.po
498
499* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
500- update ja.po
501- add translation for .desktop files.
502
503* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
504- add Requires: vine-menus
505
506* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
507- new upstream release
508
509* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
510- remove redhatize patch
511
512* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
513- rebuild to remove unneeded dependancy.
514
515* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
516- build for Vine Linux
517
518* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
519- add explicit startup-notification dependency because build system is
520  dumb
521- 2.1.3
522
523* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
524- 2.1.2
525
526* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
527- 2.0.7
528- remove patches that are upstream
529
530* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
531- Add badhack to make weblinks on desktop work
532
533* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
534- fix #70667 assertion failures
535- fix triple click patch
536
537* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
538- don't activate on double click
539
540* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
541- put button press mask in triple-click patch, maybe it will work
542- remove html-hack patch as it does nothing useful
543
544* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
545- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
546  bogus bug reports
547- add hack for HTML mime type handling in a web browser, not
548  nautilus
549
550* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
551- Updated to 2.0.6. Removed the patches I put upstream.
552- Added patch that fixes #72410
553
554* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
555- Add a simple patch so that redhat-config-packages can disable
556  the new window behavior for mounted CDs behavior.
557
558* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
559- Add patch to fix bug #70667
560
561* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
562- remove mp3
563
564* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
565- ignore the "add_to_session" preference as it only broke stuff
566- pad the left margin a bit to cope with poor word wrapping
567
568* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
569- Update to 2.0.5, remove topleft icon patch
570
571* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
572- Add patch to fix the bug where desktop icons get
573  stuck in the top left corner on startup
574
575* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
576- 2.0.4
577
578* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
579- obsolete nautilus-mozilla < 2.0 #69839
580
581* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
582- add rhconfig patch to Bluecurve theme and disable sidebar by default
583
584* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
585- drop start here files, require redhat-menus that has them
586
587* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
588- 2.0.3
589
590* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
591- build for new eel2, gail
592
593* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
594- and add the libexec components, mumble
595
596* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
597- put the components in the file list, were moved upstream
598
599* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
600- 2.0.1
601
602* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
603- Relibtoolize to fix relink problems for solib components
604- Add LANG=en_US to %makeinstall as well
605- Back out previous change, force locale to en_US to prevent UTF-8 problems
606- Add workaround for intltool-merge bug on ia64
607
608* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
609- automated rebuild
610
611* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
612- 2.0.0
613- use desktop-file-install
614- require desktop-backgrounds-basic
615
616* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
617- add wacky hack in hopes of fixing the hang-on-login thing
618
619* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
620- add build requires on new gail
621- rebuild to try to lose broken libgailutil.so.13 dependency
622
623* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
624- rebuild in different environment
625
626* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
627- 1.1.19
628
629* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
630- rebuild in different environment
631
632* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
633- really remove nautilus-devel if we are going to obsolete it
634- don't require hwbrowser
635
636* Sun May 26 2002 Tim Powers <timp@redhat.com>
637- automated rebuild
638
639* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
640- rebuild in different environment
641
642* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
643- 1.1.17
644
645* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
646- 1.1.14
647
648* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
649- require eog
650- obsolete nautilus-devel
651- fix name of schemas file in post
652
653* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
654- Update to 1.1.13
655
656* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
657- put tree view in file list
658
659* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
660- nautilus for gnome 2
661- clean up the spec file and file list a bit
662
663* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
664- merge translations
665
666* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
667- Add patch to fix trash crash
668
669* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
670- fix for metadata tmp race
671- backport thumbnail speed fix and thumbnail inf. loop fix
672
673* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
674- add some fixes from CVS version, including one for #61819 and a couple segfaults
675
676* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
677- fix thumbnails for files with future timestamp, #56862
678
679* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
680- buildrequires intltool #60633
681- apply Alex's pixbuf cache patch to save a few megs #60581
682
683* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
684- drop Milan-specific features, including png10 and ac25 patches
685- copy in 1.0.5 help component to avoid large risky patch
686- remove .la files
687- drop mozilla from ia64 again
688- remove oaf file from nautilus-mozilla that was also in the base
689  package
690
691* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
692- enable mozilla support on ia64
693
694* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
695- require Mozilla 0.9.7
696- Add patch that puts mozilla profile startup before embedding is initialized
697
698* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
699- 1.0.6, require Mozilla 0.9.6
700
701* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
702- Update to 1.0.5
703
704* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
705- Fix handling of GnomeVFSFileInfo structure (#53315)
706
707* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
708- Change handling of names on unmount to fix #52325
709
710* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
711- put nautilus-help.desktop in file list; #53109
712
713* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
714- Add po files from sources.redhat.com
715
716* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
717- Add po files from sources.redhat.com
718
719* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
720- Added patch to fix the .directory issuer
721
722* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
723- I screwed up the build yesterday, so it didn't actually contain the
724  fixes mentioned. This build should contain them.
725
726* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
727- fix bug causing 32000 stats or so in large directories,
728  should speed things up somewhat
729- fix #52104 via gruesome kdesktop-detection hack and setting
730  window type hint on our desktop window
731- fix so Start Here icon displays in sidebar
732- don't load non-local .desktop files
733
734* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
735- make Programs icon into a link, to match the other .desktop files
736- own various directories #51164
737- web page titles in Japanese, #51709
738- tree defaults to only directories #51850
739
740* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
741- make start here icon work again
742- kill some warning spew, #51661
743- cache getpwnam() results to speed things up a bit
744
745* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
746- Fix problem with missing desktop starthere.desktop file
747- New snapshot from our branch, fixes:
748  - On upgrade, icons migrated from GNOME desktop are not properly lined up
749    (#51436)
750  - icons dropped on the desktop don't end up where dropped. (#51441)
751  - Nautilus shouldn't have fam monitor read-only windows. This
752    keeps CDROMS from being unmounted until you close all
753
754    nautilus windows pointing to them. (#51442)
755  - Warnings about 'cannot statfs...' when moving items to trash.
756- Use separate start-here.desktop for panel, since the one used
757  for the root window only works from Nautilus.
758
759* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
760- Changed starthere .desktop files to be links instead
761- of spawning a new nautilus. This makes start-here:
762- much faster.
763
764* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
765- Added hwbrowser dependency
766- New snapshot, fixes the mozilla-view submit form problem
767
768* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
769- Rebuild with new xml-i18n-tools
770- fix crash in creating new desktop files
771
772* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
773- Fix up DnD code some more
774
775* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
776- Sync our CVS version; fixes some MUSTFIX
777  (the one about drawing background on startup,
778   properly translate desktop files, etc.)
779
780* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
781- Fix 64bit cleanness issue
782- Fix NULL mimetype crash
783- Disable additional_text for .desktop files
784
785* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
786- Fix unmounting devices.
787
788* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
789- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
790- mimetype sniffing.
791
792* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
793- Remove the "don't run as root" warning.
794- Remove eazel from bookmarks
795- langified (again? did someone change it?)
796
797* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
798- Apply a patch that makes nautilus dnd reset work with the latest
799- eel release.
800
801* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
802- Build on ia64 without the mozilla component.
803
804* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
805- Fix crash-on-startup showstopper
806- Fix can't-find-images bug (this one was only showing up
807  when built with debug symbols, since it was an uninitialized memory
808  read)
809
810* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
811- sync new tarball from our CVS branch,
812  fixes some drag-and-drop, changes URI scheme names,
813  etc.
814
815* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
816- Add BuildRequires (#49539, 49537)
817- Fix %%post, %%postun (#49720)
818- Background efficiency improvements and hacks
819
820* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
821- Don't launch esd on each mouseover.
822
823* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
824- move first time druid patch into my "CVS outstanding" patch
825- try to really remove Help/Feedback
826- try to really fix Help/Community Support
827- try again to get Start Here in the Go menu
828- try again to get Start Here on the desktop
829- don't show file sizes for .desktop files
830
831* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
832- add newline to ends of .desktop files that were missing them
833
834* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
835- update to my latest 'cvs diff -u' (adds default
836  Start Here link, displays .directory name in sidebar)
837- include /etc/X11/* links (starthere, sysconfig, serverconfig)
838
839* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
840- Patch to remove firsttime druid and flash
841
842* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
843- add hacks for displaying desktop files
844- add hack to turn off the "unwriteable" emblem
845
846* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
847- added defattr to the files lists to be (-,root,root)
848- languified
849
850* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
851- Need to run autoheader too.
852
853* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
854- Make the fam dependency a real runtime dependency
855- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
856- Cleaned up specfile.
857
858* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
859- Change default background and rubberband color.
860- Use the sidebar tabs from the default theme
861- BuildDepend on fam-devel, depend on fam
862- Disable the eazel update pages in the first-time druid.
863- Remove the eazel logo from the first-time druid
864
865* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
866- 1.0.4, removes eazel services icon and wizard page
867- Eazel logo is still in startup wizard for now, needs fixing
868
869* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
870- fix group (s/Desktop/Desktops/) #47134
871- remove ammonite dependency
872
873* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
874- add a different default theme
875- clean up file list overspecificity a bit
876
877* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
878- move to a CVS snapshot of nautilus for now
879  (Darin is my hero for having distcheck work out of CVS)
880
881* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
882- clean up defaults a bit
883
884* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
885- New version
886
887* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
888- Added BuildRequires lines
889- Changed Source to point to ftp.gnome.org instead of just the tarball name
890- Moved %description sections closer to their %package sections
891- Moved %changelog to the end, where so that it's not in the way
892- Changed configure and make install options to allow moving of
893  libraries, includes, binaries more easily
894- Removed hard-coded paths (don't define %prefix or %docdir)
895- replace %{prefix}/bin with %{_bindir}
896- replace %{prefix}/share with %{_datadir}
897- replace %{prefix}/lib with %{_libdir}
898- replace %{prefix}/include with %{_includedir}
899
900* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
901- removed obsoletes from sub packages and added mozilla and trilobite
902subpackages
903
904* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
905- created this thing
Note: See TracBrowser for help on using the repository browser.