source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 6201

Revision 6201, 30.5 KB checked in by Takemikaduchi, 12 years ago (diff)

gnome-themes: fix Vine theme
metacity: fix theme
others: new upstream release

Line 
1%define glib2_version 2.32.1
2%define pango_version 1.30.0
3%define gtk3_version 3.4.1
4%define libxml2_version 2.7.8
5%define eog_version 3.4.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.4.0
8%define vine_menus_version 3.0
9%define gnome_menus_version 2.32.0
10%define startup_notification_version 0.10
11%define libexif_version 0.6.19
12%define gconf_version 2.32.0
13%define gobject_introspection_version 0.9.8
14
15Name:           nautilus
16Summary:        Nautilus is a file manager for GNOME
17Summary(ja):    Nautilus - GNOME ファイルマネージャ
18Version:        3.4.2
19Release:        1%{?_dist_release}
20License:        GPLv2+
21Group:          User Interface/Desktops
22URL:            http://www.gnome.org/projects/nautilus/
23
24Vendor:         Project Vine
25Distribution:   Vine Linux
26Packager:       Takemikaduchi
27
28Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.4/%{name}-%{version}.tar.xz
29
30# Some changes to default config
31Patch1:         nautilus-2.5.7-rhconfig.patch
32Patch3:         background-no-delay.patch
33
34# Why is this not upstream ?
35Patch6:         nautilus-2.23.5-dynamic-search.patch
36
37Patch7:         rtl-fix.patch
38
39# vine
40Patch100:       nautilus-2.8.2-vine.patch
41Patch101:       nautilus-2.30.0-vine.patch
42Patch102:       run_in_gnome.patch
43
44BuildRoot:      %{_tmppath}/%{name}-%{version}-root
45Requires:       gamin
46Requires:       vine-menus >= %{vine_menus_version}
47Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
48Requires:       libexif >= %{libexif_version}
49Requires:       %{name}-libs = %{version}-%{release}
50
51Requires(pre,preun,post): GConf2 >= %{gconf_version}
52Requires(post,postun): rarian-compat
53
54BuildRequires:  intltool
55BuildRequires:  libtool >= 1.4.2-10
56BuildRequires:  automake, autoconf
57BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
58
59BuildRequires:  glib2-devel >= %{glib2_version}
60BuildRequires:  pango-devel >= %{pango_version}
61BuildRequires:  gtk3-devel >= %{gtk3_version}
62BuildRequires:  libxml2-devel >= %{libxml2_version}
63BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
64BuildRequires:  gamin-devel
65BuildRequires:  startup-notification-devel >= %{startup_notification_version}
66#BuildRequires: tracker-devel
67BuildRequires:  libexif-devel  >= %{libexif_version}
68BuildRequires:  unique3-devel
69BuildRequires:  libnotify-devel
70BuildRequires:  libSM-devel
71BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
72BuildRequires:  gsettings-desktop-schemas
73
74Obsoletes:      nautilus-extras
75Obsoletes:      nautilus-suggested
76Obsoletes:      nautilus-mozilla < 2.0
77Obsoletes:      eel2 <= 2.24.1
78
79Provides:       eel2 <= 2.24.1
80
81
82%description
83Nautilus integrates access to files, applications, media,
84Internet-based resources and the Web. Nautilus delivers a dynamic and
85rich user experience. Nautilus is an free software project developed
86under the GNU General Public License and is a core component of the
87GNOME desktop project.
88
89%description -l ja
90Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
91リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
92豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
93のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
94プロジェクトのコア・コンポーネントです。
95
96%package devel
97Summary: Support for developing nautilus extensions
98Summary(ja): Nautilus 拡張機能開発のためのサポート
99License: LGPLv2+
100Group: Development/Libraries
101Requires: %{name}-libs = %{version}-%{release}
102Requires: pkgconfig
103
104%description devel
105This package provides libraries and header files needed
106for developing nautilus extensions.
107
108%description -l ja devel
109このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
110ヘッダファイルを提供します。
111
112%package libs
113Summary: Libraries for use in nautilus extentions
114Summary(ja): Nautilus 拡張機能で利用するライブラリ
115Group: User Interface/Desktops
116
117%description libs
118This package provides libraries required by nautilus extention
119module.
120
121%description -l ja libs
122このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
123
124%prep
125%setup -q -n %{name}-%{version}
126
127##patch3 -p1 -b .no-delay
128#%patch5 -p1 -b .selinux
129##patch6 -p1 -b .dynamic-search
130%patch7 -p1 -b .rtl-fix
131
132## %patch100 -p1 -b .vine
133## %patch101 -p1 -b .vine
134%patch102 -p1 -b .vine
135
136%build
137gtkdocize
138libtoolize --force --copy
139autoreconf -f -i
140CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
141%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
142
143export tagname=CC
144LANG=en_US make LIBTOOL=/usr/bin/libtool %{?_smp_mflags}
145
146%install
147rm -rf $RPM_BUILD_ROOT
148
149export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
150export tagname=CC
151LANG=en_US make install LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT
152unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
153
154## these are in desktop-backgrounds-basic
155## (uncomment when we patch the source to look in the right place)
156## /bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/nautilus/patterns
157
158# make sure desktop files validate by ignoring sr@Latn
159perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
160# desktop-file-install can't handle empty OnlyShowIn correctly
161perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
162
163desktop-file-install --vendor gnome --delete-original       \
164  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
165  --add-only-show-in GNOME                                  \
166  $RPM_BUILD_ROOT%{_datadir}/applications/*
167
168rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
169rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
170
171# mkdir -p $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-3.0
172rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-3.0/*.{la,a}
173
174%find_lang %name
175
176%clean
177rm -rf $RPM_BUILD_ROOT
178
179%post
180/sbin/ldconfig
181touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
182
183%posttrans
184%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null ||:
185gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
186scrollkeeper-update > /dev/null 2>&1 || :
187glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
188
189
190%postun
191/sbin/ldconfig
192if [ $1 -eq 0 ] ; then
193    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
194    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
195    scrollkeeper-update > /dev/null 2>&1 || :
196    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
197fi
198
199%files  -f %{name}.lang
200%defattr(-,root,root)
201%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
202%dir %{_libdir}/nautilus
203%dir %{_libdir}/nautilus/extensions-3.0
204%{_libdir}/nautilus/extensions-3.0/*.so
205%{_libexecdir}/nautilus-convert-metadata
206%{_datadir}/GConf/gsettings/nautilus.convert
207%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
208%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
209%{_datadir}/nautilus
210%{_datadir}/applications
211%{_datadir}/mime/*
212%{_datadir}/icons/hicolor/*
213%{_bindir}/*
214%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
215%{_datadir}/glib-2.0/schemas/
216%{_mandir}/man1/*
217
218%files devel
219%defattr(-, root, root)
220%{_includedir}/nautilus
221%{_libdir}/pkgconfig/*
222%{_libdir}/*.so
223%{_datadir}/gir-1.0
224%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
225
226%files libs
227%defattr(-, root, root)
228%{_libdir}/*.so.*
229%{_libdir}/girepository-1.0
230
231
232%changelog
233* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
234- new upstream release
235
236* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
237- new upstream release
238
239* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
240- added patch102 to fix autostart in other desktop environments
241  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
242
243* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
244- new upstream release
245
246* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
247- new upstream release
248
249* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
250- new upstream release
251
252* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
253- new upstream release
254
255* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
256- new upstream release
257- drop Patch101
258- change BuildRequires: gtk3-devel instread of gtk2-devel
259- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
260- change BuildRequires: unique3-devel instread of unique-devel
261- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
262
263* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
264- fixed group of libs
265- add translation of summary and description.
266- add Vendor, Distribution and Packager tags.
267
268* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
269- new upstream release
270
271* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
272- new upstream release
273
274* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
275 - new upstream release
276
277* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
278- new upstream release
279- add BuildRequires: gobject-introspection-devel
280- remove BuildRequires: libgnomeui-devel
281- add configure option (--enable-introspection=yes)
282
283* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
284- rebuild with rpm-4.8.1 for pkg-config file
285
286* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
287- split nautilus extention libraries to -libs subpackage.
288
289* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
290- new upstream release
291
292* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
293- new upstream release
294- drop Patch100
295- add Patch101
296- add Obsoletes: eel2 <= 2.24.1
297- add Provides: eel2 <= 2.24.1
298
299* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
300- new upstream release
301- add BuildRequires: libSM-devel
302
303* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
304- removed Requires: eel2
305- added %%posttrans section
306
307* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
308- new upstream release
309
310* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
311- new upstream release
312
313* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
314- new upstream release
315
316* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
317- new upstream release
318- split -devel subpackage
319
320* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
321- new upstream release
322
323* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
324- patch6 needs autoreconf
325
326* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
327- new upstream release
328
329* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
330- new upstream release
331
332* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
333- new upstream release
334- added Requires: gvfs
335
336* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
337- new upstream release
338- added Patches from FC
339  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
340  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
341  - Fix a crash in the Properties dialog while changing owner (patch from head)
342  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
343  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
344
345* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
346- new upstream release
347- dropped Patch11-13 and added Patch7-9 from Fedora
348  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
349  - Add patch from upstream to get audio preview working again
350    (#332251)
351  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
352  - Fix a crash with small fonts (#242350)
353  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
354  - Backport fixes for async thumbnail loading from svn
355
356* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
357- run autoreconf for Patch11 changes
358
359* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
360- remove tracker dependancy, Patch13 detects tracker dynamically.
361
362* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
363- add Patch13 to support user-dirs
364
365* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
366- new upstream release
367- enable tracker support
368- add BuildRequires: tracker-devel, Requires: tracker
369
370* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
371- new upstream release
372
373* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
374- add BuildRequires: gamin-devel, Requires: gamin
375- remove fam dependency (replaced by gamin)
376
377* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
378- new upsteram release
379
380* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
381- really applied Patch110...
382
383* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
384- add Patch110 to fix corruption of help option message.
385
386* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
387- new upstream release
388
389* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
390- fix typo in ja.po
391
392* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
393- update ja.po to translate patch50 related message.
394
395* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
396- add Patch50 to show progressbar on umounting
397  (ubuntu patch in Bug 313639)
398
399* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
400- new upstream release
401
402* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
403- add Patch10 to avoid background rendering delay
404
405* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
406- new upstream release
407
408* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
409- add fix-non-UTF-8-encoding.patch (patch0)
410  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
411
412* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
413- new upstream release
414
415* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
416- new upstream release
417
418* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
419- new upstream release
420
421* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
422- new upstream release
423
424* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
425- rebuild
426
427* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
428- new upstream version
429
430* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
431- new upstream version
432
433* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
434- add vine patch to change some defaults.
435  - change default zoom sine
436  - set always_use_browser
437
438* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
439- new upstream release
440
441* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
442- add Patch110 to fix libegg(egg-recent-model.c)
443  save old umask value before create ".recently-used" file.
444 
445* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
446- change default desktop font to Sans 9 (from Sans 10)
447- add patch10 to build with gtk+-2.4
448
449* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
450- new upstream release
451
452* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
453- new upstream release
454
455* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
456- add backport patch from rawhide (Patch10)
457
458* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
459- modified vine patch
460  - change default zoom level to small
461  - change desktop font to Sans 10
462
463* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
464- new upstream release
465
466* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
467- add desktop icon patch from rawhide
468
469* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
470- remove obsolete ja.po
471
472* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
473- new upstream release
474
475* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
476- new upstream release
477
478* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
479- new upstream release
480
481* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
482- update ja.po
483
484* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
485- new upstream release
486
487* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
488- new upstream release
489
490* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
491- new upstream release
492
493* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
494- new upstream release
495
496* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
497- new upstream release
498
499* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
500- new upstream release
501
502* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
503- add nautilus-cd-burner patch
504
505* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
506- new upstream release
507
508* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
509- discard scrollkeeper outputs.
510- update PreReq tags.
511
512* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
513- change icon for nautilus-file-management-properties
514- update ja.po
515
516* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
517- update ja.po
518- add translation for .desktop files.
519
520* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
521- add Requires: vine-menus
522
523* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
524- new upstream release
525
526* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
527- remove redhatize patch
528
529* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
530- rebuild to remove unneeded dependancy.
531
532* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
533- build for Vine Linux
534
535* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
536- add explicit startup-notification dependency because build system is
537  dumb
538- 2.1.3
539
540* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
541- 2.1.2
542
543* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
544- 2.0.7
545- remove patches that are upstream
546
547* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
548- Add badhack to make weblinks on desktop work
549
550* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
551- fix #70667 assertion failures
552- fix triple click patch
553
554* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
555- don't activate on double click
556
557* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
558- put button press mask in triple-click patch, maybe it will work
559- remove html-hack patch as it does nothing useful
560
561* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
562- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
563  bogus bug reports
564- add hack for HTML mime type handling in a web browser, not
565  nautilus
566
567* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
568- Updated to 2.0.6. Removed the patches I put upstream.
569- Added patch that fixes #72410
570
571* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
572- Add a simple patch so that redhat-config-packages can disable
573  the new window behavior for mounted CDs behavior.
574
575* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
576- Add patch to fix bug #70667
577
578* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
579- remove mp3
580
581* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
582- ignore the "add_to_session" preference as it only broke stuff
583- pad the left margin a bit to cope with poor word wrapping
584
585* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
586- Update to 2.0.5, remove topleft icon patch
587
588* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
589- Add patch to fix the bug where desktop icons get
590  stuck in the top left corner on startup
591
592* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
593- 2.0.4
594
595* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
596- obsolete nautilus-mozilla < 2.0 #69839
597
598* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
599- add rhconfig patch to Bluecurve theme and disable sidebar by default
600
601* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
602- drop start here files, require redhat-menus that has them
603
604* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
605- 2.0.3
606
607* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
608- build for new eel2, gail
609
610* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
611- and add the libexec components, mumble
612
613* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
614- put the components in the file list, were moved upstream
615
616* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
617- 2.0.1
618
619* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
620- Relibtoolize to fix relink problems for solib components
621- Add LANG=en_US to %makeinstall as well
622- Back out previous change, force locale to en_US to prevent UTF-8 problems
623- Add workaround for intltool-merge bug on ia64
624
625* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
626- automated rebuild
627
628* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
629- 2.0.0
630- use desktop-file-install
631- require desktop-backgrounds-basic
632
633* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
634- add wacky hack in hopes of fixing the hang-on-login thing
635
636* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
637- add build requires on new gail
638- rebuild to try to lose broken libgailutil.so.13 dependency
639
640* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
641- rebuild in different environment
642
643* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
644- 1.1.19
645
646* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
647- rebuild in different environment
648
649* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
650- really remove nautilus-devel if we are going to obsolete it
651- don't require hwbrowser
652
653* Sun May 26 2002 Tim Powers <timp@redhat.com>
654- automated rebuild
655
656* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
657- rebuild in different environment
658
659* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
660- 1.1.17
661
662* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
663- 1.1.14
664
665* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
666- require eog
667- obsolete nautilus-devel
668- fix name of schemas file in post
669
670* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
671- Update to 1.1.13
672
673* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
674- put tree view in file list
675
676* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
677- nautilus for gnome 2
678- clean up the spec file and file list a bit
679
680* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
681- merge translations
682
683* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
684- Add patch to fix trash crash
685
686* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
687- fix for metadata tmp race
688- backport thumbnail speed fix and thumbnail inf. loop fix
689
690* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
691- add some fixes from CVS version, including one for #61819 and a couple segfaults
692
693* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
694- fix thumbnails for files with future timestamp, #56862
695
696* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
697- buildrequires intltool #60633
698- apply Alex's pixbuf cache patch to save a few megs #60581
699
700* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
701- drop Milan-specific features, including png10 and ac25 patches
702- copy in 1.0.5 help component to avoid large risky patch
703- remove .la files
704- drop mozilla from ia64 again
705- remove oaf file from nautilus-mozilla that was also in the base
706  package
707
708* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
709- enable mozilla support on ia64
710
711* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
712- require Mozilla 0.9.7
713- Add patch that puts mozilla profile startup before embedding is initialized
714
715* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
716- 1.0.6, require Mozilla 0.9.6
717
718* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
719- Update to 1.0.5
720
721* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
722- Fix handling of GnomeVFSFileInfo structure (#53315)
723
724* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
725- Change handling of names on unmount to fix #52325
726
727* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
728- put nautilus-help.desktop in file list; #53109
729
730* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
731- Add po files from sources.redhat.com
732
733* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
734- Add po files from sources.redhat.com
735
736* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
737- Added patch to fix the .directory issuer
738
739* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
740- I screwed up the build yesterday, so it didn't actually contain the
741  fixes mentioned. This build should contain them.
742
743* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
744- fix bug causing 32000 stats or so in large directories,
745  should speed things up somewhat
746- fix #52104 via gruesome kdesktop-detection hack and setting
747  window type hint on our desktop window
748- fix so Start Here icon displays in sidebar
749- don't load non-local .desktop files
750
751* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
752- make Programs icon into a link, to match the other .desktop files
753- own various directories #51164
754- web page titles in Japanese, #51709
755- tree defaults to only directories #51850
756
757* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
758- make start here icon work again
759- kill some warning spew, #51661
760- cache getpwnam() results to speed things up a bit
761
762* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
763- Fix problem with missing desktop starthere.desktop file
764- New snapshot from our branch, fixes:
765  - On upgrade, icons migrated from GNOME desktop are not properly lined up
766    (#51436)
767  - icons dropped on the desktop don't end up where dropped. (#51441)
768  - Nautilus shouldn't have fam monitor read-only windows. This
769    keeps CDROMS from being unmounted until you close all
770
771    nautilus windows pointing to them. (#51442)
772  - Warnings about 'cannot statfs...' when moving items to trash.
773- Use separate start-here.desktop for panel, since the one used
774  for the root window only works from Nautilus.
775
776* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
777- Changed starthere .desktop files to be links instead
778- of spawning a new nautilus. This makes start-here:
779- much faster.
780
781* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
782- Added hwbrowser dependency
783- New snapshot, fixes the mozilla-view submit form problem
784
785* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
786- Rebuild with new xml-i18n-tools
787- fix crash in creating new desktop files
788
789* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
790- Fix up DnD code some more
791
792* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
793- Sync our CVS version; fixes some MUSTFIX
794  (the one about drawing background on startup,
795   properly translate desktop files, etc.)
796
797* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
798- Fix 64bit cleanness issue
799- Fix NULL mimetype crash
800- Disable additional_text for .desktop files
801
802* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
803- Fix unmounting devices.
804
805* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
806- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
807- mimetype sniffing.
808
809* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
810- Remove the "don't run as root" warning.
811- Remove eazel from bookmarks
812- langified (again? did someone change it?)
813
814* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
815- Apply a patch that makes nautilus dnd reset work with the latest
816- eel release.
817
818* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
819- Build on ia64 without the mozilla component.
820
821* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
822- Fix crash-on-startup showstopper
823- Fix can't-find-images bug (this one was only showing up
824  when built with debug symbols, since it was an uninitialized memory
825  read)
826
827* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
828- sync new tarball from our CVS branch,
829  fixes some drag-and-drop, changes URI scheme names,
830  etc.
831
832* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
833- Add BuildRequires (#49539, 49537)
834- Fix %%post, %%postun (#49720)
835- Background efficiency improvements and hacks
836
837* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
838- Don't launch esd on each mouseover.
839
840* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
841- move first time druid patch into my "CVS outstanding" patch
842- try to really remove Help/Feedback
843- try to really fix Help/Community Support
844- try again to get Start Here in the Go menu
845- try again to get Start Here on the desktop
846- don't show file sizes for .desktop files
847
848* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
849- add newline to ends of .desktop files that were missing them
850
851* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
852- update to my latest 'cvs diff -u' (adds default
853  Start Here link, displays .directory name in sidebar)
854- include /etc/X11/* links (starthere, sysconfig, serverconfig)
855
856* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
857- Patch to remove firsttime druid and flash
858
859* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
860- add hacks for displaying desktop files
861- add hack to turn off the "unwriteable" emblem
862
863* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
864- added defattr to the files lists to be (-,root,root)
865- languified
866
867* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
868- Need to run autoheader too.
869
870* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
871- Make the fam dependency a real runtime dependency
872- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
873- Cleaned up specfile.
874
875* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
876- Change default background and rubberband color.
877- Use the sidebar tabs from the default theme
878- BuildDepend on fam-devel, depend on fam
879- Disable the eazel update pages in the first-time druid.
880- Remove the eazel logo from the first-time druid
881
882* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
883- 1.0.4, removes eazel services icon and wizard page
884- Eazel logo is still in startup wizard for now, needs fixing
885
886* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
887- fix group (s/Desktop/Desktops/) #47134
888- remove ammonite dependency
889
890* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
891- add a different default theme
892- clean up file list overspecificity a bit
893
894* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
895- move to a CVS snapshot of nautilus for now
896  (Darin is my hero for having distcheck work out of CVS)
897
898* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
899- clean up defaults a bit
900
901* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
902- New version
903
904* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
905- Added BuildRequires lines
906- Changed Source to point to ftp.gnome.org instead of just the tarball name
907- Moved %description sections closer to their %package sections
908- Moved %changelog to the end, where so that it's not in the way
909- Changed configure and make install options to allow moving of
910  libraries, includes, binaries more easily
911- Removed hard-coded paths (don't define %prefix or %docdir)
912- replace %{prefix}/bin with %{_bindir}
913- replace %{prefix}/share with %{_datadir}
914- replace %{prefix}/lib with %{_libdir}
915- replace %{prefix}/include with %{_includedir}
916
917* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
918- removed obsoletes from sub packages and added mozilla and trilobite
919subpackages
920
921* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
922- created this thing
Note: See TracBrowser for help on using the repository browser.