source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 6011

Revision 6011, 30.4 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define glib2_version 2.32.0
2%define pango_version 1.30.0
3%define gtk3_version 3.4.0
4%define libxml2_version 2.7.8
5%define eog_version 3.4.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.4.0
8%define vine_menus_version 3.0
9%define gnome_menus_version 2.32.0
10%define startup_notification_version 0.10
11%define libexif_version 0.6.19
12%define gconf_version 2.32.0
13%define gobject_introspection_version 0.9.8
14
15Name:           nautilus
16Summary:        Nautilus is a file manager for GNOME
17Summary(ja):    Nautilus - GNOME ファイルマネージャ
18Version:        3.4.0
19Release:        1%{?_dist_release}
20License:        GPLv2+
21Group:          User Interface/Desktops
22URL:            http://www.gnome.org/projects/nautilus/
23
24Vendor:         Project Vine
25Distribution:   Vine Linux
26Packager:       Takemikaduchi
27
28Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.4/%{name}-%{version}.tar.xz
29
30# Some changes to default config
31Patch1:         nautilus-2.5.7-rhconfig.patch
32Patch3:         background-no-delay.patch
33
34# Why is this not upstream ?
35Patch6:         nautilus-2.23.5-dynamic-search.patch
36
37Patch7:         rtl-fix.patch
38
39# vine
40Patch100:       nautilus-2.8.2-vine.patch
41Patch101:       nautilus-2.30.0-vine.patch
42Patch102:       run_in_gnome.patch
43
44BuildRoot:      %{_tmppath}/%{name}-%{version}-root
45Requires:       gamin
46Requires:       vine-menus >= %{vine_menus_version}
47Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
48Requires:       libexif >= %{libexif_version}
49Requires:       %{name}-libs = %{version}-%{release}
50
51Requires(pre,preun,post): GConf2 >= %{gconf_version}
52Requires(post,postun): rarian-compat
53
54BuildRequires:  intltool
55BuildRequires:  libtool >= 1.4.2-10
56BuildRequires:  automake, autoconf
57BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
58
59BuildRequires:  glib2-devel >= %{glib2_version}
60BuildRequires:  pango-devel >= %{pango_version}
61BuildRequires:  gtk3-devel >= %{gtk3_version}
62BuildRequires:  libxml2-devel >= %{libxml2_version}
63BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
64BuildRequires:  gamin-devel
65BuildRequires:  startup-notification-devel >= %{startup_notification_version}
66#BuildRequires: tracker-devel
67BuildRequires:  libexif-devel  >= %{libexif_version}
68BuildRequires:  unique3-devel
69BuildRequires:  libnotify-devel
70BuildRequires:  libSM-devel
71BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
72BuildRequires:  gsettings-desktop-schemas
73
74Obsoletes:      nautilus-extras
75Obsoletes:      nautilus-suggested
76Obsoletes:      nautilus-mozilla < 2.0
77Obsoletes:      eel2 <= 2.24.1
78
79Provides:       eel2 <= 2.24.1
80
81
82%description
83Nautilus integrates access to files, applications, media,
84Internet-based resources and the Web. Nautilus delivers a dynamic and
85rich user experience. Nautilus is an free software project developed
86under the GNU General Public License and is a core component of the
87GNOME desktop project.
88
89%description -l ja
90Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
91リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
92豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
93のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
94プロジェクトのコア・コンポーネントです。
95
96%package devel
97Summary: Support for developing nautilus extensions
98Summary(ja): Nautilus 拡張機能開発のためのサポート
99License: LGPLv2+
100Group: Development/Libraries
101Requires: %{name}-libs = %{version}-%{release}
102Requires: pkgconfig
103
104%description devel
105This package provides libraries and header files needed
106for developing nautilus extensions.
107
108%description -l ja devel
109このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
110ヘッダファイルを提供します。
111
112%package libs
113Summary: Libraries for use in nautilus extentions
114Summary(ja): Nautilus 拡張機能で利用するライブラリ
115Group: User Interface/Desktops
116
117%description libs
118This package provides libraries required by nautilus extention
119module.
120
121%description -l ja libs
122このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
123
124%prep
125%setup -q -n %{name}-%{version}
126
127##patch3 -p1 -b .no-delay
128#%patch5 -p1 -b .selinux
129##patch6 -p1 -b .dynamic-search
130%patch7 -p1 -b .rtl-fix
131
132## %patch100 -p1 -b .vine
133## %patch101 -p1 -b .vine
134%patch102 -p1 -b .vine
135
136%build
137gtkdocize
138libtoolize --force --copy
139autoreconf -f -i
140CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
141%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
142
143export tagname=CC
144LANG=en_US make LIBTOOL=/usr/bin/libtool %{?_smp_mflags}
145
146%install
147rm -rf $RPM_BUILD_ROOT
148
149export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
150export tagname=CC
151LANG=en_US make install LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT
152unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
153
154## these are in desktop-backgrounds-basic
155## (uncomment when we patch the source to look in the right place)
156## /bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/nautilus/patterns
157
158# make sure desktop files validate by ignoring sr@Latn
159perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
160# desktop-file-install can't handle empty OnlyShowIn correctly
161perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
162
163desktop-file-install --vendor gnome --delete-original       \
164  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
165  --add-only-show-in GNOME                                  \
166  $RPM_BUILD_ROOT%{_datadir}/applications/*
167
168rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
169rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
170
171# mkdir -p $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-3.0
172rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-3.0/*.{la,a}
173
174%find_lang %name
175
176%clean
177rm -rf $RPM_BUILD_ROOT
178
179%post
180/sbin/ldconfig
181touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
182
183%posttrans
184%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null ||:
185gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
186scrollkeeper-update > /dev/null 2>&1 || :
187glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
188
189
190%postun
191/sbin/ldconfig
192if [ $1 -eq 0 ] ; then
193    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
194    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
195    scrollkeeper-update > /dev/null 2>&1 || :
196    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
197fi
198
199%files  -f %{name}.lang
200%defattr(-,root,root)
201%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
202%dir %{_libdir}/nautilus
203%dir %{_libdir}/nautilus/extensions-3.0
204%{_libdir}/nautilus/extensions-3.0/*.so
205%{_libexecdir}/nautilus-convert-metadata
206%{_datadir}/GConf/gsettings/nautilus.convert
207%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
208%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
209%{_datadir}/nautilus
210%{_datadir}/applications
211%{_datadir}/mime/*
212%{_datadir}/icons/hicolor/*
213%{_bindir}/*
214%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
215%{_datadir}/glib-2.0/schemas/
216%{_mandir}/man1/*
217
218%files devel
219%defattr(-, root, root)
220%{_includedir}/nautilus
221%{_libdir}/pkgconfig/*
222%{_libdir}/*.so
223%{_datadir}/gir-1.0
224%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
225
226%files libs
227%defattr(-, root, root)
228%{_libdir}/*.so.*
229%{_libdir}/girepository-1.0
230
231
232%changelog
233* Sun Apr 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
234- new upstream release
235
236* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
237- added patch102 to fix autostart in other desktop environments
238  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
239
240* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
241- new upstream release
242
243* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
244- new upstream release
245
246* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
247- new upstream release
248
249* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
250- new upstream release
251
252* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
253- new upstream release
254- drop Patch101
255- change BuildRequires: gtk3-devel instread of gtk2-devel
256- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
257- change BuildRequires: unique3-devel instread of unique-devel
258- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
259
260* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
261- fixed group of libs
262- add translation of summary and description.
263- add Vendor, Distribution and Packager tags.
264
265* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
266- new upstream release
267
268* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
269- new upstream release
270
271* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
272 - new upstream release
273
274* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
275- new upstream release
276- add BuildRequires: gobject-introspection-devel
277- remove BuildRequires: libgnomeui-devel
278- add configure option (--enable-introspection=yes)
279
280* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
281- rebuild with rpm-4.8.1 for pkg-config file
282
283* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
284- split nautilus extention libraries to -libs subpackage.
285
286* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
287- new upstream release
288
289* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
290- new upstream release
291- drop Patch100
292- add Patch101
293- add Obsoletes: eel2 <= 2.24.1
294- add Provides: eel2 <= 2.24.1
295
296* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
297- new upstream release
298- add BuildRequires: libSM-devel
299
300* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
301- removed Requires: eel2
302- added %%posttrans section
303
304* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
305- new upstream release
306
307* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
308- new upstream release
309
310* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
311- new upstream release
312
313* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
314- new upstream release
315- split -devel subpackage
316
317* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
318- new upstream release
319
320* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
321- patch6 needs autoreconf
322
323* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
324- new upstream release
325
326* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
327- new upstream release
328
329* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
330- new upstream release
331- added Requires: gvfs
332
333* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
334- new upstream release
335- added Patches from FC
336  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
337  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
338  - Fix a crash in the Properties dialog while changing owner (patch from head)
339  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
340  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
341
342* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
343- new upstream release
344- dropped Patch11-13 and added Patch7-9 from Fedora
345  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
346  - Add patch from upstream to get audio preview working again
347    (#332251)
348  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
349  - Fix a crash with small fonts (#242350)
350  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
351  - Backport fixes for async thumbnail loading from svn
352
353* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
354- run autoreconf for Patch11 changes
355
356* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
357- remove tracker dependancy, Patch13 detects tracker dynamically.
358
359* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
360- add Patch13 to support user-dirs
361
362* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
363- new upstream release
364- enable tracker support
365- add BuildRequires: tracker-devel, Requires: tracker
366
367* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
368- new upstream release
369
370* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
371- add BuildRequires: gamin-devel, Requires: gamin
372- remove fam dependency (replaced by gamin)
373
374* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
375- new upsteram release
376
377* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
378- really applied Patch110...
379
380* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
381- add Patch110 to fix corruption of help option message.
382
383* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
384- new upstream release
385
386* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
387- fix typo in ja.po
388
389* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
390- update ja.po to translate patch50 related message.
391
392* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
393- add Patch50 to show progressbar on umounting
394  (ubuntu patch in Bug 313639)
395
396* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
397- new upstream release
398
399* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
400- add Patch10 to avoid background rendering delay
401
402* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
403- new upstream release
404
405* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
406- add fix-non-UTF-8-encoding.patch (patch0)
407  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
408
409* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
410- new upstream release
411
412* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
413- new upstream release
414
415* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
416- new upstream release
417
418* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
419- new upstream release
420
421* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
422- rebuild
423
424* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
425- new upstream version
426
427* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
428- new upstream version
429
430* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
431- add vine patch to change some defaults.
432  - change default zoom sine
433  - set always_use_browser
434
435* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
436- new upstream release
437
438* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
439- add Patch110 to fix libegg(egg-recent-model.c)
440  save old umask value before create ".recently-used" file.
441 
442* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
443- change default desktop font to Sans 9 (from Sans 10)
444- add patch10 to build with gtk+-2.4
445
446* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
447- new upstream release
448
449* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
450- new upstream release
451
452* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
453- add backport patch from rawhide (Patch10)
454
455* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
456- modified vine patch
457  - change default zoom level to small
458  - change desktop font to Sans 10
459
460* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
461- new upstream release
462
463* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
464- add desktop icon patch from rawhide
465
466* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
467- remove obsolete ja.po
468
469* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
470- new upstream release
471
472* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
473- new upstream release
474
475* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
476- new upstream release
477
478* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
479- update ja.po
480
481* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
482- new upstream release
483
484* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
485- new upstream release
486
487* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
488- new upstream release
489
490* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
491- new upstream release
492
493* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
494- new upstream release
495
496* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
497- new upstream release
498
499* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
500- add nautilus-cd-burner patch
501
502* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
503- new upstream release
504
505* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
506- discard scrollkeeper outputs.
507- update PreReq tags.
508
509* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
510- change icon for nautilus-file-management-properties
511- update ja.po
512
513* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
514- update ja.po
515- add translation for .desktop files.
516
517* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
518- add Requires: vine-menus
519
520* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
521- new upstream release
522
523* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
524- remove redhatize patch
525
526* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
527- rebuild to remove unneeded dependancy.
528
529* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
530- build for Vine Linux
531
532* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
533- add explicit startup-notification dependency because build system is
534  dumb
535- 2.1.3
536
537* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
538- 2.1.2
539
540* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
541- 2.0.7
542- remove patches that are upstream
543
544* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
545- Add badhack to make weblinks on desktop work
546
547* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
548- fix #70667 assertion failures
549- fix triple click patch
550
551* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
552- don't activate on double click
553
554* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
555- put button press mask in triple-click patch, maybe it will work
556- remove html-hack patch as it does nothing useful
557
558* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
559- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
560  bogus bug reports
561- add hack for HTML mime type handling in a web browser, not
562  nautilus
563
564* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
565- Updated to 2.0.6. Removed the patches I put upstream.
566- Added patch that fixes #72410
567
568* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
569- Add a simple patch so that redhat-config-packages can disable
570  the new window behavior for mounted CDs behavior.
571
572* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
573- Add patch to fix bug #70667
574
575* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
576- remove mp3
577
578* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
579- ignore the "add_to_session" preference as it only broke stuff
580- pad the left margin a bit to cope with poor word wrapping
581
582* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
583- Update to 2.0.5, remove topleft icon patch
584
585* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
586- Add patch to fix the bug where desktop icons get
587  stuck in the top left corner on startup
588
589* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
590- 2.0.4
591
592* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
593- obsolete nautilus-mozilla < 2.0 #69839
594
595* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
596- add rhconfig patch to Bluecurve theme and disable sidebar by default
597
598* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
599- drop start here files, require redhat-menus that has them
600
601* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
602- 2.0.3
603
604* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
605- build for new eel2, gail
606
607* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
608- and add the libexec components, mumble
609
610* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
611- put the components in the file list, were moved upstream
612
613* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
614- 2.0.1
615
616* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
617- Relibtoolize to fix relink problems for solib components
618- Add LANG=en_US to %makeinstall as well
619- Back out previous change, force locale to en_US to prevent UTF-8 problems
620- Add workaround for intltool-merge bug on ia64
621
622* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
623- automated rebuild
624
625* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
626- 2.0.0
627- use desktop-file-install
628- require desktop-backgrounds-basic
629
630* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
631- add wacky hack in hopes of fixing the hang-on-login thing
632
633* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
634- add build requires on new gail
635- rebuild to try to lose broken libgailutil.so.13 dependency
636
637* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
638- rebuild in different environment
639
640* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
641- 1.1.19
642
643* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
644- rebuild in different environment
645
646* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
647- really remove nautilus-devel if we are going to obsolete it
648- don't require hwbrowser
649
650* Sun May 26 2002 Tim Powers <timp@redhat.com>
651- automated rebuild
652
653* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
654- rebuild in different environment
655
656* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
657- 1.1.17
658
659* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
660- 1.1.14
661
662* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
663- require eog
664- obsolete nautilus-devel
665- fix name of schemas file in post
666
667* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
668- Update to 1.1.13
669
670* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
671- put tree view in file list
672
673* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
674- nautilus for gnome 2
675- clean up the spec file and file list a bit
676
677* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
678- merge translations
679
680* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
681- Add patch to fix trash crash
682
683* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
684- fix for metadata tmp race
685- backport thumbnail speed fix and thumbnail inf. loop fix
686
687* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
688- add some fixes from CVS version, including one for #61819 and a couple segfaults
689
690* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
691- fix thumbnails for files with future timestamp, #56862
692
693* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
694- buildrequires intltool #60633
695- apply Alex's pixbuf cache patch to save a few megs #60581
696
697* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
698- drop Milan-specific features, including png10 and ac25 patches
699- copy in 1.0.5 help component to avoid large risky patch
700- remove .la files
701- drop mozilla from ia64 again
702- remove oaf file from nautilus-mozilla that was also in the base
703  package
704
705* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
706- enable mozilla support on ia64
707
708* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
709- require Mozilla 0.9.7
710- Add patch that puts mozilla profile startup before embedding is initialized
711
712* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
713- 1.0.6, require Mozilla 0.9.6
714
715* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
716- Update to 1.0.5
717
718* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
719- Fix handling of GnomeVFSFileInfo structure (#53315)
720
721* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
722- Change handling of names on unmount to fix #52325
723
724* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
725- put nautilus-help.desktop in file list; #53109
726
727* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
728- Add po files from sources.redhat.com
729
730* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
731- Add po files from sources.redhat.com
732
733* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
734- Added patch to fix the .directory issuer
735
736* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
737- I screwed up the build yesterday, so it didn't actually contain the
738  fixes mentioned. This build should contain them.
739
740* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
741- fix bug causing 32000 stats or so in large directories,
742  should speed things up somewhat
743- fix #52104 via gruesome kdesktop-detection hack and setting
744  window type hint on our desktop window
745- fix so Start Here icon displays in sidebar
746- don't load non-local .desktop files
747
748* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
749- make Programs icon into a link, to match the other .desktop files
750- own various directories #51164
751- web page titles in Japanese, #51709
752- tree defaults to only directories #51850
753
754* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
755- make start here icon work again
756- kill some warning spew, #51661
757- cache getpwnam() results to speed things up a bit
758
759* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
760- Fix problem with missing desktop starthere.desktop file
761- New snapshot from our branch, fixes:
762  - On upgrade, icons migrated from GNOME desktop are not properly lined up
763    (#51436)
764  - icons dropped on the desktop don't end up where dropped. (#51441)
765  - Nautilus shouldn't have fam monitor read-only windows. This
766    keeps CDROMS from being unmounted until you close all
767
768    nautilus windows pointing to them. (#51442)
769  - Warnings about 'cannot statfs...' when moving items to trash.
770- Use separate start-here.desktop for panel, since the one used
771  for the root window only works from Nautilus.
772
773* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
774- Changed starthere .desktop files to be links instead
775- of spawning a new nautilus. This makes start-here:
776- much faster.
777
778* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
779- Added hwbrowser dependency
780- New snapshot, fixes the mozilla-view submit form problem
781
782* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
783- Rebuild with new xml-i18n-tools
784- fix crash in creating new desktop files
785
786* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
787- Fix up DnD code some more
788
789* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
790- Sync our CVS version; fixes some MUSTFIX
791  (the one about drawing background on startup,
792   properly translate desktop files, etc.)
793
794* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
795- Fix 64bit cleanness issue
796- Fix NULL mimetype crash
797- Disable additional_text for .desktop files
798
799* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
800- Fix unmounting devices.
801
802* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
803- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
804- mimetype sniffing.
805
806* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
807- Remove the "don't run as root" warning.
808- Remove eazel from bookmarks
809- langified (again? did someone change it?)
810
811* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
812- Apply a patch that makes nautilus dnd reset work with the latest
813- eel release.
814
815* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
816- Build on ia64 without the mozilla component.
817
818* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
819- Fix crash-on-startup showstopper
820- Fix can't-find-images bug (this one was only showing up
821  when built with debug symbols, since it was an uninitialized memory
822  read)
823
824* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
825- sync new tarball from our CVS branch,
826  fixes some drag-and-drop, changes URI scheme names,
827  etc.
828
829* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
830- Add BuildRequires (#49539, 49537)
831- Fix %%post, %%postun (#49720)
832- Background efficiency improvements and hacks
833
834* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
835- Don't launch esd on each mouseover.
836
837* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
838- move first time druid patch into my "CVS outstanding" patch
839- try to really remove Help/Feedback
840- try to really fix Help/Community Support
841- try again to get Start Here in the Go menu
842- try again to get Start Here on the desktop
843- don't show file sizes for .desktop files
844
845* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
846- add newline to ends of .desktop files that were missing them
847
848* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
849- update to my latest 'cvs diff -u' (adds default
850  Start Here link, displays .directory name in sidebar)
851- include /etc/X11/* links (starthere, sysconfig, serverconfig)
852
853* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
854- Patch to remove firsttime druid and flash
855
856* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
857- add hacks for displaying desktop files
858- add hack to turn off the "unwriteable" emblem
859
860* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
861- added defattr to the files lists to be (-,root,root)
862- languified
863
864* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
865- Need to run autoheader too.
866
867* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
868- Make the fam dependency a real runtime dependency
869- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
870- Cleaned up specfile.
871
872* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
873- Change default background and rubberband color.
874- Use the sidebar tabs from the default theme
875- BuildDepend on fam-devel, depend on fam
876- Disable the eazel update pages in the first-time druid.
877- Remove the eazel logo from the first-time druid
878
879* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
880- 1.0.4, removes eazel services icon and wizard page
881- Eazel logo is still in startup wizard for now, needs fixing
882
883* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
884- fix group (s/Desktop/Desktops/) #47134
885- remove ammonite dependency
886
887* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
888- add a different default theme
889- clean up file list overspecificity a bit
890
891* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
892- move to a CVS snapshot of nautilus for now
893  (Darin is my hero for having distcheck work out of CVS)
894
895* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
896- clean up defaults a bit
897
898* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
899- New version
900
901* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
902- Added BuildRequires lines
903- Changed Source to point to ftp.gnome.org instead of just the tarball name
904- Moved %description sections closer to their %package sections
905- Moved %changelog to the end, where so that it's not in the way
906- Changed configure and make install options to allow moving of
907  libraries, includes, binaries more easily
908- Removed hard-coded paths (don't define %prefix or %docdir)
909- replace %{prefix}/bin with %{_bindir}
910- replace %{prefix}/share with %{_datadir}
911- replace %{prefix}/lib with %{_libdir}
912- replace %{prefix}/include with %{_includedir}
913
914* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
915- removed obsoletes from sub packages and added mozilla and trilobite
916subpackages
917
918* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
919- created this thing
Note: See TracBrowser for help on using the repository browser.