source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 5524

Revision 5524, 30.3 KB checked in by kudoh, 12 years ago (diff)
Line 
1%define glib2_version 2.30.0
2%define pango_version 1.28.4
3%define gtk3_version 3.2.0
4%define libxml2_version 2.7.8
5%define eog_version 3.0.1
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.0.0
8%define vine_menus_version 3.0
9%define gnome_menus_version 2.32.0
10%define startup_notification_version 0.10
11%define libexif_version 0.6.19
12%define gconf_version 2.32.0
13%define gobject_introspection_version 0.9.8
14
15Name:           nautilus
16Summary:        Nautilus is a file manager for GNOME
17Summary(ja):    Nautilus - GNOME ファイルマネージャ
18Version:        3.2.1
19Release:        2%{?_dist_release}
20License:        GPLv2+
21Group:          User Interface/Desktops
22URL:            http://www.gnome.org/projects/nautilus/
23
24Vendor:         Project Vine
25Distribution:   Vine Linux
26Packager:       Takemikaduchi
27
28Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.2/%{name}-%{version}.tar.xz
29
30# Some changes to default config
31Patch1:         nautilus-2.5.7-rhconfig.patch
32Patch3:         background-no-delay.patch
33
34# Why is this not upstream ?
35Patch6:         nautilus-2.23.5-dynamic-search.patch
36
37Patch7:         rtl-fix.patch
38
39# vine
40Patch100:       nautilus-2.8.2-vine.patch
41Patch101:       nautilus-2.30.0-vine.patch
42Patch102:       run_in_gnome.patch
43
44BuildRoot:      %{_tmppath}/%{name}-%{version}-root
45Requires:       gamin
46Requires:       vine-menus >= %{vine_menus_version}
47Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
48Requires:       libexif >= %{libexif_version}
49Requires:       %{name}-libs = %{version}-%{release}
50
51Requires(pre,preun,post): GConf2 >= %{gconf_version}
52Requires(post,postun): rarian-compat
53
54BuildRequires:  intltool
55BuildRequires:  libtool >= 1.4.2-10
56BuildRequires:  automake, autoconf
57BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
58
59BuildRequires:  glib2-devel >= %{glib2_version}
60BuildRequires:  pango-devel >= %{pango_version}
61BuildRequires:  gtk3-devel >= %{gtk3_version}
62BuildRequires:  libxml2-devel >= %{libxml2_version}
63BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
64BuildRequires:  gamin-devel
65BuildRequires:  startup-notification-devel >= %{startup_notification_version}
66#BuildRequires: tracker-devel
67BuildRequires:  libexif-devel  >= %{libexif_version}
68BuildRequires:  unique3-devel
69BuildRequires:  libnotify-devel
70BuildRequires:  libSM-devel
71BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
72BuildRequires:  gsettings-desktop-schemas
73
74Obsoletes:      nautilus-extras
75Obsoletes:      nautilus-suggested
76Obsoletes:      nautilus-mozilla < 2.0
77Obsoletes:      eel2 <= 2.24.1
78
79Provides:       eel2 <= 2.24.1
80
81
82%description
83Nautilus integrates access to files, applications, media,
84Internet-based resources and the Web. Nautilus delivers a dynamic and
85rich user experience. Nautilus is an free software project developed
86under the GNU General Public License and is a core component of the
87GNOME desktop project.
88
89%description -l ja
90Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
91リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
92豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
93のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
94プロジェクトのコア・コンポーネントです。
95
96%package devel
97Summary: Support for developing nautilus extensions
98Summary(ja): Nautilus 拡張機能開発のためのサポート
99License: LGPLv2+
100Group: Development/Libraries
101Requires: %{name}-libs = %{version}-%{release}
102Requires: pkgconfig
103
104%description devel
105This package provides libraries and header files needed
106for developing nautilus extensions.
107
108%description -l ja devel
109このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
110ヘッダファイルを提供します。
111
112%package libs
113Summary: Libraries for use in nautilus extentions
114Summary(ja): Nautilus 拡張機能で利用するライブラリ
115Group: User Interface/Desktops
116
117%description libs
118This package provides libraries required by nautilus extention
119module.
120
121%description -l ja libs
122このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
123
124%prep
125%setup -q -n %{name}-%{version}
126
127##patch3 -p1 -b .no-delay
128#%patch5 -p1 -b .selinux
129##patch6 -p1 -b .dynamic-search
130%patch7 -p1 -b .rtl-fix
131
132## %patch100 -p1 -b .vine
133## %patch101 -p1 -b .vine
134%patch102 -p1 -b .vine
135
136%build
137gtkdocize
138libtoolize --force --copy
139autoreconf -f -i
140CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
141%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
142
143export tagname=CC
144LANG=en_US make LIBTOOL=/usr/bin/libtool %{?_smp_mflags}
145
146%install
147rm -rf $RPM_BUILD_ROOT
148
149export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
150export tagname=CC
151LANG=en_US make install LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT
152unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
153
154## these are in desktop-backgrounds-basic
155## (uncomment when we patch the source to look in the right place)
156## /bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/nautilus/patterns
157
158# make sure desktop files validate by ignoring sr@Latn
159perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
160# desktop-file-install can't handle empty OnlyShowIn correctly
161perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
162
163desktop-file-install --vendor gnome --delete-original       \
164  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
165  --add-only-show-in GNOME                                  \
166  $RPM_BUILD_ROOT%{_datadir}/applications/*
167
168rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
169rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
170
171# mkdir -p $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-3.0
172rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-3.0/*.{la,a}
173
174%find_lang %name
175
176%clean
177rm -rf $RPM_BUILD_ROOT
178
179%post
180/sbin/ldconfig
181touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
182
183%posttrans
184%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null ||:
185gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
186scrollkeeper-update > /dev/null 2>&1 || :
187glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
188
189
190%postun
191/sbin/ldconfig
192if [ $1 -eq 0 ] ; then
193    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
194    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
195    scrollkeeper-update > /dev/null 2>&1 || :
196    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
197fi
198
199%files  -f %{name}.lang
200%defattr(-,root,root)
201%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
202%dir %{_libdir}/nautilus
203%dir %{_libdir}/nautilus/extensions-3.0
204%{_libdir}/nautilus/extensions-3.0/*.so
205%{_libexecdir}/nautilus-convert-metadata
206%{_datadir}/GConf/gsettings/nautilus.convert
207%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
208%{_datadir}/nautilus
209%{_datadir}/pixmaps
210%{_datadir}/applications
211%{_datadir}/mime/*
212%{_datadir}/icons/hicolor/*
213%{_bindir}/*
214%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
215%{_datadir}/glib-2.0/schemas/
216%{_mandir}/man1/*
217
218%files devel
219%defattr(-, root, root)
220%{_includedir}/nautilus
221%{_libdir}/pkgconfig/*
222%{_libdir}/*.so
223%{_datadir}/gir-1.0
224%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
225
226%files libs
227%defattr(-, root, root)
228%{_libdir}/*.so.*
229%{_libdir}/girepository-1.0
230
231
232%changelog
233* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
234- added patch102 to fix autostart in other desktop environments
235  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
236
237* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
238- new upstream release
239
240* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
241- new upstream release
242
243* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
244- new upstream release
245
246* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
247- new upstream release
248
249* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
250- new upstream release
251- drop Patch101
252- change BuildRequires: gtk3-devel instread of gtk2-devel
253- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
254- change BuildRequires: unique3-devel instread of unique-devel
255- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
256
257* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
258- fixed group of libs
259- add translation of summary and description.
260- add Vendor, Distribution and Packager tags.
261
262* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
263- new upstream release
264
265* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
266- new upstream release
267
268* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
269 - new upstream release
270
271* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
272- new upstream release
273- add BuildRequires: gobject-introspection-devel
274- remove BuildRequires: libgnomeui-devel
275- add configure option (--enable-introspection=yes)
276
277* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
278- rebuild with rpm-4.8.1 for pkg-config file
279
280* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
281- split nautilus extention libraries to -libs subpackage.
282
283* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
284- new upstream release
285
286* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
287- new upstream release
288- drop Patch100
289- add Patch101
290- add Obsoletes: eel2 <= 2.24.1
291- add Provides: eel2 <= 2.24.1
292
293* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
294- new upstream release
295- add BuildRequires: libSM-devel
296
297* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
298- removed Requires: eel2
299- added %%posttrans section
300
301* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
302- new upstream release
303
304* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
305- new upstream release
306
307* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
308- new upstream release
309
310* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
311- new upstream release
312- split -devel subpackage
313
314* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
315- new upstream release
316
317* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
318- patch6 needs autoreconf
319
320* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
321- new upstream release
322
323* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
324- new upstream release
325
326* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
327- new upstream release
328- added Requires: gvfs
329
330* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
331- new upstream release
332- added Patches from FC
333  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
334  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
335  - Fix a crash in the Properties dialog while changing owner (patch from head)
336  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
337  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
338
339* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
340- new upstream release
341- dropped Patch11-13 and added Patch7-9 from Fedora
342  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
343  - Add patch from upstream to get audio preview working again
344    (#332251)
345  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
346  - Fix a crash with small fonts (#242350)
347  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
348  - Backport fixes for async thumbnail loading from svn
349
350* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
351- run autoreconf for Patch11 changes
352
353* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
354- remove tracker dependancy, Patch13 detects tracker dynamically.
355
356* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
357- add Patch13 to support user-dirs
358
359* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
360- new upstream release
361- enable tracker support
362- add BuildRequires: tracker-devel, Requires: tracker
363
364* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
365- new upstream release
366
367* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
368- add BuildRequires: gamin-devel, Requires: gamin
369- remove fam dependency (replaced by gamin)
370
371* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
372- new upsteram release
373
374* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
375- really applied Patch110...
376
377* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
378- add Patch110 to fix corruption of help option message.
379
380* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
381- new upstream release
382
383* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
384- fix typo in ja.po
385
386* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
387- update ja.po to translate patch50 related message.
388
389* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
390- add Patch50 to show progressbar on umounting
391  (ubuntu patch in Bug 313639)
392
393* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
394- new upstream release
395
396* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
397- add Patch10 to avoid background rendering delay
398
399* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
400- new upstream release
401
402* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
403- add fix-non-UTF-8-encoding.patch (patch0)
404  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
405
406* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
407- new upstream release
408
409* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
410- new upstream release
411
412* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
413- new upstream release
414
415* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
416- new upstream release
417
418* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
419- rebuild
420
421* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
422- new upstream version
423
424* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
425- new upstream version
426
427* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
428- add vine patch to change some defaults.
429  - change default zoom sine
430  - set always_use_browser
431
432* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
433- new upstream release
434
435* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
436- add Patch110 to fix libegg(egg-recent-model.c)
437  save old umask value before create ".recently-used" file.
438 
439* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
440- change default desktop font to Sans 9 (from Sans 10)
441- add patch10 to build with gtk+-2.4
442
443* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
444- new upstream release
445
446* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
447- new upstream release
448
449* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
450- add backport patch from rawhide (Patch10)
451
452* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
453- modified vine patch
454  - change default zoom level to small
455  - change desktop font to Sans 10
456
457* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
458- new upstream release
459
460* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
461- add desktop icon patch from rawhide
462
463* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
464- remove obsolete ja.po
465
466* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
467- new upstream release
468
469* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
470- new upstream release
471
472* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
473- new upstream release
474
475* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
476- update ja.po
477
478* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
479- new upstream release
480
481* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
482- new upstream release
483
484* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
485- new upstream release
486
487* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
488- new upstream release
489
490* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
491- new upstream release
492
493* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
494- new upstream release
495
496* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
497- add nautilus-cd-burner patch
498
499* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
500- new upstream release
501
502* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
503- discard scrollkeeper outputs.
504- update PreReq tags.
505
506* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
507- change icon for nautilus-file-management-properties
508- update ja.po
509
510* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
511- update ja.po
512- add translation for .desktop files.
513
514* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
515- add Requires: vine-menus
516
517* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
518- new upstream release
519
520* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
521- remove redhatize patch
522
523* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
524- rebuild to remove unneeded dependancy.
525
526* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
527- build for Vine Linux
528
529* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
530- add explicit startup-notification dependency because build system is
531  dumb
532- 2.1.3
533
534* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
535- 2.1.2
536
537* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
538- 2.0.7
539- remove patches that are upstream
540
541* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
542- Add badhack to make weblinks on desktop work
543
544* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
545- fix #70667 assertion failures
546- fix triple click patch
547
548* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
549- don't activate on double click
550
551* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
552- put button press mask in triple-click patch, maybe it will work
553- remove html-hack patch as it does nothing useful
554
555* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
556- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
557  bogus bug reports
558- add hack for HTML mime type handling in a web browser, not
559  nautilus
560
561* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
562- Updated to 2.0.6. Removed the patches I put upstream.
563- Added patch that fixes #72410
564
565* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
566- Add a simple patch so that redhat-config-packages can disable
567  the new window behavior for mounted CDs behavior.
568
569* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
570- Add patch to fix bug #70667
571
572* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
573- remove mp3
574
575* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
576- ignore the "add_to_session" preference as it only broke stuff
577- pad the left margin a bit to cope with poor word wrapping
578
579* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
580- Update to 2.0.5, remove topleft icon patch
581
582* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
583- Add patch to fix the bug where desktop icons get
584  stuck in the top left corner on startup
585
586* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
587- 2.0.4
588
589* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
590- obsolete nautilus-mozilla < 2.0 #69839
591
592* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
593- add rhconfig patch to Bluecurve theme and disable sidebar by default
594
595* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
596- drop start here files, require redhat-menus that has them
597
598* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
599- 2.0.3
600
601* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
602- build for new eel2, gail
603
604* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
605- and add the libexec components, mumble
606
607* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
608- put the components in the file list, were moved upstream
609
610* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
611- 2.0.1
612
613* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
614- Relibtoolize to fix relink problems for solib components
615- Add LANG=en_US to %makeinstall as well
616- Back out previous change, force locale to en_US to prevent UTF-8 problems
617- Add workaround for intltool-merge bug on ia64
618
619* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
620- automated rebuild
621
622* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
623- 2.0.0
624- use desktop-file-install
625- require desktop-backgrounds-basic
626
627* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
628- add wacky hack in hopes of fixing the hang-on-login thing
629
630* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
631- add build requires on new gail
632- rebuild to try to lose broken libgailutil.so.13 dependency
633
634* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
635- rebuild in different environment
636
637* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
638- 1.1.19
639
640* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
641- rebuild in different environment
642
643* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
644- really remove nautilus-devel if we are going to obsolete it
645- don't require hwbrowser
646
647* Sun May 26 2002 Tim Powers <timp@redhat.com>
648- automated rebuild
649
650* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
651- rebuild in different environment
652
653* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
654- 1.1.17
655
656* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
657- 1.1.14
658
659* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
660- require eog
661- obsolete nautilus-devel
662- fix name of schemas file in post
663
664* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
665- Update to 1.1.13
666
667* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
668- put tree view in file list
669
670* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
671- nautilus for gnome 2
672- clean up the spec file and file list a bit
673
674* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
675- merge translations
676
677* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
678- Add patch to fix trash crash
679
680* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
681- fix for metadata tmp race
682- backport thumbnail speed fix and thumbnail inf. loop fix
683
684* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
685- add some fixes from CVS version, including one for #61819 and a couple segfaults
686
687* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
688- fix thumbnails for files with future timestamp, #56862
689
690* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
691- buildrequires intltool #60633
692- apply Alex's pixbuf cache patch to save a few megs #60581
693
694* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
695- drop Milan-specific features, including png10 and ac25 patches
696- copy in 1.0.5 help component to avoid large risky patch
697- remove .la files
698- drop mozilla from ia64 again
699- remove oaf file from nautilus-mozilla that was also in the base
700  package
701
702* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
703- enable mozilla support on ia64
704
705* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
706- require Mozilla 0.9.7
707- Add patch that puts mozilla profile startup before embedding is initialized
708
709* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
710- 1.0.6, require Mozilla 0.9.6
711
712* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
713- Update to 1.0.5
714
715* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
716- Fix handling of GnomeVFSFileInfo structure (#53315)
717
718* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
719- Change handling of names on unmount to fix #52325
720
721* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
722- put nautilus-help.desktop in file list; #53109
723
724* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
725- Add po files from sources.redhat.com
726
727* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
728- Add po files from sources.redhat.com
729
730* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
731- Added patch to fix the .directory issuer
732
733* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
734- I screwed up the build yesterday, so it didn't actually contain the
735  fixes mentioned. This build should contain them.
736
737* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
738- fix bug causing 32000 stats or so in large directories,
739  should speed things up somewhat
740- fix #52104 via gruesome kdesktop-detection hack and setting
741  window type hint on our desktop window
742- fix so Start Here icon displays in sidebar
743- don't load non-local .desktop files
744
745* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
746- make Programs icon into a link, to match the other .desktop files
747- own various directories #51164
748- web page titles in Japanese, #51709
749- tree defaults to only directories #51850
750
751* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
752- make start here icon work again
753- kill some warning spew, #51661
754- cache getpwnam() results to speed things up a bit
755
756* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
757- Fix problem with missing desktop starthere.desktop file
758- New snapshot from our branch, fixes:
759  - On upgrade, icons migrated from GNOME desktop are not properly lined up
760    (#51436)
761  - icons dropped on the desktop don't end up where dropped. (#51441)
762  - Nautilus shouldn't have fam monitor read-only windows. This
763    keeps CDROMS from being unmounted until you close all
764
765    nautilus windows pointing to them. (#51442)
766  - Warnings about 'cannot statfs...' when moving items to trash.
767- Use separate start-here.desktop for panel, since the one used
768  for the root window only works from Nautilus.
769
770* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
771- Changed starthere .desktop files to be links instead
772- of spawning a new nautilus. This makes start-here:
773- much faster.
774
775* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
776- Added hwbrowser dependency
777- New snapshot, fixes the mozilla-view submit form problem
778
779* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
780- Rebuild with new xml-i18n-tools
781- fix crash in creating new desktop files
782
783* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
784- Fix up DnD code some more
785
786* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
787- Sync our CVS version; fixes some MUSTFIX
788  (the one about drawing background on startup,
789   properly translate desktop files, etc.)
790
791* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
792- Fix 64bit cleanness issue
793- Fix NULL mimetype crash
794- Disable additional_text for .desktop files
795
796* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
797- Fix unmounting devices.
798
799* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
800- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
801- mimetype sniffing.
802
803* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
804- Remove the "don't run as root" warning.
805- Remove eazel from bookmarks
806- langified (again? did someone change it?)
807
808* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
809- Apply a patch that makes nautilus dnd reset work with the latest
810- eel release.
811
812* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
813- Build on ia64 without the mozilla component.
814
815* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
816- Fix crash-on-startup showstopper
817- Fix can't-find-images bug (this one was only showing up
818  when built with debug symbols, since it was an uninitialized memory
819  read)
820
821* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
822- sync new tarball from our CVS branch,
823  fixes some drag-and-drop, changes URI scheme names,
824  etc.
825
826* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
827- Add BuildRequires (#49539, 49537)
828- Fix %%post, %%postun (#49720)
829- Background efficiency improvements and hacks
830
831* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
832- Don't launch esd on each mouseover.
833
834* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
835- move first time druid patch into my "CVS outstanding" patch
836- try to really remove Help/Feedback
837- try to really fix Help/Community Support
838- try again to get Start Here in the Go menu
839- try again to get Start Here on the desktop
840- don't show file sizes for .desktop files
841
842* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
843- add newline to ends of .desktop files that were missing them
844
845* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
846- update to my latest 'cvs diff -u' (adds default
847  Start Here link, displays .directory name in sidebar)
848- include /etc/X11/* links (starthere, sysconfig, serverconfig)
849
850* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
851- Patch to remove firsttime druid and flash
852
853* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
854- add hacks for displaying desktop files
855- add hack to turn off the "unwriteable" emblem
856
857* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
858- added defattr to the files lists to be (-,root,root)
859- languified
860
861* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
862- Need to run autoheader too.
863
864* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
865- Make the fam dependency a real runtime dependency
866- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
867- Cleaned up specfile.
868
869* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
870- Change default background and rubberband color.
871- Use the sidebar tabs from the default theme
872- BuildDepend on fam-devel, depend on fam
873- Disable the eazel update pages in the first-time druid.
874- Remove the eazel logo from the first-time druid
875
876* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
877- 1.0.4, removes eazel services icon and wizard page
878- Eazel logo is still in startup wizard for now, needs fixing
879
880* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
881- fix group (s/Desktop/Desktops/) #47134
882- remove ammonite dependency
883
884* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
885- add a different default theme
886- clean up file list overspecificity a bit
887
888* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
889- move to a CVS snapshot of nautilus for now
890  (Darin is my hero for having distcheck work out of CVS)
891
892* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
893- clean up defaults a bit
894
895* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
896- New version
897
898* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
899- Added BuildRequires lines
900- Changed Source to point to ftp.gnome.org instead of just the tarball name
901- Moved %description sections closer to their %package sections
902- Moved %changelog to the end, where so that it's not in the way
903- Changed configure and make install options to allow moving of
904  libraries, includes, binaries more easily
905- Removed hard-coded paths (don't define %prefix or %docdir)
906- replace %{prefix}/bin with %{_bindir}
907- replace %{prefix}/share with %{_datadir}
908- replace %{prefix}/lib with %{_libdir}
909- replace %{prefix}/include with %{_includedir}
910
911* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
912- removed obsoletes from sub packages and added mozilla and trilobite
913subpackages
914
915* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
916- created this thing
Note: See TracBrowser for help on using the repository browser.