source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 2413

Revision 2413, 28.6 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1%define glib2_version 2.26.1
2%define pango_version 1.28.3
3%define gtk2_version 2.22.1
4%define libxml2_version 2.7.7
5%define eog_version 2.32.1
6%define desktop_file_utils_version 0.16
7%define gnome_desktop_version 2.32.1
8%define vine_menus_version 3.0
9%define gnome_menus_version 2.32.1
10%define startup_notification_version 0.10
11%define libexif_version 0.6.19
12%define gconf_version 2.32.0
13%define gobject_introspection_version 0.9.12
14
15Name:           nautilus
16Summary:        Nautilus is a file manager for GNOME
17Summary(ja):    Nautilus - GNOME ファイルマネージャ
18Version:        2.32.2.1
19Release:        1%{?_dist_release}
20License:        GPLv2+
21Group:          User Interface/Desktops
22URL:            http://www.gnome.org/projects/nautilus/
23
24Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.32/%{name}-%{version}.tar.bz2
25
26# Some changes to default config
27Patch1:         nautilus-2.5.7-rhconfig.patch
28Patch3:         background-no-delay.patch
29
30# Why is this not upstream ?
31Patch6:         nautilus-2.23.5-dynamic-search.patch
32
33Patch7:         rtl-fix.patch
34
35# vine
36Patch100:       nautilus-2.8.2-vine.patch
37Patch101:       nautilus-2.30.0-vine.patch
38
39BuildRoot:      %{_tmppath}/%{name}-%{version}-root
40Requires:       gamin
41Requires:       vine-menus >= %{vine_menus_version}
42Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
43Requires:       libexif >= %{libexif_version}
44Requires:       %{name}-libs = %{version}-%{release}
45
46Requires(pre,preun,post): GConf2 >= %{gconf_version}
47Requires(post,postun): rarian-compat
48
49BuildRequires:  glib2-devel >= %{glib2_version}
50BuildRequires:  pango-devel >= %{pango_version}
51BuildRequires:  gtk2-devel >= %{gtk2_version}
52BuildRequires:  libxml2-devel >= %{libxml2_version}
53BuildRequires:  gnome-desktop-devel >= %{gnome_desktop_version}
54BuildRequires:  gamin-devel
55BuildRequires:  intltool
56BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
57BuildRequires:  libtool >= 1.4.2-10
58BuildRequires:  automake, autoconf
59BuildRequires:  startup-notification-devel >= %{startup_notification_version}
60#BuildRequires: tracker-devel >= %{tracker_version}
61BuildRequires:  libexif-devel  >= %{libexif_version}
62BuildRequires:  unique-devel
63BuildRequires:  libtool, autoconf
64BuildRequires:  libSM-devel
65BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
66
67Obsoletes:      nautilus-extras
68Obsoletes:      nautilus-suggested
69Obsoletes:      nautilus-mozilla < 2.0
70Obsoletes:      eel2 <= 2.24.1
71
72Provides:       eel2 <= 2.24.1
73
74
75%description
76Nautilus integrates access to files, applications, media,
77Internet-based resources and the Web. Nautilus delivers a dynamic and
78rich user experience. Nautilus is an free software project developed
79under the GNU General Public License and is a core component of the
80GNOME desktop project.
81
82%package devel
83Summary: Support for developing nautilus extensions
84License: LGPLv2+
85Group: Development/Libraries
86Requires: %{name}-libs = %{version}-%{release}
87Requires: pkgconfig
88
89%description devel
90This package provides libraries and header files needed
91for developing nautilus extensions.
92
93%package libs
94Summary: Libraries for use in nautilus extentions
95Group: User Interfaces/Desktops
96
97%description libs
98This package provides libraries required by nautilus extention
99module.
100
101%prep
102%setup -q -n %{name}-%{version}
103
104##patch3 -p1 -b .no-delay
105#%patch5 -p1 -b .selinux
106##patch6 -p1 -b .dynamic-search
107%patch7 -p1 -b .rtl-fix
108
109## %patch100 -p1 -b .vine
110%patch101 -p1 -b .vine
111
112%build
113gtkdocize
114libtoolize --force --copy
115autoreconf -f -i
116CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
117%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
118
119export tagname=CC
120LANG=en_US make LIBTOOL=/usr/bin/libtool %{?_smp_mflags}
121
122%install
123rm -rf $RPM_BUILD_ROOT
124
125export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
126export tagname=CC
127LANG=en_US %makeinstall LIBTOOL=/usr/bin/libtool
128unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
129
130## these are in desktop-backgrounds-basic
131## (uncomment when we patch the source to look in the right place)
132## /bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/nautilus/patterns
133
134# make sure desktop files validate by ignoring sr@Latn
135perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
136# desktop-file-install can't handle empty OnlyShowIn correctly
137perl -pi -e 's/OnlyShowIn=;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
138
139desktop-file-install --vendor gnome --delete-original       \
140  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
141  --add-only-show-in GNOME                                  \
142  $RPM_BUILD_ROOT%{_datadir}/applications/*
143
144perl -pi -e 's/OnlyShowIn=GNOME;/OnlyShowIn=;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
145
146rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{la,a}
147rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
148rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
149
150mkdir -p $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-2.0
151
152%find_lang %name
153
154%clean
155rm -rf $RPM_BUILD_ROOT
156
157%post
158/sbin/ldconfig
159touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
160export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
161gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
162
163%posttrans
164%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null ||:
165gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
166scrollkeeper-update > /dev/null 2>&1 || :
167
168%pre
169if [ "$1" -gt 1 ]; then
170    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
171    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
172fi
173
174%preun
175if [ "$1" -eq 0 ]; then
176    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
177    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
178fi
179
180%postun
181/sbin/ldconfig
182if [ $1 -eq 0 ] ; then
183    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
184    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
185    scrollkeeper-update > /dev/null 2>&1 || :
186fi
187
188%files  -f %{name}.lang
189%defattr(-,root,root)
190%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
191%dir %{_libdir}/nautilus
192%dir %{_libdir}/nautilus/extensions-2.0
193%{_libexecdir}/nautilus-convert-metadata
194%{_datadir}/nautilus
195%{_datadir}/pixmaps
196%{_datadir}/applications
197%{_datadir}/mime/*
198%{_datadir}/icons/hicolor/*
199%{_bindir}/*
200%{_sysconfdir}/gconf/schemas/*
201%{_mandir}/man1/*
202
203%files devel
204%defattr(-, root, root)
205%{_includedir}/nautilus
206%{_libdir}/pkgconfig/*
207%{_libdir}/*.so
208%{_datadir}/gir-1.0
209%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
210
211%files libs
212%defattr(-, root, root)
213%{_libdir}/*.so.*
214%{_libdir}/girepository-1.0
215
216
217%changelog
218* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
219- new upstream release
220
221* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
222- new upstream release
223
224* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
225- new upstream release
226
227* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
228- new upstream release
229- add BuildRequires: gobject-introspection-devel
230- remove BuildRequires: libgnomeui-devel
231- add configure option (--enable-introspection=yes)
232
233* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
234- rebuild with rpm-4.8.1 for pkg-config file
235
236* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
237- split nautilus extention libraries to -libs subpackage.
238
239* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
240- new upstream release
241
242* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
243- new upstream release
244- drop Patch100
245- add Patch101
246- add Obsoletes: eel2 <= 2.24.1
247- add Provides: eel2 <= 2.24.1
248
249* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
250- new upstream release
251- add BuildRequires: libSM-devel
252
253* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
254- removed Requires: eel2
255- added %%posttrans section
256
257* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
258- new upstream release
259
260* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
261- new upstream release
262
263* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
264- new upstream release
265
266* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
267- new upstream release
268- split -devel subpackage
269
270* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
271- new upstream release
272
273* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
274- patch6 needs autoreconf
275
276* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
277- new upstream release
278
279* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
280- new upstream release
281
282* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
283- new upstream release
284- added Requires: gvfs
285
286* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
287- new upstream release
288- added Patches from FC
289  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
290  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
291  - Fix a crash in the Properties dialog while changing owner (patch from head)
292  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
293  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
294
295* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
296- new upstream release
297- dropped Patch11-13 and added Patch7-9 from Fedora
298  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
299  - Add patch from upstream to get audio preview working again
300    (#332251)
301  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
302  - Fix a crash with small fonts (#242350)
303  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
304  - Backport fixes for async thumbnail loading from svn
305
306* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
307- run autoreconf for Patch11 changes
308
309* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
310- remove tracker dependancy, Patch13 detects tracker dynamically.
311
312* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
313- add Patch13 to support user-dirs
314
315* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
316- new upstream release
317- enable tracker support
318- add BuildRequires: tracker-devel, Requires: tracker
319
320* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
321- new upstream release
322
323* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
324- add BuildRequires: gamin-devel, Requires: gamin
325- remove fam dependency (replaced by gamin)
326
327* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
328- new upsteram release
329
330* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
331- really applied Patch110...
332
333* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
334- add Patch110 to fix corruption of help option message.
335
336* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
337- new upstream release
338
339* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
340- fix typo in ja.po
341
342* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
343- update ja.po to translate patch50 related message.
344
345* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
346- add Patch50 to show progressbar on umounting
347  (ubuntu patch in Bug 313639)
348
349* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
350- new upstream release
351
352* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
353- add Patch10 to avoid background rendering delay
354
355* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
356- new upstream release
357
358* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
359- add fix-non-UTF-8-encoding.patch (patch0)
360  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
361
362* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
363- new upstream release
364
365* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
366- new upstream release
367
368* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
369- new upstream release
370
371* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
372- new upstream release
373
374* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
375- rebuild
376
377* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
378- new upstream version
379
380* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
381- new upstream version
382
383* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
384- add vine patch to change some defaults.
385  - change default zoom sine
386  - set always_use_browser
387
388* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
389- new upstream release
390
391* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
392- add Patch110 to fix libegg(egg-recent-model.c)
393  save old umask value before create ".recently-used" file.
394 
395* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
396- change default desktop font to Sans 9 (from Sans 10)
397- add patch10 to build with gtk+-2.4
398
399* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
400- new upstream release
401
402* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
403- new upstream release
404
405* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
406- add backport patch from rawhide (Patch10)
407
408* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
409- modified vine patch
410  - change default zoom level to small
411  - change desktop font to Sans 10
412
413* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
414- new upstream release
415
416* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
417- add desktop icon patch from rawhide
418
419* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
420- remove obsolete ja.po
421
422* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
423- new upstream release
424
425* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
426- new upstream release
427
428* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
429- new upstream release
430
431* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
432- update ja.po
433
434* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
435- new upstream release
436
437* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
438- new upstream release
439
440* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
441- new upstream release
442
443* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
444- new upstream release
445
446* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
447- new upstream release
448
449* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
450- new upstream release
451
452* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
453- add nautilus-cd-burner patch
454
455* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
456- new upstream release
457
458* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
459- discard scrollkeeper outputs.
460- update PreReq tags.
461
462* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
463- change icon for nautilus-file-management-properties
464- update ja.po
465
466* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
467- update ja.po
468- add translation for .desktop files.
469
470* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
471- add Requires: vine-menus
472
473* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
474- new upstream release
475
476* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
477- remove redhatize patch
478
479* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
480- rebuild to remove unneeded dependancy.
481
482* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
483- build for Vine Linux
484
485* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
486- add explicit startup-notification dependency because build system is
487  dumb
488- 2.1.3
489
490* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
491- 2.1.2
492
493* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
494- 2.0.7
495- remove patches that are upstream
496
497* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
498- Add badhack to make weblinks on desktop work
499
500* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
501- fix #70667 assertion failures
502- fix triple click patch
503
504* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
505- don't activate on double click
506
507* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
508- put button press mask in triple-click patch, maybe it will work
509- remove html-hack patch as it does nothing useful
510
511* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
512- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
513  bogus bug reports
514- add hack for HTML mime type handling in a web browser, not
515  nautilus
516
517* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
518- Updated to 2.0.6. Removed the patches I put upstream.
519- Added patch that fixes #72410
520
521* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
522- Add a simple patch so that redhat-config-packages can disable
523  the new window behavior for mounted CDs behavior.
524
525* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
526- Add patch to fix bug #70667
527
528* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
529- remove mp3
530
531* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
532- ignore the "add_to_session" preference as it only broke stuff
533- pad the left margin a bit to cope with poor word wrapping
534
535* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
536- Update to 2.0.5, remove topleft icon patch
537
538* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
539- Add patch to fix the bug where desktop icons get
540  stuck in the top left corner on startup
541
542* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
543- 2.0.4
544
545* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
546- obsolete nautilus-mozilla < 2.0 #69839
547
548* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
549- add rhconfig patch to Bluecurve theme and disable sidebar by default
550
551* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
552- drop start here files, require redhat-menus that has them
553
554* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
555- 2.0.3
556
557* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
558- build for new eel2, gail
559
560* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
561- and add the libexec components, mumble
562
563* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
564- put the components in the file list, were moved upstream
565
566* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
567- 2.0.1
568
569* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
570- Relibtoolize to fix relink problems for solib components
571- Add LANG=en_US to %makeinstall as well
572- Back out previous change, force locale to en_US to prevent UTF-8 problems
573- Add workaround for intltool-merge bug on ia64
574
575* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
576- automated rebuild
577
578* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
579- 2.0.0
580- use desktop-file-install
581- require desktop-backgrounds-basic
582
583* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
584- add wacky hack in hopes of fixing the hang-on-login thing
585
586* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
587- add build requires on new gail
588- rebuild to try to lose broken libgailutil.so.13 dependency
589
590* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
591- rebuild in different environment
592
593* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
594- 1.1.19
595
596* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
597- rebuild in different environment
598
599* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
600- really remove nautilus-devel if we are going to obsolete it
601- don't require hwbrowser
602
603* Sun May 26 2002 Tim Powers <timp@redhat.com>
604- automated rebuild
605
606* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
607- rebuild in different environment
608
609* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
610- 1.1.17
611
612* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
613- 1.1.14
614
615* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
616- require eog
617- obsolete nautilus-devel
618- fix name of schemas file in post
619
620* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
621- Update to 1.1.13
622
623* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
624- put tree view in file list
625
626* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
627- nautilus for gnome 2
628- clean up the spec file and file list a bit
629
630* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
631- merge translations
632
633* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
634- Add patch to fix trash crash
635
636* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
637- fix for metadata tmp race
638- backport thumbnail speed fix and thumbnail inf. loop fix
639
640* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
641- add some fixes from CVS version, including one for #61819 and a couple segfaults
642
643* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
644- fix thumbnails for files with future timestamp, #56862
645
646* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
647- buildrequires intltool #60633
648- apply Alex's pixbuf cache patch to save a few megs #60581
649
650* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
651- drop Milan-specific features, including png10 and ac25 patches
652- copy in 1.0.5 help component to avoid large risky patch
653- remove .la files
654- drop mozilla from ia64 again
655- remove oaf file from nautilus-mozilla that was also in the base
656  package
657
658* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
659- enable mozilla support on ia64
660
661* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
662- require Mozilla 0.9.7
663- Add patch that puts mozilla profile startup before embedding is initialized
664
665* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
666- 1.0.6, require Mozilla 0.9.6
667
668* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
669- Update to 1.0.5
670
671* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
672- Fix handling of GnomeVFSFileInfo structure (#53315)
673
674* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
675- Change handling of names on unmount to fix #52325
676
677* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
678- put nautilus-help.desktop in file list; #53109
679
680* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
681- Add po files from sources.redhat.com
682
683* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
684- Add po files from sources.redhat.com
685
686* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
687- Added patch to fix the .directory issuer
688
689* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
690- I screwed up the build yesterday, so it didn't actually contain the
691  fixes mentioned. This build should contain them.
692
693* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
694- fix bug causing 32000 stats or so in large directories,
695  should speed things up somewhat
696- fix #52104 via gruesome kdesktop-detection hack and setting
697  window type hint on our desktop window
698- fix so Start Here icon displays in sidebar
699- don't load non-local .desktop files
700
701* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
702- make Programs icon into a link, to match the other .desktop files
703- own various directories #51164
704- web page titles in Japanese, #51709
705- tree defaults to only directories #51850
706
707* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
708- make start here icon work again
709- kill some warning spew, #51661
710- cache getpwnam() results to speed things up a bit
711
712* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
713- Fix problem with missing desktop starthere.desktop file
714- New snapshot from our branch, fixes:
715  - On upgrade, icons migrated from GNOME desktop are not properly lined up
716    (#51436)
717  - icons dropped on the desktop don't end up where dropped. (#51441)
718  - Nautilus shouldn't have fam monitor read-only windows. This
719    keeps CDROMS from being unmounted until you close all
720
721    nautilus windows pointing to them. (#51442)
722  - Warnings about 'cannot statfs...' when moving items to trash.
723- Use separate start-here.desktop for panel, since the one used
724  for the root window only works from Nautilus.
725
726* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
727- Changed starthere .desktop files to be links instead
728- of spawning a new nautilus. This makes start-here:
729- much faster.
730
731* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
732- Added hwbrowser dependency
733- New snapshot, fixes the mozilla-view submit form problem
734
735* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
736- Rebuild with new xml-i18n-tools
737- fix crash in creating new desktop files
738
739* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
740- Fix up DnD code some more
741
742* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
743- Sync our CVS version; fixes some MUSTFIX
744  (the one about drawing background on startup,
745   properly translate desktop files, etc.)
746
747* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
748- Fix 64bit cleanness issue
749- Fix NULL mimetype crash
750- Disable additional_text for .desktop files
751
752* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
753- Fix unmounting devices.
754
755* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
756- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
757- mimetype sniffing.
758
759* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
760- Remove the "don't run as root" warning.
761- Remove eazel from bookmarks
762- langified (again? did someone change it?)
763
764* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
765- Apply a patch that makes nautilus dnd reset work with the latest
766- eel release.
767
768* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
769- Build on ia64 without the mozilla component.
770
771* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
772- Fix crash-on-startup showstopper
773- Fix can't-find-images bug (this one was only showing up
774  when built with debug symbols, since it was an uninitialized memory
775  read)
776
777* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
778- sync new tarball from our CVS branch,
779  fixes some drag-and-drop, changes URI scheme names,
780  etc.
781
782* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
783- Add BuildRequires (#49539, 49537)
784- Fix %%post, %%postun (#49720)
785- Background efficiency improvements and hacks
786
787* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
788- Don't launch esd on each mouseover.
789
790* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
791- move first time druid patch into my "CVS outstanding" patch
792- try to really remove Help/Feedback
793- try to really fix Help/Community Support
794- try again to get Start Here in the Go menu
795- try again to get Start Here on the desktop
796- don't show file sizes for .desktop files
797
798* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
799- add newline to ends of .desktop files that were missing them
800
801* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
802- update to my latest 'cvs diff -u' (adds default
803  Start Here link, displays .directory name in sidebar)
804- include /etc/X11/* links (starthere, sysconfig, serverconfig)
805
806* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
807- Patch to remove firsttime druid and flash
808
809* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
810- add hacks for displaying desktop files
811- add hack to turn off the "unwriteable" emblem
812
813* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
814- added defattr to the files lists to be (-,root,root)
815- languified
816
817* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
818- Need to run autoheader too.
819
820* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
821- Make the fam dependency a real runtime dependency
822- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
823- Cleaned up specfile.
824
825* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
826- Change default background and rubberband color.
827- Use the sidebar tabs from the default theme
828- BuildDepend on fam-devel, depend on fam
829- Disable the eazel update pages in the first-time druid.
830- Remove the eazel logo from the first-time druid
831
832* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
833- 1.0.4, removes eazel services icon and wizard page
834- Eazel logo is still in startup wizard for now, needs fixing
835
836* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
837- fix group (s/Desktop/Desktops/) #47134
838- remove ammonite dependency
839
840* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
841- add a different default theme
842- clean up file list overspecificity a bit
843
844* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
845- move to a CVS snapshot of nautilus for now
846  (Darin is my hero for having distcheck work out of CVS)
847
848* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
849- clean up defaults a bit
850
851* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
852- New version
853
854* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
855- Added BuildRequires lines
856- Changed Source to point to ftp.gnome.org instead of just the tarball name
857- Moved %description sections closer to their %package sections
858- Moved %changelog to the end, where so that it's not in the way
859- Changed configure and make install options to allow moving of
860  libraries, includes, binaries more easily
861- Removed hard-coded paths (don't define %prefix or %docdir)
862- replace %{prefix}/bin with %{_bindir}
863- replace %{prefix}/share with %{_datadir}
864- replace %{prefix}/lib with %{_libdir}
865- replace %{prefix}/include with %{_includedir}
866
867* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
868- removed obsoletes from sub packages and added mozilla and trilobite
869subpackages
870
871* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
872- created this thing
Note: See TracBrowser for help on using the repository browser.