source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 1883

Revision 1883, 28.0 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%define glib2_version 2.24.0
2%define pango_version 1.28.0
3%define gtk2_version 2.20.0
4%define libgnomeui_version 2.24.3
5%define libxml2_version 2.5.10
6%define eog_version 2.30.0
7%define desktop_file_utils_version 0.3
8%define gnome_desktop_version 2.30.0
9%define vine_menus_version 3.0
10%define gnome_menus_version 2.30.0
11%define gnome_vfs2_version 2.24.1
12%define startup_notification_version 0.5
13%define libexif_version 0.5.12
14%define gconf_version 2.28.0
15
16Name:           nautilus
17Summary:        Nautilus is a file manager for GNOME
18Summary(ja):    Nautilus - GNOME ファイルマネージャ
19Version:        2.30.1
20Release:        3%{?_dist_release}
21License:        GPLv2+
22Group:          User Interface/Desktops
23URL:            http://www.gnome.org/projects/nautilus/
24
25Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.30/%{name}-%{version}.tar.bz2
26
27# Some changes to default config
28Patch1:         nautilus-2.5.7-rhconfig.patch
29Patch3:         background-no-delay.patch
30
31# Why is this not upstream ?
32Patch6:         nautilus-2.23.5-dynamic-search.patch
33
34Patch7:         rtl-fix.patch
35
36# vine
37Patch100:       nautilus-2.8.2-vine.patch
38Patch101:       nautilus-2.30.0-vine.patch
39
40BuildRoot:      %{_tmppath}/%{name}-%{version}-root
41Requires:       gamin
42Requires:       vine-menus >= %{vine_menus_version}
43Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
44Requires:       libexif >= %{libexif_version}
45Requires:       %{name}-libs = %{version}-%{release}
46
47Requires(pre,preun,post): GConf2 >= %{gconf_version}
48Requires(post,postun): rarian-compat
49
50BuildRequires:  glib2-devel >= %{glib2_version}
51BuildRequires:  pango-devel >= %{pango_version}
52BuildRequires:  gtk2-devel >= %{gtk2_version}
53BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
54BuildRequires:  libxml2-devel >= %{libxml2_version}
55BuildRequires:  gnome-desktop-devel >= %{gnome_desktop_version}
56BuildRequires:  gamin-devel
57BuildRequires:  intltool
58BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
59BuildRequires:  libtool >= 1.4.2-10
60BuildRequires:  automake, autoconf
61BuildRequires:  startup-notification-devel >= %{startup_notification_version}
62#BuildRequires: tracker-devel >= %{tracker_version}
63BuildRequires:  libexif-devel  >= %{libexif_version}
64BuildRequires:  unique-devel
65BuildRequires:  libtool, autoconf
66BuildRequires:  libSM-devel
67
68Obsoletes:      nautilus-extras
69Obsoletes:      nautilus-suggested
70Obsoletes:      nautilus-mozilla < 2.0
71Obsoletes:      eel2 <= 2.24.1
72
73Provides:       eel2 <= 2.24.1
74
75
76%description
77Nautilus integrates access to files, applications, media,
78Internet-based resources and the Web. Nautilus delivers a dynamic and
79rich user experience. Nautilus is an free software project developed
80under the GNU General Public License and is a core component of the
81GNOME desktop project.
82
83%package devel
84Summary: Support for developing nautilus extensions
85License: LGPLv2+
86Group: Development/Libraries
87Requires: %{name}-libs = %{version}-%{release}
88Requires: pkgconfig
89
90%description devel
91This package provides libraries and header files needed
92for developing nautilus extensions.
93
94%package libs
95Summary: Libraries for use in nautilus extentions
96Group: User Interfaces/Desktops
97
98%description libs
99This package provides libraries required by nautilus extention
100module.
101
102%prep
103%setup -q -n %{name}-%{version}
104
105##patch3 -p1 -b .no-delay
106#%patch5 -p1 -b .selinux
107##patch6 -p1 -b .dynamic-search
108%patch7 -p1 -b .rtl-fix
109
110## %patch100 -p1 -b .vine
111%patch101 -p1 -b .vine
112
113%build
114gtkdocize
115libtoolize --force --copy
116autoreconf -f -i
117CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
118%configure --disable-more-warnings --disable-update-mimedb
119
120export tagname=CC
121LANG=en_US make LIBTOOL=/usr/bin/libtool %{?_smp_mflags}
122
123%install
124rm -rf $RPM_BUILD_ROOT
125
126export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
127export tagname=CC
128LANG=en_US %makeinstall LIBTOOL=/usr/bin/libtool
129unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
130
131## these are in desktop-backgrounds-basic
132## (uncomment when we patch the source to look in the right place)
133## /bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/nautilus/patterns
134
135# make sure desktop files validate by ignoring sr@Latn
136perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
137# desktop-file-install can't handle empty OnlyShowIn correctly
138perl -pi -e 's/OnlyShowIn=;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
139
140desktop-file-install --vendor gnome --delete-original       \
141  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
142  --add-only-show-in GNOME                                  \
143  $RPM_BUILD_ROOT%{_datadir}/applications/*
144
145perl -pi -e 's/OnlyShowIn=GNOME;/OnlyShowIn=;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
146
147rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{la,a}
148rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
149rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
150
151mkdir -p $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-2.0
152
153%find_lang %name
154
155%clean
156rm -rf $RPM_BUILD_ROOT
157
158%post
159/sbin/ldconfig
160touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
161export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
162gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
163
164%posttrans
165%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null ||:
166gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
167scrollkeeper-update > /dev/null 2>&1 || :
168
169%pre
170if [ "$1" -gt 1 ]; then
171    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
172    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
173fi
174
175%preun
176if [ "$1" -eq 0 ]; then
177    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
178    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
179fi
180
181%postun
182/sbin/ldconfig
183if [ $1 -eq 0 ] ; then
184    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
185    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
186    scrollkeeper-update > /dev/null 2>&1 || :
187fi
188
189%files  -f %{name}.lang
190%defattr(-,root,root)
191%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
192%dir %{_libdir}/nautilus
193%dir %{_libdir}/nautilus/extensions-2.0
194%{_libexecdir}/nautilus-convert-metadata
195%{_datadir}/nautilus
196%{_datadir}/pixmaps
197%{_datadir}/applications
198%{_datadir}/mime/*
199%{_datadir}/icons/hicolor/*
200%{_bindir}/*
201%{_sysconfdir}/gconf/schemas/*
202%{_mandir}/man1/*
203
204%files devel
205%defattr(-, root, root)
206%{_includedir}/nautilus
207%{_libdir}/pkgconfig/*
208%{_libdir}/*.so
209%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
210
211%files libs
212%defattr(-, root, root)
213%{_libdir}/*.so.*
214
215
216%changelog
217* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
218- rebuild with rpm-4.8.1 for pkg-config file
219
220* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
221- split nautilus extention libraries to -libs subpackage.
222
223* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
224- new upstream release
225
226* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
227- new upstream release
228- drop Patch100
229- add Patch101
230- add Obsoletes: eel2 <= 2.24.1
231- add Provides: eel2 <= 2.24.1
232
233* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
234- new upstream release
235- add BuildRequires: libSM-devel
236
237* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
238- removed Requires: eel2
239- added %%posttrans section
240
241* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
242- new upstream release
243
244* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
245- new upstream release
246
247* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
248- new upstream release
249
250* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
251- new upstream release
252- split -devel subpackage
253
254* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
255- new upstream release
256
257* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
258- patch6 needs autoreconf
259
260* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
261- new upstream release
262
263* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
264- new upstream release
265
266* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
267- new upstream release
268- added Requires: gvfs
269
270* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
271- new upstream release
272- added Patches from FC
273  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
274  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
275  - Fix a crash in the Properties dialog while changing owner (patch from head)
276  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
277  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
278
279* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
280- new upstream release
281- dropped Patch11-13 and added Patch7-9 from Fedora
282  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
283  - Add patch from upstream to get audio preview working again
284    (#332251)
285  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
286  - Fix a crash with small fonts (#242350)
287  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
288  - Backport fixes for async thumbnail loading from svn
289
290* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
291- run autoreconf for Patch11 changes
292
293* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
294- remove tracker dependancy, Patch13 detects tracker dynamically.
295
296* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
297- add Patch13 to support user-dirs
298
299* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
300- new upstream release
301- enable tracker support
302- add BuildRequires: tracker-devel, Requires: tracker
303
304* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
305- new upstream release
306
307* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
308- add BuildRequires: gamin-devel, Requires: gamin
309- remove fam dependency (replaced by gamin)
310
311* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
312- new upsteram release
313
314* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
315- really applied Patch110...
316
317* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
318- add Patch110 to fix corruption of help option message.
319
320* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
321- new upstream release
322
323* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
324- fix typo in ja.po
325
326* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
327- update ja.po to translate patch50 related message.
328
329* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
330- add Patch50 to show progressbar on umounting
331  (ubuntu patch in Bug 313639)
332
333* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
334- new upstream release
335
336* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
337- add Patch10 to avoid background rendering delay
338
339* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
340- new upstream release
341
342* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
343- add fix-non-UTF-8-encoding.patch (patch0)
344  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
345
346* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
347- new upstream release
348
349* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
350- new upstream release
351
352* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
353- new upstream release
354
355* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
356- new upstream release
357
358* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
359- rebuild
360
361* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
362- new upstream version
363
364* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
365- new upstream version
366
367* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
368- add vine patch to change some defaults.
369  - change default zoom sine
370  - set always_use_browser
371
372* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
373- new upstream release
374
375* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
376- add Patch110 to fix libegg(egg-recent-model.c)
377  save old umask value before create ".recently-used" file.
378 
379* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
380- change default desktop font to Sans 9 (from Sans 10)
381- add patch10 to build with gtk+-2.4
382
383* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
384- new upstream release
385
386* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
387- new upstream release
388
389* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
390- add backport patch from rawhide (Patch10)
391
392* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
393- modified vine patch
394  - change default zoom level to small
395  - change desktop font to Sans 10
396
397* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
398- new upstream release
399
400* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
401- add desktop icon patch from rawhide
402
403* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
404- remove obsolete ja.po
405
406* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
407- new upstream release
408
409* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
410- new upstream release
411
412* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
413- new upstream release
414
415* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
416- update ja.po
417
418* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
419- new upstream release
420
421* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
422- new upstream release
423
424* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
425- new upstream release
426
427* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
428- new upstream release
429
430* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
431- new upstream release
432
433* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
434- new upstream release
435
436* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
437- add nautilus-cd-burner patch
438
439* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
440- new upstream release
441
442* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
443- discard scrollkeeper outputs.
444- update PreReq tags.
445
446* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
447- change icon for nautilus-file-management-properties
448- update ja.po
449
450* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
451- update ja.po
452- add translation for .desktop files.
453
454* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
455- add Requires: vine-menus
456
457* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
458- new upstream release
459
460* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
461- remove redhatize patch
462
463* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
464- rebuild to remove unneeded dependancy.
465
466* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
467- build for Vine Linux
468
469* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
470- add explicit startup-notification dependency because build system is
471  dumb
472- 2.1.3
473
474* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
475- 2.1.2
476
477* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
478- 2.0.7
479- remove patches that are upstream
480
481* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
482- Add badhack to make weblinks on desktop work
483
484* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
485- fix #70667 assertion failures
486- fix triple click patch
487
488* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
489- don't activate on double click
490
491* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
492- put button press mask in triple-click patch, maybe it will work
493- remove html-hack patch as it does nothing useful
494
495* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
496- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
497  bogus bug reports
498- add hack for HTML mime type handling in a web browser, not
499  nautilus
500
501* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
502- Updated to 2.0.6. Removed the patches I put upstream.
503- Added patch that fixes #72410
504
505* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
506- Add a simple patch so that redhat-config-packages can disable
507  the new window behavior for mounted CDs behavior.
508
509* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
510- Add patch to fix bug #70667
511
512* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
513- remove mp3
514
515* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
516- ignore the "add_to_session" preference as it only broke stuff
517- pad the left margin a bit to cope with poor word wrapping
518
519* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
520- Update to 2.0.5, remove topleft icon patch
521
522* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
523- Add patch to fix the bug where desktop icons get
524  stuck in the top left corner on startup
525
526* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
527- 2.0.4
528
529* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
530- obsolete nautilus-mozilla < 2.0 #69839
531
532* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
533- add rhconfig patch to Bluecurve theme and disable sidebar by default
534
535* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
536- drop start here files, require redhat-menus that has them
537
538* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
539- 2.0.3
540
541* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
542- build for new eel2, gail
543
544* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
545- and add the libexec components, mumble
546
547* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
548- put the components in the file list, were moved upstream
549
550* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
551- 2.0.1
552
553* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
554- Relibtoolize to fix relink problems for solib components
555- Add LANG=en_US to %makeinstall as well
556- Back out previous change, force locale to en_US to prevent UTF-8 problems
557- Add workaround for intltool-merge bug on ia64
558
559* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
560- automated rebuild
561
562* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
563- 2.0.0
564- use desktop-file-install
565- require desktop-backgrounds-basic
566
567* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
568- add wacky hack in hopes of fixing the hang-on-login thing
569
570* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
571- add build requires on new gail
572- rebuild to try to lose broken libgailutil.so.13 dependency
573
574* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
575- rebuild in different environment
576
577* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
578- 1.1.19
579
580* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
581- rebuild in different environment
582
583* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
584- really remove nautilus-devel if we are going to obsolete it
585- don't require hwbrowser
586
587* Sun May 26 2002 Tim Powers <timp@redhat.com>
588- automated rebuild
589
590* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
591- rebuild in different environment
592
593* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
594- 1.1.17
595
596* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
597- 1.1.14
598
599* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
600- require eog
601- obsolete nautilus-devel
602- fix name of schemas file in post
603
604* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
605- Update to 1.1.13
606
607* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
608- put tree view in file list
609
610* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
611- nautilus for gnome 2
612- clean up the spec file and file list a bit
613
614* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
615- merge translations
616
617* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
618- Add patch to fix trash crash
619
620* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
621- fix for metadata tmp race
622- backport thumbnail speed fix and thumbnail inf. loop fix
623
624* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
625- add some fixes from CVS version, including one for #61819 and a couple segfaults
626
627* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
628- fix thumbnails for files with future timestamp, #56862
629
630* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
631- buildrequires intltool #60633
632- apply Alex's pixbuf cache patch to save a few megs #60581
633
634* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
635- drop Milan-specific features, including png10 and ac25 patches
636- copy in 1.0.5 help component to avoid large risky patch
637- remove .la files
638- drop mozilla from ia64 again
639- remove oaf file from nautilus-mozilla that was also in the base
640  package
641
642* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
643- enable mozilla support on ia64
644
645* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
646- require Mozilla 0.9.7
647- Add patch that puts mozilla profile startup before embedding is initialized
648
649* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
650- 1.0.6, require Mozilla 0.9.6
651
652* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
653- Update to 1.0.5
654
655* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
656- Fix handling of GnomeVFSFileInfo structure (#53315)
657
658* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
659- Change handling of names on unmount to fix #52325
660
661* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
662- put nautilus-help.desktop in file list; #53109
663
664* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
665- Add po files from sources.redhat.com
666
667* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
668- Add po files from sources.redhat.com
669
670* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
671- Added patch to fix the .directory issuer
672
673* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
674- I screwed up the build yesterday, so it didn't actually contain the
675  fixes mentioned. This build should contain them.
676
677* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
678- fix bug causing 32000 stats or so in large directories,
679  should speed things up somewhat
680- fix #52104 via gruesome kdesktop-detection hack and setting
681  window type hint on our desktop window
682- fix so Start Here icon displays in sidebar
683- don't load non-local .desktop files
684
685* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
686- make Programs icon into a link, to match the other .desktop files
687- own various directories #51164
688- web page titles in Japanese, #51709
689- tree defaults to only directories #51850
690
691* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
692- make start here icon work again
693- kill some warning spew, #51661
694- cache getpwnam() results to speed things up a bit
695
696* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
697- Fix problem with missing desktop starthere.desktop file
698- New snapshot from our branch, fixes:
699  - On upgrade, icons migrated from GNOME desktop are not properly lined up
700    (#51436)
701  - icons dropped on the desktop don't end up where dropped. (#51441)
702  - Nautilus shouldn't have fam monitor read-only windows. This
703    keeps CDROMS from being unmounted until you close all
704
705    nautilus windows pointing to them. (#51442)
706  - Warnings about 'cannot statfs...' when moving items to trash.
707- Use separate start-here.desktop for panel, since the one used
708  for the root window only works from Nautilus.
709
710* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
711- Changed starthere .desktop files to be links instead
712- of spawning a new nautilus. This makes start-here:
713- much faster.
714
715* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
716- Added hwbrowser dependency
717- New snapshot, fixes the mozilla-view submit form problem
718
719* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
720- Rebuild with new xml-i18n-tools
721- fix crash in creating new desktop files
722
723* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
724- Fix up DnD code some more
725
726* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
727- Sync our CVS version; fixes some MUSTFIX
728  (the one about drawing background on startup,
729   properly translate desktop files, etc.)
730
731* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
732- Fix 64bit cleanness issue
733- Fix NULL mimetype crash
734- Disable additional_text for .desktop files
735
736* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
737- Fix unmounting devices.
738
739* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
740- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
741- mimetype sniffing.
742
743* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
744- Remove the "don't run as root" warning.
745- Remove eazel from bookmarks
746- langified (again? did someone change it?)
747
748* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
749- Apply a patch that makes nautilus dnd reset work with the latest
750- eel release.
751
752* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
753- Build on ia64 without the mozilla component.
754
755* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
756- Fix crash-on-startup showstopper
757- Fix can't-find-images bug (this one was only showing up
758  when built with debug symbols, since it was an uninitialized memory
759  read)
760
761* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
762- sync new tarball from our CVS branch,
763  fixes some drag-and-drop, changes URI scheme names,
764  etc.
765
766* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
767- Add BuildRequires (#49539, 49537)
768- Fix %%post, %%postun (#49720)
769- Background efficiency improvements and hacks
770
771* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
772- Don't launch esd on each mouseover.
773
774* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
775- move first time druid patch into my "CVS outstanding" patch
776- try to really remove Help/Feedback
777- try to really fix Help/Community Support
778- try again to get Start Here in the Go menu
779- try again to get Start Here on the desktop
780- don't show file sizes for .desktop files
781
782* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
783- add newline to ends of .desktop files that were missing them
784
785* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
786- update to my latest 'cvs diff -u' (adds default
787  Start Here link, displays .directory name in sidebar)
788- include /etc/X11/* links (starthere, sysconfig, serverconfig)
789
790* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
791- Patch to remove firsttime druid and flash
792
793* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
794- add hacks for displaying desktop files
795- add hack to turn off the "unwriteable" emblem
796
797* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
798- added defattr to the files lists to be (-,root,root)
799- languified
800
801* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
802- Need to run autoheader too.
803
804* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
805- Make the fam dependency a real runtime dependency
806- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
807- Cleaned up specfile.
808
809* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
810- Change default background and rubberband color.
811- Use the sidebar tabs from the default theme
812- BuildDepend on fam-devel, depend on fam
813- Disable the eazel update pages in the first-time druid.
814- Remove the eazel logo from the first-time druid
815
816* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
817- 1.0.4, removes eazel services icon and wizard page
818- Eazel logo is still in startup wizard for now, needs fixing
819
820* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
821- fix group (s/Desktop/Desktops/) #47134
822- remove ammonite dependency
823
824* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
825- add a different default theme
826- clean up file list overspecificity a bit
827
828* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
829- move to a CVS snapshot of nautilus for now
830  (Darin is my hero for having distcheck work out of CVS)
831
832* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
833- clean up defaults a bit
834
835* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
836- New version
837
838* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
839- Added BuildRequires lines
840- Changed Source to point to ftp.gnome.org instead of just the tarball name
841- Moved %description sections closer to their %package sections
842- Moved %changelog to the end, where so that it's not in the way
843- Changed configure and make install options to allow moving of
844  libraries, includes, binaries more easily
845- Removed hard-coded paths (don't define %prefix or %docdir)
846- replace %{prefix}/bin with %{_bindir}
847- replace %{prefix}/share with %{_datadir}
848- replace %{prefix}/lib with %{_libdir}
849- replace %{prefix}/include with %{_includedir}
850
851* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
852- removed obsoletes from sub packages and added mozilla and trilobite
853subpackages
854
855* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
856- created this thing
Note: See TracBrowser for help on using the repository browser.