source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 1188

Revision 1188, 27.9 KB checked in by daisuke, 14 years ago (diff)

nautilus: split out nautilus extention libs to libs subpackage

Line 
1%define glib2_version 2.24.0
2%define pango_version 1.28.0
3%define gtk2_version 2.20.0
4%define libgnomeui_version 2.24.3
5%define libxml2_version 2.5.10
6%define eog_version 2.30.0
7%define desktop_file_utils_version 0.3
8%define gnome_desktop_version 2.30.0
9%define vine_menus_version 3.0
10%define gnome_menus_version 2.30.0
11%define gnome_vfs2_version 2.24.1
12%define startup_notification_version 0.5
13%define libexif_version 0.5.12
14%define gconf_version 2.28.0
15
16Name:           nautilus
17Summary:        Nautilus is a file manager for GNOME
18Summary(ja):    Nautilus - GNOME ファイルマネージャ
19Version:        2.30.1
20Release:        2%{?_dist_release}
21License:        GPLv2+
22Group:          User Interface/Desktops
23URL:            http://www.gnome.org/projects/nautilus/
24
25Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.30/%{name}-%{version}.tar.bz2
26
27# Some changes to default config
28Patch1:         nautilus-2.5.7-rhconfig.patch
29Patch3:         background-no-delay.patch
30
31# Why is this not upstream ?
32Patch6:         nautilus-2.23.5-dynamic-search.patch
33
34Patch7:         rtl-fix.patch
35
36# vine
37Patch100:       nautilus-2.8.2-vine.patch
38Patch101:       nautilus-2.30.0-vine.patch
39
40BuildRoot:      %{_tmppath}/%{name}-%{version}-root
41Requires:       gamin
42Requires:       vine-menus >= %{vine_menus_version}
43Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
44Requires:       libexif >= %{libexif_version}
45Requires:       %{name}-libs = %{version}-%{release}
46
47Requires(pre,preun,post): GConf2 >= %{gconf_version}
48Requires(post,postun): rarian-compat
49
50BuildRequires:  glib2-devel >= %{glib2_version}
51BuildRequires:  pango-devel >= %{pango_version}
52BuildRequires:  gtk2-devel >= %{gtk2_version}
53BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
54BuildRequires:  libxml2-devel >= %{libxml2_version}
55BuildRequires:  gnome-desktop-devel >= %{gnome_desktop_version}
56BuildRequires:  gamin-devel
57BuildRequires:  intltool
58BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
59BuildRequires:  libtool >= 1.4.2-10
60BuildRequires:  automake, autoconf
61BuildRequires:  startup-notification-devel >= %{startup_notification_version}
62#BuildRequires: tracker-devel >= %{tracker_version}
63BuildRequires:  libexif-devel  >= %{libexif_version}
64BuildRequires:  unique-devel
65BuildRequires:  libtool, autoconf
66BuildRequires:  libSM-devel
67
68Obsoletes:      nautilus-extras
69Obsoletes:      nautilus-suggested
70Obsoletes:      nautilus-mozilla < 2.0
71Obsoletes:      eel2 <= 2.24.1
72
73Provides:       eel2 <= 2.24.1
74
75
76%description
77Nautilus integrates access to files, applications, media,
78Internet-based resources and the Web. Nautilus delivers a dynamic and
79rich user experience. Nautilus is an free software project developed
80under the GNU General Public License and is a core component of the
81GNOME desktop project.
82
83%package devel
84Summary: Support for developing nautilus extensions
85License: LGPLv2+
86Group: Development/Libraries
87Requires: %{name}-libs = %{version}-%{release}
88Requires: pkgconfig
89
90%description devel
91This package provides libraries and header files needed
92for developing nautilus extensions.
93
94%package libs
95Summary: Libraries for use in nautilus extentions
96Group: User Interfaces/Desktops
97
98%description libs
99This package provides libraries required by nautilus extention
100module.
101
102%prep
103%setup -q -n %{name}-%{version}
104
105##patch3 -p1 -b .no-delay
106#%patch5 -p1 -b .selinux
107##patch6 -p1 -b .dynamic-search
108%patch7 -p1 -b .rtl-fix
109
110## %patch100 -p1 -b .vine
111%patch101 -p1 -b .vine
112
113%build
114gtkdocize
115libtoolize --force --copy
116autoreconf -f -i
117CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
118%configure --disable-more-warnings --disable-update-mimedb
119
120export tagname=CC
121LANG=en_US make LIBTOOL=/usr/bin/libtool %{?_smp_mflags}
122
123%install
124rm -rf $RPM_BUILD_ROOT
125
126export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
127export tagname=CC
128LANG=en_US %makeinstall LIBTOOL=/usr/bin/libtool
129unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
130
131## these are in desktop-backgrounds-basic
132## (uncomment when we patch the source to look in the right place)
133## /bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/nautilus/patterns
134
135# make sure desktop files validate by ignoring sr@Latn
136perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
137# desktop-file-install can't handle empty OnlyShowIn correctly
138perl -pi -e 's/OnlyShowIn=;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
139
140desktop-file-install --vendor gnome --delete-original       \
141  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
142  --add-only-show-in GNOME                                  \
143  $RPM_BUILD_ROOT%{_datadir}/applications/*
144
145perl -pi -e 's/OnlyShowIn=GNOME;/OnlyShowIn=;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
146
147rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{la,a}
148rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
149rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
150
151mkdir -p $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-2.0
152
153%find_lang %name
154
155%clean
156rm -rf $RPM_BUILD_ROOT
157
158%post
159/sbin/ldconfig
160touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
161export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
162gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
163
164%posttrans
165%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null ||:
166gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
167scrollkeeper-update > /dev/null 2>&1 || :
168
169%pre
170if [ "$1" -gt 1 ]; then
171    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
172    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
173fi
174
175%preun
176if [ "$1" -eq 0 ]; then
177    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
178    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
179fi
180
181%postun
182/sbin/ldconfig
183if [ $1 -eq 0 ] ; then
184    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
185    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
186    scrollkeeper-update > /dev/null 2>&1 || :
187fi
188
189%files  -f %{name}.lang
190%defattr(-,root,root)
191%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
192%dir %{_libdir}/nautilus
193%dir %{_libdir}/nautilus/extensions-2.0
194%{_libexecdir}/nautilus-convert-metadata
195%{_datadir}/nautilus
196%{_datadir}/pixmaps
197%{_datadir}/applications
198%{_datadir}/mime/*
199%{_datadir}/icons/hicolor/*
200%{_bindir}/*
201%{_sysconfdir}/gconf/schemas/*
202%{_mandir}/man1/*
203
204%files devel
205%defattr(-, root, root)
206%{_includedir}/nautilus
207%{_libdir}/pkgconfig/*
208%{_libdir}/*.so
209%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
210
211%files libs
212%defattr(-, root, root)
213%{_libdir}/*.so.*
214
215
216%changelog
217* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
218- split nautilus extention libraries to -libs subpackage.
219
220* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
221- new upstream release
222
223* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
224- new upstream release
225- drop Patch100
226- add Patch101
227- add Obsoletes: eel2 <= 2.24.1
228- add Provides: eel2 <= 2.24.1
229
230* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
231- new upstream release
232- add BuildRequires: libSM-devel
233
234* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
235- removed Requires: eel2
236- added %%posttrans section
237
238* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
239- new upstream release
240
241* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
242- new upstream release
243
244* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
245- new upstream release
246
247* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
248- new upstream release
249- split -devel subpackage
250
251* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
252- new upstream release
253
254* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
255- patch6 needs autoreconf
256
257* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
258- new upstream release
259
260* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
261- new upstream release
262
263* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
264- new upstream release
265- added Requires: gvfs
266
267* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
268- new upstream release
269- added Patches from FC
270  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
271  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
272  - Fix a crash in the Properties dialog while changing owner (patch from head)
273  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
274  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
275
276* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
277- new upstream release
278- dropped Patch11-13 and added Patch7-9 from Fedora
279  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
280  - Add patch from upstream to get audio preview working again
281    (#332251)
282  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
283  - Fix a crash with small fonts (#242350)
284  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
285  - Backport fixes for async thumbnail loading from svn
286
287* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
288- run autoreconf for Patch11 changes
289
290* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
291- remove tracker dependancy, Patch13 detects tracker dynamically.
292
293* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
294- add Patch13 to support user-dirs
295
296* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
297- new upstream release
298- enable tracker support
299- add BuildRequires: tracker-devel, Requires: tracker
300
301* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
302- new upstream release
303
304* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
305- add BuildRequires: gamin-devel, Requires: gamin
306- remove fam dependency (replaced by gamin)
307
308* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
309- new upsteram release
310
311* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
312- really applied Patch110...
313
314* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
315- add Patch110 to fix corruption of help option message.
316
317* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
318- new upstream release
319
320* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
321- fix typo in ja.po
322
323* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
324- update ja.po to translate patch50 related message.
325
326* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
327- add Patch50 to show progressbar on umounting
328  (ubuntu patch in Bug 313639)
329
330* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
331- new upstream release
332
333* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
334- add Patch10 to avoid background rendering delay
335
336* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
337- new upstream release
338
339* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
340- add fix-non-UTF-8-encoding.patch (patch0)
341  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
342
343* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
344- new upstream release
345
346* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
347- new upstream release
348
349* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
350- new upstream release
351
352* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
353- new upstream release
354
355* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
356- rebuild
357
358* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
359- new upstream version
360
361* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
362- new upstream version
363
364* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
365- add vine patch to change some defaults.
366  - change default zoom sine
367  - set always_use_browser
368
369* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
370- new upstream release
371
372* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
373- add Patch110 to fix libegg(egg-recent-model.c)
374  save old umask value before create ".recently-used" file.
375 
376* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
377- change default desktop font to Sans 9 (from Sans 10)
378- add patch10 to build with gtk+-2.4
379
380* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
381- new upstream release
382
383* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
384- new upstream release
385
386* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
387- add backport patch from rawhide (Patch10)
388
389* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
390- modified vine patch
391  - change default zoom level to small
392  - change desktop font to Sans 10
393
394* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
395- new upstream release
396
397* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
398- add desktop icon patch from rawhide
399
400* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
401- remove obsolete ja.po
402
403* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
404- new upstream release
405
406* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
407- new upstream release
408
409* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
410- new upstream release
411
412* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
413- update ja.po
414
415* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
416- new upstream release
417
418* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
419- new upstream release
420
421* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
422- new upstream release
423
424* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
425- new upstream release
426
427* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
428- new upstream release
429
430* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
431- new upstream release
432
433* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
434- add nautilus-cd-burner patch
435
436* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
437- new upstream release
438
439* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
440- discard scrollkeeper outputs.
441- update PreReq tags.
442
443* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
444- change icon for nautilus-file-management-properties
445- update ja.po
446
447* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
448- update ja.po
449- add translation for .desktop files.
450
451* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
452- add Requires: vine-menus
453
454* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
455- new upstream release
456
457* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
458- remove redhatize patch
459
460* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
461- rebuild to remove unneeded dependancy.
462
463* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
464- build for Vine Linux
465
466* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
467- add explicit startup-notification dependency because build system is
468  dumb
469- 2.1.3
470
471* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
472- 2.1.2
473
474* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
475- 2.0.7
476- remove patches that are upstream
477
478* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
479- Add badhack to make weblinks on desktop work
480
481* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
482- fix #70667 assertion failures
483- fix triple click patch
484
485* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
486- don't activate on double click
487
488* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
489- put button press mask in triple-click patch, maybe it will work
490- remove html-hack patch as it does nothing useful
491
492* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
493- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
494  bogus bug reports
495- add hack for HTML mime type handling in a web browser, not
496  nautilus
497
498* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
499- Updated to 2.0.6. Removed the patches I put upstream.
500- Added patch that fixes #72410
501
502* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
503- Add a simple patch so that redhat-config-packages can disable
504  the new window behavior for mounted CDs behavior.
505
506* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
507- Add patch to fix bug #70667
508
509* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
510- remove mp3
511
512* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
513- ignore the "add_to_session" preference as it only broke stuff
514- pad the left margin a bit to cope with poor word wrapping
515
516* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
517- Update to 2.0.5, remove topleft icon patch
518
519* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
520- Add patch to fix the bug where desktop icons get
521  stuck in the top left corner on startup
522
523* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
524- 2.0.4
525
526* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
527- obsolete nautilus-mozilla < 2.0 #69839
528
529* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
530- add rhconfig patch to Bluecurve theme and disable sidebar by default
531
532* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
533- drop start here files, require redhat-menus that has them
534
535* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
536- 2.0.3
537
538* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
539- build for new eel2, gail
540
541* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
542- and add the libexec components, mumble
543
544* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
545- put the components in the file list, were moved upstream
546
547* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
548- 2.0.1
549
550* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
551- Relibtoolize to fix relink problems for solib components
552- Add LANG=en_US to %makeinstall as well
553- Back out previous change, force locale to en_US to prevent UTF-8 problems
554- Add workaround for intltool-merge bug on ia64
555
556* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
557- automated rebuild
558
559* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
560- 2.0.0
561- use desktop-file-install
562- require desktop-backgrounds-basic
563
564* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
565- add wacky hack in hopes of fixing the hang-on-login thing
566
567* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
568- add build requires on new gail
569- rebuild to try to lose broken libgailutil.so.13 dependency
570
571* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
572- rebuild in different environment
573
574* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
575- 1.1.19
576
577* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
578- rebuild in different environment
579
580* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
581- really remove nautilus-devel if we are going to obsolete it
582- don't require hwbrowser
583
584* Sun May 26 2002 Tim Powers <timp@redhat.com>
585- automated rebuild
586
587* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
588- rebuild in different environment
589
590* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
591- 1.1.17
592
593* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
594- 1.1.14
595
596* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
597- require eog
598- obsolete nautilus-devel
599- fix name of schemas file in post
600
601* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
602- Update to 1.1.13
603
604* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
605- put tree view in file list
606
607* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
608- nautilus for gnome 2
609- clean up the spec file and file list a bit
610
611* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
612- merge translations
613
614* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
615- Add patch to fix trash crash
616
617* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
618- fix for metadata tmp race
619- backport thumbnail speed fix and thumbnail inf. loop fix
620
621* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
622- add some fixes from CVS version, including one for #61819 and a couple segfaults
623
624* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
625- fix thumbnails for files with future timestamp, #56862
626
627* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
628- buildrequires intltool #60633
629- apply Alex's pixbuf cache patch to save a few megs #60581
630
631* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
632- drop Milan-specific features, including png10 and ac25 patches
633- copy in 1.0.5 help component to avoid large risky patch
634- remove .la files
635- drop mozilla from ia64 again
636- remove oaf file from nautilus-mozilla that was also in the base
637  package
638
639* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
640- enable mozilla support on ia64
641
642* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
643- require Mozilla 0.9.7
644- Add patch that puts mozilla profile startup before embedding is initialized
645
646* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
647- 1.0.6, require Mozilla 0.9.6
648
649* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
650- Update to 1.0.5
651
652* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
653- Fix handling of GnomeVFSFileInfo structure (#53315)
654
655* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
656- Change handling of names on unmount to fix #52325
657
658* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
659- put nautilus-help.desktop in file list; #53109
660
661* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
662- Add po files from sources.redhat.com
663
664* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
665- Add po files from sources.redhat.com
666
667* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
668- Added patch to fix the .directory issuer
669
670* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
671- I screwed up the build yesterday, so it didn't actually contain the
672  fixes mentioned. This build should contain them.
673
674* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
675- fix bug causing 32000 stats or so in large directories,
676  should speed things up somewhat
677- fix #52104 via gruesome kdesktop-detection hack and setting
678  window type hint on our desktop window
679- fix so Start Here icon displays in sidebar
680- don't load non-local .desktop files
681
682* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
683- make Programs icon into a link, to match the other .desktop files
684- own various directories #51164
685- web page titles in Japanese, #51709
686- tree defaults to only directories #51850
687
688* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
689- make start here icon work again
690- kill some warning spew, #51661
691- cache getpwnam() results to speed things up a bit
692
693* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
694- Fix problem with missing desktop starthere.desktop file
695- New snapshot from our branch, fixes:
696  - On upgrade, icons migrated from GNOME desktop are not properly lined up
697    (#51436)
698  - icons dropped on the desktop don't end up where dropped. (#51441)
699  - Nautilus shouldn't have fam monitor read-only windows. This
700    keeps CDROMS from being unmounted until you close all
701
702    nautilus windows pointing to them. (#51442)
703  - Warnings about 'cannot statfs...' when moving items to trash.
704- Use separate start-here.desktop for panel, since the one used
705  for the root window only works from Nautilus.
706
707* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
708- Changed starthere .desktop files to be links instead
709- of spawning a new nautilus. This makes start-here:
710- much faster.
711
712* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
713- Added hwbrowser dependency
714- New snapshot, fixes the mozilla-view submit form problem
715
716* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
717- Rebuild with new xml-i18n-tools
718- fix crash in creating new desktop files
719
720* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
721- Fix up DnD code some more
722
723* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
724- Sync our CVS version; fixes some MUSTFIX
725  (the one about drawing background on startup,
726   properly translate desktop files, etc.)
727
728* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
729- Fix 64bit cleanness issue
730- Fix NULL mimetype crash
731- Disable additional_text for .desktop files
732
733* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
734- Fix unmounting devices.
735
736* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
737- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
738- mimetype sniffing.
739
740* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
741- Remove the "don't run as root" warning.
742- Remove eazel from bookmarks
743- langified (again? did someone change it?)
744
745* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
746- Apply a patch that makes nautilus dnd reset work with the latest
747- eel release.
748
749* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
750- Build on ia64 without the mozilla component.
751
752* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
753- Fix crash-on-startup showstopper
754- Fix can't-find-images bug (this one was only showing up
755  when built with debug symbols, since it was an uninitialized memory
756  read)
757
758* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
759- sync new tarball from our CVS branch,
760  fixes some drag-and-drop, changes URI scheme names,
761  etc.
762
763* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
764- Add BuildRequires (#49539, 49537)
765- Fix %%post, %%postun (#49720)
766- Background efficiency improvements and hacks
767
768* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
769- Don't launch esd on each mouseover.
770
771* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
772- move first time druid patch into my "CVS outstanding" patch
773- try to really remove Help/Feedback
774- try to really fix Help/Community Support
775- try again to get Start Here in the Go menu
776- try again to get Start Here on the desktop
777- don't show file sizes for .desktop files
778
779* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
780- add newline to ends of .desktop files that were missing them
781
782* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
783- update to my latest 'cvs diff -u' (adds default
784  Start Here link, displays .directory name in sidebar)
785- include /etc/X11/* links (starthere, sysconfig, serverconfig)
786
787* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
788- Patch to remove firsttime druid and flash
789
790* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
791- add hacks for displaying desktop files
792- add hack to turn off the "unwriteable" emblem
793
794* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
795- added defattr to the files lists to be (-,root,root)
796- languified
797
798* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
799- Need to run autoheader too.
800
801* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
802- Make the fam dependency a real runtime dependency
803- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
804- Cleaned up specfile.
805
806* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
807- Change default background and rubberband color.
808- Use the sidebar tabs from the default theme
809- BuildDepend on fam-devel, depend on fam
810- Disable the eazel update pages in the first-time druid.
811- Remove the eazel logo from the first-time druid
812
813* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
814- 1.0.4, removes eazel services icon and wizard page
815- Eazel logo is still in startup wizard for now, needs fixing
816
817* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
818- fix group (s/Desktop/Desktops/) #47134
819- remove ammonite dependency
820
821* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
822- add a different default theme
823- clean up file list overspecificity a bit
824
825* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
826- move to a CVS snapshot of nautilus for now
827  (Darin is my hero for having distcheck work out of CVS)
828
829* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
830- clean up defaults a bit
831
832* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
833- New version
834
835* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
836- Added BuildRequires lines
837- Changed Source to point to ftp.gnome.org instead of just the tarball name
838- Moved %description sections closer to their %package sections
839- Moved %changelog to the end, where so that it's not in the way
840- Changed configure and make install options to allow moving of
841  libraries, includes, binaries more easily
842- Removed hard-coded paths (don't define %prefix or %docdir)
843- replace %{prefix}/bin with %{_bindir}
844- replace %{prefix}/share with %{_datadir}
845- replace %{prefix}/lib with %{_libdir}
846- replace %{prefix}/include with %{_includedir}
847
848* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
849- removed obsoletes from sub packages and added mozilla and trilobite
850subpackages
851
852* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
853- created this thing
Note: See TracBrowser for help on using the repository browser.