source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 10716

Revision 10716, 31.7 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME-3.20

Line 
1%define glib2_version 2.48.0
2%define pango_version 1.40.0
3%define gtk3_version 3.20.0
4%define libxml2_version 2.9.1
5%define eog_version 3.20.0
6%define gnome_desktop3_version 3.20.0
7%define vine_menus_version 3.0
8%define startup_notification_version 0.10
9%define libexif_version 0.6.19
10%define tracker_version 1.6.0
11%define gobject_introspection_version 0.9.8
12
13Name:           nautilus
14Summary:        Nautilus is a file manager for GNOME
15Summary(ja):    Nautilus - GNOME ファイルマネージャ
16Version:        3.20.2
17Release:        1%{?_dist_release}
18License:        GPLv2+
19Group:          User Interface/Desktops
20URL:            http://www.gnome.org/projects/nautilus/
21
22Vendor:         Project Vine
23Distribution:   Vine Linux
24Packager:       Takemikaduchi
25
26Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.20/%{name}-%{version}.tar.xz
27
28# vine
29Patch102:       run_in_gnome.patch
30Patch2000:      nautilus-vine-settings.patch
31
32BuildRoot:      %{_tmppath}/%{name}-%{version}-root
33Requires:       gamin
34Requires:       vine-menus >= %{vine_menus_version}
35Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
36Requires:       libexif >= %{libexif_version}
37Requires:       %{name}-libs = %{version}-%{release}
38
39BuildRequires:  intltool
40BuildRequires:  libtool >= 1.4.2-10
41BuildRequires:  automake, autoconf
42BuildRequires:  desktop-file-utils
43
44BuildRequires:  glib2-devel >= %{glib2_version}
45BuildRequires:  pango-devel >= %{pango_version}
46BuildRequires:  gtk3-devel >= %{gtk3_version}
47BuildRequires:  libxml2-devel >= %{libxml2_version}
48BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
49BuildRequires:  gamin-devel
50BuildRequires:  startup-notification-devel >= %{startup_notification_version}
51BuildRequires:  tracker-devel >= %{tracker_version}
52BuildRequires:  libexif-devel >= %{libexif_version}
53BuildRequires:  unique3-devel
54BuildRequires:  libnotify-devel
55BuildRequires:  libSM-devel
56BuildRequires:  exempi-devel
57BuildRequires:  tracker-devel
58BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
59BuildRequires:  gsettings-desktop-schemas
60
61Obsoletes:      nautilus-extras
62Obsoletes:      nautilus-suggested
63Obsoletes:      nautilus-mozilla < 2.0
64Obsoletes:      eel2 <= 2.24.1
65
66Provides:       eel2 <= 2.24.1
67
68
69%description
70Nautilus integrates access to files, applications, media,
71Internet-based resources and the Web. Nautilus delivers a dynamic and
72rich user experience. Nautilus is an free software project developed
73under the GNU General Public License and is a core component of the
74GNOME desktop project.
75
76%description -l ja
77Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
78リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
79豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
80のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
81プロジェクトのコア・コンポーネントです。
82
83
84%package        devel
85Summary:        Support for developing nautilus extensions
86Summary(ja):    Nautilus 拡張機能開発のためのサポート
87License:        LGPLv2+
88Group:          Development/Libraries
89Requires:       %{name}-libs = %{version}-%{release}
90Requires:       pkgconfig
91
92%description    devel
93This package provides libraries and header files needed
94for developing nautilus extensions.
95
96%description -l ja devel
97このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
98ヘッダファイルを提供します。
99
100
101%package        libs
102Summary:        Libraries for use in nautilus extentions
103Summary(ja):    Nautilus 拡張機能で利用するライブラリ
104Group:          System Environment/Libraries
105
106%description    libs
107This package provides libraries required by nautilus extention
108module.
109
110%description -l ja libs
111このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
112
113
114%package        docs
115Summary:        Documentation for %{name}
116Summary(ja):    %{name} 用のドキュメント
117Group:          Documentation
118BuildArch:      noarch
119
120%description    docs
121This package contains documentation for %{name}.
122
123
124%prep
125%setup -q -n %{name}-%{version}
126
127%patch102 -p1 -b .vine
128%patch2000 -p1 -b .vine
129
130%build
131#gtkdocize
132#libtoolize --force --copy
133#autoreconf -f -i
134CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
135%configure \
136        --disable-more-warnings \
137        --disable-update-mimedb \
138        --disable-selinux \
139        --enable-introspection=yes
140
141make %{?_smp_mflags}
142
143%install
144rm -rf $RPM_BUILD_ROOT
145
146make install DESTDIR=$RPM_BUILD_ROOT
147
148# make sure desktop files validate by ignoring sr@Latn
149perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
150# desktop-file-install can't handle empty OnlyShowIn correctly
151perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
152
153desktop-file-install --vendor "" --delete-original       \
154  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
155  --add-only-show-in GNOME                                  \
156  $RPM_BUILD_ROOT%{_datadir}/applications/*
157
158find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
159
160%find_lang %name
161
162%clean
163rm -rf $RPM_BUILD_ROOT
164
165%postun
166if [ $1 -eq 0 ] ; then
167    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
168fi
169
170%posttrans
171glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
172
173%post libs -p /sbin/ldconfig
174%postun libs -p /sbin/ldconfig
175
176
177%files  -f %{name}.lang
178%defattr(-,root,root,-)
179%doc AUTHORS COPYING COPYING.LIB NEWS README
180%dir %{_libdir}/nautilus
181%dir %{_libdir}/nautilus/extensions-3.0
182%{_libdir}/nautilus/extensions-3.0/*.so
183%{_datadir}/appdata/org.gnome.Nautilus.appdata.xml
184%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
185%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
186%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
187%{_datadir}/applications/*.desktop
188%{_bindir}/*
189%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
190%{_datadir}/glib-2.0/schemas/
191%{_mandir}/man1/*
192
193%files devel
194%defattr(-,root,root,-)
195%{_includedir}/nautilus
196%{_libdir}/pkgconfig/*
197%{_libdir}/*.so
198%{_datadir}/gir-1.0
199
200%files libs
201%defattr(-,root,root,-)
202%{_libdir}/*.so.*
203%{_libdir}/girepository-1.0/*.typelib
204
205%files docs
206%defattr(-,root,root,-)
207%{_datadir}/gtk-doc/html/libnautilus-extension/*
208
209
210%changelog
211* Sat Jul 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.2-1
212- new upstream release
213- update Patch2000
214
215* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.4-1
216- new upstream release
217
218* Sat Nov 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
219- new upstream release
220
221* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
222- new upstream release
223
224* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
225- new upstream release
226
227* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
228- new upstream release
229
230* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
231- new upstream release
232- update Patch2000 (nautilus-vine-settings.patch)
233- create %%{name}-docs subpackage
234
235* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.2-2
236- moved libs subpackage to System Environment/Libraries Group
237
238* Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
239- new upstream release
240
241* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
242- new upstream release
243- remove Patch0 (nautilus-3.14.0-git20141015.patch)
244
245* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
246- new upstream release
247- add Patch0 (nautilus-3.14.0-git20141015.patch)
248
249* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
250- new upstream release
251
252* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
253- new upstream release
254
255* Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
256- new upstream release
257
258* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
259- new upstream release
260- add Patch2000 (nautilus-vine-settings.patch)
261
262* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
263- new upstream release
264
265* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
266- new upstream release
267
268* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
269- new upstream release
270
271* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
272- new upstream release
273
274* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
275- new upstream release
276
277* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
278- new upstream release
279- remove Patch0,7
280- add BuildRequires: exempi-devel, tracker-devel
281
282* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
283- add Patch0 (nautilus-3.4.2-ja.po.patch)
284
285* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
286- new upstream release
287
288* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
289- new upstream release
290
291* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
292- added patch102 to fix autostart in other desktop environments
293  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
294
295* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
296- new upstream release
297
298* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
299- new upstream release
300
301* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
302- new upstream release
303
304* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
305- new upstream release
306
307* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
308- new upstream release
309- drop Patch101
310- change BuildRequires: gtk3-devel instread of gtk2-devel
311- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
312- change BuildRequires: unique3-devel instread of unique-devel
313- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
314
315* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
316- fixed group of libs
317- add translation of summary and description.
318- add Vendor, Distribution and Packager tags.
319
320* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
321- new upstream release
322
323* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
324- new upstream release
325
326* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
327 - new upstream release
328
329* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
330- new upstream release
331- add BuildRequires: gobject-introspection-devel
332- remove BuildRequires: libgnomeui-devel
333- add configure option (--enable-introspection=yes)
334
335* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
336- rebuild with rpm-4.8.1 for pkg-config file
337
338* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
339- split nautilus extention libraries to -libs subpackage.
340
341* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
342- new upstream release
343
344* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
345- new upstream release
346- drop Patch100
347- add Patch101
348- add Obsoletes: eel2 <= 2.24.1
349- add Provides: eel2 <= 2.24.1
350
351* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
352- new upstream release
353- add BuildRequires: libSM-devel
354
355* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
356- removed Requires: eel2
357- added %%posttrans section
358
359* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
360- new upstream release
361
362* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
363- new upstream release
364
365* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
366- new upstream release
367
368* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
369- new upstream release
370- split -devel subpackage
371
372* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
373- new upstream release
374
375* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
376- patch6 needs autoreconf
377
378* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
379- new upstream release
380
381* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
382- new upstream release
383
384* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
385- new upstream release
386- added Requires: gvfs
387
388* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
389- new upstream release
390- added Patches from FC
391  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
392  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
393  - Fix a crash in the Properties dialog while changing owner (patch from head)
394  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
395  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
396
397* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
398- new upstream release
399- dropped Patch11-13 and added Patch7-9 from Fedora
400  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
401  - Add patch from upstream to get audio preview working again
402    (#332251)
403  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
404  - Fix a crash with small fonts (#242350)
405  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
406  - Backport fixes for async thumbnail loading from svn
407
408* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
409- run autoreconf for Patch11 changes
410
411* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
412- remove tracker dependancy, Patch13 detects tracker dynamically.
413
414* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
415- add Patch13 to support user-dirs
416
417* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
418- new upstream release
419- enable tracker support
420- add BuildRequires: tracker-devel, Requires: tracker
421
422* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
423- new upstream release
424
425* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
426- add BuildRequires: gamin-devel, Requires: gamin
427- remove fam dependency (replaced by gamin)
428
429* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
430- new upsteram release
431
432* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
433- really applied Patch110...
434
435* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
436- add Patch110 to fix corruption of help option message.
437
438* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
439- new upstream release
440
441* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
442- fix typo in ja.po
443
444* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
445- update ja.po to translate patch50 related message.
446
447* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
448- add Patch50 to show progressbar on umounting
449  (ubuntu patch in Bug 313639)
450
451* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
452- new upstream release
453
454* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
455- add Patch10 to avoid background rendering delay
456
457* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
458- new upstream release
459
460* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
461- add fix-non-UTF-8-encoding.patch (patch0)
462  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
463
464* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
465- new upstream release
466
467* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
468- new upstream release
469
470* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
471- new upstream release
472
473* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
474- new upstream release
475
476* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
477- rebuild
478
479* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
480- new upstream version
481
482* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
483- new upstream version
484
485* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
486- add vine patch to change some defaults.
487  - change default zoom sine
488  - set always_use_browser
489
490* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
491- new upstream release
492
493* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
494- add Patch110 to fix libegg(egg-recent-model.c)
495  save old umask value before create ".recently-used" file.
496 
497* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
498- change default desktop font to Sans 9 (from Sans 10)
499- add patch10 to build with gtk+-2.4
500
501* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
502- new upstream release
503
504* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
505- new upstream release
506
507* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
508- add backport patch from rawhide (Patch10)
509
510* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
511- modified vine patch
512  - change default zoom level to small
513  - change desktop font to Sans 10
514
515* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
516- new upstream release
517
518* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
519- add desktop icon patch from rawhide
520
521* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
522- remove obsolete ja.po
523
524* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
525- new upstream release
526
527* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
528- new upstream release
529
530* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
531- new upstream release
532
533* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
534- update ja.po
535
536* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
537- new upstream release
538
539* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
540- new upstream release
541
542* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
543- new upstream release
544
545* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
546- new upstream release
547
548* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
549- new upstream release
550
551* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
552- new upstream release
553
554* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
555- add nautilus-cd-burner patch
556
557* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
558- new upstream release
559
560* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
561- discard scrollkeeper outputs.
562- update PreReq tags.
563
564* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
565- change icon for nautilus-file-management-properties
566- update ja.po
567
568* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
569- update ja.po
570- add translation for .desktop files.
571
572* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
573- add Requires: vine-menus
574
575* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
576- new upstream release
577
578* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
579- remove redhatize patch
580
581* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
582- rebuild to remove unneeded dependancy.
583
584* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
585- build for Vine Linux
586
587* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
588- add explicit startup-notification dependency because build system is
589  dumb
590- 2.1.3
591
592* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
593- 2.1.2
594
595* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
596- 2.0.7
597- remove patches that are upstream
598
599* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
600- Add badhack to make weblinks on desktop work
601
602* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
603- fix #70667 assertion failures
604- fix triple click patch
605
606* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
607- don't activate on double click
608
609* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
610- put button press mask in triple-click patch, maybe it will work
611- remove html-hack patch as it does nothing useful
612
613* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
614- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
615  bogus bug reports
616- add hack for HTML mime type handling in a web browser, not
617  nautilus
618
619* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
620- Updated to 2.0.6. Removed the patches I put upstream.
621- Added patch that fixes #72410
622
623* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
624- Add a simple patch so that redhat-config-packages can disable
625  the new window behavior for mounted CDs behavior.
626
627* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
628- Add patch to fix bug #70667
629
630* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
631- remove mp3
632
633* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
634- ignore the "add_to_session" preference as it only broke stuff
635- pad the left margin a bit to cope with poor word wrapping
636
637* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
638- Update to 2.0.5, remove topleft icon patch
639
640* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
641- Add patch to fix the bug where desktop icons get
642  stuck in the top left corner on startup
643
644* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
645- 2.0.4
646
647* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
648- obsolete nautilus-mozilla < 2.0 #69839
649
650* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
651- add rhconfig patch to Bluecurve theme and disable sidebar by default
652
653* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
654- drop start here files, require redhat-menus that has them
655
656* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
657- 2.0.3
658
659* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
660- build for new eel2, gail
661
662* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
663- and add the libexec components, mumble
664
665* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
666- put the components in the file list, were moved upstream
667
668* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
669- 2.0.1
670
671* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
672- Relibtoolize to fix relink problems for solib components
673- Add LANG=en_US to %makeinstall as well
674- Back out previous change, force locale to en_US to prevent UTF-8 problems
675- Add workaround for intltool-merge bug on ia64
676
677* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
678- automated rebuild
679
680* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
681- 2.0.0
682- use desktop-file-install
683- require desktop-backgrounds-basic
684
685* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
686- add wacky hack in hopes of fixing the hang-on-login thing
687
688* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
689- add build requires on new gail
690- rebuild to try to lose broken libgailutil.so.13 dependency
691
692* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
693- rebuild in different environment
694
695* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
696- 1.1.19
697
698* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
699- rebuild in different environment
700
701* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
702- really remove nautilus-devel if we are going to obsolete it
703- don't require hwbrowser
704
705* Sun May 26 2002 Tim Powers <timp@redhat.com>
706- automated rebuild
707
708* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
709- rebuild in different environment
710
711* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
712- 1.1.17
713
714* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
715- 1.1.14
716
717* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
718- require eog
719- obsolete nautilus-devel
720- fix name of schemas file in post
721
722* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
723- Update to 1.1.13
724
725* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
726- put tree view in file list
727
728* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
729- nautilus for gnome 2
730- clean up the spec file and file list a bit
731
732* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
733- merge translations
734
735* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
736- Add patch to fix trash crash
737
738* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
739- fix for metadata tmp race
740- backport thumbnail speed fix and thumbnail inf. loop fix
741
742* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
743- add some fixes from CVS version, including one for #61819 and a couple segfaults
744
745* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
746- fix thumbnails for files with future timestamp, #56862
747
748* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
749- buildrequires intltool #60633
750- apply Alex's pixbuf cache patch to save a few megs #60581
751
752* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
753- drop Milan-specific features, including png10 and ac25 patches
754- copy in 1.0.5 help component to avoid large risky patch
755- remove .la files
756- drop mozilla from ia64 again
757- remove oaf file from nautilus-mozilla that was also in the base
758  package
759
760* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
761- enable mozilla support on ia64
762
763* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
764- require Mozilla 0.9.7
765- Add patch that puts mozilla profile startup before embedding is initialized
766
767* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
768- 1.0.6, require Mozilla 0.9.6
769
770* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
771- Update to 1.0.5
772
773* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
774- Fix handling of GnomeVFSFileInfo structure (#53315)
775
776* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
777- Change handling of names on unmount to fix #52325
778
779* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
780- put nautilus-help.desktop in file list; #53109
781
782* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
783- Add po files from sources.redhat.com
784
785* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
786- Add po files from sources.redhat.com
787
788* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
789- Added patch to fix the .directory issuer
790
791* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
792- I screwed up the build yesterday, so it didn't actually contain the
793  fixes mentioned. This build should contain them.
794
795* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
796- fix bug causing 32000 stats or so in large directories,
797  should speed things up somewhat
798- fix #52104 via gruesome kdesktop-detection hack and setting
799  window type hint on our desktop window
800- fix so Start Here icon displays in sidebar
801- don't load non-local .desktop files
802
803* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
804- make Programs icon into a link, to match the other .desktop files
805- own various directories #51164
806- web page titles in Japanese, #51709
807- tree defaults to only directories #51850
808
809* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
810- make start here icon work again
811- kill some warning spew, #51661
812- cache getpwnam() results to speed things up a bit
813
814* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
815- Fix problem with missing desktop starthere.desktop file
816- New snapshot from our branch, fixes:
817  - On upgrade, icons migrated from GNOME desktop are not properly lined up
818    (#51436)
819  - icons dropped on the desktop don't end up where dropped. (#51441)
820  - Nautilus shouldn't have fam monitor read-only windows. This
821    keeps CDROMS from being unmounted until you close all
822
823    nautilus windows pointing to them. (#51442)
824  - Warnings about 'cannot statfs...' when moving items to trash.
825- Use separate start-here.desktop for panel, since the one used
826  for the root window only works from Nautilus.
827
828* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
829- Changed starthere .desktop files to be links instead
830- of spawning a new nautilus. This makes start-here:
831- much faster.
832
833* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
834- Added hwbrowser dependency
835- New snapshot, fixes the mozilla-view submit form problem
836
837* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
838- Rebuild with new xml-i18n-tools
839- fix crash in creating new desktop files
840
841* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
842- Fix up DnD code some more
843
844* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
845- Sync our CVS version; fixes some MUSTFIX
846  (the one about drawing background on startup,
847   properly translate desktop files, etc.)
848
849* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
850- Fix 64bit cleanness issue
851- Fix NULL mimetype crash
852- Disable additional_text for .desktop files
853
854* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
855- Fix unmounting devices.
856
857* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
858- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
859- mimetype sniffing.
860
861* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
862- Remove the "don't run as root" warning.
863- Remove eazel from bookmarks
864- langified (again? did someone change it?)
865
866* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
867- Apply a patch that makes nautilus dnd reset work with the latest
868- eel release.
869
870* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
871- Build on ia64 without the mozilla component.
872
873* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
874- Fix crash-on-startup showstopper
875- Fix can't-find-images bug (this one was only showing up
876  when built with debug symbols, since it was an uninitialized memory
877  read)
878
879* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
880- sync new tarball from our CVS branch,
881  fixes some drag-and-drop, changes URI scheme names,
882  etc.
883
884* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
885- Add BuildRequires (#49539, 49537)
886- Fix %%post, %%postun (#49720)
887- Background efficiency improvements and hacks
888
889* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
890- Don't launch esd on each mouseover.
891
892* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
893- move first time druid patch into my "CVS outstanding" patch
894- try to really remove Help/Feedback
895- try to really fix Help/Community Support
896- try again to get Start Here in the Go menu
897- try again to get Start Here on the desktop
898- don't show file sizes for .desktop files
899
900* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
901- add newline to ends of .desktop files that were missing them
902
903* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
904- update to my latest 'cvs diff -u' (adds default
905  Start Here link, displays .directory name in sidebar)
906- include /etc/X11/* links (starthere, sysconfig, serverconfig)
907
908* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
909- Patch to remove firsttime druid and flash
910
911* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
912- add hacks for displaying desktop files
913- add hack to turn off the "unwriteable" emblem
914
915* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
916- added defattr to the files lists to be (-,root,root)
917- languified
918
919* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
920- Need to run autoheader too.
921
922* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
923- Make the fam dependency a real runtime dependency
924- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
925- Cleaned up specfile.
926
927* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
928- Change default background and rubberband color.
929- Use the sidebar tabs from the default theme
930- BuildDepend on fam-devel, depend on fam
931- Disable the eazel update pages in the first-time druid.
932- Remove the eazel logo from the first-time druid
933
934* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
935- 1.0.4, removes eazel services icon and wizard page
936- Eazel logo is still in startup wizard for now, needs fixing
937
938* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
939- fix group (s/Desktop/Desktops/) #47134
940- remove ammonite dependency
941
942* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
943- add a different default theme
944- clean up file list overspecificity a bit
945
946* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
947- move to a CVS snapshot of nautilus for now
948  (Darin is my hero for having distcheck work out of CVS)
949
950* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
951- clean up defaults a bit
952
953* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
954- New version
955
956* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
957- Added BuildRequires lines
958- Changed Source to point to ftp.gnome.org instead of just the tarball name
959- Moved %description sections closer to their %package sections
960- Moved %changelog to the end, where so that it's not in the way
961- Changed configure and make install options to allow moving of
962  libraries, includes, binaries more easily
963- Removed hard-coded paths (don't define %prefix or %docdir)
964- replace %{prefix}/bin with %{_bindir}
965- replace %{prefix}/share with %{_datadir}
966- replace %{prefix}/lib with %{_libdir}
967- replace %{prefix}/include with %{_includedir}
968
969* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
970- removed obsoletes from sub packages and added mozilla and trilobite
971subpackages
972
973* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
974- created this thing
Note: See TracBrowser for help on using the repository browser.