source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 8353

Revision 8353, 30.4 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.0

Line 
1%define glib2_version 2.40.0
2%define pango_version 1.36.3
3%define gtk3_version 3.12.0
4%define libxml2_version 2.9.1
5%define eog_version 3.12.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.12.0
8%define vine_menus_version 3.0
9%define startup_notification_version 0.10
10%define libexif_version 0.6.19
11%define tracker_version 1.0.0
12%define gobject_introspection_version 0.9.8
13
14Name:                   nautilus
15Summary:                Nautilus is a file manager for GNOME
16Summary(ja):    Nautilus - GNOME ファイルマネージャ
17Version:                3.12.0
18Release:                1%{?_dist_release}
19License:                GPLv2+
20Group:                  User Interface/Desktops
21URL:                    http://www.gnome.org/projects/nautilus/
22
23Vendor:                 Project Vine
24Distribution:   Vine Linux
25Packager:               Takemikaduchi
26
27Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.12/%{name}-%{version}.tar.xz
28
29# Some changes to default config
30Patch1:         nautilus-2.5.7-rhconfig.patch
31
32# vine
33Patch102:       run_in_gnome.patch
34Patch2000:      nautilus-vine-settings.patch
35
36BuildRoot:      %{_tmppath}/%{name}-%{version}-root
37Requires:       gamin
38Requires:       vine-menus >= %{vine_menus_version}
39Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
40Requires:       libexif >= %{libexif_version}
41Requires:       %{name}-libs = %{version}-%{release}
42
43BuildRequires:  intltool
44BuildRequires:  libtool >= 1.4.2-10
45BuildRequires:  automake, autoconf
46BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
47
48BuildRequires:  glib2-devel >= %{glib2_version}
49BuildRequires:  pango-devel >= %{pango_version}
50BuildRequires:  gtk3-devel >= %{gtk3_version}
51BuildRequires:  libxml2-devel >= %{libxml2_version}
52BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
53BuildRequires:  gamin-devel
54BuildRequires:  startup-notification-devel >= %{startup_notification_version}
55BuildRequires:  tracker-devel >= %{tracker_version}
56BuildRequires:  libexif-devel >= %{libexif_version}
57BuildRequires:  unique3-devel
58BuildRequires:  libnotify-devel
59BuildRequires:  libSM-devel
60BuildRequires:  exempi-devel
61BuildRequires:  tracker-devel
62BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
63BuildRequires:  gsettings-desktop-schemas
64
65Obsoletes:      nautilus-extras
66Obsoletes:      nautilus-suggested
67Obsoletes:      nautilus-mozilla < 2.0
68Obsoletes:      eel2 <= 2.24.1
69
70Provides:       eel2 <= 2.24.1
71
72
73%description
74Nautilus integrates access to files, applications, media,
75Internet-based resources and the Web. Nautilus delivers a dynamic and
76rich user experience. Nautilus is an free software project developed
77under the GNU General Public License and is a core component of the
78GNOME desktop project.
79
80%description -l ja
81Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
82リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
83豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
84のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
85プロジェクトのコア・コンポーネントです。
86
87%package devel
88Summary: Support for developing nautilus extensions
89Summary(ja): Nautilus 拡張機能開発のためのサポート
90License: LGPLv2+
91Group: Development/Libraries
92Requires: %{name}-libs = %{version}-%{release}
93Requires: pkgconfig
94
95%description devel
96This package provides libraries and header files needed
97for developing nautilus extensions.
98
99%description -l ja devel
100このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
101ヘッダファイルを提供します。
102
103%package libs
104Summary: Libraries for use in nautilus extentions
105Summary(ja): Nautilus 拡張機能で利用するライブラリ
106Group: User Interface/Desktops
107
108%description libs
109This package provides libraries required by nautilus extention
110module.
111
112%description -l ja libs
113このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
114
115%prep
116%setup -q -n %{name}-%{version}
117
118%patch102 -p1 -b .vine
119
120%patch2000 -p1 -b .vine
121
122%build
123gtkdocize
124libtoolize --force --copy
125autoreconf -f -i
126CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
127%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
128
129make %{?_smp_mflags}
130
131%install
132rm -rf $RPM_BUILD_ROOT
133
134make install DESTDIR=$RPM_BUILD_ROOT
135
136# make sure desktop files validate by ignoring sr@Latn
137perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
138# desktop-file-install can't handle empty OnlyShowIn correctly
139perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
140
141desktop-file-install --vendor gnome --delete-original       \
142  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
143  --add-only-show-in GNOME                                  \
144  $RPM_BUILD_ROOT%{_datadir}/applications/*
145
146find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
147
148%find_lang %name
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
153%postun
154if [ $1 -eq 0 ] ; then
155    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
156fi
157
158%posttrans
159update-mime-database %{_datadir}/mime &> /dev/null ||:
160glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
161
162%post libs -p /sbin/ldconfig
163%postun libs -p /sbin/ldconfig
164
165
166%files  -f %{name}.lang
167%defattr(-,root,root)
168%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
169%dir %{_libdir}/nautilus
170%dir %{_libdir}/nautilus/extensions-3.0
171%{_libdir}/nautilus/extensions-3.0/*.so
172%{_libexecdir}/nautilus-convert-metadata
173%{_datadir}/GConf/gsettings/nautilus.convert
174%{_datadir}/appdata/nautilus.appdata.xml
175%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
176%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
177%{_datadir}/dbus-1/services/org.gnome.Nautilus.SearchProvider.service
178%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
179%{_datadir}/nautilus
180%{_datadir}/applications
181%{_datadir}/mime/*
182%{_bindir}/*
183%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
184%{_datadir}/glib-2.0/schemas/
185%{_mandir}/man1/*
186
187%files devel
188%defattr(-, root, root)
189%{_includedir}/nautilus
190%{_libdir}/pkgconfig/*
191%{_libdir}/*.so
192%{_datadir}/gir-1.0
193%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
194
195%files libs
196%defattr(-, root, root)
197%{_libdir}/*.so.*
198%{_libdir}/girepository-1.0/*.typelib
199
200
201%changelog
202* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
203- new upstream release
204
205* Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
206- new upstream release
207
208* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
209- new upstream release
210- add Patch2000 (nautilus-vine-settings.patch)
211
212* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
213- new upstream release
214
215* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
216- new upstream release
217
218* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
219- new upstream release
220
221* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
222- new upstream release
223
224* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
225- new upstream release
226
227* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
228- new upstream release
229- remove Patch0,7
230- add BuildRequires: exempi-devel, tracker-devel
231
232* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
233- add Patch0 (nautilus-3.4.2-ja.po.patch)
234
235* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
236- new upstream release
237
238* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
239- new upstream release
240
241* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
242- added patch102 to fix autostart in other desktop environments
243  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
244
245* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
246- new upstream release
247
248* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
249- new upstream release
250
251* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
252- new upstream release
253
254* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
255- new upstream release
256
257* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
258- new upstream release
259- drop Patch101
260- change BuildRequires: gtk3-devel instread of gtk2-devel
261- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
262- change BuildRequires: unique3-devel instread of unique-devel
263- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
264
265* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
266- fixed group of libs
267- add translation of summary and description.
268- add Vendor, Distribution and Packager tags.
269
270* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
271- new upstream release
272
273* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
274- new upstream release
275
276* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
277 - new upstream release
278
279* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
280- new upstream release
281- add BuildRequires: gobject-introspection-devel
282- remove BuildRequires: libgnomeui-devel
283- add configure option (--enable-introspection=yes)
284
285* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
286- rebuild with rpm-4.8.1 for pkg-config file
287
288* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
289- split nautilus extention libraries to -libs subpackage.
290
291* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
292- new upstream release
293
294* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
295- new upstream release
296- drop Patch100
297- add Patch101
298- add Obsoletes: eel2 <= 2.24.1
299- add Provides: eel2 <= 2.24.1
300
301* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
302- new upstream release
303- add BuildRequires: libSM-devel
304
305* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
306- removed Requires: eel2
307- added %%posttrans section
308
309* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
310- new upstream release
311
312* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
313- new upstream release
314
315* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
316- new upstream release
317
318* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
319- new upstream release
320- split -devel subpackage
321
322* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
323- new upstream release
324
325* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
326- patch6 needs autoreconf
327
328* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
329- new upstream release
330
331* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
332- new upstream release
333
334* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
335- new upstream release
336- added Requires: gvfs
337
338* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
339- new upstream release
340- added Patches from FC
341  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
342  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
343  - Fix a crash in the Properties dialog while changing owner (patch from head)
344  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
345  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
346
347* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
348- new upstream release
349- dropped Patch11-13 and added Patch7-9 from Fedora
350  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
351  - Add patch from upstream to get audio preview working again
352    (#332251)
353  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
354  - Fix a crash with small fonts (#242350)
355  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
356  - Backport fixes for async thumbnail loading from svn
357
358* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
359- run autoreconf for Patch11 changes
360
361* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
362- remove tracker dependancy, Patch13 detects tracker dynamically.
363
364* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
365- add Patch13 to support user-dirs
366
367* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
368- new upstream release
369- enable tracker support
370- add BuildRequires: tracker-devel, Requires: tracker
371
372* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
373- new upstream release
374
375* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
376- add BuildRequires: gamin-devel, Requires: gamin
377- remove fam dependency (replaced by gamin)
378
379* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
380- new upsteram release
381
382* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
383- really applied Patch110...
384
385* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
386- add Patch110 to fix corruption of help option message.
387
388* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
389- new upstream release
390
391* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
392- fix typo in ja.po
393
394* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
395- update ja.po to translate patch50 related message.
396
397* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
398- add Patch50 to show progressbar on umounting
399  (ubuntu patch in Bug 313639)
400
401* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
402- new upstream release
403
404* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
405- add Patch10 to avoid background rendering delay
406
407* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
408- new upstream release
409
410* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
411- add fix-non-UTF-8-encoding.patch (patch0)
412  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
413
414* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
415- new upstream release
416
417* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
418- new upstream release
419
420* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
421- new upstream release
422
423* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
424- new upstream release
425
426* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
427- rebuild
428
429* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
430- new upstream version
431
432* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
433- new upstream version
434
435* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
436- add vine patch to change some defaults.
437  - change default zoom sine
438  - set always_use_browser
439
440* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
441- new upstream release
442
443* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
444- add Patch110 to fix libegg(egg-recent-model.c)
445  save old umask value before create ".recently-used" file.
446 
447* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
448- change default desktop font to Sans 9 (from Sans 10)
449- add patch10 to build with gtk+-2.4
450
451* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
452- new upstream release
453
454* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
455- new upstream release
456
457* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
458- add backport patch from rawhide (Patch10)
459
460* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
461- modified vine patch
462  - change default zoom level to small
463  - change desktop font to Sans 10
464
465* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
466- new upstream release
467
468* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
469- add desktop icon patch from rawhide
470
471* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
472- remove obsolete ja.po
473
474* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
475- new upstream release
476
477* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
478- new upstream release
479
480* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
481- new upstream release
482
483* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
484- update ja.po
485
486* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
487- new upstream release
488
489* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
490- new upstream release
491
492* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
493- new upstream release
494
495* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
496- new upstream release
497
498* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
499- new upstream release
500
501* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
502- new upstream release
503
504* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
505- add nautilus-cd-burner patch
506
507* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
508- new upstream release
509
510* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
511- discard scrollkeeper outputs.
512- update PreReq tags.
513
514* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
515- change icon for nautilus-file-management-properties
516- update ja.po
517
518* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
519- update ja.po
520- add translation for .desktop files.
521
522* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
523- add Requires: vine-menus
524
525* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
526- new upstream release
527
528* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
529- remove redhatize patch
530
531* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
532- rebuild to remove unneeded dependancy.
533
534* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
535- build for Vine Linux
536
537* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
538- add explicit startup-notification dependency because build system is
539  dumb
540- 2.1.3
541
542* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
543- 2.1.2
544
545* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
546- 2.0.7
547- remove patches that are upstream
548
549* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
550- Add badhack to make weblinks on desktop work
551
552* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
553- fix #70667 assertion failures
554- fix triple click patch
555
556* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
557- don't activate on double click
558
559* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
560- put button press mask in triple-click patch, maybe it will work
561- remove html-hack patch as it does nothing useful
562
563* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
564- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
565  bogus bug reports
566- add hack for HTML mime type handling in a web browser, not
567  nautilus
568
569* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
570- Updated to 2.0.6. Removed the patches I put upstream.
571- Added patch that fixes #72410
572
573* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
574- Add a simple patch so that redhat-config-packages can disable
575  the new window behavior for mounted CDs behavior.
576
577* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
578- Add patch to fix bug #70667
579
580* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
581- remove mp3
582
583* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
584- ignore the "add_to_session" preference as it only broke stuff
585- pad the left margin a bit to cope with poor word wrapping
586
587* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
588- Update to 2.0.5, remove topleft icon patch
589
590* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
591- Add patch to fix the bug where desktop icons get
592  stuck in the top left corner on startup
593
594* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
595- 2.0.4
596
597* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
598- obsolete nautilus-mozilla < 2.0 #69839
599
600* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
601- add rhconfig patch to Bluecurve theme and disable sidebar by default
602
603* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
604- drop start here files, require redhat-menus that has them
605
606* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
607- 2.0.3
608
609* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
610- build for new eel2, gail
611
612* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
613- and add the libexec components, mumble
614
615* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
616- put the components in the file list, were moved upstream
617
618* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
619- 2.0.1
620
621* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
622- Relibtoolize to fix relink problems for solib components
623- Add LANG=en_US to %makeinstall as well
624- Back out previous change, force locale to en_US to prevent UTF-8 problems
625- Add workaround for intltool-merge bug on ia64
626
627* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
628- automated rebuild
629
630* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
631- 2.0.0
632- use desktop-file-install
633- require desktop-backgrounds-basic
634
635* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
636- add wacky hack in hopes of fixing the hang-on-login thing
637
638* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
639- add build requires on new gail
640- rebuild to try to lose broken libgailutil.so.13 dependency
641
642* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
643- rebuild in different environment
644
645* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
646- 1.1.19
647
648* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
649- rebuild in different environment
650
651* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
652- really remove nautilus-devel if we are going to obsolete it
653- don't require hwbrowser
654
655* Sun May 26 2002 Tim Powers <timp@redhat.com>
656- automated rebuild
657
658* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
659- rebuild in different environment
660
661* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
662- 1.1.17
663
664* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
665- 1.1.14
666
667* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
668- require eog
669- obsolete nautilus-devel
670- fix name of schemas file in post
671
672* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
673- Update to 1.1.13
674
675* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
676- put tree view in file list
677
678* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
679- nautilus for gnome 2
680- clean up the spec file and file list a bit
681
682* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
683- merge translations
684
685* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
686- Add patch to fix trash crash
687
688* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
689- fix for metadata tmp race
690- backport thumbnail speed fix and thumbnail inf. loop fix
691
692* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
693- add some fixes from CVS version, including one for #61819 and a couple segfaults
694
695* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
696- fix thumbnails for files with future timestamp, #56862
697
698* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
699- buildrequires intltool #60633
700- apply Alex's pixbuf cache patch to save a few megs #60581
701
702* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
703- drop Milan-specific features, including png10 and ac25 patches
704- copy in 1.0.5 help component to avoid large risky patch
705- remove .la files
706- drop mozilla from ia64 again
707- remove oaf file from nautilus-mozilla that was also in the base
708  package
709
710* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
711- enable mozilla support on ia64
712
713* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
714- require Mozilla 0.9.7
715- Add patch that puts mozilla profile startup before embedding is initialized
716
717* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
718- 1.0.6, require Mozilla 0.9.6
719
720* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
721- Update to 1.0.5
722
723* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
724- Fix handling of GnomeVFSFileInfo structure (#53315)
725
726* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
727- Change handling of names on unmount to fix #52325
728
729* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
730- put nautilus-help.desktop in file list; #53109
731
732* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
733- Add po files from sources.redhat.com
734
735* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
736- Add po files from sources.redhat.com
737
738* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
739- Added patch to fix the .directory issuer
740
741* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
742- I screwed up the build yesterday, so it didn't actually contain the
743  fixes mentioned. This build should contain them.
744
745* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
746- fix bug causing 32000 stats or so in large directories,
747  should speed things up somewhat
748- fix #52104 via gruesome kdesktop-detection hack and setting
749  window type hint on our desktop window
750- fix so Start Here icon displays in sidebar
751- don't load non-local .desktop files
752
753* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
754- make Programs icon into a link, to match the other .desktop files
755- own various directories #51164
756- web page titles in Japanese, #51709
757- tree defaults to only directories #51850
758
759* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
760- make start here icon work again
761- kill some warning spew, #51661
762- cache getpwnam() results to speed things up a bit
763
764* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
765- Fix problem with missing desktop starthere.desktop file
766- New snapshot from our branch, fixes:
767  - On upgrade, icons migrated from GNOME desktop are not properly lined up
768    (#51436)
769  - icons dropped on the desktop don't end up where dropped. (#51441)
770  - Nautilus shouldn't have fam monitor read-only windows. This
771    keeps CDROMS from being unmounted until you close all
772
773    nautilus windows pointing to them. (#51442)
774  - Warnings about 'cannot statfs...' when moving items to trash.
775- Use separate start-here.desktop for panel, since the one used
776  for the root window only works from Nautilus.
777
778* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
779- Changed starthere .desktop files to be links instead
780- of spawning a new nautilus. This makes start-here:
781- much faster.
782
783* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
784- Added hwbrowser dependency
785- New snapshot, fixes the mozilla-view submit form problem
786
787* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
788- Rebuild with new xml-i18n-tools
789- fix crash in creating new desktop files
790
791* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
792- Fix up DnD code some more
793
794* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
795- Sync our CVS version; fixes some MUSTFIX
796  (the one about drawing background on startup,
797   properly translate desktop files, etc.)
798
799* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
800- Fix 64bit cleanness issue
801- Fix NULL mimetype crash
802- Disable additional_text for .desktop files
803
804* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
805- Fix unmounting devices.
806
807* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
808- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
809- mimetype sniffing.
810
811* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
812- Remove the "don't run as root" warning.
813- Remove eazel from bookmarks
814- langified (again? did someone change it?)
815
816* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
817- Apply a patch that makes nautilus dnd reset work with the latest
818- eel release.
819
820* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
821- Build on ia64 without the mozilla component.
822
823* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
824- Fix crash-on-startup showstopper
825- Fix can't-find-images bug (this one was only showing up
826  when built with debug symbols, since it was an uninitialized memory
827  read)
828
829* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
830- sync new tarball from our CVS branch,
831  fixes some drag-and-drop, changes URI scheme names,
832  etc.
833
834* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
835- Add BuildRequires (#49539, 49537)
836- Fix %%post, %%postun (#49720)
837- Background efficiency improvements and hacks
838
839* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
840- Don't launch esd on each mouseover.
841
842* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
843- move first time druid patch into my "CVS outstanding" patch
844- try to really remove Help/Feedback
845- try to really fix Help/Community Support
846- try again to get Start Here in the Go menu
847- try again to get Start Here on the desktop
848- don't show file sizes for .desktop files
849
850* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
851- add newline to ends of .desktop files that were missing them
852
853* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
854- update to my latest 'cvs diff -u' (adds default
855  Start Here link, displays .directory name in sidebar)
856- include /etc/X11/* links (starthere, sysconfig, serverconfig)
857
858* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
859- Patch to remove firsttime druid and flash
860
861* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
862- add hacks for displaying desktop files
863- add hack to turn off the "unwriteable" emblem
864
865* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
866- added defattr to the files lists to be (-,root,root)
867- languified
868
869* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
870- Need to run autoheader too.
871
872* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
873- Make the fam dependency a real runtime dependency
874- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
875- Cleaned up specfile.
876
877* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
878- Change default background and rubberband color.
879- Use the sidebar tabs from the default theme
880- BuildDepend on fam-devel, depend on fam
881- Disable the eazel update pages in the first-time druid.
882- Remove the eazel logo from the first-time druid
883
884* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
885- 1.0.4, removes eazel services icon and wizard page
886- Eazel logo is still in startup wizard for now, needs fixing
887
888* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
889- fix group (s/Desktop/Desktops/) #47134
890- remove ammonite dependency
891
892* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
893- add a different default theme
894- clean up file list overspecificity a bit
895
896* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
897- move to a CVS snapshot of nautilus for now
898  (Darin is my hero for having distcheck work out of CVS)
899
900* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
901- clean up defaults a bit
902
903* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
904- New version
905
906* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
907- Added BuildRequires lines
908- Changed Source to point to ftp.gnome.org instead of just the tarball name
909- Moved %description sections closer to their %package sections
910- Moved %changelog to the end, where so that it's not in the way
911- Changed configure and make install options to allow moving of
912  libraries, includes, binaries more easily
913- Removed hard-coded paths (don't define %prefix or %docdir)
914- replace %{prefix}/bin with %{_bindir}
915- replace %{prefix}/share with %{_datadir}
916- replace %{prefix}/lib with %{_libdir}
917- replace %{prefix}/include with %{_includedir}
918
919* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
920- removed obsoletes from sub packages and added mozilla and trilobite
921subpackages
922
923* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
924- created this thing
Note: See TracBrowser for help on using the repository browser.