source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 7633

Revision 7633, 29.9 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.8.1

Line 
1%define glib2_version 2.36.0
2%define pango_version 1.34.0
3%define gtk3_version 3.8.0
4%define libxml2_version 2.9.0
5%define eog_version 3.8.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.8.0
8%define vine_menus_version 3.0
9%define startup_notification_version 0.10
10%define libexif_version 0.6.19
11%define gconf_version 2.32.0
12%define tracker_version 0.16
13%define gobject_introspection_version 0.9.8
14
15Name:                   nautilus
16Summary:                Nautilus is a file manager for GNOME
17Summary(ja):    Nautilus - GNOME ファイルマネージャ
18Version:                3.8.1
19Release:                1%{?_dist_release}
20License:                GPLv2+
21Group:                  User Interface/Desktops
22URL:                    http://www.gnome.org/projects/nautilus/
23
24Vendor:                 Project Vine
25Distribution:   Vine Linux
26Packager:               Takemikaduchi
27
28Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.8/%{name}-%{version}.tar.xz
29
30# Some changes to default config
31Patch1:         nautilus-2.5.7-rhconfig.patch
32
33# vine
34Patch102:       run_in_gnome.patch
35
36BuildRoot:      %{_tmppath}/%{name}-%{version}-root
37Requires:       gamin
38Requires:       vine-menus >= %{vine_menus_version}
39Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
40Requires:       libexif >= %{libexif_version}
41Requires:       %{name}-libs = %{version}-%{release}
42
43BuildRequires:  intltool
44BuildRequires:  libtool >= 1.4.2-10
45BuildRequires:  automake, autoconf
46BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
47
48BuildRequires:  glib2-devel >= %{glib2_version}
49BuildRequires:  pango-devel >= %{pango_version}
50BuildRequires:  gtk3-devel >= %{gtk3_version}
51BuildRequires:  libxml2-devel >= %{libxml2_version}
52BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
53BuildRequires:  gamin-devel
54BuildRequires:  startup-notification-devel >= %{startup_notification_version}
55BuildRequires:  tracker-devel >= %{tracker_version}
56BuildRequires:  libexif-devel >= %{libexif_version}
57BuildRequires:  unique3-devel
58BuildRequires:  libnotify-devel
59BuildRequires:  libSM-devel
60BuildRequires:  exempi-devel
61BuildRequires:  tracker-devel
62BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
63BuildRequires:  gsettings-desktop-schemas
64
65Obsoletes:      nautilus-extras
66Obsoletes:      nautilus-suggested
67Obsoletes:      nautilus-mozilla < 2.0
68Obsoletes:      eel2 <= 2.24.1
69
70Provides:       eel2 <= 2.24.1
71
72
73%description
74Nautilus integrates access to files, applications, media,
75Internet-based resources and the Web. Nautilus delivers a dynamic and
76rich user experience. Nautilus is an free software project developed
77under the GNU General Public License and is a core component of the
78GNOME desktop project.
79
80%description -l ja
81Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
82リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
83豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
84のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
85プロジェクトのコア・コンポーネントです。
86
87%package devel
88Summary: Support for developing nautilus extensions
89Summary(ja): Nautilus 拡張機能開発のためのサポート
90License: LGPLv2+
91Group: Development/Libraries
92Requires: %{name}-libs = %{version}-%{release}
93Requires: pkgconfig
94
95%description devel
96This package provides libraries and header files needed
97for developing nautilus extensions.
98
99%description -l ja devel
100このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
101ヘッダファイルを提供します。
102
103%package libs
104Summary: Libraries for use in nautilus extentions
105Summary(ja): Nautilus 拡張機能で利用するライブラリ
106Group: User Interface/Desktops
107
108%description libs
109This package provides libraries required by nautilus extention
110module.
111
112%description -l ja libs
113このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
114
115%prep
116%setup -q -n %{name}-%{version}
117
118%patch102 -p1 -b .vine
119
120%build
121gtkdocize
122libtoolize --force --copy
123autoreconf -f -i
124CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
125%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
126
127make %{?_smp_mflags}
128
129%install
130rm -rf $RPM_BUILD_ROOT
131
132make install DESTDIR=$RPM_BUILD_ROOT
133
134# make sure desktop files validate by ignoring sr@Latn
135perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
136# desktop-file-install can't handle empty OnlyShowIn correctly
137perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
138
139desktop-file-install --vendor gnome --delete-original       \
140  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
141  --add-only-show-in GNOME                                  \
142  $RPM_BUILD_ROOT%{_datadir}/applications/*
143
144find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
145
146%find_lang %name
147
148%clean
149rm -rf $RPM_BUILD_ROOT
150
151%postun
152if [ $1 -eq 0 ] ; then
153    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
154fi
155
156%posttrans
157update-mime-database %{_datadir}/mime &> /dev/null ||:
158glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
159
160%post libs -p /sbin/ldconfig
161%postun libs -p /sbin/ldconfig
162
163
164%files  -f %{name}.lang
165%defattr(-,root,root)
166%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
167%dir %{_libdir}/nautilus
168%dir %{_libdir}/nautilus/extensions-3.0
169%{_libdir}/nautilus/extensions-3.0/*.so
170%{_libexecdir}/nautilus-convert-metadata
171%{_datadir}/GConf/gsettings/nautilus.convert
172%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
173%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
174%{_datadir}/dbus-1/services/org.gnome.Nautilus.SearchProvider.service
175%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
176%{_datadir}/nautilus
177%{_datadir}/applications
178%{_datadir}/mime/*
179%{_bindir}/*
180%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
181%{_datadir}/glib-2.0/schemas/
182%{_mandir}/man1/*
183
184%files devel
185%defattr(-, root, root)
186%{_includedir}/nautilus
187%{_libdir}/pkgconfig/*
188%{_libdir}/*.so
189%{_datadir}/gir-1.0
190%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
191
192%files libs
193%defattr(-, root, root)
194%{_libdir}/*.so.*
195%{_libdir}/girepository-1.0/*.typelib
196
197
198%changelog
199* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
200- new upstream release
201
202* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
203- new upstream release
204
205* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
206- new upstream release
207
208* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
209- new upstream release
210
211* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
212- new upstream release
213- remove Patch0,7
214- add BuildRequires: exempi-devel, tracker-devel
215
216* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
217- add Patch0 (nautilus-3.4.2-ja.po.patch)
218
219* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
220- new upstream release
221
222* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
223- new upstream release
224
225* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
226- added patch102 to fix autostart in other desktop environments
227  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
228
229* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
230- new upstream release
231
232* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
233- new upstream release
234
235* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
236- new upstream release
237
238* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
239- new upstream release
240
241* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
242- new upstream release
243- drop Patch101
244- change BuildRequires: gtk3-devel instread of gtk2-devel
245- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
246- change BuildRequires: unique3-devel instread of unique-devel
247- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
248
249* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
250- fixed group of libs
251- add translation of summary and description.
252- add Vendor, Distribution and Packager tags.
253
254* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
255- new upstream release
256
257* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
258- new upstream release
259
260* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
261 - new upstream release
262
263* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
264- new upstream release
265- add BuildRequires: gobject-introspection-devel
266- remove BuildRequires: libgnomeui-devel
267- add configure option (--enable-introspection=yes)
268
269* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
270- rebuild with rpm-4.8.1 for pkg-config file
271
272* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
273- split nautilus extention libraries to -libs subpackage.
274
275* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
276- new upstream release
277
278* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
279- new upstream release
280- drop Patch100
281- add Patch101
282- add Obsoletes: eel2 <= 2.24.1
283- add Provides: eel2 <= 2.24.1
284
285* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
286- new upstream release
287- add BuildRequires: libSM-devel
288
289* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
290- removed Requires: eel2
291- added %%posttrans section
292
293* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
294- new upstream release
295
296* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
297- new upstream release
298
299* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
300- new upstream release
301
302* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
303- new upstream release
304- split -devel subpackage
305
306* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
307- new upstream release
308
309* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
310- patch6 needs autoreconf
311
312* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
313- new upstream release
314
315* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
316- new upstream release
317
318* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
319- new upstream release
320- added Requires: gvfs
321
322* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
323- new upstream release
324- added Patches from FC
325  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
326  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
327  - Fix a crash in the Properties dialog while changing owner (patch from head)
328  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
329  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
330
331* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
332- new upstream release
333- dropped Patch11-13 and added Patch7-9 from Fedora
334  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
335  - Add patch from upstream to get audio preview working again
336    (#332251)
337  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
338  - Fix a crash with small fonts (#242350)
339  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
340  - Backport fixes for async thumbnail loading from svn
341
342* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
343- run autoreconf for Patch11 changes
344
345* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
346- remove tracker dependancy, Patch13 detects tracker dynamically.
347
348* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
349- add Patch13 to support user-dirs
350
351* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
352- new upstream release
353- enable tracker support
354- add BuildRequires: tracker-devel, Requires: tracker
355
356* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
357- new upstream release
358
359* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
360- add BuildRequires: gamin-devel, Requires: gamin
361- remove fam dependency (replaced by gamin)
362
363* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
364- new upsteram release
365
366* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
367- really applied Patch110...
368
369* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
370- add Patch110 to fix corruption of help option message.
371
372* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
373- new upstream release
374
375* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
376- fix typo in ja.po
377
378* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
379- update ja.po to translate patch50 related message.
380
381* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
382- add Patch50 to show progressbar on umounting
383  (ubuntu patch in Bug 313639)
384
385* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
386- new upstream release
387
388* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
389- add Patch10 to avoid background rendering delay
390
391* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
392- new upstream release
393
394* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
395- add fix-non-UTF-8-encoding.patch (patch0)
396  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
397
398* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
399- new upstream release
400
401* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
402- new upstream release
403
404* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
405- new upstream release
406
407* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
408- new upstream release
409
410* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
411- rebuild
412
413* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
414- new upstream version
415
416* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
417- new upstream version
418
419* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
420- add vine patch to change some defaults.
421  - change default zoom sine
422  - set always_use_browser
423
424* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
425- new upstream release
426
427* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
428- add Patch110 to fix libegg(egg-recent-model.c)
429  save old umask value before create ".recently-used" file.
430 
431* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
432- change default desktop font to Sans 9 (from Sans 10)
433- add patch10 to build with gtk+-2.4
434
435* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
436- new upstream release
437
438* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
439- new upstream release
440
441* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
442- add backport patch from rawhide (Patch10)
443
444* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
445- modified vine patch
446  - change default zoom level to small
447  - change desktop font to Sans 10
448
449* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
450- new upstream release
451
452* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
453- add desktop icon patch from rawhide
454
455* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
456- remove obsolete ja.po
457
458* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
459- new upstream release
460
461* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
462- new upstream release
463
464* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
465- new upstream release
466
467* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
468- update ja.po
469
470* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
471- new upstream release
472
473* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
474- new upstream release
475
476* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
477- new upstream release
478
479* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
480- new upstream release
481
482* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
483- new upstream release
484
485* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
486- new upstream release
487
488* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
489- add nautilus-cd-burner patch
490
491* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
492- new upstream release
493
494* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
495- discard scrollkeeper outputs.
496- update PreReq tags.
497
498* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
499- change icon for nautilus-file-management-properties
500- update ja.po
501
502* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
503- update ja.po
504- add translation for .desktop files.
505
506* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
507- add Requires: vine-menus
508
509* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
510- new upstream release
511
512* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
513- remove redhatize patch
514
515* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
516- rebuild to remove unneeded dependancy.
517
518* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
519- build for Vine Linux
520
521* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
522- add explicit startup-notification dependency because build system is
523  dumb
524- 2.1.3
525
526* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
527- 2.1.2
528
529* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
530- 2.0.7
531- remove patches that are upstream
532
533* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
534- Add badhack to make weblinks on desktop work
535
536* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
537- fix #70667 assertion failures
538- fix triple click patch
539
540* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
541- don't activate on double click
542
543* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
544- put button press mask in triple-click patch, maybe it will work
545- remove html-hack patch as it does nothing useful
546
547* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
548- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
549  bogus bug reports
550- add hack for HTML mime type handling in a web browser, not
551  nautilus
552
553* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
554- Updated to 2.0.6. Removed the patches I put upstream.
555- Added patch that fixes #72410
556
557* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
558- Add a simple patch so that redhat-config-packages can disable
559  the new window behavior for mounted CDs behavior.
560
561* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
562- Add patch to fix bug #70667
563
564* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
565- remove mp3
566
567* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
568- ignore the "add_to_session" preference as it only broke stuff
569- pad the left margin a bit to cope with poor word wrapping
570
571* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
572- Update to 2.0.5, remove topleft icon patch
573
574* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
575- Add patch to fix the bug where desktop icons get
576  stuck in the top left corner on startup
577
578* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
579- 2.0.4
580
581* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
582- obsolete nautilus-mozilla < 2.0 #69839
583
584* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
585- add rhconfig patch to Bluecurve theme and disable sidebar by default
586
587* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
588- drop start here files, require redhat-menus that has them
589
590* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
591- 2.0.3
592
593* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
594- build for new eel2, gail
595
596* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
597- and add the libexec components, mumble
598
599* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
600- put the components in the file list, were moved upstream
601
602* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
603- 2.0.1
604
605* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
606- Relibtoolize to fix relink problems for solib components
607- Add LANG=en_US to %makeinstall as well
608- Back out previous change, force locale to en_US to prevent UTF-8 problems
609- Add workaround for intltool-merge bug on ia64
610
611* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
612- automated rebuild
613
614* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
615- 2.0.0
616- use desktop-file-install
617- require desktop-backgrounds-basic
618
619* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
620- add wacky hack in hopes of fixing the hang-on-login thing
621
622* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
623- add build requires on new gail
624- rebuild to try to lose broken libgailutil.so.13 dependency
625
626* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
627- rebuild in different environment
628
629* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
630- 1.1.19
631
632* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
633- rebuild in different environment
634
635* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
636- really remove nautilus-devel if we are going to obsolete it
637- don't require hwbrowser
638
639* Sun May 26 2002 Tim Powers <timp@redhat.com>
640- automated rebuild
641
642* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
643- rebuild in different environment
644
645* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
646- 1.1.17
647
648* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
649- 1.1.14
650
651* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
652- require eog
653- obsolete nautilus-devel
654- fix name of schemas file in post
655
656* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
657- Update to 1.1.13
658
659* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
660- put tree view in file list
661
662* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
663- nautilus for gnome 2
664- clean up the spec file and file list a bit
665
666* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
667- merge translations
668
669* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
670- Add patch to fix trash crash
671
672* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
673- fix for metadata tmp race
674- backport thumbnail speed fix and thumbnail inf. loop fix
675
676* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
677- add some fixes from CVS version, including one for #61819 and a couple segfaults
678
679* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
680- fix thumbnails for files with future timestamp, #56862
681
682* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
683- buildrequires intltool #60633
684- apply Alex's pixbuf cache patch to save a few megs #60581
685
686* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
687- drop Milan-specific features, including png10 and ac25 patches
688- copy in 1.0.5 help component to avoid large risky patch
689- remove .la files
690- drop mozilla from ia64 again
691- remove oaf file from nautilus-mozilla that was also in the base
692  package
693
694* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
695- enable mozilla support on ia64
696
697* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
698- require Mozilla 0.9.7
699- Add patch that puts mozilla profile startup before embedding is initialized
700
701* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
702- 1.0.6, require Mozilla 0.9.6
703
704* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
705- Update to 1.0.5
706
707* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
708- Fix handling of GnomeVFSFileInfo structure (#53315)
709
710* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
711- Change handling of names on unmount to fix #52325
712
713* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
714- put nautilus-help.desktop in file list; #53109
715
716* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
717- Add po files from sources.redhat.com
718
719* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
720- Add po files from sources.redhat.com
721
722* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
723- Added patch to fix the .directory issuer
724
725* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
726- I screwed up the build yesterday, so it didn't actually contain the
727  fixes mentioned. This build should contain them.
728
729* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
730- fix bug causing 32000 stats or so in large directories,
731  should speed things up somewhat
732- fix #52104 via gruesome kdesktop-detection hack and setting
733  window type hint on our desktop window
734- fix so Start Here icon displays in sidebar
735- don't load non-local .desktop files
736
737* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
738- make Programs icon into a link, to match the other .desktop files
739- own various directories #51164
740- web page titles in Japanese, #51709
741- tree defaults to only directories #51850
742
743* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
744- make start here icon work again
745- kill some warning spew, #51661
746- cache getpwnam() results to speed things up a bit
747
748* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
749- Fix problem with missing desktop starthere.desktop file
750- New snapshot from our branch, fixes:
751  - On upgrade, icons migrated from GNOME desktop are not properly lined up
752    (#51436)
753  - icons dropped on the desktop don't end up where dropped. (#51441)
754  - Nautilus shouldn't have fam monitor read-only windows. This
755    keeps CDROMS from being unmounted until you close all
756
757    nautilus windows pointing to them. (#51442)
758  - Warnings about 'cannot statfs...' when moving items to trash.
759- Use separate start-here.desktop for panel, since the one used
760  for the root window only works from Nautilus.
761
762* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
763- Changed starthere .desktop files to be links instead
764- of spawning a new nautilus. This makes start-here:
765- much faster.
766
767* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
768- Added hwbrowser dependency
769- New snapshot, fixes the mozilla-view submit form problem
770
771* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
772- Rebuild with new xml-i18n-tools
773- fix crash in creating new desktop files
774
775* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
776- Fix up DnD code some more
777
778* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
779- Sync our CVS version; fixes some MUSTFIX
780  (the one about drawing background on startup,
781   properly translate desktop files, etc.)
782
783* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
784- Fix 64bit cleanness issue
785- Fix NULL mimetype crash
786- Disable additional_text for .desktop files
787
788* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
789- Fix unmounting devices.
790
791* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
792- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
793- mimetype sniffing.
794
795* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
796- Remove the "don't run as root" warning.
797- Remove eazel from bookmarks
798- langified (again? did someone change it?)
799
800* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
801- Apply a patch that makes nautilus dnd reset work with the latest
802- eel release.
803
804* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
805- Build on ia64 without the mozilla component.
806
807* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
808- Fix crash-on-startup showstopper
809- Fix can't-find-images bug (this one was only showing up
810  when built with debug symbols, since it was an uninitialized memory
811  read)
812
813* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
814- sync new tarball from our CVS branch,
815  fixes some drag-and-drop, changes URI scheme names,
816  etc.
817
818* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
819- Add BuildRequires (#49539, 49537)
820- Fix %%post, %%postun (#49720)
821- Background efficiency improvements and hacks
822
823* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
824- Don't launch esd on each mouseover.
825
826* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
827- move first time druid patch into my "CVS outstanding" patch
828- try to really remove Help/Feedback
829- try to really fix Help/Community Support
830- try again to get Start Here in the Go menu
831- try again to get Start Here on the desktop
832- don't show file sizes for .desktop files
833
834* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
835- add newline to ends of .desktop files that were missing them
836
837* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
838- update to my latest 'cvs diff -u' (adds default
839  Start Here link, displays .directory name in sidebar)
840- include /etc/X11/* links (starthere, sysconfig, serverconfig)
841
842* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
843- Patch to remove firsttime druid and flash
844
845* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
846- add hacks for displaying desktop files
847- add hack to turn off the "unwriteable" emblem
848
849* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
850- added defattr to the files lists to be (-,root,root)
851- languified
852
853* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
854- Need to run autoheader too.
855
856* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
857- Make the fam dependency a real runtime dependency
858- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
859- Cleaned up specfile.
860
861* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
862- Change default background and rubberband color.
863- Use the sidebar tabs from the default theme
864- BuildDepend on fam-devel, depend on fam
865- Disable the eazel update pages in the first-time druid.
866- Remove the eazel logo from the first-time druid
867
868* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
869- 1.0.4, removes eazel services icon and wizard page
870- Eazel logo is still in startup wizard for now, needs fixing
871
872* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
873- fix group (s/Desktop/Desktops/) #47134
874- remove ammonite dependency
875
876* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
877- add a different default theme
878- clean up file list overspecificity a bit
879
880* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
881- move to a CVS snapshot of nautilus for now
882  (Darin is my hero for having distcheck work out of CVS)
883
884* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
885- clean up defaults a bit
886
887* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
888- New version
889
890* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
891- Added BuildRequires lines
892- Changed Source to point to ftp.gnome.org instead of just the tarball name
893- Moved %description sections closer to their %package sections
894- Moved %changelog to the end, where so that it's not in the way
895- Changed configure and make install options to allow moving of
896  libraries, includes, binaries more easily
897- Removed hard-coded paths (don't define %prefix or %docdir)
898- replace %{prefix}/bin with %{_bindir}
899- replace %{prefix}/share with %{_datadir}
900- replace %{prefix}/lib with %{_libdir}
901- replace %{prefix}/include with %{_includedir}
902
903* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
904- removed obsoletes from sub packages and added mozilla and trilobite
905subpackages
906
907* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
908- created this thing
Note: See TracBrowser for help on using the repository browser.