source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 4616

Revision 4616, 29.9 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define glib2_version 2.28.6
2%define pango_version 1.28.4
3%define gtk3_version 3.0.9
4%define libxml2_version 2.7.8
5%define eog_version 3.0.1
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.0.0
8%define vine_menus_version 3.0
9%define gnome_menus_version 2.32.0
10%define startup_notification_version 0.10
11%define libexif_version 0.6.19
12%define gconf_version 2.32.0
13%define gobject_introspection_version 0.9.8
14
15Name:           nautilus
16Summary:        Nautilus is a file manager for GNOME
17Summary(ja):    Nautilus - GNOME ファイルマネージャ
18Version:        3.1.4
19Release:        1%{?_dist_release}
20License:        GPLv2+
21Group:          User Interface/Desktops
22URL:            http://www.gnome.org/projects/nautilus/
23
24Vendor:         Project Vine
25Distribution:   Vine Linux
26Packager:       Takemikaduchi
27
28Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.1/%{name}-%{version}.tar.xz
29
30# Some changes to default config
31Patch1:         nautilus-2.5.7-rhconfig.patch
32Patch3:         background-no-delay.patch
33
34# Why is this not upstream ?
35Patch6:         nautilus-2.23.5-dynamic-search.patch
36
37Patch7:         rtl-fix.patch
38
39# vine
40Patch100:       nautilus-2.8.2-vine.patch
41Patch101:       nautilus-2.30.0-vine.patch
42
43BuildRoot:      %{_tmppath}/%{name}-%{version}-root
44Requires:       gamin
45Requires:       vine-menus >= %{vine_menus_version}
46Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
47Requires:       libexif >= %{libexif_version}
48Requires:       %{name}-libs = %{version}-%{release}
49
50Requires(pre,preun,post): GConf2 >= %{gconf_version}
51Requires(post,postun): rarian-compat
52
53BuildRequires:  glib2-devel >= %{glib2_version}
54BuildRequires:  pango-devel >= %{pango_version}
55BuildRequires:  gtk3-devel >= %{gtk3_version}
56BuildRequires:  libxml2-devel >= %{libxml2_version}
57BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
58BuildRequires:  gamin-devel
59BuildRequires:  intltool
60BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
61BuildRequires:  libtool >= 1.4.2-10
62BuildRequires:  automake, autoconf
63BuildRequires:  startup-notification-devel >= %{startup_notification_version}
64#BuildRequires: tracker-devel >= %{tracker_version}
65BuildRequires:  libexif-devel  >= %{libexif_version}
66BuildRequires:  unique3-devel
67BuildRequires:  libnotify-devel
68BuildRequires:  libSM-devel
69BuildRequires:  libtool, autoconf
70BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
71BuildRequires:  gsettings-desktop-schemas
72
73Obsoletes:      nautilus-extras
74Obsoletes:      nautilus-suggested
75Obsoletes:      nautilus-mozilla < 2.0
76Obsoletes:      eel2 <= 2.24.1
77
78Provides:       eel2 <= 2.24.1
79
80
81%description
82Nautilus integrates access to files, applications, media,
83Internet-based resources and the Web. Nautilus delivers a dynamic and
84rich user experience. Nautilus is an free software project developed
85under the GNU General Public License and is a core component of the
86GNOME desktop project.
87
88%description -l ja
89Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
90リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
91豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
92のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
93プロジェクトのコア・コンポーネントです。
94
95%package devel
96Summary: Support for developing nautilus extensions
97Summary(ja): Nautilus 拡張機能開発のためのサポート
98License: LGPLv2+
99Group: Development/Libraries
100Requires: %{name}-libs = %{version}-%{release}
101Requires: pkgconfig
102
103%description devel
104This package provides libraries and header files needed
105for developing nautilus extensions.
106
107%description -l ja devel
108このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
109ヘッダファイルを提供します。
110
111%package libs
112Summary: Libraries for use in nautilus extentions
113Summary(ja): Nautilus 拡張機能で利用するライブラリ
114Group: User Interface/Desktops
115
116%description libs
117This package provides libraries required by nautilus extention
118module.
119
120%description -l ja libs
121このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
122
123%prep
124%setup -q -n %{name}-%{version}
125
126##patch3 -p1 -b .no-delay
127#%patch5 -p1 -b .selinux
128##patch6 -p1 -b .dynamic-search
129%patch7 -p1 -b .rtl-fix
130
131## %patch100 -p1 -b .vine
132## %patch101 -p1 -b .vine
133
134%build
135gtkdocize
136libtoolize --force --copy
137autoreconf -f -i
138CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
139%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
140
141export tagname=CC
142LANG=en_US make LIBTOOL=/usr/bin/libtool %{?_smp_mflags}
143
144%install
145rm -rf $RPM_BUILD_ROOT
146
147export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
148export tagname=CC
149LANG=en_US make install LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT
150unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
151
152## these are in desktop-backgrounds-basic
153## (uncomment when we patch the source to look in the right place)
154## /bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/nautilus/patterns
155
156# make sure desktop files validate by ignoring sr@Latn
157perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
158# desktop-file-install can't handle empty OnlyShowIn correctly
159perl -pi -e 's/OnlyShowIn=;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
160
161desktop-file-install --vendor gnome --delete-original       \
162  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
163  --add-only-show-in GNOME                                  \
164  $RPM_BUILD_ROOT%{_datadir}/applications/*
165
166perl -pi -e 's/OnlyShowIn=GNOME;/OnlyShowIn=;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
167
168rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{la,a}
169rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
170rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
171
172# mkdir -p $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-3.0
173rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-3.0/*.{la,a}
174
175%find_lang %name
176
177%clean
178rm -rf $RPM_BUILD_ROOT
179
180%post
181/sbin/ldconfig
182touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
183
184%posttrans
185%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null ||:
186gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
187scrollkeeper-update > /dev/null 2>&1 || :
188glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
189
190
191%postun
192/sbin/ldconfig
193if [ $1 -eq 0 ] ; then
194    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
195    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
196    scrollkeeper-update > /dev/null 2>&1 || :
197    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
198fi
199
200%files  -f %{name}.lang
201%defattr(-,root,root)
202%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
203%dir %{_libdir}/nautilus
204%dir %{_libdir}/nautilus/extensions-3.0
205%{_libdir}/nautilus/extensions-3.0/*.so
206%{_libexecdir}/nautilus-convert-metadata
207%{_datadir}/GConf/gsettings/nautilus.convert
208%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
209%{_datadir}/nautilus
210%{_datadir}/pixmaps
211%{_datadir}/applications
212%{_datadir}/mime/*
213%{_datadir}/icons/hicolor/*
214%{_bindir}/*
215%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
216%{_datadir}/glib-2.0/schemas/
217%{_mandir}/man1/*
218
219%files devel
220%defattr(-, root, root)
221%{_includedir}/nautilus
222%{_libdir}/pkgconfig/*
223%{_libdir}/*.so
224%{_datadir}/gir-1.0
225%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
226
227%files libs
228%defattr(-, root, root)
229%{_libdir}/*.so.*
230%{_libdir}/girepository-1.0
231
232
233%changelog
234* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
235- new upstream release
236- drop Patch101
237- change BuildRequires: gtk3-devel instread of gtk2-devel
238- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
239- change BuildRequires: unique3-devel instread of unique-devel
240- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
241
242* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
243- fixed group of libs
244- add translation of summary and description.
245- add Vendor, Distribution and Packager tags.
246
247* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
248- new upstream release
249
250* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
251- new upstream release
252
253* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
254 - new upstream release
255
256* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
257- new upstream release
258- add BuildRequires: gobject-introspection-devel
259- remove BuildRequires: libgnomeui-devel
260- add configure option (--enable-introspection=yes)
261
262* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
263- rebuild with rpm-4.8.1 for pkg-config file
264
265* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
266- split nautilus extention libraries to -libs subpackage.
267
268* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
269- new upstream release
270
271* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
272- new upstream release
273- drop Patch100
274- add Patch101
275- add Obsoletes: eel2 <= 2.24.1
276- add Provides: eel2 <= 2.24.1
277
278* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
279- new upstream release
280- add BuildRequires: libSM-devel
281
282* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
283- removed Requires: eel2
284- added %%posttrans section
285
286* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
287- new upstream release
288
289* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
290- new upstream release
291
292* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
293- new upstream release
294
295* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
296- new upstream release
297- split -devel subpackage
298
299* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
300- new upstream release
301
302* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
303- patch6 needs autoreconf
304
305* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
306- new upstream release
307
308* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
309- new upstream release
310
311* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
312- new upstream release
313- added Requires: gvfs
314
315* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
316- new upstream release
317- added Patches from FC
318  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
319  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
320  - Fix a crash in the Properties dialog while changing owner (patch from head)
321  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
322  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
323
324* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
325- new upstream release
326- dropped Patch11-13 and added Patch7-9 from Fedora
327  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
328  - Add patch from upstream to get audio preview working again
329    (#332251)
330  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
331  - Fix a crash with small fonts (#242350)
332  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
333  - Backport fixes for async thumbnail loading from svn
334
335* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
336- run autoreconf for Patch11 changes
337
338* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
339- remove tracker dependancy, Patch13 detects tracker dynamically.
340
341* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
342- add Patch13 to support user-dirs
343
344* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
345- new upstream release
346- enable tracker support
347- add BuildRequires: tracker-devel, Requires: tracker
348
349* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
350- new upstream release
351
352* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
353- add BuildRequires: gamin-devel, Requires: gamin
354- remove fam dependency (replaced by gamin)
355
356* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
357- new upsteram release
358
359* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
360- really applied Patch110...
361
362* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
363- add Patch110 to fix corruption of help option message.
364
365* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
366- new upstream release
367
368* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
369- fix typo in ja.po
370
371* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
372- update ja.po to translate patch50 related message.
373
374* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
375- add Patch50 to show progressbar on umounting
376  (ubuntu patch in Bug 313639)
377
378* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
379- new upstream release
380
381* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
382- add Patch10 to avoid background rendering delay
383
384* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
385- new upstream release
386
387* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
388- add fix-non-UTF-8-encoding.patch (patch0)
389  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
390
391* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
392- new upstream release
393
394* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
395- new upstream release
396
397* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
398- new upstream release
399
400* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
401- new upstream release
402
403* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
404- rebuild
405
406* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
407- new upstream version
408
409* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
410- new upstream version
411
412* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
413- add vine patch to change some defaults.
414  - change default zoom sine
415  - set always_use_browser
416
417* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
418- new upstream release
419
420* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
421- add Patch110 to fix libegg(egg-recent-model.c)
422  save old umask value before create ".recently-used" file.
423 
424* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
425- change default desktop font to Sans 9 (from Sans 10)
426- add patch10 to build with gtk+-2.4
427
428* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
429- new upstream release
430
431* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
432- new upstream release
433
434* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
435- add backport patch from rawhide (Patch10)
436
437* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
438- modified vine patch
439  - change default zoom level to small
440  - change desktop font to Sans 10
441
442* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
443- new upstream release
444
445* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
446- add desktop icon patch from rawhide
447
448* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
449- remove obsolete ja.po
450
451* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
452- new upstream release
453
454* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
455- new upstream release
456
457* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
458- new upstream release
459
460* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
461- update ja.po
462
463* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
464- new upstream release
465
466* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
467- new upstream release
468
469* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
470- new upstream release
471
472* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
473- new upstream release
474
475* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
476- new upstream release
477
478* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
479- new upstream release
480
481* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
482- add nautilus-cd-burner patch
483
484* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
485- new upstream release
486
487* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
488- discard scrollkeeper outputs.
489- update PreReq tags.
490
491* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
492- change icon for nautilus-file-management-properties
493- update ja.po
494
495* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
496- update ja.po
497- add translation for .desktop files.
498
499* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
500- add Requires: vine-menus
501
502* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
503- new upstream release
504
505* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
506- remove redhatize patch
507
508* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
509- rebuild to remove unneeded dependancy.
510
511* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
512- build for Vine Linux
513
514* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
515- add explicit startup-notification dependency because build system is
516  dumb
517- 2.1.3
518
519* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
520- 2.1.2
521
522* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
523- 2.0.7
524- remove patches that are upstream
525
526* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
527- Add badhack to make weblinks on desktop work
528
529* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
530- fix #70667 assertion failures
531- fix triple click patch
532
533* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
534- don't activate on double click
535
536* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
537- put button press mask in triple-click patch, maybe it will work
538- remove html-hack patch as it does nothing useful
539
540* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
541- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
542  bogus bug reports
543- add hack for HTML mime type handling in a web browser, not
544  nautilus
545
546* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
547- Updated to 2.0.6. Removed the patches I put upstream.
548- Added patch that fixes #72410
549
550* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
551- Add a simple patch so that redhat-config-packages can disable
552  the new window behavior for mounted CDs behavior.
553
554* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
555- Add patch to fix bug #70667
556
557* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
558- remove mp3
559
560* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
561- ignore the "add_to_session" preference as it only broke stuff
562- pad the left margin a bit to cope with poor word wrapping
563
564* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
565- Update to 2.0.5, remove topleft icon patch
566
567* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
568- Add patch to fix the bug where desktop icons get
569  stuck in the top left corner on startup
570
571* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
572- 2.0.4
573
574* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
575- obsolete nautilus-mozilla < 2.0 #69839
576
577* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
578- add rhconfig patch to Bluecurve theme and disable sidebar by default
579
580* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
581- drop start here files, require redhat-menus that has them
582
583* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
584- 2.0.3
585
586* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
587- build for new eel2, gail
588
589* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
590- and add the libexec components, mumble
591
592* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
593- put the components in the file list, were moved upstream
594
595* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
596- 2.0.1
597
598* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
599- Relibtoolize to fix relink problems for solib components
600- Add LANG=en_US to %makeinstall as well
601- Back out previous change, force locale to en_US to prevent UTF-8 problems
602- Add workaround for intltool-merge bug on ia64
603
604* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
605- automated rebuild
606
607* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
608- 2.0.0
609- use desktop-file-install
610- require desktop-backgrounds-basic
611
612* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
613- add wacky hack in hopes of fixing the hang-on-login thing
614
615* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
616- add build requires on new gail
617- rebuild to try to lose broken libgailutil.so.13 dependency
618
619* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
620- rebuild in different environment
621
622* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
623- 1.1.19
624
625* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
626- rebuild in different environment
627
628* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
629- really remove nautilus-devel if we are going to obsolete it
630- don't require hwbrowser
631
632* Sun May 26 2002 Tim Powers <timp@redhat.com>
633- automated rebuild
634
635* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
636- rebuild in different environment
637
638* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
639- 1.1.17
640
641* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
642- 1.1.14
643
644* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
645- require eog
646- obsolete nautilus-devel
647- fix name of schemas file in post
648
649* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
650- Update to 1.1.13
651
652* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
653- put tree view in file list
654
655* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
656- nautilus for gnome 2
657- clean up the spec file and file list a bit
658
659* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
660- merge translations
661
662* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
663- Add patch to fix trash crash
664
665* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
666- fix for metadata tmp race
667- backport thumbnail speed fix and thumbnail inf. loop fix
668
669* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
670- add some fixes from CVS version, including one for #61819 and a couple segfaults
671
672* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
673- fix thumbnails for files with future timestamp, #56862
674
675* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
676- buildrequires intltool #60633
677- apply Alex's pixbuf cache patch to save a few megs #60581
678
679* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
680- drop Milan-specific features, including png10 and ac25 patches
681- copy in 1.0.5 help component to avoid large risky patch
682- remove .la files
683- drop mozilla from ia64 again
684- remove oaf file from nautilus-mozilla that was also in the base
685  package
686
687* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
688- enable mozilla support on ia64
689
690* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
691- require Mozilla 0.9.7
692- Add patch that puts mozilla profile startup before embedding is initialized
693
694* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
695- 1.0.6, require Mozilla 0.9.6
696
697* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
698- Update to 1.0.5
699
700* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
701- Fix handling of GnomeVFSFileInfo structure (#53315)
702
703* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
704- Change handling of names on unmount to fix #52325
705
706* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
707- put nautilus-help.desktop in file list; #53109
708
709* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
710- Add po files from sources.redhat.com
711
712* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
713- Add po files from sources.redhat.com
714
715* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
716- Added patch to fix the .directory issuer
717
718* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
719- I screwed up the build yesterday, so it didn't actually contain the
720  fixes mentioned. This build should contain them.
721
722* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
723- fix bug causing 32000 stats or so in large directories,
724  should speed things up somewhat
725- fix #52104 via gruesome kdesktop-detection hack and setting
726  window type hint on our desktop window
727- fix so Start Here icon displays in sidebar
728- don't load non-local .desktop files
729
730* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
731- make Programs icon into a link, to match the other .desktop files
732- own various directories #51164
733- web page titles in Japanese, #51709
734- tree defaults to only directories #51850
735
736* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
737- make start here icon work again
738- kill some warning spew, #51661
739- cache getpwnam() results to speed things up a bit
740
741* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
742- Fix problem with missing desktop starthere.desktop file
743- New snapshot from our branch, fixes:
744  - On upgrade, icons migrated from GNOME desktop are not properly lined up
745    (#51436)
746  - icons dropped on the desktop don't end up where dropped. (#51441)
747  - Nautilus shouldn't have fam monitor read-only windows. This
748    keeps CDROMS from being unmounted until you close all
749
750    nautilus windows pointing to them. (#51442)
751  - Warnings about 'cannot statfs...' when moving items to trash.
752- Use separate start-here.desktop for panel, since the one used
753  for the root window only works from Nautilus.
754
755* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
756- Changed starthere .desktop files to be links instead
757- of spawning a new nautilus. This makes start-here:
758- much faster.
759
760* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
761- Added hwbrowser dependency
762- New snapshot, fixes the mozilla-view submit form problem
763
764* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
765- Rebuild with new xml-i18n-tools
766- fix crash in creating new desktop files
767
768* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
769- Fix up DnD code some more
770
771* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
772- Sync our CVS version; fixes some MUSTFIX
773  (the one about drawing background on startup,
774   properly translate desktop files, etc.)
775
776* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
777- Fix 64bit cleanness issue
778- Fix NULL mimetype crash
779- Disable additional_text for .desktop files
780
781* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
782- Fix unmounting devices.
783
784* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
785- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
786- mimetype sniffing.
787
788* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
789- Remove the "don't run as root" warning.
790- Remove eazel from bookmarks
791- langified (again? did someone change it?)
792
793* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
794- Apply a patch that makes nautilus dnd reset work with the latest
795- eel release.
796
797* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
798- Build on ia64 without the mozilla component.
799
800* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
801- Fix crash-on-startup showstopper
802- Fix can't-find-images bug (this one was only showing up
803  when built with debug symbols, since it was an uninitialized memory
804  read)
805
806* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
807- sync new tarball from our CVS branch,
808  fixes some drag-and-drop, changes URI scheme names,
809  etc.
810
811* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
812- Add BuildRequires (#49539, 49537)
813- Fix %%post, %%postun (#49720)
814- Background efficiency improvements and hacks
815
816* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
817- Don't launch esd on each mouseover.
818
819* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
820- move first time druid patch into my "CVS outstanding" patch
821- try to really remove Help/Feedback
822- try to really fix Help/Community Support
823- try again to get Start Here in the Go menu
824- try again to get Start Here on the desktop
825- don't show file sizes for .desktop files
826
827* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
828- add newline to ends of .desktop files that were missing them
829
830* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
831- update to my latest 'cvs diff -u' (adds default
832  Start Here link, displays .directory name in sidebar)
833- include /etc/X11/* links (starthere, sysconfig, serverconfig)
834
835* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
836- Patch to remove firsttime druid and flash
837
838* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
839- add hacks for displaying desktop files
840- add hack to turn off the "unwriteable" emblem
841
842* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
843- added defattr to the files lists to be (-,root,root)
844- languified
845
846* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
847- Need to run autoheader too.
848
849* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
850- Make the fam dependency a real runtime dependency
851- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
852- Cleaned up specfile.
853
854* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
855- Change default background and rubberband color.
856- Use the sidebar tabs from the default theme
857- BuildDepend on fam-devel, depend on fam
858- Disable the eazel update pages in the first-time druid.
859- Remove the eazel logo from the first-time druid
860
861* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
862- 1.0.4, removes eazel services icon and wizard page
863- Eazel logo is still in startup wizard for now, needs fixing
864
865* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
866- fix group (s/Desktop/Desktops/) #47134
867- remove ammonite dependency
868
869* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
870- add a different default theme
871- clean up file list overspecificity a bit
872
873* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
874- move to a CVS snapshot of nautilus for now
875  (Darin is my hero for having distcheck work out of CVS)
876
877* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
878- clean up defaults a bit
879
880* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
881- New version
882
883* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
884- Added BuildRequires lines
885- Changed Source to point to ftp.gnome.org instead of just the tarball name
886- Moved %description sections closer to their %package sections
887- Moved %changelog to the end, where so that it's not in the way
888- Changed configure and make install options to allow moving of
889  libraries, includes, binaries more easily
890- Removed hard-coded paths (don't define %prefix or %docdir)
891- replace %{prefix}/bin with %{_bindir}
892- replace %{prefix}/share with %{_datadir}
893- replace %{prefix}/lib with %{_libdir}
894- replace %{prefix}/include with %{_includedir}
895
896* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
897- removed obsoletes from sub packages and added mozilla and trilobite
898subpackages
899
900* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
901- created this thing
Note: See TracBrowser for help on using the repository browser.