source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 2041

Revision 2041, 28.3 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1%define glib2_version 2.26.0
2%define pango_version 1.28.3
3%define gtk2_version 2.22.0
4%define libxml2_version 2.7.7
5%define eog_version 2.32.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop_version 2.32.0
8%define vine_menus_version 3.0
9%define gnome_menus_version 2.32.0
10%define startup_notification_version 0.10
11%define libexif_version 0.6.19
12%define gconf_version 2.32.0
13%define gobject_introspection_version 0.9.8
14
15Name:           nautilus
16Summary:        Nautilus is a file manager for GNOME
17Summary(ja):    Nautilus - GNOME ファイルマネージャ
18Version:        2.32.0
19Release:        1%{?_dist_release}
20License:        GPLv2+
21Group:          User Interface/Desktops
22URL:            http://www.gnome.org/projects/nautilus/
23
24Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.32/%{name}-%{version}.tar.bz2
25
26# Some changes to default config
27Patch1:         nautilus-2.5.7-rhconfig.patch
28Patch3:         background-no-delay.patch
29
30# Why is this not upstream ?
31Patch6:         nautilus-2.23.5-dynamic-search.patch
32
33Patch7:         rtl-fix.patch
34
35# vine
36Patch100:       nautilus-2.8.2-vine.patch
37Patch101:       nautilus-2.30.0-vine.patch
38
39BuildRoot:      %{_tmppath}/%{name}-%{version}-root
40Requires:       gamin
41Requires:       vine-menus >= %{vine_menus_version}
42Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
43Requires:       libexif >= %{libexif_version}
44Requires:       %{name}-libs = %{version}-%{release}
45
46Requires(pre,preun,post): GConf2 >= %{gconf_version}
47Requires(post,postun): rarian-compat
48
49BuildRequires:  glib2-devel >= %{glib2_version}
50BuildRequires:  pango-devel >= %{pango_version}
51BuildRequires:  gtk2-devel >= %{gtk2_version}
52BuildRequires:  libxml2-devel >= %{libxml2_version}
53BuildRequires:  gnome-desktop-devel >= %{gnome_desktop_version}
54BuildRequires:  gamin-devel
55BuildRequires:  intltool
56BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
57BuildRequires:  libtool >= 1.4.2-10
58BuildRequires:  automake, autoconf
59BuildRequires:  startup-notification-devel >= %{startup_notification_version}
60#BuildRequires: tracker-devel >= %{tracker_version}
61BuildRequires:  libexif-devel  >= %{libexif_version}
62BuildRequires:  unique-devel
63BuildRequires:  libtool, autoconf
64BuildRequires:  libSM-devel
65BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
66
67Obsoletes:      nautilus-extras
68Obsoletes:      nautilus-suggested
69Obsoletes:      nautilus-mozilla < 2.0
70Obsoletes:      eel2 <= 2.24.1
71
72Provides:       eel2 <= 2.24.1
73
74
75%description
76Nautilus integrates access to files, applications, media,
77Internet-based resources and the Web. Nautilus delivers a dynamic and
78rich user experience. Nautilus is an free software project developed
79under the GNU General Public License and is a core component of the
80GNOME desktop project.
81
82%package devel
83Summary: Support for developing nautilus extensions
84License: LGPLv2+
85Group: Development/Libraries
86Requires: %{name}-libs = %{version}-%{release}
87Requires: pkgconfig
88
89%description devel
90This package provides libraries and header files needed
91for developing nautilus extensions.
92
93%package libs
94Summary: Libraries for use in nautilus extentions
95Group: User Interfaces/Desktops
96
97%description libs
98This package provides libraries required by nautilus extention
99module.
100
101%prep
102%setup -q -n %{name}-%{version}
103
104##patch3 -p1 -b .no-delay
105#%patch5 -p1 -b .selinux
106##patch6 -p1 -b .dynamic-search
107%patch7 -p1 -b .rtl-fix
108
109## %patch100 -p1 -b .vine
110%patch101 -p1 -b .vine
111
112%build
113gtkdocize
114libtoolize --force --copy
115autoreconf -f -i
116CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
117%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
118
119export tagname=CC
120LANG=en_US make LIBTOOL=/usr/bin/libtool %{?_smp_mflags}
121
122%install
123rm -rf $RPM_BUILD_ROOT
124
125export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
126export tagname=CC
127LANG=en_US %makeinstall LIBTOOL=/usr/bin/libtool
128unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
129
130## these are in desktop-backgrounds-basic
131## (uncomment when we patch the source to look in the right place)
132## /bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/nautilus/patterns
133
134# make sure desktop files validate by ignoring sr@Latn
135perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
136# desktop-file-install can't handle empty OnlyShowIn correctly
137perl -pi -e 's/OnlyShowIn=;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
138
139desktop-file-install --vendor gnome --delete-original       \
140  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
141  --add-only-show-in GNOME                                  \
142  $RPM_BUILD_ROOT%{_datadir}/applications/*
143
144perl -pi -e 's/OnlyShowIn=GNOME;/OnlyShowIn=;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
145
146rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{la,a}
147rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
148rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
149
150mkdir -p $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-2.0
151
152%find_lang %name
153
154%clean
155rm -rf $RPM_BUILD_ROOT
156
157%post
158/sbin/ldconfig
159touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
160export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
161gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
162
163%posttrans
164%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null ||:
165gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
166scrollkeeper-update > /dev/null 2>&1 || :
167
168%pre
169if [ "$1" -gt 1 ]; then
170    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
171    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
172fi
173
174%preun
175if [ "$1" -eq 0 ]; then
176    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
177    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
178fi
179
180%postun
181/sbin/ldconfig
182if [ $1 -eq 0 ] ; then
183    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
184    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
185    scrollkeeper-update > /dev/null 2>&1 || :
186fi
187
188%files  -f %{name}.lang
189%defattr(-,root,root)
190%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
191%dir %{_libdir}/nautilus
192%dir %{_libdir}/nautilus/extensions-2.0
193%{_libexecdir}/nautilus-convert-metadata
194%{_datadir}/nautilus
195%{_datadir}/pixmaps
196%{_datadir}/applications
197%{_datadir}/mime/*
198%{_datadir}/icons/hicolor/*
199%{_bindir}/*
200%{_sysconfdir}/gconf/schemas/*
201%{_mandir}/man1/*
202
203%files devel
204%defattr(-, root, root)
205%{_includedir}/nautilus
206%{_libdir}/pkgconfig/*
207%{_libdir}/*.so
208%{_datadir}/gir-1.0
209%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
210
211%files libs
212%defattr(-, root, root)
213%{_libdir}/*.so.*
214%{_libdir}/girepository-1.0
215
216
217%changelog
218* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
219- new upstream release
220- add BuildRequires: gobject-introspection-devel
221- remove BuildRequires: libgnomeui-devel
222- add configure option (--enable-introspection=yes)
223
224* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
225- rebuild with rpm-4.8.1 for pkg-config file
226
227* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
228- split nautilus extention libraries to -libs subpackage.
229
230* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
231- new upstream release
232
233* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
234- new upstream release
235- drop Patch100
236- add Patch101
237- add Obsoletes: eel2 <= 2.24.1
238- add Provides: eel2 <= 2.24.1
239
240* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
241- new upstream release
242- add BuildRequires: libSM-devel
243
244* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
245- removed Requires: eel2
246- added %%posttrans section
247
248* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
249- new upstream release
250
251* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
252- new upstream release
253
254* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
255- new upstream release
256
257* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
258- new upstream release
259- split -devel subpackage
260
261* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
262- new upstream release
263
264* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
265- patch6 needs autoreconf
266
267* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
268- new upstream release
269
270* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
271- new upstream release
272
273* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
274- new upstream release
275- added Requires: gvfs
276
277* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
278- new upstream release
279- added Patches from FC
280  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
281  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
282  - Fix a crash in the Properties dialog while changing owner (patch from head)
283  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
284  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
285
286* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
287- new upstream release
288- dropped Patch11-13 and added Patch7-9 from Fedora
289  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
290  - Add patch from upstream to get audio preview working again
291    (#332251)
292  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
293  - Fix a crash with small fonts (#242350)
294  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
295  - Backport fixes for async thumbnail loading from svn
296
297* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
298- run autoreconf for Patch11 changes
299
300* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
301- remove tracker dependancy, Patch13 detects tracker dynamically.
302
303* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
304- add Patch13 to support user-dirs
305
306* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
307- new upstream release
308- enable tracker support
309- add BuildRequires: tracker-devel, Requires: tracker
310
311* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
312- new upstream release
313
314* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
315- add BuildRequires: gamin-devel, Requires: gamin
316- remove fam dependency (replaced by gamin)
317
318* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
319- new upsteram release
320
321* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
322- really applied Patch110...
323
324* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
325- add Patch110 to fix corruption of help option message.
326
327* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
328- new upstream release
329
330* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
331- fix typo in ja.po
332
333* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
334- update ja.po to translate patch50 related message.
335
336* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
337- add Patch50 to show progressbar on umounting
338  (ubuntu patch in Bug 313639)
339
340* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
341- new upstream release
342
343* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
344- add Patch10 to avoid background rendering delay
345
346* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
347- new upstream release
348
349* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
350- add fix-non-UTF-8-encoding.patch (patch0)
351  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
352
353* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
354- new upstream release
355
356* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
357- new upstream release
358
359* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
360- new upstream release
361
362* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
363- new upstream release
364
365* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
366- rebuild
367
368* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
369- new upstream version
370
371* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
372- new upstream version
373
374* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
375- add vine patch to change some defaults.
376  - change default zoom sine
377  - set always_use_browser
378
379* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
380- new upstream release
381
382* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
383- add Patch110 to fix libegg(egg-recent-model.c)
384  save old umask value before create ".recently-used" file.
385 
386* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
387- change default desktop font to Sans 9 (from Sans 10)
388- add patch10 to build with gtk+-2.4
389
390* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
391- new upstream release
392
393* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
394- new upstream release
395
396* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
397- add backport patch from rawhide (Patch10)
398
399* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
400- modified vine patch
401  - change default zoom level to small
402  - change desktop font to Sans 10
403
404* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
405- new upstream release
406
407* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
408- add desktop icon patch from rawhide
409
410* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
411- remove obsolete ja.po
412
413* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
414- new upstream release
415
416* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
417- new upstream release
418
419* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
420- new upstream release
421
422* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
423- update ja.po
424
425* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
426- new upstream release
427
428* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
429- new upstream release
430
431* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
432- new upstream release
433
434* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
435- new upstream release
436
437* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
438- new upstream release
439
440* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
441- new upstream release
442
443* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
444- add nautilus-cd-burner patch
445
446* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
447- new upstream release
448
449* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
450- discard scrollkeeper outputs.
451- update PreReq tags.
452
453* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
454- change icon for nautilus-file-management-properties
455- update ja.po
456
457* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
458- update ja.po
459- add translation for .desktop files.
460
461* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
462- add Requires: vine-menus
463
464* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
465- new upstream release
466
467* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
468- remove redhatize patch
469
470* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
471- rebuild to remove unneeded dependancy.
472
473* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
474- build for Vine Linux
475
476* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
477- add explicit startup-notification dependency because build system is
478  dumb
479- 2.1.3
480
481* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
482- 2.1.2
483
484* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
485- 2.0.7
486- remove patches that are upstream
487
488* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
489- Add badhack to make weblinks on desktop work
490
491* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
492- fix #70667 assertion failures
493- fix triple click patch
494
495* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
496- don't activate on double click
497
498* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
499- put button press mask in triple-click patch, maybe it will work
500- remove html-hack patch as it does nothing useful
501
502* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
503- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
504  bogus bug reports
505- add hack for HTML mime type handling in a web browser, not
506  nautilus
507
508* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
509- Updated to 2.0.6. Removed the patches I put upstream.
510- Added patch that fixes #72410
511
512* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
513- Add a simple patch so that redhat-config-packages can disable
514  the new window behavior for mounted CDs behavior.
515
516* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
517- Add patch to fix bug #70667
518
519* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
520- remove mp3
521
522* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
523- ignore the "add_to_session" preference as it only broke stuff
524- pad the left margin a bit to cope with poor word wrapping
525
526* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
527- Update to 2.0.5, remove topleft icon patch
528
529* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
530- Add patch to fix the bug where desktop icons get
531  stuck in the top left corner on startup
532
533* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
534- 2.0.4
535
536* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
537- obsolete nautilus-mozilla < 2.0 #69839
538
539* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
540- add rhconfig patch to Bluecurve theme and disable sidebar by default
541
542* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
543- drop start here files, require redhat-menus that has them
544
545* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
546- 2.0.3
547
548* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
549- build for new eel2, gail
550
551* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
552- and add the libexec components, mumble
553
554* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
555- put the components in the file list, were moved upstream
556
557* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
558- 2.0.1
559
560* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
561- Relibtoolize to fix relink problems for solib components
562- Add LANG=en_US to %makeinstall as well
563- Back out previous change, force locale to en_US to prevent UTF-8 problems
564- Add workaround for intltool-merge bug on ia64
565
566* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
567- automated rebuild
568
569* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
570- 2.0.0
571- use desktop-file-install
572- require desktop-backgrounds-basic
573
574* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
575- add wacky hack in hopes of fixing the hang-on-login thing
576
577* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
578- add build requires on new gail
579- rebuild to try to lose broken libgailutil.so.13 dependency
580
581* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
582- rebuild in different environment
583
584* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
585- 1.1.19
586
587* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
588- rebuild in different environment
589
590* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
591- really remove nautilus-devel if we are going to obsolete it
592- don't require hwbrowser
593
594* Sun May 26 2002 Tim Powers <timp@redhat.com>
595- automated rebuild
596
597* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
598- rebuild in different environment
599
600* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
601- 1.1.17
602
603* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
604- 1.1.14
605
606* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
607- require eog
608- obsolete nautilus-devel
609- fix name of schemas file in post
610
611* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
612- Update to 1.1.13
613
614* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
615- put tree view in file list
616
617* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
618- nautilus for gnome 2
619- clean up the spec file and file list a bit
620
621* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
622- merge translations
623
624* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
625- Add patch to fix trash crash
626
627* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
628- fix for metadata tmp race
629- backport thumbnail speed fix and thumbnail inf. loop fix
630
631* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
632- add some fixes from CVS version, including one for #61819 and a couple segfaults
633
634* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
635- fix thumbnails for files with future timestamp, #56862
636
637* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
638- buildrequires intltool #60633
639- apply Alex's pixbuf cache patch to save a few megs #60581
640
641* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
642- drop Milan-specific features, including png10 and ac25 patches
643- copy in 1.0.5 help component to avoid large risky patch
644- remove .la files
645- drop mozilla from ia64 again
646- remove oaf file from nautilus-mozilla that was also in the base
647  package
648
649* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
650- enable mozilla support on ia64
651
652* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
653- require Mozilla 0.9.7
654- Add patch that puts mozilla profile startup before embedding is initialized
655
656* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
657- 1.0.6, require Mozilla 0.9.6
658
659* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
660- Update to 1.0.5
661
662* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
663- Fix handling of GnomeVFSFileInfo structure (#53315)
664
665* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
666- Change handling of names on unmount to fix #52325
667
668* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
669- put nautilus-help.desktop in file list; #53109
670
671* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
672- Add po files from sources.redhat.com
673
674* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
675- Add po files from sources.redhat.com
676
677* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
678- Added patch to fix the .directory issuer
679
680* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
681- I screwed up the build yesterday, so it didn't actually contain the
682  fixes mentioned. This build should contain them.
683
684* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
685- fix bug causing 32000 stats or so in large directories,
686  should speed things up somewhat
687- fix #52104 via gruesome kdesktop-detection hack and setting
688  window type hint on our desktop window
689- fix so Start Here icon displays in sidebar
690- don't load non-local .desktop files
691
692* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
693- make Programs icon into a link, to match the other .desktop files
694- own various directories #51164
695- web page titles in Japanese, #51709
696- tree defaults to only directories #51850
697
698* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
699- make start here icon work again
700- kill some warning spew, #51661
701- cache getpwnam() results to speed things up a bit
702
703* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
704- Fix problem with missing desktop starthere.desktop file
705- New snapshot from our branch, fixes:
706  - On upgrade, icons migrated from GNOME desktop are not properly lined up
707    (#51436)
708  - icons dropped on the desktop don't end up where dropped. (#51441)
709  - Nautilus shouldn't have fam monitor read-only windows. This
710    keeps CDROMS from being unmounted until you close all
711
712    nautilus windows pointing to them. (#51442)
713  - Warnings about 'cannot statfs...' when moving items to trash.
714- Use separate start-here.desktop for panel, since the one used
715  for the root window only works from Nautilus.
716
717* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
718- Changed starthere .desktop files to be links instead
719- of spawning a new nautilus. This makes start-here:
720- much faster.
721
722* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
723- Added hwbrowser dependency
724- New snapshot, fixes the mozilla-view submit form problem
725
726* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
727- Rebuild with new xml-i18n-tools
728- fix crash in creating new desktop files
729
730* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
731- Fix up DnD code some more
732
733* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
734- Sync our CVS version; fixes some MUSTFIX
735  (the one about drawing background on startup,
736   properly translate desktop files, etc.)
737
738* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
739- Fix 64bit cleanness issue
740- Fix NULL mimetype crash
741- Disable additional_text for .desktop files
742
743* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
744- Fix unmounting devices.
745
746* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
747- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
748- mimetype sniffing.
749
750* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
751- Remove the "don't run as root" warning.
752- Remove eazel from bookmarks
753- langified (again? did someone change it?)
754
755* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
756- Apply a patch that makes nautilus dnd reset work with the latest
757- eel release.
758
759* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
760- Build on ia64 without the mozilla component.
761
762* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
763- Fix crash-on-startup showstopper
764- Fix can't-find-images bug (this one was only showing up
765  when built with debug symbols, since it was an uninitialized memory
766  read)
767
768* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
769- sync new tarball from our CVS branch,
770  fixes some drag-and-drop, changes URI scheme names,
771  etc.
772
773* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
774- Add BuildRequires (#49539, 49537)
775- Fix %%post, %%postun (#49720)
776- Background efficiency improvements and hacks
777
778* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
779- Don't launch esd on each mouseover.
780
781* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
782- move first time druid patch into my "CVS outstanding" patch
783- try to really remove Help/Feedback
784- try to really fix Help/Community Support
785- try again to get Start Here in the Go menu
786- try again to get Start Here on the desktop
787- don't show file sizes for .desktop files
788
789* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
790- add newline to ends of .desktop files that were missing them
791
792* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
793- update to my latest 'cvs diff -u' (adds default
794  Start Here link, displays .directory name in sidebar)
795- include /etc/X11/* links (starthere, sysconfig, serverconfig)
796
797* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
798- Patch to remove firsttime druid and flash
799
800* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
801- add hacks for displaying desktop files
802- add hack to turn off the "unwriteable" emblem
803
804* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
805- added defattr to the files lists to be (-,root,root)
806- languified
807
808* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
809- Need to run autoheader too.
810
811* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
812- Make the fam dependency a real runtime dependency
813- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
814- Cleaned up specfile.
815
816* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
817- Change default background and rubberband color.
818- Use the sidebar tabs from the default theme
819- BuildDepend on fam-devel, depend on fam
820- Disable the eazel update pages in the first-time druid.
821- Remove the eazel logo from the first-time druid
822
823* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
824- 1.0.4, removes eazel services icon and wizard page
825- Eazel logo is still in startup wizard for now, needs fixing
826
827* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
828- fix group (s/Desktop/Desktops/) #47134
829- remove ammonite dependency
830
831* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
832- add a different default theme
833- clean up file list overspecificity a bit
834
835* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
836- move to a CVS snapshot of nautilus for now
837  (Darin is my hero for having distcheck work out of CVS)
838
839* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
840- clean up defaults a bit
841
842* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
843- New version
844
845* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
846- Added BuildRequires lines
847- Changed Source to point to ftp.gnome.org instead of just the tarball name
848- Moved %description sections closer to their %package sections
849- Moved %changelog to the end, where so that it's not in the way
850- Changed configure and make install options to allow moving of
851  libraries, includes, binaries more easily
852- Removed hard-coded paths (don't define %prefix or %docdir)
853- replace %{prefix}/bin with %{_bindir}
854- replace %{prefix}/share with %{_datadir}
855- replace %{prefix}/lib with %{_libdir}
856- replace %{prefix}/include with %{_includedir}
857
858* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
859- removed obsoletes from sub packages and added mozilla and trilobite
860subpackages
861
862* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
863- created this thing
Note: See TracBrowser for help on using the repository browser.