source: projects/specs/trunk/n/nautilus-sendto/nautilus-sendto-vl.spec @ 521

Revision 521, 9.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        Nautilus context menu for sending files
2Summary(ja):    "ファイルを送る"ための Nautilus コンテキストメニュー
3
4Name:           nautilus-sendto
5Version:        2.28.2
6Release:        1%{?_dist_release}
7
8Group:          User Interface/Desktops
9License:        GPLv2+
10URL:            ftp://ftp.gnome.org/pub/gnome/sources/%{name}
11Source0:        http://download.gnome.org/sources/%{name}/1.1/%{name}-%{version}.tar.bz2
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13
14BuildRequires:  gtk2-devel >= 2.14.0
15BuildRequires:  libglade2-devel >= 2.6.0
16BuildRequires:  evolution-data-server-devel >= 2.24.0
17BuildRequires:  libgnomeui-devel >= 2.24.0
18BuildRequires:  nautilus >= 2.24.0
19BuildRequires:  pidgin-devel >= 2.5.0
20BuildRequires:  gettext
21BuildRequires:  perl-XML-Parser intltool
22BuildRequires:  dbus-glib-devel >= 0.70
23BuildRequires:  nautilus-devel
24BuildRequires:  empathy-devel
25
26Requires(pre): GConf2
27Requires(post): GConf2
28Requires(preun): GConf2
29
30# For compat with old nautilus-sendto packaging
31Provides: nautilus-sendto-gaim
32Obsoletes: nautilus-sendto-bluetooth
33Provides: nautilus-sendto-bluetooth
34
35%description
36The nautilus-sendto package provides a Nautilus context menu for
37sending files via other desktop applications.  These functions are
38implemented as plugins, so nautilus-sendto can be extended with
39additional features.
40
41%description -l ja     
42nautilus-sendto パッケージは他のデスクトップアプリケーションを介して
43ファイルを送るためのコンテキストメニューを提供しています。
44これらの機能はプラグインとして提供され、追加の機能を拡張することができます。
45
46%package devel
47Summary:        Development files for %{name}
48Summary(ja):    %{name} の開発ファイル
49Group:          Development/Libraries
50License:        LGPLv2+
51Requires:       %{name} = %{version}-%{release}
52Requires:       gtk-doc pkgconfig
53
54%description devel
55This package contains the libraries amd header files that are needed
56for writing plugins for nautilus-sendto.
57
58%prep
59%setup -q
60
61%build
62%configure
63make %{?_smp_mflags}
64
65
66%install
67rm -rf $RPM_BUILD_ROOT
68export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
69make install DESTDIR=$RPM_BUILD_ROOT
70unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
71
72find $RPM_BUILD_ROOT \( -name '*.a' -o -name '*.la' \) -exec rm -f {} \;
73%find_lang %{name}
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%post
79export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
80gconftool-2 --makefile-install-rule \
81        %{_sysconfdir}/gconf/schemas/nst.schemas > /dev/null || :
82
83%pre
84if [ "$1" -gt 1 ]; then
85  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
86  gconftool-2 --makefile-uninstall-rule \
87        %{_sysconfdir}/gconf/schemas/nst.schemas > /dev/null || :
88fi
89
90%preun
91if [ "$1" -eq 0 ]; then
92  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
93  gconftool-2 --makefile-uninstall-rule \
94        %{_sysconfdir}/gconf/schemas/nst.schemas > /dev/null || :
95fi
96
97%files -f %{name}.lang
98%defattr(-,root,root,-)
99%doc AUTHORS ChangeLog ChangeLog.pre-1.1.4.1 COPYING NEWS
100%{_libdir}/nautilus/extensions-2.0/libnautilus-sendto.so
101%dir %{_libdir}/nautilus-sendto
102%dir %{_libdir}/nautilus-sendto/plugins
103%{_libdir}/nautilus-sendto/plugins/*.so
104%{_datadir}/nautilus-sendto
105%{_bindir}/nautilus-sendto
106%{_sysconfdir}/gconf/schemas/nst.schemas
107%{_mandir}/man1/nautilus-sendto.1.gz
108
109%files devel
110%defattr(-,root,root,-)
111%{_datadir}/gtk-doc/html/nautilus-sendto/
112%{_libdir}/pkgconfig/nautilus-sendto.pc
113%{_includedir}/nautilus-sendto/nautilus-sendto-plugin.h
114
115%changelog
116* Thu Nov 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.28.2-1
117- Update to 2.28.2
118- splitted -devel package
119- Remove unneeded pidgin and gajim BRs
120
121* Thu Sep 24 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.28.0-1
122- Update to 2.28.0
123
124* Sun Sep 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.7-1
125- Update to 1.1.7
126
127* Tue Aug 11 2009 Shu KONNO <owa@bg.wakwak.com> 1.1.6-2
128- added BR: nautilus-devel
129
130* Sun Aug 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.6-1
131- Update to 1.1.6
132
133* Sun Jun 14 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.5-2
134- added Japanese description
135- Disable the evolution plugin, it will be in Evolution itself
136  prefer to http://bugzilla.gnome.org/show_bug.cgi?id=579099
137
138* Sat May 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.5-1
139- Update to 1.1.5
140
141* Fri Apr 24 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.4-1
142- Update to 1.1.4
143- spec in UTF-8
144
145* Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.3-1
146- Update to 1.1.3
147- dropt Patch0
148- changed Summary(ja)
149- fixed BuildRoot
150
151* Sat Apr 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.2-1
152- Update to 1.1.2
153- added Patch0 (import Fedora package)
154
155* Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
156- initial build for Vine Linux
157
158* Tue Sep 23 2008 - Bastien Nocera <bnocera@redhat.com> - 1.1.0
159- Update to 1.1.0
160
161* Wed Jul 23 2008 - Bastien Nocera <bnocera@redhat.com> - 1.0.1
162- Update to 1.0.1
163
164* Thu Jun 12 2008 - Bastien Nocera <bnocera@redhat.com> - 1.0.0
165- Update to 1.0.0
166
167* Wed May 14 2008 Matthias Clasen <mclasen@redhat.com> - 0.14.0-4
168- Rebuild again
169
170* Tue May 13 2008 - Bastien Nocera <bnocera@redhat.com> - 0.14.0-3
171- Rebuild
172
173* Sun May  4 2008 Matthias Clasen <mclasen@redhat.com> - 0.14.0-2
174- Fix source url
175
176* Thu Mar 27 2008 - Bastien Nocera <bnocera@redhat.com> - 0.14.0-1
177- Update to 0.14.0
178
179* Thu Feb 07 2008 - Bastien Nocera <bnocera@redhat.com> - 0.13.2-1
180- Update to 0.13.2
181
182* Mon Jan 21 2008 - Bastien Nocera <bnocera@redhat.com> - 0.13.1-1
183- Update to 0.13.1
184
185* Sun Jan 20 2008 - Bastien Nocera <bnocera@redhat.com> - 0.13-1
186- Update to 0.13
187
188* Fri Dec 28 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.12-7
189- Fix icq file transfers with pidgin RH #408511
190
191* Wed Dec 26 2007 Matthias Clasen <mclasen@redhat.com> - 0.12-6
192- Install the nautilus exension in the right spot
193
194* Mon Nov 19 2007 Matthias Clasen <mclasen@redhat.com> - 0.12-5
195- Fix the pidgin plugin to work with libpurple (#389121)
196
197* Tue Oct 23 2007 Matthias Clasen <mclasen@redhat.com> - 0.12-4
198- Rebuild against new dbus-glib
199
200* Wed Oct 10 2007 Matthias Clasen <mclasen@redhat.com> - 0.12-3
201- Rebuild
202
203* Mon Aug 13 2007 - Bastien Nocera <bnocera@redhat.com> - 0.12-2
204- Fix the Thunderbird patch to apply properly
205
206* Mon Aug 13 2007 - Bastien Nocera <bnocera@redhat.com> - 0.12-1
207- Update to 0.12 and drop obsolete patches
208
209* Tue Aug  7 2007 Matthias Clasen <mclasen@redhat.com> - 0.10-5
210- Update the license field
211
212* Fri May 11 2007 Stu Tomlinson <stu@nosnilmot.com> - 0.10-4
213- Update to work with pidgin
214
215* Wed May  9 2007 Matthias Clasen <mclasen@redhat.com> - 0.10-3
216- Fix a problem with dbus error handling  (#239588)
217
218* Mon Apr 16 2007 Warren Togami <wtogami@redhat.com> - 0.10-2
219- disable gaim dep temporarily during transition to pidgin
220
221* Sun Mar 11 2007 - Bastien Nocera <bnocera@redhat.com> - 0.10-1
222- Update to 0.10, as 0.9 didn't compile
223
224* Fri Mar 09 2007 - Bastien Nocera <bnocera@redhat.com> - 0.9-1
225- Update to 0.9
226- Remove the bluetooth subpackage, it only depends on
227  gbus-glib now
228
229* Tue Jan 23 2007 Alexander Larsson <alexl@redhat.com> - 0.8-4
230- Rebuild against new gaim (#223765)
231
232* Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.8-3
233- Rebuild against new libbtctl
234
235* Fri Oct 27 2006 Matthew Barnes <mbarnes@redhat.com> - 0.8-2
236- Update BuildRequires for evolution-data-server-devel.
237- Rebuild against evolution-data-server-1.9.1.
238
239* Fri Oct 20 2006 Matthias Clasen <mclasen@redhat.com> - 0.8-1
240- Upgrade to 0.8
241
242* Sat Sep 16 2006 Matthias Clasen <mclasen@redhat.com> - 0.7-5
243- Include Thunderbird support and make it work
244- Add missing BRs
245
246* Mon Aug 14 2006 Alexander Larsson <alexl@redhat.com> - 0.7-4
247- Buildrequire nautilus-devel
248
249* Thu Aug 10 2006 Alexander Larsson <alexl@redhat.com> - 0.7-3
250- Make nautilus-sendto-bluetooth require gnome-bluetooth (#201908)
251
252* Sat Aug 05 2006 Caolan McNamara <caolanm@redhat.com> - 0.7-2
253- rebuild against new e-d-s
254
255* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7-1.1
256- rebuild
257
258* Tue Jul 11 2006 Matthias Clasen  <mclasen@redhat.com> - 0.7-1
259- Update to 0.7
260
261* Wed Jun 14 2006 Alexander Larsson <alexl@redhat.com> - 0.5-4
262- Rebuild again, hopefully fixing libbluetooth issue
263
264* Mon Jun 12 2006 Alexander Larsson <alexl@redhat.com> - 0.5-3
265- Rebuild for new libbluetooth soname
266
267* Sat Jun 10 2006 Matthias Clasen <mclasen@redhat.com> 0.5-2
268- Add missing BuildRequires
269
270* Mon May 22 2006 Alexander Larsson <alexl@redhat.com> 0.5-1
271- Update to 0.5
272- Add libgnomeui-devel buildreq
273
274* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.4-7.2
275- bump again for double-long bug on ppc(64)
276
277* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.4-7.1
278- rebuilt for new gcc4.1 snapshot and glibc changes
279
280* Sat Jan 28 2006 David Malcolm <dmalcolm@redhat.com> 0.4-7
281- rebuild for new e-d-s
282
283* Tue Dec 20 2005 Alexander Larsson <alexl@redhat.com> 0.4-6
284- Rebuild
285
286* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
287- rebuilt
288
289* Wed Nov  9 2005 Alexander Larsson <alexl@redhat.com> - 0.4-5
290- Build in Core
291- Move gaim plugin into main package
292- Fix up some build requirements
293- No bluetooth on s390*
294
295* Sat Oct  8 2005 Paul W. Frields <stickster@gmail.com> - 0.4-4
296- Eliminate superfluous Requires
297
298* Sat Oct  8 2005 Paul W. Frields <stickster@gmail.com> - 0.4-3
299- Rearrange Requires and BuildRequires for subpackages
300- Include default Evolution plugin in main package
301
302* Fri Oct  7 2005 Paul W. Frields <stickster@gmail.com> - 0.4-2
303- Use appropriate BuildRequires for nautilus and gaim
304
305* Fri Oct  7 2005 Paul W. Frields <stickster@gmail.com> - 0.4-1
306- Initial version
Note: See TracBrowser for help on using the repository browser.