source: projects/specs/trunk/n/nautilus-actions/nautilus-actions-vl.spec @ 521

Revision 521, 5.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        Nautilus extension for customizing the context menu
2Summary(ja): コンテキストメニューをカスタマイズするための Nautilus 拡張
3Name:           nautilus-actions
4Version:        1.12.3
5Release:        1%{?_dist_release}
6Group:          User Interface/Desktops
7License:        GPLv2+
8URL:            http://www.grumz.net/node/8
9#Source0:       ftp://ftp2.grumz.net/grumz/%{name}-%{version}.tar.gz
10Source0:        ftp://pwi.dyndns.biz/tarballs/%{name}/%{name}-%{version}.tar.bz2
11#Patch0:        nact-gnome_vfs_workaround.patch
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  libgnomeui-devel, libglade2-devel, nautilus-devel
15BuildRequires:  e2fsprogs-devel, gettext, perl-XML-Parser
16BuildRequires:  unique-devel
17
18%if %{?_dist_release} == "vl6"
19BuildRequires:  libuuid-devel
20%endif
21
22BuildRequires:  desktop-file-utils intltool
23Requires(pre):  GConf2
24Requires(preun):GConf2
25
26%description
27Nautilus actions is an extension for Nautilus, the GNOME file manager.
28It provides an easy way to configure programs to be launch on files
29selected in Nautilus interface.
30
31%description -l ja
32Nautilus actions は、GNOME のファイルマネージャである Nautilus の機能拡張です。
33Nautilus のインターフェイスにて選択されたファイル上でプログラムを起動するための
34簡単な設定方法を提供します。
35
36%prep
37%setup -q
38#%patch0 -p0 -b .fix
39
40%build
41%configure --enable-commandline-tool --disable-schemas-install
42make %{?_smp_mflags}
43
44%install
45rm -rf %{buildroot}
46make DESTDIR=%{buildroot} install
47
48rm -rf %{buildroot}/%{_libdir}/nautilus/extensions-2.0/libnautilus-actions.la
49rm -rf %{buildroot}%{_datadir}/applications/fedora-nact.desktop
50
51desktop-file-install --delete-original                  \
52        --vendor vine                           \
53        --dir %{buildroot}%{_datadir}/applications      \
54        --mode 0644                                     \
55        --remove-category Application                   \
56        --remove-category AdvancedSettings              \
57        --add-category GNOME                            \
58        --add-category Settings                         \
59        %{buildroot}%{_datadir}/applications/nact.desktop
60
61%find_lang %{name}
62
63%clean
64rm -rf %{buildroot}
65
66%post
67touch --no-create %{_datadir}/icons/hicolor || :
68
69%postun
70if [ $1 -eq 0 ] ; then
71    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
72    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
73fi
74
75%files -f %{name}.lang
76%defattr(-,root,root,-)
77%doc AUTHORS COPYING ChangeLog README TODO
78%{_bindir}/nautilus-actions-*
79%{_libdir}/nautilus/extensions-2.0/libnautilus-actions.so
80%{_datadir}/%{name}/
81%{_datadir}/icons/hicolor/*/apps/nautilus-actions.*
82%{_datadir}/applications/vine-nact.desktop
83
84%changelog
85* Tue Feb 2 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.12.3-1
86- new upstream release
87
88* Sun Jan 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.12.0-3
89- BuildRequires: libuuid-devel enabled VineSeed, disabled Stable
90  (Because VineSeed provide libuuid-* packages, but Stable don't provide now)
91
92* Thu Jan 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.12.0-2
93- added BuildRequires: libuuid-devel, unique-devel (see [BTS:VineLinux:0893])
94
95* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.12.0-1vl5
96- new upstream release
97- added  --disable-schemas-install in cofigure option
98
99* Sun Aug 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.11.2-1vl5
100- new upstream release
101
102* Sun Jun 14 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.10.1-1vl5
103- new upstream release
104- changed Source0 URL
105- dropt Patch0
106
107* Sat May 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.9-0.20090508-1vl5
108- updated Source0
109- imported Patch0 from fedora
110- added Description -l ja
111- spec in UTF-8
112
113* Mon Apr 20 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.9-0.20081020-1vl5
114- initial build for VineSeed
115
116* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9-0.4.svn20081020
117- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
118
119* Thu Oct 23 2008 Deji Akingunola <dakingun@gmail.com> - 1.9-0.3.svn20081020
120- Update to a svn snapshot to fix bug #450988
121
122* Sat May 17 2008 Deji Akingunola <dakingun@gmail.com> - 1.4.1-4
123- Fix the nautilus-extension directory
124
125* Sun Feb 10 2008 Deji Akingunola <dakingun@gmail.com> - 1.4.1-3
126- Rebuild for gcc43
127
128* Wed Aug 22 2007 Deji Akingunola <dakingun@gmail.com> - 1.4.1-2
129- Update the Source url
130- Rebuild
131
132* Fri Aug 03 2007 Deji Akingunola <dakingun@gmail.com> - 1.4.1-2
133- License tag update
134
135* Thu May 03 2007 Deji Akingunola <dakingun@gmail.com> - 1.4.1-1
136- New (bug-fix) release
137
138* Wed Sep 13 2006 Deji Akingunola <dakingun@gmail.com> - 1.4-4
139- Fix issue with nautilus-action-config, bug #205967
140
141* Mon Aug 28 2006 Deji Akingunola <dakingun@gmail.com> - 1.4-3
142- Rebuild for FC6
143
144* Tue Aug 22 2006 Deji Akingunola <dakingun@gmail.com> - 1.4-2
145- Requires nautilus-devel instead of just nautilus to build
146
147* Tue Aug 22 2006 Deji Akingunola <dakingun@gmail.com> - 1.4-1
148- Update to version 1.4
149
150* Tue May 30 2006 Deji Akingunola <dakingun@gmail.com> - 1.2-2
151- Add gettext and perl(XML::Parser) to BRs
152
153* Mon May 01 2006 Deji Akingunola <dakingun@gmail.com> - 1.2-1
154- Update to version 1.2
155- Make sure fix for upgrade from ver. < 1.0 doesn't throw up errors
156
157* Mon Feb 13 2006 Deji Akingunola <dakingun@gmail.com> - 1.0-2
158- Rebuild for Fedora Extras 5
159
160* Wed Feb 8 2006 Deji Akingunola <dakingun@gmail.com> - 1.0-1
161- New upstream version
162- Do away with gconf schemas installation
163
164* Mon Jan 2 2006 Deji Akingunola <dakingun@gmail.com> - 0.99-6
165- Add nautilus extensions dir to configure arguments
166
167* Sun Jan 1 2006 Deji Akingunola <dakingun@gmail.com> - 0.99-5
168- Remove libXdmcp-devel as BR, nautilus now takkes care of it
169
170* Sun Dec 18 2005 Deji Akingunola <dakingun@gmail.com> - 0.99-4
171- Remove libSM-devel from build require as libgnomeui now build-requires
172- Add libXdmcp-devel to the build requires
173
174* Tue Nov 29 2005 Deji Akingunola <dakingun@gmail.com> - 0.99-2
175- Remove unnecesary configure options
176- Clean-up the desktop file installation
177- Add e2fsprogs-devel buildrequire and remove explicit require on nautilus
178
179* Fri Nov 25 2005 Deji Akingunola <dakingun@gmail.com> - 0.99-1
180- initial Extras release
Note: See TracBrowser for help on using the repository browser.