source: projects/specs/trunk/n/nautilus-actions/nautilus-actions-vl.spec @ 2412

Revision 2412, 8.5 KB checked in by Takemikaduchi, 13 years ago (diff)

add BuildRequires?

Line 
1Summary:        Nautilus extension for customizing the context menu
2Summary(ja): コンテキストメニューをカスタマイズするための Nautilus 拡張
3Name:           nautilus-actions
4Version:        3.0.3
5Release:        2%{?_dist_release}
6Group:          User Interface/Desktops
7License:        GPLv2+
8URL:            http://www.nautilus-actions.org/
9Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.0/%{name}-%{version}.tar.bz2
10
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13BuildRequires: desktop-file-utils
14BuildRequires: e2fsprogs-devel
15BuildRequires: gettext
16BuildRequires: glib2-devel >= 2.16.0
17BuildRequires: gtk2-devel >= 2.12.0
18BuildRequires: dbus-glib-devel
19BuildRequires: intltool >= 0.35.5
20BuildRequires: libgnomeui-devel
21BuildRequires: libglade2-devel
22BuildRequires: libgtop2-devel >= 2.23.1
23BuildRequires: libSM-devel
24BuildRequires: libxml2-devel
25BuildRequires: nautilus-devel
26BuildRequires: perl-XML-Parser
27BuildRequires: pkgconfig
28BuildRequires: unique-devel
29BuildRequires: gnome-doc-utils >= 0.3.2
30
31%if %{?_dist_release} == "vl6"
32BuildRequires:  libuuid-devel
33%endif
34
35Requires(pre):  GConf2
36Requires(preun):GConf2
37
38%description
39Nautilus actions is an extension for Nautilus, the GNOME file manager.
40It provides an easy way to configure programs to be launch on files
41selected in Nautilus interface.
42
43%description -l ja
44Nautilus actions は、GNOME のファイルマネージャである Nautilus の機能拡張です。
45Nautilus のインターフェイスにて選択されたファイル上でプログラムを起動するための
46簡単な設定方法を提供します。
47
48%package devel
49Summary: Development tools for the %{name}
50Summary(ja): %{name} の開発ツール
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
53
54%description devel
55This package contains headers and shared libraries needed for development
56with %{name}.
57
58%description -l ja devel
59このパッケージは %{name} の開発に必要なヘッダと共有ライブラリを含みます。
60
61%prep
62%setup -q
63
64%build
65%configure --enable-commandline-tool --disable-schemas-install
66make %{?_smp_mflags}
67
68%install
69rm -rf %{buildroot}
70make DESTDIR=%{buildroot} install
71
72rm -rf %{buildroot}/%{_libdir}/nautilus-actions/*.la
73rm -rf %{buildroot}/%{_libdir}/nautilus/extensions-2.0/libnautilus-actions-menu.la
74rm -rf %{buildroot}/%{_libdir}/nautilus/extensions-2.0/libnautilus-actions-tracker.la
75rm -rf %{buildroot}%{_datadir}/applications/fedora-nact.desktop
76
77desktop-file-install --delete-original                  \
78        --vendor vine                           \
79        --dir %{buildroot}%{_datadir}/applications      \
80        --mode 0644                                     \
81        --remove-category Application                   \
82        --remove-category AdvancedSettings              \
83        --remove-category FileManager                   \
84        --add-category GTK                              \
85        --add-category Settings                         \
86        %{buildroot}%{_datadir}/applications/nact.desktop
87
88%find_lang %{name}
89
90%clean
91rm -rf %{buildroot}
92
93%post
94touch --no-create %{_datadir}/icons/hicolor || :
95
96%postun
97if [ $1 -eq 0 ] ; then
98    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
99    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
100fi
101
102%posttrans
103gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
104
105%files -f %{name}.lang
106%defattr(-,root,root,-)
107%doc AUTHORS COPYING ChangeLog README TODO
108%{_bindir}/nautilus-actions-*
109%{_libdir}/nautilus-actions/libna*.so
110%{_libdir}/nautilus/extensions-2.0/libnautilus-actions-menu.so
111%{_libdir}/nautilus/extensions-2.0/libnautilus-actions-tracker.so
112%{_datadir}/%{name}/
113%{_datadir}/icons/hicolor/*/apps/nautilus-actions.*
114%{_datadir}/applications/vine-nact.desktop
115%{_datadir}/gnome/help/%{name}*
116%{_datadir}/gtk-doc/*
117%{_datadir}/omf/*
118
119%files devel
120%defattr(-,root,root,-)
121%{_includedir}/%{name}/
122
123%changelog
124* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-2
125- add BuildRequires: gnome-doc-utils
126- remove Release tag (devel package)
127
128* Thu Dec 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.3-1
129- new upstream release
130
131* Sun Dec 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.2-1
132- new upstream release
133
134* Wed Oct 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0-1
135- new upstream release
136- cleaned up spec
137- changed URL
138- changed source0 URL
139- added and arranged BuildRequires
140  - BuildRequires: desktop-file-utils
141  - BuildRequires: e2fsprogs-devel
142  - BuildRequires: gettext
143  - BuildRequires: glib2-devel >= 2.16.0
144  - BuildRequires: gtk2-devel >= 2.12.0
145  - BuildRequires: dbus-glib-devel
146  - BuildRequires: intltool >= 0.35.5
147  - BuildRequires: libgnomeui-devel
148  - BuildRequires: libglade2-devel
149  - BuildRequires: libgtop2-devel >= 2.23.1
150  - BuildRequires: libSM-devel
151  - BuildRequires: libxml2-devel
152  - BuildRequires: nautilus-devel
153  - BuildRequires: perl-XML-Parser
154  - BuildRequires: pkgconfig
155  - BuildRequires: unique-devel
156- splitted -devel package
157- changed desktop-file-install action
158  - added --remove-category FileManager
159  - changed --add-category GNOME to GTK
160- run gtk-update-icon-cache on %%posttrans
161
162* Tue Jun 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.30.3-1
163- new upstream release
164
165* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.30.2-1
166- new upstream release
167
168* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.30.0-1
169- new upstream release
170- add BuildRequires: libSM-devel
171
172* Tue Feb 2 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.12.3-1
173- new upstream release
174
175* Sun Jan 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.12.0-3
176- BuildRequires: libuuid-devel enabled VineSeed, disabled Stable
177  (Because VineSeed provide libuuid-* packages, but Stable don't provide now)
178
179* Thu Jan 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.12.0-2
180- added BuildRequires: libuuid-devel, unique-devel (see [BTS:VineLinux:0893])
181
182* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.12.0-1vl5
183- new upstream release
184- added  --disable-schemas-install in cofigure option
185
186* Sun Aug 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.11.2-1vl5
187- new upstream release
188
189* Sun Jun 14 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.10.1-1vl5
190- new upstream release
191- changed Source0 URL
192- dropt Patch0
193
194* Sat May 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.9-0.20090508-1vl5
195- updated Source0
196- imported Patch0 from fedora
197- added Description -l ja
198- spec in UTF-8
199
200* Mon Apr 20 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.9-0.20081020-1vl5
201- initial build for VineSeed
202
203* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9-0.4.svn20081020
204- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
205
206* Thu Oct 23 2008 Deji Akingunola <dakingun@gmail.com> - 1.9-0.3.svn20081020
207- Update to a svn snapshot to fix bug #450988
208
209* Sat May 17 2008 Deji Akingunola <dakingun@gmail.com> - 1.4.1-4
210- Fix the nautilus-extension directory
211
212* Sun Feb 10 2008 Deji Akingunola <dakingun@gmail.com> - 1.4.1-3
213- Rebuild for gcc43
214
215* Wed Aug 22 2007 Deji Akingunola <dakingun@gmail.com> - 1.4.1-2
216- Update the Source url
217- Rebuild
218
219* Fri Aug 03 2007 Deji Akingunola <dakingun@gmail.com> - 1.4.1-2
220- License tag update
221
222* Thu May 03 2007 Deji Akingunola <dakingun@gmail.com> - 1.4.1-1
223- New (bug-fix) release
224
225* Wed Sep 13 2006 Deji Akingunola <dakingun@gmail.com> - 1.4-4
226- Fix issue with nautilus-action-config, bug #205967
227
228* Mon Aug 28 2006 Deji Akingunola <dakingun@gmail.com> - 1.4-3
229- Rebuild for FC6
230
231* Tue Aug 22 2006 Deji Akingunola <dakingun@gmail.com> - 1.4-2
232- Requires nautilus-devel instead of just nautilus to build
233
234* Tue Aug 22 2006 Deji Akingunola <dakingun@gmail.com> - 1.4-1
235- Update to version 1.4
236
237* Tue May 30 2006 Deji Akingunola <dakingun@gmail.com> - 1.2-2
238- Add gettext and perl(XML::Parser) to BRs
239
240* Mon May 01 2006 Deji Akingunola <dakingun@gmail.com> - 1.2-1
241- Update to version 1.2
242- Make sure fix for upgrade from ver. < 1.0 doesn't throw up errors
243
244* Mon Feb 13 2006 Deji Akingunola <dakingun@gmail.com> - 1.0-2
245- Rebuild for Fedora Extras 5
246
247* Wed Feb 8 2006 Deji Akingunola <dakingun@gmail.com> - 1.0-1
248- New upstream version
249- Do away with gconf schemas installation
250
251* Mon Jan 2 2006 Deji Akingunola <dakingun@gmail.com> - 0.99-6
252- Add nautilus extensions dir to configure arguments
253
254* Sun Jan 1 2006 Deji Akingunola <dakingun@gmail.com> - 0.99-5
255- Remove libXdmcp-devel as BR, nautilus now takkes care of it
256
257* Sun Dec 18 2005 Deji Akingunola <dakingun@gmail.com> - 0.99-4
258- Remove libSM-devel from build require as libgnomeui now build-requires
259- Add libXdmcp-devel to the build requires
260
261* Tue Nov 29 2005 Deji Akingunola <dakingun@gmail.com> - 0.99-2
262- Remove unnecesary configure options
263- Clean-up the desktop file installation
264- Add e2fsprogs-devel buildrequire and remove explicit require on nautilus
265
266* Fri Nov 25 2005 Deji Akingunola <dakingun@gmail.com> - 0.99-1
267- initial Extras release
Note: See TracBrowser for help on using the repository browser.