source: projects/specs/trunk/n/nasm/nasm-vl.spec @ 521

Revision 521, 5.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define nasm_version 2.07
2%define download http://www.nasm.us/pub/nasm/releasebuilds
3Summary: The Netwide Assembler, a portable x86 assembler with Intel-like syntax
4Summary(ja): Netwide アセンブラ: Intel ライクなシンタックスのポータブル x86 アセンブラ
5Name: nasm
6Version: %{nasm_version}.00
7Release: 1%{?_dist_release}
8License: LGPL
9Group: Development/Languages
10URL: http://nasm.sourceforge.net/
11Source0: %{download}/%{nasm_version}/nasm-%{nasm_version}.tar.bz2
12Source1: %{download}/%{nasm_version}/nasm-%{nasm_version}-xdoc.tar.bz2
13BuildPrereq: perl, ghostscript, texinfo
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15
16Vendor: Project Vine
17Distribution: Vine Linux
18Packager: <owa>
19
20%package doc
21Summary: Extensive documentation for NASM
22SUmmary(ja): NASM のドキュメント
23Group: Applications/Documentation
24PreReq: install-info
25
26%package rdoff
27Summary: Tools for the RDOFF binary format, sometimes used with NASM.
28Summary(ja): NASM で使われる RDOFF バイナリフォーマット用ツール
29Group: Development/Tools
30
31%description
32NASM is the Netwide Assembler, a free portable assembler for the Intel
3380x86 microprocessor series, using primarily the traditional Intel
34instruction mnemonics and syntax.
35
36%description -l ja
37NASM は Netwide アセンブラです。Intel 80x86 プロセッサシリーズ用の
38フリーでポータブルなアセンブラで、基本的に伝統的な Intel インストラクション
39ニーモニックと文法を使います。
40
41%description doc
42Extensive documentation for the Netwide Assembler, NASM, in HTML,
43info, PostScript and text formats.
44
45%description doc -l ja
46Netwide アセンブラ NASM のドキュメントです。
47HTML、Info、ポストスクリプト、テキスト形式です。
48
49%description rdoff
50Tools for the operating-system independent RDOFF binary format, which
51is sometimes used with the Netwide Assembler (NASM).  These tools
52include linker, library manager, loader, and information dump.
53
54%description rdoff -l ja
55RDOFF バイナリフォーマットの OS 用のツールで、NASM が使います。
56ここには、リンカ、ライブラリマネージャ、ローダ、ダンプが入っています。
57
58%prep
59%setup -q -n nasm-%{nasm_version} -b 1
60
61%build
62LDFLAGS=-s %configure
63
64## don't use _smp_mflags (at 2.07.00)
65#make %{?_smp_mflags} everything
66make everything
67
68%install
69[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
70mkdir -p $RPM_BUILD_ROOT%{_bindir}
71mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
72mkdir -p $RPM_BUILD_ROOT%{_infodir}
73make INSTALLROOT="$RPM_BUILD_ROOT" docdir=%{_docdir}/nasm-doc install_everything
74mkdir -p included-docs
75cp -pr $RPM_BUILD_ROOT%{_docdir}/nasm-doc/* included-docs/
76rm -rf $RPM_BUILD_ROOT%{_docdir}/nasm-doc
77
78%clean
79[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
80
81%post doc
82/sbin/install-info %{_infodir}/nasm.info.gz %{_infodir}/dir
83
84%preun doc
85if [ $1 = 0 ]; then
86  /sbin/install-info --delete %{_infodir}/nasm.info.gz %{_infodir}/dir
87fi
88
89
90%files
91%defattr(-,root,root)
92%doc AUTHORS CHANGES ChangeLog INSTALL LICENSE README TODO
93%{_bindir}/nasm
94%{_bindir}/ndisasm
95%{_mandir}/man1/*.1.gz
96
97%files doc
98%defattr(-,root,root)
99%doc included-docs/*
100%{_infodir}/nasm.info*
101
102%files rdoff
103%defattr(-,root,root)
104%doc rdoff/README
105%{_bindir}/ldrdf
106%{_bindir}/rdf2bin
107%{_bindir}/rdf2com
108%{_bindir}/rdf2ihx
109%{_bindir}/rdf2ith
110%{_bindir}/rdf2srec
111%{_bindir}/rdfdump
112%{_bindir}/rdflib
113%{_bindir}/rdx
114
115%changelog
116* Sat Sep 05 2009 Shu KONNO <owa@bg.wakwak.com> nasm-2.07.00-1
117- updated nasm to nasm-2.07
118
119* Mon Jul 13 2009 Shu KONNO <owa@bg.wakwak.com> nasm-2.06.00-1
120- updated nasm to nasm-2.06
121- added nasm-2.06-xdoc
122- changed download url
123
124* Tue Sep 30 2008 Shu KONNO <owa@bg.wakwak.com> nasm-2.04.00-1vl5
125- updated nasm to nasm-2.04
126- fixed typo of changelog version
127
128* Sat Jun 14 2008 Shu KONNO <owa@bg.wakwak.com> nasm-2.03.00-1vl5
129- updated nasm to nasm-2.03
130- applied new versioning policy and spec in utf-8
131
132* Fri Feb 22 2008 Shu KONNO <owa@bg.wakwak.com> nasm-2.02.00-0vl1
133- updated nasm to nasm-2.02
134
135* Mon Jan 28 2008 Shu KONNO <owa@bg.wakwak.com> nasm-2.01.00-0vl1
136- updated nasm to nasm-2.01
137
138* Thu Nov 29 2007 Shu KONNO <owa@bg.wakwak.com> nasm-2.0.0-0vl1
139- updated nasm to nasm-2.00
140
141* Sun Nov 25 2007 Shu KONNO <owa@bg.wakwak.com> nasm-2.0-0vl0rc1
142- updated nasm to nasm-2.00rc1
143
144* Sun Aug 20 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.98.39-0vl2
145- drop stupid macros
146- fix dependencies
147  - add BuildRequires: texinfo
148  - add BuildRequires: ghostscript instead of /usr/bin/ps2pdf
149  - doc: add PreReq: install-info instead of /sbin/install-info
150- chande doc's group to Applications/Documentation
151
152* Sat Jun  4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.39-0vl1
153- new upstream release
154
155* Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.38-0vl1
156- updated to 0.98.38
157- fixed %doc of nasm-doc
158
159* Thu Jul 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.36-0vl3
160- fixed nasm-doc Group: Documentation
161- changed URL:
162- s/Copyright/License/
163
164* Tue May 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.36-0vl2
165- merged Vine Plus spec file and Vine Seed Plus spec file (sorry....)
166
167* Thu May  1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.36-0vl1
168- update 0.98.36 based on sourceforge
169 - change licence to LGPL
170 - change URL
171- add BuildPrereq: perl
172
173* Tue Jan 27 2003 Masaki Shinomiya <shino@pos.to> 0.98.35-0vl1
174- source upstream, new URL, doc files
175
176* Sat Apr 14 2001 Shoji Matsumoto <shom@vinelinux.org> 0.98-0vl2
177- add ja desc
178- modify %files
179- use %configure
180- build for Seed
181
182* Fri Dec 15 2000 Hirotaka Mizutani
183      - 0.98-0vl1
184      - updated for VineLinux2.1
Note: See TracBrowser for help on using the repository browser.