source: projects/specs/trunk/n/nasm/nasm-vl.spec @ 9734

Revision 9734, 6.6 KB checked in by inagaki, 9 years ago (diff)

2015-09-06 Ryoichi INAGAKI <ryo1@…>

  • llvm, nasm: updated


Line 
1%define nasm_version 2.11.08
2%define download http://www.nasm.us/pub/nasm/releasebuilds
3Summary: The Netwide Assembler, a portable x86 assembler with Intel-like syntax
4Summary(ja): Netwide アセンブラ: Intel ライクなシンタックスのポータブル x86 アセンブラ
5Name: nasm
6Version: %{nasm_version}
7Release: 1%{?_dist_release}
8License: BSD
9Group: Development/Languages
10URL: http://nasm.sourceforge.net/
11Source0: %{download}/%{nasm_version}/nasm-%{nasm_version}.tar.xz
12Source1: %{download}/%{nasm_version}/nasm-%{nasm_version}-xdoc.tar.xz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: ghostscript
16BuildRequires: perl
17BuildRequires: texinfo
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: owa
22
23%package doc
24Summary: Extensive documentation for NASM
25SUmmary(ja): NASM のドキュメント
26Group: Applications/Documentation
27Requires(post): install-info
28Requires(preun): install-info
29
30%package rdoff
31Summary: Tools for the RDOFF binary format, sometimes used with NASM.
32Summary(ja): NASM で使われる RDOFF バイナリフォーマット用ツール
33Group: Development/Tools
34
35%description
36NASM is the Netwide Assembler, a free portable assembler for the Intel
3780x86 microprocessor series, using primarily the traditional Intel
38instruction mnemonics and syntax.
39
40%description -l ja
41NASM は Netwide アセンブラです。Intel 80x86 プロセッサシリーズ用の
42フリーでポータブルなアセンブラで、基本的に伝統的な Intel インストラクション
43ニーモニックと文法を使います。
44
45%description doc
46Extensive documentation for the Netwide Assembler, NASM, in HTML,
47info, PostScript and text formats.
48
49%description doc -l ja
50Netwide アセンブラ NASM のドキュメントです。
51HTML、Info、ポストスクリプト、テキスト形式です。
52
53%description rdoff
54Tools for the operating-system independent RDOFF binary format, which
55is sometimes used with the Netwide Assembler (NASM).  These tools
56include linker, library manager, loader, and information dump.
57
58%description rdoff -l ja
59RDOFF バイナリフォーマットの OS 用のツールで、NASM が使います。
60ここには、リンカ、ライブラリマネージャ、ローダ、ダンプが入っています。
61
62%prep
63%setup -q -n nasm-%{nasm_version} -b 1
64
65%build
66LDFLAGS=-s %configure
67
68## don't use _smp_mflags (at 2.07.00)
69#make %{?_smp_mflags} everything
70make everything
71
72%install
73[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
74mkdir -p $RPM_BUILD_ROOT%{_bindir}
75mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
76mkdir -p $RPM_BUILD_ROOT%{_infodir}
77make INSTALLROOT="$RPM_BUILD_ROOT" docdir=%{_docdir}/nasm-doc install_everything
78mkdir -p included-docs
79cp -pr $RPM_BUILD_ROOT%{_docdir}/nasm-doc/* included-docs/
80rm -rf $RPM_BUILD_ROOT%{_docdir}/nasm-doc
81
82%clean
83[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
84
85%post doc
86/sbin/install-info %{_infodir}/nasm.info.gz %{_infodir}/dir
87
88%preun doc
89if [ $1 = 0 ]; then
90  /sbin/install-info --delete %{_infodir}/nasm.info.gz %{_infodir}/dir
91fi
92
93
94%files
95%defattr(-,root,root)
96%doc AUTHORS CHANGES ChangeLog INSTALL LICENSE README TODO
97%{_bindir}/nasm
98%{_bindir}/ndisasm
99%{_mandir}/man1/*.1.gz
100
101%files doc
102%defattr(-,root,root)
103%doc included-docs/*
104%{_infodir}/nasm.info*
105
106%files rdoff
107%defattr(-,root,root)
108%doc rdoff/README
109%{_bindir}/ldrdf
110%{_bindir}/rdf2bin
111%{_bindir}/rdf2com
112%{_bindir}/rdf2ihx
113%{_bindir}/rdf2ith
114%{_bindir}/rdf2srec
115%{_bindir}/rdfdump
116%{_bindir}/rdflib
117%{_bindir}/rdx
118
119%changelog
120* Sat Sep  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> nasm-2.11.08-1
121- updated nasm to nasm-2.11.08
122- updated xdoc to nasm-2.11.08-xdoc
123
124* Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> nasm-2.11.05-1
125- updated nasm to nasm-2.11.05
126- updated xdoc to nasm-2.11.05-xdoc
127- updated License to BSD (see, LICENSE)
128
129* Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> nasm-2.09.08-1
130- updated nasm to nasm-2.09.08
131- updated xdoc to nasm-2.09.08-xdoc
132
133* Mon Nov 22 2010 Shu KONNO <owa@bg.wakwak.com> nasm-2.09.03-1
134- updated nasm to nasm-2.09.03
135- updated xdoc to nasm-2.09.03-xdoc
136
137* Wed Sep 08 2010 Shu KONNO <owa@bg.wakwak.com> nasm-2.09.01-1
138- updated nasm to nasm-2.09.01
139- updated xdoc to nasm-2.09.01-xdoc
140
141* Thu Sep 02 2010 Shu KONNO <owa@bg.wakwak.com> nasm-2.09-1
142- updated nasm to nasm-2.09
143- updated xdoc to nasm-2.09-xdoc
144
145* Tue Mar 16 2010 Shu KONNO <owa@bg.wakwak.com> nasm-2.08.01-1
146- updated nasm to nasm-2.08.01
147- updated xdoc to nasm-2.08.01-xdoc
148
149* Sat Sep 05 2009 Shu KONNO <owa@bg.wakwak.com> nasm-2.07.00-1
150- updated nasm to nasm-2.07
151
152* Mon Jul 13 2009 Shu KONNO <owa@bg.wakwak.com> nasm-2.06.00-1
153- updated nasm to nasm-2.06
154- added nasm-2.06-xdoc
155- changed download url
156
157* Tue Sep 30 2008 Shu KONNO <owa@bg.wakwak.com> nasm-2.04.00-1vl5
158- updated nasm to nasm-2.04
159- fixed typo of changelog version
160
161* Sat Jun 14 2008 Shu KONNO <owa@bg.wakwak.com> nasm-2.03.00-1vl5
162- updated nasm to nasm-2.03
163- applied new versioning policy and spec in utf-8
164
165* Fri Feb 22 2008 Shu KONNO <owa@bg.wakwak.com> nasm-2.02.00-0vl1
166- updated nasm to nasm-2.02
167
168* Mon Jan 28 2008 Shu KONNO <owa@bg.wakwak.com> nasm-2.01.00-0vl1
169- updated nasm to nasm-2.01
170
171* Thu Nov 29 2007 Shu KONNO <owa@bg.wakwak.com> nasm-2.0.0-0vl1
172- updated nasm to nasm-2.00
173
174* Sun Nov 25 2007 Shu KONNO <owa@bg.wakwak.com> nasm-2.0-0vl0rc1
175- updated nasm to nasm-2.00rc1
176
177* Sun Aug 20 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.98.39-0vl2
178- drop stupid macros
179- fix dependencies
180  - add BuildRequires: texinfo
181  - add BuildRequires: ghostscript instead of /usr/bin/ps2pdf
182  - doc: add PreReq: install-info instead of /sbin/install-info
183- chande doc's group to Applications/Documentation
184
185* Sat Jun  4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.39-0vl1
186- new upstream release
187
188* Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.38-0vl1
189- updated to 0.98.38
190- fixed %doc of nasm-doc
191
192* Thu Jul 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.36-0vl3
193- fixed nasm-doc Group: Documentation
194- changed URL:
195- s/Copyright/License/
196
197* Tue May 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.36-0vl2
198- merged Vine Plus spec file and Vine Seed Plus spec file (sorry....)
199
200* Thu May  1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.36-0vl1
201- update 0.98.36 based on sourceforge
202 - change licence to LGPL
203 - change URL
204- add BuildPrereq: perl
205
206* Tue Jan 27 2003 Masaki Shinomiya <shino@pos.to> 0.98.35-0vl1
207- source upstream, new URL, doc files
208
209* Sat Apr 14 2001 Shoji Matsumoto <shom@vinelinux.org> 0.98-0vl2
210- add ja desc
211- modify %files
212- use %configure
213- build for Seed
214
215* Fri Dec 15 2000 Hirotaka Mizutani
216      - 0.98-0vl1
217      - updated for VineLinux2.1
Note: See TracBrowser for help on using the repository browser.