source: projects/specs/trunk/n/nas/nas-vl.spec @ 9019

Revision 9019, 8.8 KB checked in by inagaki, 9 years ago (diff)

2014-10-24 Ryoichi INAGAKI <ryo1@…>

  • file, nas: updated


Line 
1Name:           nas     
2Summary:        The Network Audio System (NAS)
3Summary(ja):    ネットワークオーディオシステム (NAS)
4Version:        1.9.3
5Release:        4%{?_dist_release}
6
7URL:            http://radscan.com/nas.html
8
9License:        Public Domain
10Group:          System Environment/Daemons
11Source0:        http://nas.codebrilliance.com/nas/nas-%{version}.src.tar.gz
12Source1:        http://apt.kde-redhat.org/apt/kde-redhat/SOURCES/nas/nasd.init
13Source2:        http://apt.kde-redhat.org/apt/kde-redhat/SOURCES/nas/nasd.sysconfig
14Patch0:         %{name}-1.9.3-Move-AuErrorDB-to-SHAREDIR.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildRequires:  bison flex
18BuildRequires:  imake
19BuildRequires:  libX11-devel libXau-devel libXaw-devel libXext-devel
20BuildRequires:  libXpm-devel libXp-devel libXt-devel
21%define libdir_x11 %{_libdir}/X11
22
23Requires(preun): chkconfig /sbin/service
24Requires(post): chkconfig
25
26Requires:       %{name}-libs = %{version}-%{release}
27
28Vendor:         Project Vine
29Distribution:   Vine Linux
30
31%description
32In a nutshell, NAS is the audio equivalent of an X display server.
33The Network Audio System (NAS) was developed by NCD for playing,
34recording, and manipulating audio data over a network.  Like the
35X Window System, it uses the client/server model to separate
36applications from the specific drivers that control audio input
37and output devices.
38
39Key features of the Network Audio System include:
40        o  Device-independent audio over the network
41        o  Lots of audio file and data formats
42        o  Can store sounds in server for rapid replay
43        o  Extensive mixing, separating, and manipulation of audio data
44        o  Simultaneous use of audio devices by multiple applications
45        o  Use by a growing number of ISVs
46        o  Small size
47        o  Free!  No obnoxious licensing terms
48
49%description -l ja
50簡単にいうと、NAS は X ディスプレイサーバのオーディオ版です。
51NCD (Network Computing Devices) 社で開発されたネットワークオーディオシステム
52(NAS) は、ネットワーク越しにオーディオデータを再生・録音・操作するための
53ものです。X Window System と同様にクライアント/サーバモデルを採用し、
54アプリケーションをオーディオ入出力デバイスおよび特定のドライバから切り離す
55設計になっています。
56
57NAS の特徴は以下の通りです:
58        o  デバイスに依存しない、ネットワーク越しのオーディオ
59        o  多数のオーディオファイルやデータフォーマットに対応
60        o  サーバ上にサウンドを保持、すばやくリプレイが可能
61        o  オーディオデータのミキシング、セパレーション、操作が可能
62        o  複数のアプリケーションからのオーディオデバイス同時利用が可能
63        o  多数のソフトウェアメーカーによる利用実績
64        o  コンパクトで小さなサイズ
65        o  フリーです!面倒なライセンス条件はありません
66
67%package devel
68Summary:        Development and doc files for the NAS
69Summary(ja):    NAS 用開発ファイルとドキュメント
70Group:          Development/Libraries
71Requires:       %{name}-libs = %{version}-%{release}
72
73%description devel
74Development files and the documentation
75
76%description devel -l ja
77NAS 用開発ファイルとドキュメント
78
79
80%package libs
81Summary: Runtime libraries for NAS
82Summary(ja): NAS のランタイムライブラリ
83Group:   System Environment/Libraries
84
85%description libs
86%{summary}.
87
88
89%prep
90%setup -q
91%patch0 -p1 -b .move_AuErrorDB
92iconv --from-code=ISO_8859-15 --to-code=UTF-8 HISTORY >HISTORY.tmp
93mv HISTORY.tmp HISTORY
94
95
96%build
97xmkmf
98find . -name Makefile \
99| xargs sed -i -e 's/^\(\s*CDEBUGFLAGS\s*=.*\)/\1 $(RPM_OPT_FLAGS)/'
100make %{?_smp_mflags} World MFLAGS="IRULESRC=%{_datadir}/X11/config"
101
102
103%install
104rm -rf %{buildroot}
105
106make MFLAGS="IRULESRC=%{_datadir}/X11/config" \
107  DESTDIR=%{buildroot} BINDIR=%{_bindir} INCROOT=%{_includedir} \
108  LIBDIR=%{libdir_x11}  SHLIBDIR=%{_libdir} USRLIBDIR=%{_libdir} MANPATH=%{_mandir} \
109  INSTALLFLAGS='-p' \
110  install install.man
111
112install -p -m755 -D %{SOURCE1} %{buildroot}%{_initrddir}/nasd
113install -p -m644 -D %{SOURCE2} %{buildroot}%{_sysconfdir}/sysconfig/nasd
114
115# remove static lib
116rm -f %{buildroot}%{_libdir}/*.a
117# rename cofigfile
118mv %{buildroot}/etc/nas/nasd.conf.eg %{buildroot}/etc/nas/nasd.conf
119
120
121%post
122/sbin/chkconfig --add nasd
123
124
125%preun
126if [ $1 = 0 ] ; then
127  /sbin/chkconfig --del nasd
128  /sbin/service nasd stop >/dev/null 2>&1 ||:
129fi
130
131
132%post libs -p /sbin/ldconfig
133
134%postun libs -p /sbin/ldconfig
135
136
137%clean
138rm -rf %{buildroot}
139
140
141%files
142%defattr(-,root,root,-)
143%dir %{_sysconfdir}/nas
144%config(noreplace) %{_sysconfdir}/nas/nasd.conf
145%config(noreplace) %{_sysconfdir}/sysconfig/nasd
146%{_initrddir}/nasd
147%{_bindir}/*
148%{_mandir}/man1/*
149%{_mandir}/man5/*
150
151%files libs
152%defattr(-,root,root,-)
153%doc README FAQ HISTORY TODO
154%{_libdir}/libaudio.so.*
155%{_datadir}/X11/AuErrorDB
156
157%files devel
158%defattr(-,root,root,-)
159%{_includedir}/audio/
160%{_libdir}/libaudio.so
161%{_mandir}/man3/*
162
163
164%changelog
165* Fri Oct 24 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.9.3-4
166- moved nas to System Environment/Daemons Group
167
168* Sun May 27 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.9.3-3
169- add Japanese summary and description to libs subpackage
170
171* Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.3-2
172- add Japanese summary and description
173
174* Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.3-1
175- new upstream release
176- add Patch0 (move AuErrorDB to sharedir)
177
178* Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.9.1-7
179- Initial build for Vine Linux
180
181* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.1-6
182- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
183
184* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.1-5
185- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
186
187* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.9.1-4
188- -libs subpkg (f9+, #438547)
189- %%install: INSTALLFLAGS='-p' (preserve timestamps)
190- fixup %%changelog whitespace
191
192* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.9.1-3
193- Autorebuild for GCC 4.3
194
195* Sun Nov 11 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9.1-2
196- fix spec file
197
198* Sun Nov 11 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9.1-1
199- update to 1.9.1
200- remove unneeded patches
201
202* Fri Nov 02 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9a-3
203- add better patch for #247468
204
205* Fri Nov 02 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9a-2
206- add patch to fix #247468
207
208* Sun Oct 28 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9a-1
209- update to 1.9a to fix #245712
210
211* Sat Aug 18 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9-4
212- fix for bug #245712
213
214* Sat Aug 11  2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9-3
215- fix for bug #250453
216
217* Fri May 04 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9-2%{?dist}
218- rebuild for the new ppc64 arch
219
220* Sun Apr 08 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.9-1%{?dist}
221- update to 1.9
222- remove old patch file
223
224* Mon Mar 26 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.8b-1%{?dist}
225- update to 1.8b
226
227* Thu Mar 22 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.8a-2%{?dist}
228- use the SVN version of 1.8a
229
230* Wed Mar 21 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.8a-1%{?dist}
231- fix bug 233353
232
233* Thu Feb 09 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.8-13%{?dist}
234- use the corrected patch
235
236* Thu Feb 08 2007 Frank Büttner  <frank-buettner@gmx.net> - 1.8-11%{?dist}
237- fix bug 227759
238
239* Tue Sep 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 1.8-10
240- don't rely-on/use potentially broken %%_libdir/X11 symlink (#207180)
241
242* Mon Sep 11 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-9%{?dist}
243- second rebuild for FC6
244
245* Mon Jul 24 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-8%{?dist}
246- fix ugly output when starting the daemon
247
248* Fri Jul 21 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-7%{?dist}
249- disable build for EMT64 on FC4
250
251* Thu Jul 13 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-6%{?dist}
252- fix build on EMT64
253
254* Wed Jul 12 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-5%{?dist}
255- fix include dir
256
257* Fri Jul 7 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-4%{?dist}
258- add Requires(preun): chkconfig /sbin/service
259- add Requires(post):  chkconfig
260- add remarks for FC4
261
262* Fri Jul 7 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-3%{?dist}
263- move man3 to devel
264- rename nasd.conf.eg to .conf
265- add build depend for libXext-devel libXt-devel
266- change license to Public Domain
267- add path to make intall
268- add rc.d/sysconfig  files
269
270* Fri Jul 7 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-2%{?dist}
271- move libaudio.so.2 to main package
272- switch package name from NAS to nas
273- fix depend for devel package
274- fix version
275- add nas subdir in etc to main package
276- set license to Distributable
277- add readme file
278
279* Fri Jul 7 2006 Frank Büttner  <frank-buettner@gmx.net> - 1.8-1%{?dist}
280- start
Note: See TracBrowser for help on using the repository browser.