source: projects/specs/trunk/n/nant/nant-vl.spec @ 9472

Revision 9472, 3.0 KB checked in by inagaki, 9 years ago (diff)

2015-03-28 Ryoichi INAGAKI <ryo1@…>

  • dbus-sharp, dbus-sharp-glib, gecko-sharp2, gio-sharp, gnome-desktop-sharp2, kimono, libgpod, mono-debugger, mono-zeroconf, webkit-sharp: rebuilt
  • gnome-sharp2, libgdiplus, mono, mono-addins, mono-basic, nant: updated


Line 
1%define git 20130131
2
3Summary: A .NET based build tool
4Summary(ja): .NET ベースのビルドツール
5Name: nant
6Version: 0.92
7Release: 1%{?git:.git%{git}}%{?_dist_release}
8License: GPLv2+ and LGPLv2+
9Group: Development/Tools
10URL: http://nant.sourceforge.net/
11
12#Source0: http://downloads.sourceforge.net/nant/%{name}-%{version}-src.tar.gz
13# git clone //github.com/letiemble/nant.git
14Source0: %{name}.tar.xz
15
16BuildArch: noarch
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: dos2unix
19BuildRequires: mono-core
20BuildRequires: mono-devel
21BuildRequires: pkgconfig
22
23Autoreq: no
24Requires: mono-core
25Requires: mono-data
26Requires: mono-web
27Requires: mono-winforms
28#Requires: mono(System)
29#Requires: mono(System.Data)
30#Requires: mono(System.Drawing)
31#Requires: mono(System.Web)
32#Requires: mono(System.Windows.Forms)
33#Requires: mono(System.Xml)
34#Requires: mono(mscorlib)
35
36# ignore some bundled dlls
37%define _use_internal_dependency_generator 0
38%define __find_provides env sh -c 'filelist=($(grep -v log4net.dll | grep -v scvs.exe | grep -v nunit | grep -v NDoc | grep -v neutral)) && { printf "%s\\n" "${filelist[@]}" | /usr/lib/rpm/find-provides && printf "%s\\n" "${filelist[@]}" | /usr/lib/rpm/mono-find-provides ; } | sort | uniq'
39%define __find_requires env sh -c 'filelist=($(cat)) && { printf "%s\\n" "${filelist[@]}" |  /usr/lib/rpm/mono-find-requires ; } | sort | uniq'
40
41Vendor: Project Vine
42Distribution: Vine Linux
43
44%description
45NAnt is a .NET based build tool. In theory it is kind of like make
46without make's wrinkles. In practice it's a lot like Ant.
47
48%package devel
49Summary:        NAnt pkgconfig files
50License:        LGPLv2
51Group:          Development/Libraries
52Requires:       nant = %{version}-%{release}
53
54%description devel
55This package contains the pkgconfig files for NAnt.
56
57%prep
58%setup -q -n %{name}
59
60%build
61make TARGET=mono-4.5 MCS="gmcs -sdk:4"
62
63%install
64rm -rf $RPM_BUILD_ROOT
65make install prefix=%{_prefix} DESTDIR=$RPM_BUILD_ROOT TARGET=mono-4.5 MCS="gmcs -sdk:4" docdir=%{_docdir}
66
67mkdir -p $RPM_BUILD_ROOT%{_datadir}/pkgconfig
68mv $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/%{name}.pc $RPM_BUILD_ROOT%{_datadir}/pkgconfig
69
70chmod -x $RPM_BUILD_ROOT%{_datadir}/NAnt/bin/lib/common/2.0/nunit-console.exe.config
71dos2unix $RPM_BUILD_ROOT%{_datadir}/NAnt/bin/lib/common/2.0/nunit-console.exe.config
72
73rm -rf _docs
74mkdir -p _docs
75mv $RPM_BUILD_ROOT%{_docdir}/NAnt/* _docs
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%files
81%defattr(-,root,root)
82%doc COPYING.txt README.txt _docs/*
83%{_bindir}/nant
84%dir %{_datadir}/NAnt
85%{_datadir}/NAnt/*
86
87%files devel
88%defattr(-,root,root)
89%{_datadir}/pkgconfig/%{name}.pc
90
91%changelog
92* Sat Mar 28 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.92-1.git20140131
93- updated to 0.92+git based on OpenSUSE
94- built with mono 3.12.1
95
96* Mon Apr 25 2011 Shu KONNO <owa@bg.wakwak.com> 0.90-3
97- rebuilt with mono-2.10.1-3
98
99* Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 0.90-2
100- rebuilt with mono-2.10.1
101
102* Tue Oct 12 2010 Shu KONNO <owa@bg.wakwak.com> 0.90-1
103- initial build for VineSeed
104
Note: See TracBrowser for help on using the repository browser.