source: projects/specs/trunk/n/nanny/nanny-vl.spec @ 5701

Revision 5701, 3.3 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(0)")}
2
3%define pkg_version 2.31.1
4%define pkg_release 2%{?_dist_release}
5
6Summary:        An easy way to control what your kids are doing in the computer.
7Summary(ja):    子どもがコンピュータ上で操作できる内容を簡単に制限する
8Name:           nanny
9Version:        %{pkg_version}
10Release:        %{pkg_release}
11
12Source0:        %{name}-%{version}.tar.bz2
13Source1:        initd.nanny
14
15Patch0:         nanny-fix-admin-console-desktop.patch
16
17License:        GPL2
18Group:          Applications/System
19URL:            http://projects.gnome.org/nanny/
20
21Requires:       python >= 2.6
22Requires:       gnome-python-libgtop2
23Requires:       python-hachoir-regex
24Requires:       python-imaging
25Requires:       python-twisted
26
27BuildRequires:  python-devel >= 2.6
28BuildRequires:  glib2-devel >= 2.16.0
29BuildRequires:  gtk2-devel >= 2.17.4
30BuildRequires:  gnome-desktop-devel >= 2.26.0
31BuildRequires:  GConf2-devel >= 2.16.0
32BuildRequires:  cairo-devel
33BuildRequires:  dbus-glib-devel
34BuildRequires:  dbus-python-devel
35BuildRequires:  glade3-devel
36BuildRequires:  libgtop2-devel
37BuildRequires:  pango-devel
38BuildRequires:  pygtk2-devel
39
40BuildRequires:  python-twisted
41BuildRequires:  python-imaging
42BuildRequires:  python-hachoir-regex
43BuildRequires:  gnome-python-libgtop2
44BuildRequires:  gnome-doc-utils >= 0.3.2
45
46BuildRoot:      %{_tmppath}/%{name}-%{version}-root
47
48Vendor: Project Vine
49Distribution: Vine Linux
50Packager: Takemikaduchi
51
52
53%description
54Gnome Nanny is an easy way to control what your kids are doing in the computer.
55You can limit how much time a day each one of them is browsing the web, chatting
56or doing email. You can also decide at which times of the day the can do this
57things. Gnome Nanny filters what web pages are seen by each user, so you can block
58all undesirable webs and have your kids enjoy the internet with ease of mind,
59no more worries!
60
61%prep
62%setup -q
63%patch0
64
65
66%build
67%configure --with-init-scripts=redhat
68%{__make} %{?_smp_mflags}
69
70
71%install
72%{__rm} -rf ${RPM_BUILD_ROOT}
73%{__make} install DESTDIR=${RPM_BUILD_ROOT}
74
75install -m 0755 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/nanny
76
77%find_lang %{name} --with-gnome
78
79
80%clean
81%{__rm} -rf ${RPM_BUILD_ROOT}
82
83%post
84touch --no-create %{_datadir}/icons/hicolor & > /dev/null
85%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
86update-desktop-database &> /dev/null ||:
87
88%postun
89update-desktop-database -q & > /dev/null || :
90if [ $1 -eq 0 ]; then
91        touch --no-create %{_datadir}/icons/hicolor & > /dev/null
92        %{_bindir}/gtk-update-icon-cache %{_datadir}/icons/hicolor & > /dev/null
93fi
94
95
96%files -f %{name}.lang
97%defattr(-,root,root)
98%doc COPYING ChangeLog NEWS README
99%config %{_sysconfdir}/dbus-1/system.d/nanny-daemon.conf
100%{_sysconfdir}/%{name}/applists/*
101%{_sysconfdir}/rc.d/init.d/nanny
102%{_sysconfdir}/xdg/autostart/nanny-systray.desktop
103%{_bindir}/nanny-systray
104%{python_sitelib}/%{name}/*
105%{_sbindir}/nanny-admin-console
106%{_sbindir}/nanny-desktop-blocker
107%{_datadir}/applications/nanny-admin-console.desktop
108%{_datadir}/icons/hicolor/*/apps/*
109%{_datadir}/%{name}/*
110%{_datadir}/polkit-1/actions/org.gnome.nanny.policy
111
112
113%changelog
114* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.1-2
115- rebuild with python-2.7.2
116
117* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.1-1
118- initial build for Vine Linux
119
Note: See TracBrowser for help on using the repository browser.