source: projects/specs/trunk/m/mysql-connector-odbc/mysql-connector-odbc-vl.spec @ 8756

Revision 8756, 8.3 KB checked in by tomop, 10 years ago (diff)

mysql-connector-odbc-5.3.2-2

Line 
1#%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define build_compat32 0
3
4Summary: ODBC driver for MySQL
5Name: mysql-connector-odbc
6Version: 5.3.2
7Release: 2%{?_dist_release}
8Group: System Environment/Libraries
9URL: http://dev.mysql.com/downloads/connector/odbc/
10# exceptions allow library to be linked with most open source SW,
11# not only GPL code.
12License: GPLv2 with exceptions
13
14Source0: http://dev.mysql.com/get/Downloads/Connector-ODBC/5.2/%{name}-%{version}-src.tar.gz
15
16# mysql-connector-odbc expects to be able to get at a bunch of utility
17# functions inside libmysqlclient.  Now that we are restricting what symbols
18# are exported by libmysqlclient, that doesn't work.  Instead, copy those
19# functions here.  mysql and mysql-connector-odbc are published under the same
20# license, so this creates no legal issues.  (Note: we don't worry about
21# polluting application namespace in mysql-connector-odbc, since it's never
22# directly statically linked with any application code.)
23Source1: mariadb-mysys.tar.gz
24
25Patch1: myodbc-add-mysys.patch
26Patch2: myodbc-shutdown.patch
27Patch3: myodbc-64bit.patch
28Patch4: myodbc-movecmpfunc.patch
29Patch5: mysql-connector-odbc-buffsize.patch
30Patch6: mysql-connector-odbc-cleartext.patch
31Patch7: mysql-connector-odbc-format-security.patch
32Patch8: mysql-connector-odbc-5.2.5-aarch64.patch
33Patch9: myodbc-mariadb10.patch
34
35BuildRequires: libmysqlclient-devel unixODBC-devel gtk3-devel
36BuildRequires: cmake
37BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
38
39%description
40An ODBC (rev 3) driver for MySQL, for use with unixODBC.
41
42%package -n compat32-%{name}
43Summary: ODBC driver for MySQL
44Group: System Environment/Libraries
45Requires: %{name} = %{version}-%{release}
46
47%description -n compat32-%{name}
48An ODBC (rev 3) driver for MySQL, for use with unixODBC.
49
50%prep
51%setup -q -n %{name}-%{version}-src
52
53tar xfz %{SOURCE1}
54
55%patch1 -p1
56%patch2 -p1
57%patch3 -p1
58%patch4 -p1
59%patch5 -p1
60%patch6 -p1
61%patch7 -p1
62%patch8 -p1
63%patch9 -p1
64
65# mysql_config does not support --cxxflags option
66sed -i 's/--cxxflags/--cflags/g' cmake/FindMySQL.cmake
67
68%build
69# mysql 5.5.10 has stopped #define'ing THREAD in its exports, and has
70# started #define'ing MY_PTHREAD_FASTMUTEX, and neither of those changes
71# sit well with mysql-connector-odbc 5.1.10.  Revisit need for these hacks
72# when updating to newer release.
73export CFLAGS="%{optflags} -lpthread -fno-strict-aliasing -DTHREAD=1 -UMY_PTHREAD_FASTMUTEX -DDBUG_OFF"
74
75cmake . -G "Unix Makefiles" \
76        -DWITH_UNIXODBC=1 \
77        -DRPM_BUILD=1 \
78        -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
79        -DMYSQLCLIENT_LIB_NAME=mysqlclient
80
81make %{?_smp_mflags} VERBOSE=1
82
83%install
84export tagname=CC
85make DESTDIR=$RPM_BUILD_ROOT install
86
87# Remove stuff not to be packaged (possibly reconsider later)
88rm -f $RPM_BUILD_ROOT%{_bindir}/myodbc-installer
89
90rm -f $RPM_BUILD_ROOT/usr/COPYING
91rm -f $RPM_BUILD_ROOT/usr/README
92rm -f $RPM_BUILD_ROOT/usr/README.debug
93rm -f $RPM_BUILD_ROOT/usr/ChangeLog
94rm -f $RPM_BUILD_ROOT/usr/INSTALL
95rm -f $RPM_BUILD_ROOT/usr/Licenses_for_Third-Party_Components.txt
96
97# Create a symlink for library to offer name that users are used to
98ln -sf libmyodbc5w.so $RPM_BUILD_ROOT%{_libdir}/libmyodbc5.so
99
100# Upstream provides a test suite with functional and regression tests.
101# However, some tests fail, so it would deserve some more investigation.
102# We don't include the test suite until it works fine.
103rm -rf $RPM_BUILD_ROOT/usr/test
104
105%post
106/sbin/ldconfig
107
108%postun
109/sbin/ldconfig
110
111%post -n compat32-%{name}
112/sbin/ldconfig
113
114%postun -n compat32-%{name}
115/sbin/ldconfig
116
117%files
118%doc README README.debug ChangeLog COPYING
119%{_libdir}/lib*so
120
121%if %{build_compat32}
122%files -n compat32-%{name}
123%{_libdir}/lib*so
124%endif
125
126%changelog
127* Tue Jul  8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.2-2
128- initial build for Vine Linux.
129
130* Thu Jun 12 2014 Jakub Dorňák <jdornak@redhat.com> - 5.3.2-1
131- Rebase to version 5.3.2
132- MariaDB 10 compatibility
133
134* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.6-2
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
136
137* Fri Jan 24 2014 Jakub Dorňák <jdornak@redhat.com> - 5.2.6-1
138- Update to 2.5.6
139  Resolves: #1047895
140
141* Wed Jan  8 2014 Marcin Juszkiewicz <mjuszkiewicz redhat com> - 5.2.5-5
142- Build failed because whether to use lib64 or not is done by checking
143  list of known 64-bit architectures. So added AArch64 to that list.
144  Resolves: #1041348
145
146* Thu Dec 12 2013 Jakub Dorňák <jdornak@redhat.com> - 5.2.5-4
147- format-security
148  Resolves: #1037209
149
150* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.5-3
151- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
152
153* Mon Jun 17 2013 Honza Horak <hhorak@redhat.com> - 5.2.5-2
154- Avoid potential segfault
155  Resolves: #974794
156
157* Fri May 24 2013 Honza Horak <hhorak@redhat.com> - 5.2.5-1
158- Update to 5.2.5
159- Enlarge buffer size for query string when getting info about tables
160  Related: #948619
161
162* Wed Apr  3 2013 Honza Horak <hhorak@redhat.com> - 5.2.4-2
163- Fix libdir in cmake for ppc64
164
165* Tue Mar  5 2013 Honza Horak <hhorak@redhat.com> - 5.2.4-1
166- Update to 5.2.4
167
168* Fri Mar  1 2013 Honza Horak <hhorak@redhat.com> - 5.1.11-3
169- Fix data types for mariadb
170
171* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.11-2
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
173
174* Sun Jul 22 2012 Tom Lane <tgl@redhat.com> 5.1.11-1
175- Update to 5.1.11
176
177* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.10-2
178- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
179
180* Sun Feb  5 2012 Tom Lane <tgl@redhat.com> 5.1.10-1
181- Update to 5.1.10
182
183* Tue Jan 10 2012 Tom Lane <tgl@redhat.com> 5.1.9-1
184- Update to 5.1.9
185- Add --with-unixODBC-libs to configure command for safer multilib behavior
186Related: #757088
187
188* Wed Mar 23 2011 Tom Lane <tgl@redhat.com> 5.1.8-3
189- Rebuild for libmysqlclient 5.5.10 soname version bump
190
191* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.8-2
192- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
193
194* Thu Dec 23 2010 Tom Lane <tgl@redhat.com> 5.1.8-1
195- Update to 5.1.8
196- Deal with mysql packaging changes that prevent us from using mysys
197  utility functions directly
198
199* Wed Jan 20 2010 Tom Lane <tgl@redhat.com> 5.1.5r1144-7
200- Correct Source: tag and comment to reflect how to get the tarball
201
202* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 5.1.5r1144-6
203- rebuilt with new openssl
204
205* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.5r1144-5
206- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
207
208* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.5r1144-4
209- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
210
211* Fri Feb 20 2009 Tom Lane <tgl@redhat.com> 5.1.5r1144-3
212- Fix some 64-bitness issues with unixODBC 2.2.14.
213
214* Fri Feb 20 2009 Tom Lane <tgl@redhat.com> 5.1.5r1144-2
215- Rebuild for unixODBC 2.2.14.
216- Fix problem with null username/password specifications
217
218* Thu Jan 22 2009 Tom Lane <tgl@redhat.com> 5.1.5r1144-1
219- Update to mysql-connector-odbc 5.1.5r1144, to go with MySQL 5.1.x.
220  Note the library name has changed from libmyodbc3 to libmyodbc5.
221
222* Tue Aug  5 2008 Tom Lane <tgl@redhat.com> 3.51.26r1127-1
223- Update to mysql-connector-odbc 3.51.26r1127
224
225* Tue Mar 25 2008 Tom Lane <tgl@redhat.com> 3.51.24r1071-1
226- Update to mysql-connector-odbc 3.51.24r1071
227
228* Tue Feb 12 2008 Tom Lane <tgl@redhat.com> 3.51.23r998-1
229- Update to mysql-connector-odbc 3.51.23r998
230
231* Wed Dec  5 2007 Tom Lane <tgl@redhat.com> 3.51.14r248-3
232- Rebuild for new openssl
233
234* Thu Aug  2 2007 Tom Lane <tgl@redhat.com> 3.51.14r248-2
235- Update License tag to match code.
236
237* Fri Apr 20 2007 Tom Lane <tgl@redhat.com> 3.51.14r248-1
238- Update to mysql-connector-odbc 3.51.14r248
239Resolves: #236473
240- Fix build problem on multilib machines
241
242* Mon Jul 17 2006 Tom Lane <tgl@redhat.com> 3.51.12-2.2
243- rebuild
244
245* Mon Mar 27 2006 Tom Lane <tgl@redhat.com> 3.51.12-2
246- Remove DLL-unload cleanup call from connection shutdown (bz#185343)
247
248* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.51.12-1.2.1
249- bump again for double-long bug on ppc(64)
250
251* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.51.12-1.2
252- rebuilt for new gcc4.1 snapshot and glibc changes
253
254* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
255- rebuilt
256
257* Fri Nov 11 2005 Tom Lane <tgl@redhat.com> 3.51.12-1
258- New package replacing MyODBC.
Note: See TracBrowser for help on using the repository browser.