source: projects/specs/trunk/m/mutter/mutter-vl.spec @ 521

Revision 521, 3.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pkg_version 2.28.0
2%define pkg_release 1%{?_dist_release}
3
4Summary:     Window and compositing manager based on Clutter
5Name:        mutter
6Version:     %{pkg_version}
7Release:     %{pkg_release}
8Source0:     %{name}-%{version}.tar.bz2
9License:     GPLv2+
10Group:       User Interface/Desktops
11URL:         http://git.gnome.org/browse/mutter
12
13Requires(post,postun): scrollkeeper >= 0.1.4
14Requires(post,pre,preun): GConf2 >= 2.14
15BuildRequires: pkgconfig
16BuildRequires: gtk2-devel
17BuildRequires: clutter-devel
18BuildRequires: libSM-devel
19BuildRequires: GConf2-devel
20BuildRequires: gir-repository-devel
21BuildRequires: python-devel
22BuildRequires: startup-notification-devel
23BuildRequires: gnome-doc-utils
24BuildRequires: desktop-file-utils
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: Takemikaduchi
30
31
32%description
33Mutter is a minimal X window manager aimed at nontechnical users and is designed to integrate well with the GNOME desktop. Mutter lacks some features that may be expected by traditional UNIX or other technical users; these users may want to investigate other available window managers for use with GNOME or standalone.
34
35
36%package devel
37Summary:     Development files of the mutter library.
38Group:       Development/Libraries
39
40Requires: %{name} = %{version}-%{release}
41Requires: pkgconfig
42Requires: gtk-doc
43
44%description devel
45Development files of the mutter library.
46
47
48%prep
49%setup -q
50
51
52%build
53%configure --disable-static
54%{__make} %{?_smp_mflags}
55
56
57%install
58%{__rm} -rf ${RPM_BUILD_ROOT}
59%{__make} install DESTDIR=${RPM_BUILD_ROOT}
60
61%find_lang %{name}
62
63%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/*.la
64
65
66%clean
67%{__rm} -rf ${RPM_BUILD_ROOT}
68
69
70%post
71/sbin/ldconfig
72export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
73gconftool-2 --makefile-install-rule \
74    %{_sysconfdir}/gconf/schemas/mutter.schemas \
75  > /dev/null || :
76/sbin/ldconfig
77touch --no-create %{_datadir}/icons/hicolor
78if [ -x /usr/bin/gtk-update-icon-cache ]; then
79  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
80fi
81
82%pre
83if [ "$1" -gt 1 ]; then
84  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
85  gconftool-2 --makefile-uninstall-rule \
86    %{_sysconfdir}/gconf/schemas/mutter.schemas \
87    > /dev/null || :
88fi
89
90%preun
91if [ "$1" -eq 0 ]; then
92  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
93  gconftool-2 --makefile-uninstall-rule \
94    %{_sysconfdir}/gconf/schemas/mutter.schemas \
95    > /dev/null || :
96fi
97
98%postun
99scrollkeeper-update -q || :
100/sbin/ldconfig
101touch --no-create %{_datadir}/icons/hicolor
102if [ -x /usr/bin/gtk-update-icon-cache ]; then
103  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
104fi
105
106
107%files -f %{name}.lang
108%defattr(-,root,root)
109%doc COPYING ChangeLog NEWS README
110%{_bindir}/mutter
111%{_bindir}/mutter-message
112%{_libdir}/lib*.so.*
113%{_libdir}/mutter/*
114%{_datadir}/applications/*
115%{_datadir}/gnome/wm-properties/*
116%{_datadir}/mutter/*
117%{_sysconfdir}/gconf/schemas/*
118%{_mandir}/man1/mutter.1.gz
119%{_mandir}/man1/mutter-message.1.gz
120
121%files devel
122%defattr(-,root,root,-)
123%{_bindir}/mutter-theme-viewer
124%{_bindir}/mutter-window-demo
125%{_includedir}/mutter/*
126%{_libdir}/lib*.so
127%{_libdir}/pkgconfig/*
128%{_mandir}/man1/mutter-theme-viewer.1.gz
129%{_mandir}/man1/mutter-window-demo.1.gz
130
131%changelog
132* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
133- initial build for Vine Linux
134
Note: See TracBrowser for help on using the repository browser.