source: projects/specs/trunk/m/mutter/mutter-vl.spec @ 4850

Revision 4850, 4.6 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2.0

Line 
1%define pkg_version 3.2.0
2%define pkg_release 1%{?_dist_release}
3
4Summary:     Window and compositing manager based on Clutter
5Name:        mutter
6Version:     %{pkg_version}
7Release:     %{pkg_release}
8Source0:     http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.2/%{name}-%{version}.tar.xz
9
10Patch101:    mutter-vine-customize.patch
11
12License:     GPLv2+
13Group:       User Interface/Desktops
14URL:         http://git.gnome.org/browse/mutter
15
16Requires(post,postun): scrollkeeper >= 0.1.4
17Requires(post,pre,preun): GConf2 >= 2.14
18BuildRequires: pkgconfig
19BuildRequires: gtk3-devel
20BuildRequires: clutter-devel
21BuildRequires: libSM-devel
22BuildRequires: GConf2-devel
23BuildRequires: gobject-introspection-devel
24BuildRequires: python-devel
25BuildRequires: startup-notification-devel
26BuildRequires: libcanberra-gtk3-devel
27BuildRequires: gnome-doc-utils
28BuildRequires: desktop-file-utils
29BuildRequires: zenity
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: Takemikaduchi
35
36
37%description
38Mutter is a minimal X window manager aimed at nontechnical users and is designed to integrate well with the GNOME desktop. Mutter lacks some features that may be expected by traditional UNIX or other technical users; these users may want to investigate other available window managers for use with GNOME or standalone.
39
40
41%package devel
42Summary:     Development files of the mutter library.
43Group:       Development/Libraries
44
45Requires: %{name} = %{version}-%{release}
46Requires: pkgconfig
47Requires: gtk-doc
48Requires: gtk3-devel
49Requires: clutter-devel
50Requires: libX11-devel
51
52%description devel
53Development files of the mutter library.
54
55
56%prep
57%setup -q
58%patch101 -p1 -b .vine
59
60
61%build
62%configure --disable-static
63%{__make} %{?_smp_mflags}
64
65
66%install
67%{__rm} -rf ${RPM_BUILD_ROOT}
68%{__make} install DESTDIR=${RPM_BUILD_ROOT}
69
70%find_lang %{name}
71
72find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
73
74
75%clean
76%{__rm} -rf ${RPM_BUILD_ROOT}
77
78
79%post
80/sbin/ldconfig
81export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
82gconftool-2 --makefile-install-rule \
83    %{_sysconfdir}/gconf/schemas/mutter.schemas \
84  > /dev/null || :
85/sbin/ldconfig
86touch --no-create %{_datadir}/icons/hicolor
87if [ -x /usr/bin/gtk-update-icon-cache ]; then
88  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
89fi
90
91%pre
92if [ "$1" -gt 1 ]; then
93  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
94  gconftool-2 --makefile-uninstall-rule \
95    %{_sysconfdir}/gconf/schemas/mutter.schemas \
96    > /dev/null || :
97fi
98
99%preun
100if [ "$1" -eq 0 ]; then
101  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
102  gconftool-2 --makefile-uninstall-rule \
103    %{_sysconfdir}/gconf/schemas/mutter.schemas \
104    > /dev/null || :
105fi
106
107%postun
108scrollkeeper-update -q || :
109/sbin/ldconfig
110touch --no-create %{_datadir}/icons/hicolor
111if [ -x /usr/bin/gtk-update-icon-cache ]; then
112  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
113fi
114
115
116%files -f %{name}.lang
117%defattr(-,root,root)
118%doc COPYING ChangeLog NEWS README
119%{_bindir}/mutter
120%{_bindir}/mutter-message
121%{_libdir}/lib*.so.*
122%{_libdir}/mutter/*
123%{_datadir}/applications/*
124%{_datadir}/gnome/wm-properties/*
125%{_datadir}/mutter/*
126%{_sysconfdir}/gconf/schemas/*
127%{_mandir}/man1/mutter.1.gz
128%{_mandir}/man1/mutter-message.1.gz
129
130%files devel
131%defattr(-,root,root,-)
132%{_bindir}/mutter-theme-viewer
133%{_bindir}/mutter-window-demo
134%{_includedir}/mutter/*
135%{_libdir}/lib*.so
136%{_libdir}/pkgconfig/*
137%{_mandir}/man1/mutter-theme-viewer.1.gz
138%{_mandir}/man1/mutter-window-demo.1.gz
139
140%changelog
141* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
142- new upstream release
143
144* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
145- new upstream release
146
147* Sun Sep 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.91.1-1
148- new upstream release
149- add Requires: gtk3-devel, libX11-devel (-devel package)
150
151* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
152- new upstream release
153- add BuildRequires: zenity
154
155* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
156- new upstream release
157- change BuildRequires: gobject-introspection-devel instead of gir-repository-devel
158- change BuildRequires: gtk3-devel instead of gtk2-devel
159- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
160- add Patch101 (mutter-vine-customize.patch)
161
162* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
163- rebuild with rpm-4.8.1 for pkg-config file
164
165* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
166- new upstream release
167- add BuildRequires: libcanberra-devel
168- Requires: clutter-devel (devel package)
169
170* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
171- initial build for Vine Linux
172
Note: See TracBrowser for help on using the repository browser.