source: projects/specs/trunk/m/munin/munin-vl.spec @ 5977

Revision 5977, 20.1 KB checked in by yasumichi, 12 years ago (diff)

first import

Line 
1Name:      munin
2Version:   1.4.6
3Release:   1%{?_dist_release}
4Summary:   Network-wide graphing framework (grapher/gatherer)
5License:   GPLv2 and Bitstream Vera
6Group:     System Environment/Daemons
7URL:       http://munin.projects.linpro.no/
8
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
10
11Source0: http://downloads.sourceforge.net/sourceforge/munin/%{name}-%{version}.tar.gz
12Source10: http://downloads.sourceforge.net/sourceforge/munin/%{name}-%{version}.tar.gz.sha256sum
13
14Patch1: munin-1.4.6-restorecon.patch
15Patch2: munin-1.4.2-fontfix.patch
16
17Source1: munin-1.2.4-sendmail-config
18Source2: munin-1.2.5-hddtemp_smartctl-config
19Source3: munin-node.logrotate
20Source4: munin.logrotate
21Source6: munin-1.2.6-postfix-config
22Source7: munin-1.4.5-df-config
23Source8: munin-node.service
24Source9: %{name}.conf
25
26BuildArchitectures: noarch
27
28BuildRequires: perl-Module-Build
29# needed for hostname for the defaut config
30BuildRequires: net-tools
31BuildRequires: perl-HTML-Template
32BuildRequires: perl-Log-Log4perl
33BuildRequires: perl-Net-Server
34BuildRequires: perl-Net_SSLeay
35BuildRequires: perl-Net-SNMP
36
37# java buildrequires on fedora
38%if 0%{?rhel} > 4 || 0%{?fedora} > 6
39BuildRequires: java-1.7.0-devel
40BuildRequires: mx4j
41BuildRequires: jpackage-utils
42%endif
43
44%if 0%{?rhel} > 6 || 0%{?fedora} > 15
45BuildRequires: systemd-units
46%endif
47
48Requires: %{name}-common = %{version}
49Requires: perl-Net-Server
50Requires: perl-Net-SNMP
51Requires: rrdtool
52Requires: logrotate
53Requires: /bin/mail
54Requires(pre): shadow-utils
55Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
56%if 0%{?rhel} > 5 || 0%{?fedora} > 6
57Requires: dejavu-sans-mono-fonts
58%else
59Requires: bitstream-vera-fonts
60%endif
61
62%description
63Munin is a highly flexible and powerful solution used to create graphs of
64virtually everything imaginable throughout your network, while still
65maintaining a rattling ease of installation and configuration.
66
67This package contains the grapher/gatherer. You will only need one instance of
68it in your network. It will periodically poll all the nodes in your network
69it's aware of for data, which it in turn will use to create graphs and HTML
70pages, suitable for viewing with your graphical web browser of choice.
71
72Munin is written in Perl, and relies heavily on Tobi Oetiker's excellent
73RRDtool.
74
75%package node
76Group: System Environment/Daemons
77Summary: Network-wide graphing framework (node)
78BuildArchitectures: noarch
79Requires: %{name}-common = %{version}
80Requires: perl-Net-Server
81Requires: procps >= 2.0.7
82#Requires: sysstat, /usr/bin/which, hdparm
83Requires: /usr/bin/which, hdparm
84Requires(pre): shadow-utils
85Requires(post): /sbin/chkconfig
86Requires(preun): /sbin/chkconfig
87Requires(preun): /sbin/service
88Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
89
90%description node
91Munin is a highly flexible and powerful solution used to create graphs of
92virtually everything imaginable throughout your network, while still
93maintaining a rattling ease of installation and configuration.
94
95This package contains node software. You should install it on all the nodes
96in your network. It will know how to extract all sorts of data from the
97node it runs on, and will wait for the gatherer to request this data for
98further processing.
99
100It includes a range of plugins capable of extracting common values such as
101cpu usage, network usage, load average, and so on. Creating your own plugins
102which are capable of extracting other system-specific values is very easy,
103and is often done in a matter of minutes. You can also create plugins which
104relay information from other devices in your network that can't run Munin,
105such as a switch or a server running another operating system, by using
106SNMP or similar technology.
107
108Munin is written in Perl, and relies heavily on Tobi Oetiker's excellent
109RRDtool.
110
111%package common
112Group: System Environment/Daemons
113Summary: Network-wide graphing framework (common files)
114BuildArchitectures: noarch
115Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
116
117%description common
118Munin is a highly flexible and powerful solution used to create graphs of
119virtually everything imaginable throughout your network, while still
120maintaining a rattling ease of installation and configuration.
121
122This package contains common files that are used by both the server (munin)
123and node (munin-node) packages.
124
125%if 0%{?rhel} > 4 || 0%{?fedora} > 6
126%package java-plugins
127Group: System Environment/Daemons
128Summary: java-plugins for munin
129Requires: %{name}-node = %{version}
130BuildArchitectures: noarch
131
132%description java-plugins
133java-plugins for munin-node.
134%endif
135
136%prep
137%setup -q
138%patch1 -p1
139
140%if 0%{?rhel} < 6 && 0%{?fedora} < 11
141%patch2 -p0
142%endif
143
144%build
145%if 0%{?rhel} > 4 || 0%{?fedora} > 6
146export  CLASSPATH=plugins/javalib/org/munin/plugin/jmx:$(build-classpath mx4j):$CLASSPATH
147%endif
148make    CONFIG=dists/redhat/Makefile.config
149
150%install
151
152## Node
153make    CONFIG=dists/redhat/Makefile.config \
154%if 0%{?rhel} > 4 || 0%{?fedora} > 6
155        JAVALIBDIR=%{buildroot}%{_datadir}/java \
156%endif
157        PREFIX=%{buildroot}%{_prefix} \
158        DOCDIR=%{buildroot}%{_docdir}/%{name}-%{version} \
159        MANDIR=%{buildroot}%{_mandir} \
160        DESTDIR=%{buildroot} \
161        install
162
163mkdir -p %{buildroot}/etc/munin/plugins
164mkdir -p %{buildroot}/etc/munin/node.d
165mkdir -p %{buildroot}/etc/munin/plugin-conf.d
166mkdir -p %{buildroot}/etc/munin/conf.d
167mkdir -p %{buildroot}/etc/logrotate.d
168mkdir -p %{buildroot}/var/lib/munin
169mkdir -p %{buildroot}/var/log/munin
170
171# Fix default config file
172sed -i 's,/etc/munin/munin-conf.d,/etc/munin/conf.d,' %{buildroot}/etc/munin/munin.conf
173
174#
175# don't enable munin-node by default.
176#
177%if 0%{?rhel} > 6 || 0%{?fedora} > 15
178mkdir -p %{buildroot}/lib/systemd/system/
179install -m 0644 %{SOURCE8} %{buildroot}/lib/systemd/system/munin-node.service
180%else
181mkdir -p %{buildroot}/etc/rc.d/init.d
182cat dists/redhat/munin-node.rc | sed -e 's/2345/\-/' > %{buildroot}/etc/rc.d/init.d/munin-node
183chmod 755 %{buildroot}/etc/rc.d/init.d/munin-node
184%endif
185
186%if 0%{?rhel} > 6 || 0%{?fedora} > 14
187mkdir -p %{buildroot}%{_sysconfdir}/tmpfiles.d
188install -m 0644 %{SOURCE9} %{buildroot}%{_sysconfdir}/tmpfiles.d/%{name}.conf
189%endif
190
191install -m0644 dists/tarball/plugins.conf %{buildroot}/etc/munin/plugin-conf.d/munin-node
192
193#
194# remove the Sybase plugin for now, as they need perl modules
195# that are not in extras. We can readd them when/if those modules are added.
196#
197rm -f %{buildroot}/usr/share/munin/plugins/sybase_space
198
199## Server
200
201mkdir -p %{buildroot}/var/www/html/munin
202mkdir -p %{buildroot}/var/log/munin
203mkdir -p %{buildroot}/etc/cron.d
204mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}
205
206install -m 0644 dists/redhat/munin.cron.d %{buildroot}/etc/cron.d/munin
207cp -a master/www/* %{buildroot}/var/www/html/munin/
208
209# install config for sendmail under fedora
210install -m 0644 %{SOURCE1} %{buildroot}/etc/munin/plugin-conf.d/sendmail
211# install config for hddtemp_smartctl
212install -m 0644 %{SOURCE2} %{buildroot}/etc/munin/plugin-conf.d/hddtemp_smartctl
213# install logrotate scripts
214install -m 0644 %{SOURCE3} %{buildroot}/etc/logrotate.d/munin-node
215install -m 0644 %{SOURCE4} %{buildroot}/etc/logrotate.d/munin
216# install config for postfix under fedora
217install -m 0644 %{SOURCE6} %{buildroot}/etc/munin/plugin-conf.d/postfix
218# install df config to exclude fses we shouldn't try and monitor
219install -m 0644 %{SOURCE7} %{buildroot}/etc/munin/plugin-conf.d/df
220# Create for BZ 786030
221touch %{buildroot}/var/lib/munin/plugin-state/yum.state
222
223# Use system font
224rm -f $RPM_BUILD_ROOT/%{_datadir}/munin/DejaVuSansMono.ttf
225rm -f $RPM_BUILD_ROOT/%{_datadir}/munin/DejaVuSans.ttf
226
227%clean
228rm -rf $RPM_BUILD_ROOT
229
230#
231# node package scripts
232#
233%pre node
234getent group munin >/dev/null || groupadd -r munin
235getent passwd munin >/dev/null || \
236useradd -r -g munin -d /var/lib/munin -s /sbin/nologin \
237    -c "Munin user" munin
238exit 0
239
240%post node
241/sbin/chkconfig --add munin-node
242# Only run configure on a new install, not an upgrade.
243if [ "$1" = "1" ]; then
244     /usr/sbin/munin-node-configure --shell 2> /dev/null | sh >& /dev/null || :
245fi
246
247%preun node
248%if 0%{?rhel} > 6 || 0%{?fedora} > 15
249test "$1" != 0 || %{_bindir}/systemctl disable munin-node.service || :
250%else
251test "$1" != 0 || %{_initrddir}/munin-node stop &>/dev/null || :
252test "$1" != 0 || /sbin/chkconfig --del munin-node
253%endif
254
255%postun node
256find /etc/munin/plugins/ -maxdepth 1 -type l -print0 |xargs -0 rm
257
258#
259# main package scripts
260#
261%pre
262getent group munin >/dev/null || groupadd -r munin
263getent passwd munin >/dev/null || \
264useradd -r -g munin -d /var/lib/munin -s /sbin/nologin \
265    -c "Munin user" munin
266exit 0
267
268%files
269%defattr(-, root, root)
270%doc %{_docdir}/%{name}-%{version}/
271%{_bindir}/munin-cron
272%{_bindir}/munindoc
273%{_bindir}/munin-check
274%dir %{_datadir}/munin
275%{_datadir}/munin/munin-graph
276%{_datadir}/munin/munin-html
277%{_datadir}/munin/munin-limits
278%{_datadir}/munin/munin-update
279%{perl_vendorlib}/Munin/Master
280%dir /etc/munin/templates
281%dir /etc/munin
282%dir /etc/munin/conf.d
283%config(noreplace) /etc/munin/templates/*
284%config(noreplace) /etc/cron.d/munin
285%config(noreplace) /etc/munin/munin.conf
286%config(noreplace) /etc/logrotate.d/munin
287%attr(-, munin, munin) %dir /var/lib/munin
288%attr(-, munin, munin) %dir /var/lib/munin/plugin-state
289%attr(-, munin, munin) %dir /var/run/munin
290%attr(-, munin, munin) %dir /var/log/munin
291%attr(-, munin, munin) /var/www/html/munin
292%doc %{_mandir}/man8/munin*
293%doc %{_mandir}/man5/munin.conf*
294
295%files node
296%defattr(-, root, root)
297%config(noreplace) /etc/munin/munin-node.conf
298%dir /etc/munin/plugin-conf.d
299%dir /etc/munin/node.d
300%config(noreplace) /etc/munin/plugin-conf.d/munin-node
301%config(noreplace) /etc/munin/plugin-conf.d/sendmail
302%config(noreplace) /etc/munin/plugin-conf.d/hddtemp_smartctl
303%config(noreplace) /etc/munin/plugin-conf.d/postfix
304%config(noreplace) /etc/munin/plugin-conf.d/df
305%config(noreplace) /etc/logrotate.d/munin-node
306%if 0%{?rhel} > 6 || 0%{?fedora} > 15
307/lib/systemd/system/munin-node.service
308%else
309/etc/rc.d/init.d/munin-node
310%endif
311%{_sbindir}/munin-run
312%{_sbindir}/munin-node
313%{_sbindir}/munin-node-configure
314%attr(-, munin, munin) %dir /var/log/munin
315%dir %{_datadir}/munin
316%dir /etc/munin/plugins
317%dir /etc/munin
318%attr(-, munin, munin) %dir /var/lib/munin
319%dir %attr(-, munin, munin) /var/lib/munin/plugin-state
320%attr(-, munin, munin) /var/lib/munin/plugin-state/yum.state
321%if 0%{?rhel} > 4 || 0%{?fedora} > 6
322%exclude %{_datadir}/munin/plugins/jmx_
323%endif
324%{_datadir}/munin/plugins/
325%doc %{_docdir}/%{name}-%{version}/
326%doc %{_mandir}/man5/munin-node*
327%doc %{_mandir}/man3/Munin*
328%doc %{_mandir}/man1/munin*
329%{perl_vendorlib}/Munin/Node
330%{perl_vendorlib}/Munin/Plugin*
331
332%files common
333%defattr(-, root, root)
334%doc Announce-1.4.0 ChangeLog COPYING HACKING.pod perltidyrc README RELEASE UPGRADING
335%dir %{perl_vendorlib}/Munin
336%{perl_vendorlib}/Munin/Common
337
338%if 0%{?rhel} > 6 || 0%{?fedora} > 14
339%dir %{_localstatedir}/run/%{name}/
340%config(noreplace) %{_sysconfdir}/tmpfiles.d/%{name}.conf
341%endif
342
343%if 0%{?rhel} > 4 || 0%{?fedora} > 6
344%files java-plugins
345%defattr(-, root, root)
346%{_datadir}/java/%{name}-jmx-plugins.jar
347%{_datadir}/munin/plugins/jmx_
348%endif
349
350
351%changelog
352* Thu Mar 22 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.4.6-1
353- Initial build for Vine Linux.
354
355* Wed Feb 22 2012 Kevin Fenzi <kevin@scrye.com> 1.4.6-8
356- Build against java-1.7.0 now. Fixes bug #796345
357
358* Tue Jan 31 2012 D. Johnson <fenris02@fedoraproject.org> - 1.4.6-7
359- Create state file for yum-plugin. Fixes BZ #786030.
360
361* Fri Jan 20 2012 Kevin Fenzi <kevin@scrye.com> - 1.4.6-6
362- Add PrivateTmp=true to systemd unit file. Fixes bug #782512
363- Change logrotate to use munin user. Fixes bug #771017
364
365* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.6-5.3
366- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
367
368* Mon Oct 17 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.4.6-4.3
369- Rebuild for java 1.6.0 downgrade (fesco ticket 663)
370
371* Sat Aug 27 2011 Kevin Fenzi <kevin@scrye.com> - 1.4.6-4.1
372- Add patch to run restorecon in the sysvinit script.
373- This doesn't matter on f16+
374
375* Sat Aug 20 2011 D. Johnson <fenris02@fedoraproject.org> - 1.4.6-4
376- fix tmpfiles.d file for f15 (BZ# 731181)
377
378* Thu Jul 21 2011 Petr Sabata <contyk@redhat.com> - 1.4.6-3
379- Perl mass rebuild
380
381* Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 1.4.6-2
382- Perl mass rebuild
383
384* Wed Jul  8 2011 D. Johnson <fenris02@fedoraproject.org> - 1.4.6-1
385- update to 1.4.6
386
387* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-13
388- Perl mass rebuild
389
390* Wed Jun 15 2011 D. Johnson <fenris02@fedoraproject.org> - 1.4.5-12
391- Use tmpfiles.d instead of ExecStartPre
392- Add patch for noSuchObject errors (BZ# 712245)
393
394* Fri Jun 10 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-11
395- Perl 5.14 mass rebuild
396
397* Wed Jun  1 2011 D. Johnson <fenris02@fedoraproject.org> - 1.4.5-10
398- Fixes http://munin-monitoring.org/ticket/887
399
400* Mon May 30 2011 D. Johnson <fenris02@fedoraproject.org> - 1.4.5-9
401- Native systemd service file for munin-node (BZ# 699275)
402
403* Tue Feb 08 2011 Kevin Fenzi <kevin@tummy.com> - 1.4.5-8
404- Fix issue with uppercase node names returning no data. Fixes #673263
405
406* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.5-7
407- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
408
409* Sun Dec 05 2010 Kevin Fenzi <kevin@tummy.com> - 1.4.5-6
410- Adjust the df fix to include all the right fses
411
412* Thu Nov 25 2010 Kevin Fenzi <kevin@tummy.com> - 1.4.5-5
413- Exclude some fses from df plugin. fixes #601410
414
415* Wed Aug 11 2010 Todd Zullinger <tmz@pobox.com> - 1.4.5-4.1
416- Move jmx_ plugin to java-plugins package
417
418* Wed Jul 07 2010 Kevin Fenzi <kevin@tummy.com> - 1.4.5-4
419- Move docs to common subpackage to make sure COPYING is installed.
420
421* Sat Jul 03 2010 Kevin Fenzi <kevin@tummy.com> - 1.4.5-3
422- Add /etc/munin/node.d dir
423
424* Sat Jun 12 2010 Kevin Fenzi <kevin@tummy.com> - 1.4.5-2
425- Add /etc/munin/conf.d/ dir
426
427* Sat Jun 05 2010 Kevin Fenzi <kevin@tummy.com> - 1.4.5-1
428- Update to 1.4.5
429
430* Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.4.4-2
431- Mass rebuild with perl-5.12.0
432
433* Mon Mar 01 2010 Kevin Fenzi <kevin@tummy.com> - 1.4.4-1
434- Update to 1.4.4
435- Add more doc files. Fixes bug #563824
436- fw_forwarded_local fixed upstream in 1.4.4. Fixes bug #568500
437
438* Sun Jan 17 2010 Kevin Fenzi <kevin@tummy.com> - 1.4.3-2
439- Fix owner on state files.
440- Add some BuildRequires.
441- Make munin-node-configure only run on install, not upgrade. bug 540687
442
443* Thu Dec 31 2009 Kevin Fenzi <kevin@tummy.com> - 1.4.3-1
444- Update to 1.4.3
445
446* Thu Dec 17 2009 Ingvar Hagelund <ingvar@linpro.no> - 1.4.2-1
447- New upstream release
448- Removed upstream packaged fonts
449- Added a patch that makes rrdtool use the system bitstream vera fonts on
450  rhel < 6 and fedora < 11
451
452* Fri Dec 11 2009 Ingvar Hagelund <ingvar@linpro.no> - 1.4.1-3
453- More correct fedora and el versions for previous font path fix
454- Added a patch that fixes a quoting bug in GraphOld.pm, fixing fonts on el4
455
456* Wed Dec 09 2009 Ingvar Hagelund <ingvar@linpro.no> - 1.4.1-2
457- Remove jmx plugins when not supported (like on el4 and older fedora)
458- Correct font path on older distros like el5, el4 and fedora<11
459
460* Fri Dec 04 2009 Kevin Fenzi <kevin@tummy.com> - 1.4.1-1
461- Update to 1.4.1
462
463* Sat Nov 28 2009 Kevin Fenzi <kevin@tummy.com> - 1.4.0-1
464- Update to final 1.4.0 version
465
466* Sat Nov 21 2009 Kevin Fenzi <kevin@tummy.com> - 1.4.0-0.1.beta
467- Update to beta 1.4.0 version.
468- Add common subpackage for common files.
469
470* Sun Nov 08 2009 Kevin Fenzi <kevin@tummy.com> - 1.4.0-0.1.alpha
471- Initial alpha version of 1.4.0
472
473* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.6-10
474- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
475
476* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.6-9
477- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
478
479* Sat Jan 24 2009 Andreas Thienemann <andreas@bawue.net> - 1.2.6-8
480- Updated dependencies to better reflect plugin requirements
481- Added hddtemp_smartctl patch to only scan for standby state on /dev/[sh]d? devices.
482
483* Sat Jan 17 2009 Kevin Fenzi <kevin@tummy.com> - 1.2.6-7
484- Adjust font requires for new dejavu-sans-mono-fonts name (fixes #480463)
485
486* Mon Jan 12 2009 Kevin Fenzi <kevin@tummy.com> - 1.2.6-6
487- Fix to require the correct font
488
489* Sun Jan 11 2009 Kevin Fenzi <kevin@tummy.com> - 1.2.6-5
490- Switch to using dejavu-fonts instead of bitstream-vera
491
492* Sun Jan 04 2009 Kevin Fenzi <kevin@tummy.com> - 1.2.6-4
493- Require bitstream-vera-fonts-sans-mono for Font (fixes #477428)
494
495* Mon Aug 11 2008 Kevin Fenzi <kevin@tummy.com> - 1.2.6-3
496- Move Munin/Plugin.pm to the node subpackage (fixes #457403)
497
498* Sat Jul 12 2008 Kevin Fenzi <kevin@tummy.com> - 1.2.6-2
499- Apply postfix patch (fixes #454159)
500- Add perl version dep and remove unneeded perl-HTML-Template (fixes #453923)
501
502* Fri Jun 20 2008 Kevin Fenzi <kevin@tummy.com> - 1.2.6-1
503- Upgrade to 1.2.6
504
505* Tue May 20 2008 Kevin Fenzi <kevin@tummy.com> - 1.2.5-5
506- Rebuild for new perl
507
508* Wed Dec 26 2007 Kevin Fenzi <kevin@tummy.com> - 1.2.5-4
509- Add patch to fix ampersand and degrees in plugins (fixes #376441)
510
511* Fri Nov 30 2007 Kevin Fenzi <kevin@tummy.com> - 1.2.5-3
512- Removed unnneeded plugins.conf file (fixes #288541)
513- Fix license tag.
514- Fix ip_conntrack monitoring (fixes #253192)
515- Switch to new useradd guidelines.
516
517* Tue Mar 27 2007 Kevin Fenzi <kevin@tummy.com> - 1.2.5-2
518- Fix directory ownership (fixes #233886)
519
520* Tue Oct 17 2006 Kevin Fenzi <kevin@tummy.com> - 1.2.5-1
521- Update to 1.2.5
522- Fix HD stats (fixes #205042)
523- Add in logrotate scripts that seem to have been dropped upstream
524
525* Sun Aug 27 2006 Kevin Fenzi <kevin@tummy.com> - 1.2.4-10
526- Rebuild for fc6
527
528* Tue Jun 27 2006 Kevin Fenzi <kevin@tummy.com> - 1.2.4-9
529- Re-enable snmp plugins now that perl-Net-SNMP is available (fixes 196588)
530- Thanks to Herbert Straub <herbert@linuxhacker.at> for patch.
531- Fix sendmail plugins to look in the right place for the queue
532
533* Sat Apr 22 2006 Kevin Fenzi <kevin@tummy.com> - 1.2.4-8
534- add patch to remove unneeded munin-nagios in cron.
535- add patch to remove buildhostname in munin.conf (fixes #188928)
536- clean up prep section of spec.
537
538* Fri Feb 24 2006 Kevin Fenzi <kevin@scrye.com> - 1.2.4-7
539- Remove bogus Provides for perl RRDs (fixes #182702)
540
541* Thu Feb 16 2006 Kevin Fenzi <kevin@tummy.com> - 1.2.4-6
542- Readded old changelog entries per request
543- Rebuilt for fc5
544
545* Sat Dec 24 2005 Kevin Fenzi <kevin@tummy.com> - 1.2.4-5
546- Fixed ownership for /var/log/munin in node subpackage (fixes 176529)
547
548* Wed Dec 14 2005 Kevin Fenzi <kevin@tummy.com> - 1.2.4-4
549- Fixed ownership for /var/lib/munin in node subpackage
550
551* Wed Dec 14 2005 Kevin Fenzi <kevin@tummy.com> - 1.2.4-3
552- Fixed libdir messup to allow builds on x86_64
553
554* Mon Dec 12 2005 Kevin Fenzi <kevin@tummy.com> - 1.2.4-2
555- Removed plugins that require Net-SNMP and Sybase
556
557* Tue Dec  6 2005 Kevin Fenzi <kevin@tummy.com> - 1.2.4-1
558- Inital cleanup for fedora-extras
559
560* Thu Apr 21 2005 Ingvar Hagelund <ingvar@linpro.no> - 1.2.3-4
561- Fixed a bug in the iostat plugin
562
563* Wed Apr 20 2005 Ingvar Hagelund <ingvar@linpro.no> - 1.2.3-3
564- Added the missing /var/run/munin
565
566* Tue Apr 19 2005 Ingvar Hagelund <ingvar@linpro.no> - 1.2.3-2
567- Removed a lot of unecessary perl dependencies
568
569* Mon Apr 18 2005 Ingvar Hagelund <ingvar@linpro.no> - 1.2.3-1
570- Sync with svn
571
572* Tue Mar 22 2005 Ingvar Hagelund <ingvar@linpro.no> - 1.2.2-5
573- Sync with release of 1.2.2
574- Add some nice text from the suse specfile
575- Minimal changes in the header
576- Some cosmetic changes
577- Added logrotate scripts (stolen from debian package)
578
579* Sun Feb 01 2004 Ingvar Hagelund <ingvar@linpro.no>
580- Sync with CVS. Version 1.0.0pre2
581
582* Sun Jan 18 2004 Ingvar Hagelund <ingvar@linpro.no>
583- Sync with CVS. Change names to munin.
584
585* Fri Oct 31 2003 Ingvar Hagelund <ingvar@linpro.no>
586- Lot of small fixes. Now builds on more RPM distros
587
588* Wed May 21 2003 Ingvar Hagelund <ingvar@linpro.no>
589- Sync with CVS
590- 0.9.5-1
591
592* Tue Apr  1 2003 Ingvar Hagelund <ingvar@linpro.no>
593- Sync with CVS
594- Makefile-based install of core files
595- Build doc (only pod2man)
596
597* Thu Jan  9 2003 Ingvar Hagelund <ingvar@linpro.no>
598- Sync with CVS, auto rpmbuild
599
600* Thu Jan  2 2003 Ingvar Hagelund <ingvar@linpro.no>
601- Fix spec file for RedHat 8.0 and new version of lrrd
602
603* Wed Sep  4 2002 Ingvar Hagelund <ingvar@linpro.no>
604- Small bugfixes in the rpm package
605
606* Tue Jun 18 2002 Kjetil Torgrim Homme <kjetilho@linpro.no>
607- new package
Note: See TracBrowser for help on using the repository browser.