source: projects/specs/trunk/m/msgpack/msgpack-vl.spec @ 11090

Revision 11090, 2.5 KB checked in by iwaim, 7 years ago (diff)

msgpack 2.1.1-1

Line 
1%define ver 2.1.1
2%define rel 1
3
4Name:           msgpack
5Version:        %{ver}
6Release:        %{rel}%{?_dist_release}
7Summary:        Binary-based efficient object serialization library
8Group:          System Environment/Libraries
9
10License:        Boost Software License 1.0
11URL:            http://msgpack.org
12Source0:        http://msgpack.org/releases/cpp/%{name}-%{version}.tar.gz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires:  cmake >= 2.8.6
16BuildRequires:  zlib-devel
17BuildRequires:  libboost-devel
18# for %%check
19BuildRequires:  gtest-devel
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: iwaim
24
25%description
26MessagePack is a binary-based efficient object serialization
27library. It enables to exchange structured objects between many
28languages like JSON. But unlike JSON, it is very fast and small.
29
30
31%package devel
32Summary:        Libraries and header files for %{name}
33Group:          Development/Libraries
34Requires:       %{name} = %{version}-%{release}
35
36%description devel
37Libraries and header files for %{name}
38
39
40%prep
41%setup -q
42
43
44%build
45%__cmake \
46        -DCMAKE_VERBOSE_MAKEFILE=ON \
47        -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
48        -DCMAKE_INSTALL_LIBDIR:PATH=%{_libdir} \
49        -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
50        -DLIB_INSTALL_DIR:PATH=%{_libdir} \
51        -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
52        -DSHARE_INSTALL_PREFIX:PATH=%{_datadir} \
53        -DMSGPACK_BOOST=ON \
54        -DBoost_USE_STATIC_LIBS=OFF \
55.
56make %{?_smp_mflags}
57
58
59%check
60make test
61
62
63%install
64make install DESTDIR=$RPM_BUILD_ROOT
65find $RPM_BUILD_ROOT -name '*.la' -exec rm -f '{}' ';'
66
67
68%post -p /sbin/ldconfig
69
70%postun -p /sbin/ldconfig
71
72
73%files
74%doc AUTHORS COPYING ChangeLog LICENSE* NOTICE README README.md
75%{_libdir}/*.so.*
76
77%files devel
78%{_includedir}/*
79%{_libdir}/*.so
80%{_libdir}/pkgconfig/msgpack.pc
81
82
83%changelog
84* Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.2.1-1
85- update to 2.2.1
86- update License tag
87- update BuildRequires
88 - using cmake
89 - using libboost
90
91* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 0.5.8-2
92- rebuild with gcc-5.4.0
93
94* Tue Dec 31 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.5.8-1
95- update to 0.5.8
96- drop gtest patch: upstream fixed
97- add pkgconfig file in msgpack-devel package
98
99* Fri Feb  1 2013 IWAI, Masaharu <iwai@alib.jp> 0.5.7-1
100- initial build for Vine Linux
101
102* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.7-2
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
104
105* Wed Feb 15 2012 Daiki Ueno <dueno@redhat.com> - 0.5.7-1
106- initial packaging for Fedora
107
Note: See TracBrowser for help on using the repository browser.