source: projects/specs/trunk/m/mpfr/mpfr-vl.spec @ 521

Revision 521, 2.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A C library for multiple-precision floating-point computations
2Name: mpfr
3Version: 2.4.1
4Release: 1%{?_dist_release}
5URL: http://www.mpfr.org/
6Source0: http://www.mpfr.org/mpfr-current/mpfr-%{version}.tar.bz2
7#Patch0: mpfr-2.3.0-upstream.patch
8License: LGPLv2+ and GPLv2+ and GFDL
9Group: System Environment/Libraries
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildRequires: gmp-devel
12Requires: gmp >= 4.2.1
13
14%description
15The MPFR library is a C library for multiple-precision floating-point
16computations with "correct rounding". The MPFR is efficient and
17also has a well-defined semantics. It copies the good ideas from the
18ANSI/IEEE-754 standard for double-precision floating-point arithmetic
19(53-bit mantissa). MPFR is based on the GMP multiple-precision library.
20
21%package devel
22Summary: Development tools A C library for mpfr library
23Group: Development/Libraries
24Requires: %{name} = %{version}-%{release}
25Requires(post): /sbin/install-info
26Requires(preun): /sbin/install-info
27
28%description devel
29The static libraries, header files and documentation for using the MPFR
30multiple-precision floating-point library in applications.
31
32If you want to develop applications which will use the MPFR library,
33you'll need to install the mpfr-devel package.  You'll also need to
34install the mpfr package.
35
36%prep
37%setup -q
38#patch0 -p1 -b .up
39
40%build
41
42%configure --disable-assert
43make %{?_smp_mflags}
44
45%install
46rm -rf $RPM_BUILD_ROOT
47make install DESTDIR=$RPM_BUILD_ROOT
48pushd $RPM_BUILD_ROOT%{_infodir}
49#iconv  -f iso-8859-1 -t utf-8 mpfr.info >mpfr.info.aux
50iconv  -f iso-8859-1 -t euc-jp mpfr.info >mpfr.info.aux
51mv mpfr.info.aux mpfr.info
52popd
53rm -f $RPM_BUILD_ROOT%{_libdir}/libmpfr.la
54rm -f $RPM_BUILD_ROOT%{_infodir}/dir
55rm -f $RPM_BUILD_ROOT%{_libdir}/libmpfr.a
56cd ..
57
58
59%check
60make %{?_smp_mflags} check
61
62%post -p /sbin/ldconfig
63
64%postun -p /sbin/ldconfig
65
66%post devel
67/sbin/install-info %{_infodir}/mpfr.info.gz %{_infodir}/dir || :
68
69%preun devel
70if [ "$1" = 0 ]; then
71   /sbin/install-info --delete %{_infodir}/mpfr.info.gz %{_infodir}/dir || :
72fi
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%files
78%defattr(-,root,root,-)
79%doc COPYING COPYING.LIB NEWS README
80%{_libdir}/libmpfr.so.*
81
82%files devel
83%defattr(-,root,root,-)
84%{_libdir}/libmpfr.so
85%{_includedir}/*.h
86%{_infodir}/mpfr.info*
87
88%changelog
89* Sat Nov 28 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-1
90- new upstream release
91
92* Mon May 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3.1-1
93- new upstream release
94- applied new versioning policy
95
96* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3.0-1vl1
97- initial build for Vine Linux
98
99* Thu Sep 20 2007 Ivana Varekova <varekova@redhat.com> 2.3.0-1
100- update to 2.3.0
101- fix license flag
102
103* Mon Aug 20 2007 Ivana Varekova <varekova@redhat.com> 2.2.1-2
104- spec file cleanup (#253440)
105
106* Mon Jan 16 2007 Ivana Varekova <varekova@redhat.com> 2.2.1-1
107- started
108
Note: See TracBrowser for help on using the repository browser.