source: projects/specs/trunk/m/mozplugger/mozplugger-vl.spec @ 521

Revision 521, 10.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _mozillapath    %{_libdir}/mozilla/plugins
2%define vine31 0
3
4Summary: A generic mozilla plug-in
5Summary: ÈÆÍÑ mozilla ¥×¥é¥°¥¤¥ó
6Name: mozplugger
7Version: 1.7.3
8Release: 0vl2
9License: GPL
10Group: Applications/Internet
11URL:   http://mozplugger.mozdev.org
12
13Source0: http://mozplugger.mozdev.org/files/mozplugger-%{version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: XOrg-devel
17Requires:  sox
18Requires:  ImageMagick
19Requires:  gqview
20Requires:  perl
21#Requires:  TiMidity++
22%if !%{vine31}
23Requires:  totem
24%endif
25Obsoletes: plugger
26Provides:  plugger
27
28%description
29MozPlugger is a generic Mozilla plug-in that allows the use of standard Linux
30programs as plug-ins for media types on the Internet.
31
32%prep
33%setup -q -n %{name}-%{version}
34
35%build
36make RPM_OPT_FLAGS="$RPM_OPT_FLAGS" XLIBDIR="/usr/X11R6/%{_lib}" linux
37
38%install
39rm -rf $RPM_BUILD_ROOT
40mkdir -p $RPM_BUILD_ROOT%{_mozillapath}/plugins \
41        $RPM_BUILD_ROOT%{_libdir}/netscape/plugins \
42        $RPM_BUILD_ROOT%{_bindir} \
43        $RPM_BUILD_ROOT%{_sysconfdir} \
44        $RPM_BUILD_ROOT%{_mandir}/man7
45
46install -m 755 mozplugger-helper $RPM_BUILD_ROOT%{_bindir}
47install -m 755 mozplugger-controller $RPM_BUILD_ROOT%{_bindir}
48install -m 755 mozplugger.so $RPM_BUILD_ROOT%{_mozillapath}
49install -m 644 mozpluggerrc $RPM_BUILD_ROOT%{_sysconfdir}/mozpluggerrc
50bzip2 -d mozplugger.7.bz2
51install -m 644 mozplugger.7 $RPM_BUILD_ROOT%{_mandir}/man7
52
53mkdir -p $RPM_BUILD_ROOT%{_mozillapath}
54ln -s %{_mozillapath}/mozplugger.so \
55         $RPM_BUILD_ROOT%{_libdir}/netscape/plugins/mozplugger.so
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60
61%triggerin -- acroread-nppdf
62[ "$2" -ge 1 ] || exit 0
63if [ -r %{_sysconfdir}/mozpluggerrc ]; then
64        perl -pi -e 's@^application/pdf:@\#application/pdf:@g' %{_sysconfdir}/mozpluggerrc
65        perl -pi -e 's@^application/x-pdf:@\#application/x-pdf:@g' %{_sysconfdir}/mozpluggerrc
66        touch %{_mozillapath}/mozplugger.so
67fi
68
69%triggerun -- acroread-nppdf
70[ "$2" = "0" ] || exit 0
71if [ -r %{_sysconfdir}/mozpluggerrc ]; then
72        perl -pi -e 's@^\#application/pdf:@application/pdf:@g' %{_sysconfdir}/mozpluggerrc
73        perl -pi -e 's@^\#application/x-pdf:@application/x-pdf:@g' %{_sysconfdir}/mozpluggerrc
74        touch %{_mozillapath}/mozplugger.so
75fi
76
77%triggerpostun -- acroread-nppdf
78[ "$2" = "0" ] || exit 0
79if [ -r %{_sysconfdir}/mozpluggerrc ]; then
80        perl -pi -e 's@^\#application/pdf:@application/pdf:@g' %{_sysconfdir}/mozpluggerrc
81        perl -pi -e 's@^\#application/x-pdf:@application/x-pdf:@g' %{_sysconfdir}/mozpluggerrc
82        touch %{_mozillapath}/mozplugger.so
83fi
84
85%triggerin -- RealPlayer-rpnp
86[ "$2" -ge 1 ] || exit 0
87if [ -r %{_sysconfdir}/mozpluggerrc ]; then
88        perl -pi -e 's@^audio/x-pn-realaudio-plugin:@\#audio/x-pn-realaudio-plugin:@g' %{_sysconfdir}/mozpluggerrc
89        touch %{_mozillapath}/mozplugger.so
90fi
91
92%triggerun -- RealPlayer-rpnp
93[ "$2" = "0" ] || exit 0
94if [ -r %{_sysconfdir}/mozpluggerrc ]; then
95        perl -pi -e 's@^\#audio/x-pn-realaudio-plugin@audio/x-pn-realaudio-plugin:@g' %{_sysconfdir}/mozpluggerrc
96        touch %{_mozillapath}/mozplugger.so
97fi
98
99%triggerpostun -- RealPlayer-rpnp
100[ "$2" = "0" ] || exit 0
101if [ -r %{_sysconfdir}/mozpluggerrc ]; then
102        perl -pi -e 's@^\#audio/x-pn-realaudio-plugin:@audio/x-pn-realaudio-plugin:@g' %{_sysconfdir}/mozpluggerrc
103        touch %{_mozillapath}/mozplugger.so
104fi
105
106
107%files
108%defattr(-,root,root)
109%doc README COPYING
110%config(noreplace) %{_sysconfdir}/mozpluggerrc
111%{_bindir}/mozplugger-helper
112%{_bindir}/mozplugger-controller
113%{_libdir}/netscape/plugins/mozplugger.so
114%{_mozillapath}/mozplugger.so
115%{_mandir}/man7/*
116
117%changelog
118* Sat Jul 22 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.3-0vl2
119- rebuilt for VineSeed (4.0)
120- changed Group to Applications/Internet
121
122* Fri May 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.3-0vl1.1
123- rebuild with %%vine31 defined
124
125* Fri May 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.3-0vl1.1
126- rebuild with %%vine31 defined
127
128* Thu May 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.3-0vl1
129- rebuild for Vine Linux 3.x
130
131* Thu May 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.3-0vl2
132- new upstream release
133
134* Wed May 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2-0vl1
135- new upstream source
136
137* Sun Dec 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-0vl1
138- initial build for Vine Linux
139
140* Thu Dec 18 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.4.2-2mdk
141- Added Patch0: removed -cache 100 (cause hang with mplayer sometimes), moved
142  ooffice before soffice.
143
144* Thu Dec 18 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.4.2-1mdk
145- Release 1.4.2.
146- Removed Patch0, merged upstream.
147- Removed Patch5 (no longer needed).
148- Removed Patch3 (lib64), merged upstream.
149- Removed Patch4 (amd64), merged upstream.
150
151* Mon Oct 20 2003 Gwenole Beauchesne <gbeauchesne@mandrakesoft.com> 1.3.0-8mdk
152- Really make sure it works on 64-bit platforms.
153
154* Mon Oct 13 2003 Gwenole Beauchesne <gbeauchesne@mandrakesoft.com> 1.3.0-7mdk
155- Really make it work on amd64.
156
157* Mon Oct 13 2003 Gwenole Beauchesne <gbeauchesne@mandrakesoft.com> 1.3.0-6mdk
158- lib64 fixes
159
160* Fri Sep 12 2003 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 1.3.0-5mdk
161- Backported patch from 1.3.2 to fix a regression (so to find the
162  the mozplugger helper in ~/.mozilla, ~/.netscape or ~/.opera).
163
164* Tue Sep 02 2003 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 1.3.0-4mdk
165- Avoid "exits" in timidity entry, otherwise MIDI file is played only once.
166
167* Tue Sep 02 2003 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 1.3.0-3mdk
168- Added Requires: TiMidiTy++.
169- added text/rtf mime type, and use ooffice also to handle it.
170
171* Sun Aug 31 2003 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 1.3.0-2mdk
172- Backported patches from 1.3.1: removed dead code & fixed problems with
173  timidity.
174- Use -vo xv,x11.
175- Used by default mozplugger for application/pdf mime-type. Enabled
176  triggering for acroread-nppdf, and RealPlayer-rpnp package.
177
178* Mon Jul 07 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.3.0-1mdk
179- Release 1.3.0.
180- Removed Patch1.
181- Default plugin dir to %{_mozillapath}.
182
183* Mon Jun 16 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.2.1-2mdk
184- Fixed Patch0 (it wasn't totally merged in upstream!!).
185
186* Mon Jun 16 2003 Per ¥êyvind Karlsen <peroyvind@sintrax.net> 1.2.1-1mdk
187- Release 1.2.1
188- quiet setup
189- dropped P0, merged upstream
190- regenerate P1
191
192* Mon May 12 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.1.3-1mdk
193- Release 1.1.3.
194
195* Tue Feb 18 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.1.1-3mdk
196- use noisy option for quicktime entry too.
197
198* Tue Feb 18 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.1.1-2mdk
199- Removed .bmp,.png from mozpluggerrc, because natively supported.
200- Use noisy option.
201
202* Mon Feb 17 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.1.1-1mdk
203- Release: 1.1.1.
204- Updated Patch0.
205- Removed Patch2, now merged into main.
206
207* Mon Feb 17 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.1-3mdk
208- Removed preload from ogg entry in mozpluggerrc.
209- Updated Patch2.
210- Set path of mozilla.
211
212* Sun Feb 16 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.1-2mdk
213- Updated URL.
214
215* Sun Feb 16 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.1-1mdk
216- Release 1.1.
217
218* Sat Feb 15 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.0-1mdk
219- Initial release ofn mozplugger 1.0.
220- Readatped patches of previous plugger.
221
222* Sat Dec 14 2002 Giuseppe Ghib<ghibo@mandrakesoft.com> 4.0-8mdk
223- added application/x-maplyer2 to /etc/pluggerrc for .wmv files
224- added mplayer in Requires:.
225
226* Sat Sep 07 2002 Giuseppe Ghib<ghibo@mandrakesoft.com> 4.0-7mdk
227- added audio/x-realaudio to /etc/pluggerrc.
228
229* Sat Aug 31 2002 Giuseppe Ghib<ghibo@mandrakesoft.com> 4.0-6mdk
230- added missed MPlayer in video/x-mpeg mime item of pluggerrc.
231
232* Fri Aug 30 2002 Giuseppe Ghib<ghibo@mandrakesoft.com> 4.0-5mdk
233- removed audio/x-pn-realaudio-plugin in pluggerrc (let the
234  native rpnp.so plugin provide this if needed).
235- added in /etc/pluggerrc: application/vnd.rn-realmedia, application/smil,
236  audio/vnd.rn-realaudio, audio/x-pn-realaudio, video/vnd.rn-realvideo
237  to be used with realplay.
238
239* Wed Aug 28 2002 Giuseppe Ghib<ghibo@mandrakesoft.com> 4.0-4mdk
240- Removed streaming for mtvp (video/x-mpeg) and mpg123 (audio/x-mp3) because
241  streaming doesn't work under mozilla.
242- Moved mtvp beyond xine and mplayer in video/x-mpeg.
243- Let application/pdf, application/x-pdf be used with the acroread plugin
244  because it works better than "swallowing".
245- Added OpenOffice mime entries in pluggerrc (from RH).
246- Added Typo & Description patches from RH.
247- Added Patch4 for compiling with gcc 2.96 (but not yet enabled).
248- Updated mozilla path.
249
250* Sun Aug 04 2002 Giuseppe Ghib<ghibo@mandrakesoft.com> 4.0-3mdk
251- Fixed path (bug #33) for new mozilla.
252
253* Mon Jan 28 2002 Frederic Crozat <fcrozat@mandrakesoft.com> 4.0-2mdk
254- Remove dependency on netscape, since plugger can be user by mozilla
255  and its derivate
256
257* Sat Jan 26 2002 Giuseppe Ghib<ghibo@mandrakesoft.com> 4.0-1mdk
258- updated to version 4.0.
259- updated pluggerrc file.
260- removed debug patch (Patch1).
261- updated Patch2.
262- added Patch3 (-mozilla), merged from RedHat.
263
264* Sat Aug 26 2001 Giuseppe Ghib<ghibo@mandrakesoft.com> 3.3-1mdk
265- updated to version 3.3.
266- new pluggerrc file.
267
268* Thu Jul 19 2001 Stefan van der Eijk <stefan@eijk.nu> 3.2-8mdk
269- BuildRequires:        XFree86-devel
270- Copyright --> License
271
272* Wed Mar 14 2001 Giuseppe Ghib<ghibo@mandrakesoft.com> 3.2-7mdk
273- removed debug.
274
275* Fri Sep 29 2000 Giuseppe Ghib<ghibo@mandrakesoft.com> 3.2-6mdk
276- more macros.
277- removed xanim in Requires.
278
279* Tue Aug 29 2000 Giuseppe Ghib<ghibo@mandrakesoft.com> 3.2-5mdk
280- use of %%_mandir.
281
282* Sat Apr 22 2000 Giuseppe Ghib<ghibo@mandrakesoft.com> 3.2-4mdk
283- changed plugger debug file from /tmp/ndebug to $HOME/tmp/plugger-debug.
284  so netscape doesn't crashes if /tmp/ndebug is already existing and
285  not writeble (e.g. because owned by a different user).
286
287* Fri Apr 21 2000 Denis Havlik <denis@mandrakesoft.com> 3.2-3mdk
288- fixed "Requires:" (netscape-common -> netscape)
289
290* Wed Apr 19 2000 Denis Havlik <denis@mandrakesoft.com> 3.2-2mdk
291- spechelper, fixed release,
292- added "Obsoletes: npxanim"
293- added "Requires: netscape-common xanim mikmod mpg123 sox ImageMagick"
294
295* Wed Apr 19 2000 Giuseppe Ghib<ghibo@mandrakesoft.com> 3.2-1mdk
296- initial build based on RedHat 3.2-2 version
297- removed png from pluggerrc (netscape has native support for it).
298- fixed group.
299- added man page.
300
301* Thu Jan 27 2000 Tim Powers <timp@redhat.com>
302- fixed munged group, summary etc.
303
304* Tue Nov 23 1999 Tim Powers <timp@redhat.com>
305- updated to 3.2
306- quiet scripts
307- updated patch
308
309* Sat Aug 21 1999 Bill Nottingham <notting@redhat.com>
310- initial build
Note: See TracBrowser for help on using the repository browser.