source: projects/specs/trunk/m/moonlight/moonlight-vl.spec @ 1790

Revision 1790, 9.2 KB checked in by owa, 14 years ago (diff)

fixed spec of moonlight

Line 
1%define mono_dir %{_prefix}/lib/mono
2%define monodoc_dir %{_prefix}/lib/monodoc
3%define moonlight_dir %{_prefix}/lib/moonlight
4%define pkgconfigdir %{_datadir}/pkgconfig
5%define included_mono 2.6
6
7Summary:  An open source implementation of Silverlight
8Summary(ja): Silverlight のオープンソースによる実装
9Name: moonlight
10Version: 2.0
11Release: 3%{?_dist_release}
12
13Group: Applications/Multimedia
14License: LGPL v2.0 only ; MIT License (or similar) ; Ms-Pl
15URL: http://go-mono.com/moonlight/
16
17Source0: ftp://ftp.novell.com/pub/mono/sources/moon/2.0/moonlight-%{version}.tar.bz2
18Source1: ftp://ftp.novell.com/pub/mono/sources/moon/2.0/mono-%{included_mono}.tar.bz2
19Source2: ftp://ftp.novell.com/pub/mono/sources/moon/2.0/mono-basic-%{included_mono}.tar.bz2
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22#Patch0: missing-files.patch
23#BuildRequires: mono-devel >= 2.6
24#BuildRequires: monodoc
25BuildRequires: gtk-sharp2
26BuildRequires: rsvg2-sharp
27BuildRequires: wnck-sharp
28BuildRequires: gcc-c++
29BuildRequires: gtk2-devel
30BuildRequires: alsa-lib-devel
31BuildRequires: xulrunner-devel
32#BuildRequires: automake
33#BuildRequires: autoconf
34ExclusiveArch: %ix86 x86_64
35
36%description
37Moonlight is an open source implementation of Microsoft Silverlight for
38Unix systems.
39
40%description -l ja
41Moonlight は Unix 系システムのための,Microsoft Silverlight のオープン
42ソースな実装です.
43
44
45%package libs
46Summary: Moonlight libmoon
47Group: System Environment/Libraries
48License: LGPL v2.0 only
49
50%description libs
51Moonlight libmoon
52
53%package devel
54Summary: Moonlight libmoon C/C++ development files
55Group: Development/Libraries
56License: LGPL v2.0 only
57Requires: %{name}-libs == %{version}
58
59%description devel
60Development files for libmoon
61
62%package tools
63Summary: Moonlight tools
64Group: Development/Tools
65Requires: %{name}-libs == %{version}
66
67%description tools
68Moonlight tools (mopen, xamlg, xaml2html, mxap, respack, svg2xaml)
69
70%package plugin
71Summary: Moonlight browser plugin
72Group: Applications/Internet
73Requires: %{name}-libs == %{version}
74
75%description plugin
76Browser plugin for Novell Moonlight
77
78%package web-devel
79Summary: Development files for Moonlight Web
80Group: Development/Libraries
81License: MIT License (or similar) ; Ms-Pl
82Requires: %{name}-plugin == %{version}
83
84%description web-devel
85Development files for creating Moonlight web applications.
86
87%package desktop
88Summary: Mono bindings for Moonlight Desktop
89Group: Development/Libraries
90License: MIT License (or similar) ; Ms-Pl
91Requires: %{name}-libs == %{version}
92
93%description desktop
94Mono bindings for Novell Moonlight.
95
96%package desktop-devel
97Summary: Development files for Moonlight Desktop
98Group: Development/Libraries
99License: MIT License (or similar) ; Ms-Pl
100Requires: %{name}-libs == %{version}
101Requires: glib2-devel
102Requires: gtk-sharp2
103Requires: %{name}-desktop == %{version}
104Requires: %{name}-tools == %{version}
105
106%description desktop-devel
107Development files for Moonlight Desktop.
108
109%package sharp
110Summary: Moonlight sharp
111Group: Development/Libraries
112Requires: %{name}-libs == %{version}
113
114%description sharp
115Provides a gtk-sharp object that can be used to embed a moonlight surface in a desktop application.
116
117
118%prep
119%setup -q
120%setup -q -T -D -b 1 -n %{name}-%{version}
121%setup -q -T -D -b 2 -n %{name}-%{version}
122
123
124%build
125# The plugin requires a complete build of it's own mono
126pushd ../mono-%{included_mono}
127./configure \
128        --prefix=%{_builddir}/install \
129        --with-mcs-docs=no \
130        --with-ikvm-native=no \
131        ;
132# mono is not strictly -j safe
133%{__make} EXTERNAL_MCS=false EXTERNAL_RUNTIME=false
134%{__make} install
135find %{_builddir}/install -name \*.la -delete
136popd
137
138# Configure against the junk install of mono
139export PATH=%{_builddir}/install/bin:${PATH}
140export LD_LIBRARY_PATH=%{_builddir}/install/lib:${LD_LIBRARY_PATH}
141export PKG_CONFIG_PATH=%{_builddir}/install/lib/pkgconfig:${PKG_CONFIG_PATH}
142#autoreconf -f -i -Wnone
143%configure \
144        --with-ffmpeg=no \
145        --with-cairo=system \
146        --with-mcspath=%{_builddir}/mono-%{included_mono}/mcs \
147        --with-mono-basic-path=%{_builddir}/mono-basic-%{included_mono} \
148        --with-ff3=yes \
149        --with-testing=no \
150        --with-performance=no \
151        --with-examples=no \
152        --with-debug=no \
153        --with-sanity-checks=no \
154
155export MONO_GAC_PREFIX=%{_builddir}/install:%{_prefix}
156%{__make} %{?_smp_mflags}
157
158
159%install
160rm -rf $RPM_BUILD_ROOT
161export PATH=%{_builddir}/install/bin:${PATH}
162export LD_LIBRARY_PATH=%{_builddir}/install/lib:${LD_LIBRARY_PATH}
163export PKG_CONFIG_PATH=%{_builddir}/install/lib/pkgconfig:${PKG_CONFIG_PATH}
164make install DESTDIR=${RPM_BUILD_ROOT} pkgconfigdir=%{pkgconfigdir}
165
166mkdir -p $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
167ln -s %{_libdir}/moonlight/plugin/libmoonloader.so \
168        $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/libmoonloader.so
169
170# remove unuse files
171rm -f $RPM_BUILD_ROOT%{_libdir}/libshocker.so
172find %{buildroot} -name \*.la -delete
173
174
175%post libs -p /sbin/ldconfig
176%postun libs -p /sbin/ldconfig
177%clean
178rm -rf $RPM_BUILD_ROOT
179
180
181%files libs
182%defattr(-, root, root)
183%doc AUTHORS COPYING ChangeLog README TODO NEWS
184%{_libdir}/libmoon.so.*
185
186%files devel
187%defattr(-, root, root)
188%{_libdir}/libmoon.so
189
190%files tools
191%defattr(-, root, root)
192%{_bindir}/mopen
193%{_bindir}/munxap
194%{_bindir}/mxap
195%{_bindir}/respack
196%{_bindir}/sockpol
197%{_bindir}/unrespack
198%{_bindir}/xaml2html
199%{_bindir}/xamlg
200%dir %{_libdir}/moonlight
201%{_libdir}/moonlight/mopen.exe*
202%{_libdir}/moonlight/munxap.exe
203%{_libdir}/moonlight/mxap.exe
204%{_libdir}/moonlight/respack.exe
205%{_libdir}/moonlight/xaml2html.exe
206%{_libdir}/moonlight/xamlg.exe
207%{_libdir}/moonlight/sockpol.exe
208%{_mandir}/man1/mopen.1.gz
209%{_mandir}/man1/mxap.1.gz
210%{_mandir}/man1/respack.1.gz
211%{_mandir}/man1/svg2xaml.1.gz
212%{_mandir}/man1/xamlg.1.gz
213%{_mandir}/man1/sockpol.1.gz
214
215%files plugin
216%defattr(-, root, root)
217%dir %{_libdir}/moonlight/plugin
218%{_libdir}/moonlight/plugin/Microsoft.VisualBasic.dll
219%{_libdir}/moonlight/plugin/System.Core.dll*
220%{_libdir}/moonlight/plugin/System.Net.dll*
221%{_libdir}/moonlight/plugin/System.Runtime.Serialization.dll*
222%{_libdir}/moonlight/plugin/System.ServiceModel.Web.dll*
223%{_libdir}/moonlight/plugin/System.ServiceModel.dll*
224%{_libdir}/moonlight/plugin/System.Windows.Browser.dll*
225%{_libdir}/moonlight/plugin/System.Windows.dll*
226%{_libdir}/moonlight/plugin/System.Xml.dll*
227%{_libdir}/moonlight/plugin/System.dll*
228%{_libdir}/moonlight/plugin/libmoonloader.so
229%{_libdir}/moonlight/plugin/libmoonplugin-ff3bridge.so
230%{_libdir}/moonlight/plugin/libmoonplugin.so
231%{_libdir}/moonlight/plugin/mscorlib.dll*
232%{_libdir}/mozilla/plugins/libmoonloader.so
233
234%files web-devel
235%defattr(-, root, root)
236%{_bindir}/smcs
237%dir %{moonlight_dir}/2.0-redist
238%{moonlight_dir}/2.0-redist/System.Windows.Controls.Data.dll*
239%{moonlight_dir}/2.0-redist/System.Windows.Controls.dll*
240%{moonlight_dir}/2.0-redist/System.Xml.Linq.dll*
241%dir %{moonlight_dir}/2.0
242%{moonlight_dir}/2.0/Microsoft.VisualBasic.dll*
243%{moonlight_dir}/2.0/Mono.CompilerServices.SymbolWriter.dll*
244%{moonlight_dir}/2.0/System.Core.dll*
245%{moonlight_dir}/2.0/System.Net.dll*
246%{moonlight_dir}/2.0/System.Runtime.Serialization.dll*
247%{moonlight_dir}/2.0/System.ServiceModel.Web.dll*
248%{moonlight_dir}/2.0/System.ServiceModel.dll*
249%{moonlight_dir}/2.0/System.Windows.Browser.dll*
250%{moonlight_dir}/2.0/System.Windows.dll*
251%{moonlight_dir}/2.0/System.Xml.dll*
252%{moonlight_dir}/2.0/System.dll*
253%{moonlight_dir}/2.0/mscorlib.dll*
254%{moonlight_dir}/2.0/respack.exe*
255%{moonlight_dir}/2.0/smcs.exe*
256%{moonlight_dir}/2.0/buildversion
257%{pkgconfigdir}/moonlight-web-2.0.pc
258
259%files desktop
260%defattr(-, root, root)
261%{mono_dir}/gac/Moon.Windows.Desktop
262%{mono_dir}/gac/Moonlight.Gtk
263%{mono_dir}/gac/System.Windows
264%{mono_dir}/gac/System.Windows.Browser
265%{mono_dir}/gac/System.Windows.Controls
266%{mono_dir}/gac/System.Windows.Controls.Data
267
268%files desktop-devel
269%defattr(-, root, root)
270%dir %{mono_dir}/moonlight
271%{mono_dir}/moonlight/Moon.Windows.Desktop.dll*
272%{mono_dir}/moonlight/System.Windows.Browser.dll*
273%{mono_dir}/moonlight/System.Windows.Controls.Data.dll*
274%{mono_dir}/moonlight/System.Windows.Controls.dll*
275%{mono_dir}/moonlight/System.Windows.dll*
276%{pkgconfigdir}/moonlight-desktop-2.0.pc
277# It may make sense in the future to have a moonlight-gtk package
278%{mono_dir}/moonlight/Moonlight.Gtk.dll*
279%{monodoc_dir}/sources/moonlight-gtk.source
280%{monodoc_dir}/sources/moonlight-gtk.tree
281%{monodoc_dir}/sources/moonlight-gtk.zip
282%{pkgconfigdir}/moonlight-gtk-2.0.pc
283
284
285%changelog
286* Wed Sep 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.0-3
287- export PATH, LD_LIBRARY_PATH, PKG_CONFIG_PATH, MONO_GAC_PREFIX
288
289* Sat Sep  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0-2
290- fixed Group
291- added BR: wnck-sharp
292
293* Thu Dec 31 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-1
294- updated moonlight to 2.0
295
296* Thu Jul 09 2009 Shu KONNO <owa@bg.wakwak.com> 1.0.1-1
297- updated moon to 1.0.1
298- dropt missing-files.patch (included in source)
299- built with latest rpm to update mono-dependencies
300
301* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 0.8.1-2
302- changed plugin Group to Applications/Internet
303- changed other sub packages Group to Development/Libraries
304- added %%pkgconfigdir macro
305
306* Sat Sep 27 2008 Shu KONNO <owa@bg.wakwak.com> 0.8.1-1
307- new upstream release
308- added missing-files.patch from suse
309- added --with-managed=desktop
310
311* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 0.8-1
312- initial build for VineSeed
313    - moonlight 0.8
314    - vine versioning policy
315    - spec in utf-8
316
Note: See TracBrowser for help on using the repository browser.