source: projects/specs/trunk/m/mono-basic/mono-basic-vl.spec @ 763

Revision 763, 2.7 KB checked in by owa, 14 years ago (diff)

updated mono to 2.6.3

Line 
1%define mono_ver 2.6.2
2%define mono_dir %{_prefix}/lib/mono
3Summary: Visual Basic .NET support for Mono
4Summary(ja): Mono 用 Visual Basic .NET サポート
5Name: mono-basic
6Version: %{mono_ver}
7Release: 1%{?_dist_release}
8Group: Development/Languages
9License: GPL, LGPL, MIT X11
10URL: http://www.mono-project.com/
11Source0: http://mono.ximian.com/monobuild/preview/sources/%{name}/%{name}-%{version}.tar.bz2
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildArch: noarch
14Requires: mono-core >= %{mono_ver}
15Requires: mono-winforms mono-web
16Requires: mono-data mono-locale-extras
17BuildRequires: mono-core >= %{mono_ver}
18BuildRequires: mono-winforms mono-web
19BuildRequires: mono-data mono-locale-extras
20#define __find_provides %{_bindir}/mono-find-provides
21#define __find_requires %{_bindir}/mono-find-requires
22
23%description
24This package contains the Visual Basic .NET compiler and language
25runtime. This allows you to compile and run VB.NET application and
26assemblies.
27
28%if 0
29%define gac_dll(dll)  %{mono_dir}/gac/%{1} \
30  %{mono_dir}/?.0/%{1}.dll \
31  %{nil}
32%define mono_bin(bin) %{_bindir}/%{1} \
33  %{mono_dir}/?.0/%{1}.exe \
34  %{mono_dir}/?.0/%{1}.exe.* \
35  %{nil}
36%define mono_bin_1(bin, dll) %{_bindir}/%{1} \
37  %{mono_dir}/1.0/%{2}.exe \
38  %{mono_dir}/1.0/%{2}.exe.* \
39  %{nil}
40%define mono_bin_2(bin, dll) %{_bindir}/%{1} \
41  %{mono_dir}/2.0/%{2}.exe \
42  %{mono_dir}/2.0/%{2}.exe.* \
43  %{nil}
44%endif
45
46%prep
47%setup -q
48
49%build
50./configure --prefix=%{_prefix}
51make
52
53%install
54[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
55
56make install DESTDIR=$RPM_BUILD_ROOT
57
58%clean
59[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
60
61
62%files
63%defattr(-,root,root,-)
64%doc ChangeLog README
65%{_bindir}/vbnc
66%{mono_dir}/2.0/Microsoft.VisualBasic.dll
67%{mono_dir}/2.0/vbnc.exe
68%{mono_dir}/2.0/vbnc.exe.mdb
69%{mono_dir}/2.0/vbnc.rsp
70%{mono_dir}/gac/Microsoft.VisualBasic
71%{_mandir}/man1/*
72
73%changelog
74* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.2-1
75- updated mono-basic to 2.6.2
76
77* Sun Dec 27 2009 Shu KONNO <owa@bg.wakwak.com> 2.6-1
78- updated mono-basic to 2.6
79
80* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2-2
81- rebuilt with latest rpm to update mono-dependencies
82
83* Thu Jul 02 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
84- updated mono-basic to 2.4.2
85
86* Tue Mar 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
87- new upstream release
88
89* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1vl5
90- updated mono-basic to 2.0
91- added BuildArch: noarch
92- changed url
93
94* Tue Aug 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.5-1vl5
95- applied new versioning policy, spec in utf-8
96
97* Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
98- initial build for Vine
99- splited from mono package
100
Note: See TracBrowser for help on using the repository browser.