source: projects/specs/trunk/m/mod_ruby/mod_ruby-vl.spec @ 521

Revision 521, 7.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define docroot                 /home/httpd
2%define apxs                    /usr/sbin/apxs
3%define apxs2                   /usr/bin/apxs
4%define httpdmoddir             %(%{apxs} -q LIBEXECDIR)
5%define httpdconfdir            %(%{apxs} -q SYSCONFDIR)
6%define apache2moddir           %(%{apxs2} -q LIBEXECDIR)
7%define apache2confdir          %(%{apxs2} -q SYSCONFDIR)
8%define httpdconfmodruby        httpd.conf.mod_ruby
9%define apache2confmodruby      httpd.conf.mod_ruby
10%define apachever               1.3.29
11%define apache2ver              2.2.9
12
13Summary: A Ruby interpreter for the Apache Web server.
14Summary(ja): Apacheサーバ組み込みのRuby言語インタプリタ
15Name: mod_ruby
16Version: 1.2.6
17Release: 1%{?_dist_release}
18License: distributable
19Group: System Environment/Daemons
20Source0: http://www.modruby.net/archive/%{name}-%{version}.tar.gz
21Source99: httpd.conf.mod_ruby
22Source100: httpd.conf.mod_ruby-apache2
23Patch10: mod_ruby-1.2.6-fix-xldflags.patch
24URL: http://www.modruby.net/
25Prefix: /usr
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: ruby, ruby-devel
28BuildPreReq: apache, apache-devel >= %{apachever}
29BuildPreReq: apache2, apache2-devel >= %{apache2ver}
30Requires: apache >= %{apachever}, liberuby >= 1.0.5
31Requires: ruby >= 1.8
32Requires: mod_ruby-common = %{version}-%{release}
33
34%description
35mod_ruby embeds the Ruby interpreter into the Apache web server,
36allowing Ruby CGI scripts to be executed natively. These scripts
37will start up much faster than without mod_ruby.
38
39%description -l ja
40mod_rubyはApacheウェブサーバにRubyインタプリタを組み込み、CGIスクリ
41プトがネイティブに起動されることを許します。スクリプトはmod_rubyを利
42用しない場合よりも速く起動するでしょう。
43
44
45%package apache2
46Summary: A Ruby interpreter for the Apache2 Web server.
47Summary(ja): Apache2サーバ組み込みのRuby言語インタプリタ
48Group: System Environment/Daemons
49Requires: apache2 >= %{apache2ver}
50Requires: ruby >= 1.8
51Requires: mod_ruby-common = %{version}-%{release}
52
53%description apache2
54mod_ruby embeds the Ruby interpreter into the Apache web server,
55allowing Ruby CGI scripts to be executed natively. These scripts
56will start up much faster than without mod_ruby.
57
58%description apache2 -l ja
59mod_rubyはApache2ウェブサーバにRubyインタプリタを組み込み、CGIスクリ
60プトがネイティブに起動されることを許します。スクリプトはmod_rubyを利
61用しない場合よりも速く起動するでしょう。
62
63
64%package common
65Summary: Ruby libraries for mod_ruby
66Summary(ja): mod_ruby 用の Ruby ライブラリ
67Group: System Environment/Daemons
68Requires: ruby >= 1.8
69
70%description common
71Ruby libraries for mod_ruby
72
73%description common -l ja
74mod_ruby 用の Ruby ライブラリ
75
76
77%prep
78%setup -q -c
79%patch10 -p0
80
81
82%build
83## for apache1
84cd %{name}-%{version}
85ruby configure.rb --with-apxs=%{apxs}
86make
87cd ..
88
89
90%install
91rm -rf ${RPM_BUILD_ROOT}
92mkdir -p ${RPM_BUILD_ROOT}%{httpdmoddir}
93mkdir -p ${RPM_BUILD_ROOT}%{httpdconfdir}
94
95# installing binaries ...
96cd %{name}-%{version}
97make install DESTDIR=${RPM_BUILD_ROOT}
98cd ..
99
100sed -e 's|@@DOCROOT@@|%{docroot}|g' < %{SOURCE99} \
101  > ${RPM_BUILD_ROOT}/%{httpdconfdir}/%{httpdconfmodruby}
102chmod 644 ${RPM_BUILD_ROOT}/%{httpdconfdir}/%{httpdconfmodruby}
103
104## for apache2
105cd %{name}-%{version}
106make clean
107ruby configure.rb --with-apxs=%{apxs2} --with-apr-includes=/usr/include/apr-1
108make
109
110mkdir -p ${RPM_BUILD_ROOT}%{apache2moddir}
111mkdir -p ${RPM_BUILD_ROOT}%{apache2confdir}
112make install DESTDIR=${RPM_BUILD_ROOT}
113
114sed -e 's|@@DOCROOT@@|%{docroot}|g' < %{SOURCE100} \
115  > ${RPM_BUILD_ROOT}/%{apache2confdir}/%{apache2confmodruby}
116chmod 644 ${RPM_BUILD_ROOT}/%{apache2confdir}/%{apache2confmodruby}
117
118
119%clean
120rm -rf ${RPM_BUILD_ROOT}
121rm -f *.files
122
123
124%files
125%defattr(-, root, root)
126%doc %{name}-%{version}/README.en
127%doc %{name}-%{version}/README.ja
128%doc %{name}-%{version}/ChangeLog
129%doc %{name}-%{version}/examples/
130%config %{httpdconfdir}/%{httpdconfmodruby}
131%{_libdir}/apache/*
132
133
134%files apache2
135%defattr(-, root, root)
136%doc %{name}-%{version}/README.en
137%doc %{name}-%{version}/README.ja
138%doc %{name}-%{version}/ChangeLog
139%doc %{name}-%{version}/examples/
140%config %{apache2confdir}/%{apache2confmodruby}
141%{_libdir}/apache2/*
142
143
144%files common
145%defattr(-, root, root)
146%doc %{name}-%{version}/README.en
147%doc %{name}-%{version}/README.ja
148%doc %{name}-%{version}/ChangeLog
149%{_libdir}/ruby/1.8/auto-reload.rb
150%dir %{_libdir}/ruby/1.8/apache
151%{_libdir}/ruby/1.8/apache/*
152
153
154%changelog
155* Mon Sep 22 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.6-1
156- new upstream release
157- add apache2/common subpackages
158
159* Wed Aug 27 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.7-1vl5
160- applied new versioning policy, spec in utf-8
161
162* Mon Aug 27 2007 Shu KONNO <owa@bg.wakwak.com> 1.0.7-0vl2
163- s/Copyright/License/
164
165* Sat Feb 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-0vl1
166- new upstream release
167- rebuild on apache-1.3.29, ruby-1.8.1
168
169* Thu Aug 22 2002 Satoshi MACHINO <machino@vinelinux.org> 1.0.0-0vl1
170- new upstream version.
171
172* Thu May 30 2002 akira yamada <akira@vinelinux.org> 0.9.8-0vl2
173- updated URL of upstream sources.
174
175* Thu May 30 2002 akira yamada <akira@vinelinux.org> 0.9.8-0vl1
176- new upstream version.
177
178* Fri Mar 08 2002 akira yamada <akira@vinelinux.org> 0.9.7-0vl1
179- new upstream version.
180
181* Mon Feb 11 2002 akira yamada <akira@vinelinux.org> 0.9.6-0vl1
182- new upstream version.
183
184* Mon Oct 17 2001 akira yamada <akira@vinelinux.org> 0.9.4-0vl1
185- new upstream version.
186
187* Mon Oct 17 2001 akira yamada <akira@vinelinux.org> 0.9.3-0vl2
188- rebuild with apache-1.3.22. Requires: apache = 1.3.22.
189- added apache to BuildRequires. (apxs checks /usr/bin/httpd.)
190
191* Mon Sep 03 2001 akira yamada <akira@vinelinux.org> 0.9.3-0vl1
192- new upstream release.
193
194* Sat Aug 18 2001 akira yamada <akira@vinelinux.org>
195- 0.9.2-0vl1
196- new upstream version 0.9.2.
197
198* Wed Aug 08 2001 akira yamada <akira@vinelinux.org>
199- 0.9.1-0vl1
200- new upstream version 0.9.1.
201
202* Fri Jul 06 2001 akira yamada <akira@vinelinux.org>
203- new upstream version 0.9.0.
204
205* Thu Jul 03 2001 akira yamada <akira@vinelinux.org>
206- remove liberuby-dev from BuildRequires.
207
208* Thu Jun 28 2001 akira yamada <akira@vinelinux.org>
209- new upstream version 0.8.5.
210
211* Thu Jun 21 2001 akira yamada <akira@vinelinux.org>
212- new upstream version 0.8.4.
213
214* Mon Jun 06 2001 akira yamada <akira@vinelinux.org>
215- new upstream version 0.8.3.
216
217* Mon Jun 04 2001 akira yamada <akira@vinelinux.org>
218- new upstream version 0.8.2.
219
220* Thu May 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl3
221- rebuild with papche-1.3.20
222
223* Thu Apr 13 2001 akira yamada <akira@vinelinux.org>
224- new upstream version 0.8.0.
225
226* Thu Mar 15 2001 akira yamada <akira@vinelinux.org>
227- rebuild with apache-1.3.19.
228
229* Fri Feb 09 2001 akira yamada <akira@vinelinux.org>
230- rebuild with apache-1.3.17.
231
232* Wed Dec 20 2000 akira yamada <akira@vinelinux.org>
233- Updated to new upstream version 0.2.2.
234
235* Sun Nov 05 2000 akira yamada <akira@vinelinux.org>
236- excute Makefile.RB with --apxs option, because normal user's PATH dose not
237  include /usr/sbin.
238
239* Thu Oct 19 2000 akira yamada <akira@vinelinux.org>
240- Updated to new upstream version 0.2.1.
241- BuildPreReq: apache-devel, Requires: apache.
242- Build with apache 1.3.14.
243
244* Wed Oct 11 2000 akira yamada <akira@vinelinux.org>
245- Removed mod_ruby-0.2.0-egcs-2.91.66.patch, because fixed this probrem in
246  ruby.
247
248* Thu Oct 03 2000 akira yamada <akira@vinelinux.org>
249- Added mod_ruby-0.2.0-egcs-2.91.66.patch to work around for segv.
250
251* Thu Oct 03 2000 akira yamada <akira@vinelinux.org>
252- Initial packaging.
Note: See TracBrowser for help on using the repository browser.