source: projects/specs/trunk/m/mod_python/mod_python-vl.spec @ 521

Revision 521, 8.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define contentdir /var/www
2%define httpd apache2
3%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
4
5Summary: An embedded Python interpreter for the Apache HTTP Server
6Summary(ja): Apacheサーバの組み込みPython言語インタプリタ
7Name: mod_python
8Version: 3.3.1
9Release: 3%{?_dist_release}
10URL: http://www.modpython.org/
11Source: http://www.apache.org/dist/httpd/modpython/%{name}-%{version}.tgz
12Source1: python.conf.vine
13Patch1: mod_python-3.1.3-ldflags.patch
14Patch2: mod_python-3.1.4-cflags.patch
15Patch3: mod_python-3.3.1-buckets.patch
16License: Apache License Version 2.0
17Group: System Environment/Daemons
18BuildRequires: python, python-devel
19BuildRequires: %{httpd}-devel >= 2.0.40-6
20#Requires: %{httpd}-mmn = %(cat %{_includedir}/%{httpd}/.mmn || echo missing)
21Requires: %{httpd} >= 2.0.40
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%description
27Mod_python is a module that embeds the Python language interpreter within
28the server, allowing Apache handlers to be written in Python.
29
30Mod_python brings together the versatility of Python and the power of
31the Apache Web server for a considerable boost in flexibility and
32performance over the traditional CGI approach.
33
34%prep
35%setup -q
36%patch1 -p1 -b .ldflags
37%patch2 -p1 -b .cflags
38%patch3 -p1 -b .buckets
39
40%build
41%configure --with-apxs=/usr/bin/apxs --with-max-locks=4
42make %{?_smp_mflags} APXS_CFLAGS="-Wc,-fno-strict-aliasing"
43
44
45%install
46[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
47mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{httpd}/modules
48make install DESTDIR=$RPM_BUILD_ROOT
49
50# Install the config file
51mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/%{httpd}/conf.d
52install -m 644 %SOURCE1 $RPM_BUILD_ROOT%{_sysconfdir}/%{httpd}/conf.d/python.conf
53
54# Install the manual.
55mkdir -p $RPM_BUILD_ROOT%{contentdir}/manual/mod/mod_python
56cp -a doc-html/* $RPM_BUILD_ROOT%{contentdir}/manual/mod/mod_python/
57
58%clean
59[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
60
61%files
62%defattr(-,root,root)
63%doc README NEWS CREDITS LICENSE NOTICE
64%{contentdir}/manual/mod/mod_python
65%{_libdir}/%{httpd}/modules/mod_python.so
66%config(noreplace) %{_sysconfdir}/%{httpd}/conf.d/*.conf
67%{python_sitearch}/mod_python*
68
69%changelog
70* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 3.3.1-3
71- rebuild with python-2.6
72
73* Sun Mar 29 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.3.1-2
74- add Patch3 to fix build failure (from RH bugzilla #465246)
75
76* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 3.3.1-1vl5
77- initial build for Vine Linux
78        - applied vine versioning policy, spec in utf-8
79        - use /usr/bin/apxs instead of /usr/sbin/apxs
80        - modified python.conf
81
82* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.3.1-7
83- Autorebuild for GCC 4.3
84
85* Fri Jan  4 2008 Joe Orton <jorton@redhat.com> 3.3.1-6
86- fix rebuild failure due to new egg-info directory
87
88* Sun Sep  2 2007 Joe Orton <jorton@redhat.com> 3.3.1-5
89- rebuild for fixed 32-bit APR
90
91* Tue Aug 21 2007 Joe Orton <jorton@redhat.com> 3.3.1-4
92- fix License
93
94* Mon Feb 19 2007 Jeremy Katz <katzj@redhat.com> - 3.3.1-3
95- don't use legacy python-abi requires syntax
96
97* Fri Feb 16 2007 Joe Orton <jorton@redhat.com> 3.3.1-2
98- update to 3.3.1
99- fix BuildRoot, Summary, drop BR for autoconf
100
101* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 3.2.10-4
102- rebuild against python 2.5
103
104* Tue Nov 21 2006 Joe Orton <jorton@redhat.com> 3.2.10-3
105- update to 3.2.10
106
107* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com>
108- rebuild
109
110* Mon Feb 27 2006 Joe Orton <jorton@redhat.com> 3.2.8-3
111- remove use of apr_sockaddr_port_get
112
113* Mon Feb 27 2006 Joe Orton <jorton@redhat.com> 3.2.8-2
114- update to 3.2.8
115
116* Mon Feb 13 2006 Joe Orton <jorton@redhat.com> 3.1.4-4
117- fix configure syntax error with bash 3.1 (#180731)
118
119* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.1.4-3.2.1
120- bump again for double-long bug on ppc(64)
121
122* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.1.4-3.2
123- rebuilt for new gcc4.1 snapshot and glibc changes
124
125* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
126- rebuilt
127
128* Fri Dec  2 2005 Joe Orton <jorton@redhat.com> 3.1.4-3
129- rebuild for httpd 2.2
130- build with -fno-strict-aliasing
131- don't use deprecated APR_STATUS_IS_SUCCESS() macro
132
133* Fri Mar  4 2005 Joe Orton <jorton@redhat.com> 3.1.4-2
134- rebuild
135
136* Thu Feb 10 2005 Joe Orton <jorton@redhat.com> 3.1.4-1
137- update to 3.1.4
138
139* Tue Feb  1 2005 Joe Orton <jorton@redhat.com> 3.1.3-8
140- link against shared libpython (#129019)
141- add python.conf comment on using PSP (#121212)
142
143* Thu Nov 18 2004 Joe Orton <jorton@redhat.com> 3.1.3-7
144- require python-abi
145
146* Thu Nov 18 2004 Joe Orton <jorton@redhat.com> 3.1.3-6
147- rebuild for Python 2.4
148
149* Tue Oct 12 2004 Joe Orton <jorton@redhat.com> 3.1.3-5
150- include LICENSE and NOTICE
151
152* Tue Oct 12 2004 Joe Orton <jorton@redhat.com> 3.1.3-4
153- use a maximum of four semaphores by default
154
155* Tue Jul 13 2004 Nils Philippsen <nphilipp@redhat.com>
156- set default-handler for manual files to fix #127622
157
158* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
159- rebuilt
160
161* Mon Mar  8 2004 Mihai Ibanescu <misa@redhat.com> 3.1.3-0.1
162- upgrade to 3.1.3
163
164* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
165- rebuilt
166
167* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
168- rebuilt
169
170* Tue Feb  3 2004 Gary Benson <gbenson@redhat.com> 3.0.4-1
171- upgrade to 3.0.4 (fixes CVE CAN-2003-0973)
172
173* Fri Nov  7 2003 Joe Orton <jorton@redhat.com> 3.0.3-4
174- rebuild for python 2.3.2
175
176* Thu Jul  3 2003 Gary Benson <gbenson@redhat.com> 3.0.3-3
177- fix license (#98245)
178
179* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> 3.0.3-2
180- rebuilt
181
182* Tue May 13 2003 Gary Benson <gbenson@redhat.com> 3.0.3-1
183- upgrade to 3.0.3.
184
185* Thu Feb 20 2003 Gary Benson <gbenson@redhat.com> 3.0.1-3
186- call PyOS_AfterFork() after forking (#84610)
187
188* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 3.0.1-2
189- rebuilt
190
191* Mon Dec  9 2002 Gary Benson <gbenson@redhat.com> 3.0.1-1
192- upgrade to 3.0.1.
193
194* Mon Nov 18 2002 Gary Benson <gbenson@redhat.com> 3.0.0-12
195- upgrade to beta4.
196
197* Wed Nov  6 2002 Gary Benson <gbenson@redhat.com> 3.0.0-11
198- install libraries in lib64 when pertinent.
199
200* Fri Sep 13 2002 Gary Benson <gbenson@redhat.com>
201- add a filter example to /etc/httpd/conf.d/python.conf
202
203* Wed Sep 11 2002 Gary Benson <gbenson@redhat.com>
204- undisable filters (#73825)
205- fix filter lookup breakage
206
207* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 3.0.0-10
208- require httpd-mmn for module ABI compatibility
209
210* Tue Aug 28 2002 Gary Benson <gbenson@redhat.com> 3.0.0-9
211- remove empty files from the generated manual
212
213* Fri Aug 23 2002 Gary Benson <gbenson@redhat.com> 3.0.0-8
214- add built manual to snapshot tarball and install it (#69361)
215- add some examples to /etc/httpd/conf.d/python.conf (#71316)
216
217* Mon Aug 12 2002 Gary Benson <gbenson@redhat.com> 3.0.0-7
218- rebuild against httpd-2.0.40
219
220* Mon Jul 22 2002 Gary Benson <gbenson@redhat.com> 3.0.0-6
221- upgrade to latest CVS
222
223* Tue Jul  9 2002 Gary Benson <gbenson@redhat.com> 3.0.0-5
224- bring input filter API in line with 2.0.36 (#66566)
225
226* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 3.0.0-4
227- upgrade to latest CVS
228
229* Fri Jun 21 2002 Gary Benson <gbenson@redhat.com>
230- move /etc/httpd2 back to /etc/httpd
231
232* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 3.0.0-3
233- automated rebuild
234
235* Mon Jun 10 2002 Gary Benson <gbenson@redhat.com> 3.0.0-2
236- drop the CVS date from the release
237
238* Mon Jun 10 2002 Gary Benson <gbenson@redhat.com> 3.0.0-1.20020610
239- upgrade to latest CVS
240
241* Mon May 27 2002 Gary Benson <gbenson@redhat.com> 3.0.0-1.20020527
242- upgrade to latest CVS and change paths for httpd-2.0
243- make it build with 2.0.36
244- add the config file.
245
246* Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 2.7.8-2
247- rebuild in new environment
248
249* Mon Apr 22 2002 Nalin Dahyabhai <nalin@redhat.com> 2.7.8-1
250- update for RHSA-2002:070
251
252* Thu Feb 28 2002 Nalin Dahyabhai <nalin@redhat.com> 2.7.6-5
253- add patch for cleanups (#57232)
254
255* Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 2.7.6-4
256- rebuild with python 1.5
257
258* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
259- automated rebuild
260
261* Fri Jan 04 2002 Florian La Roche <Florian.LaRoche@redhat.de>
262- change for python 2.2
263
264* Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com>
265- update to 2.7.6
266
267* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
268- update to 2.7.5
269- add URL
270- move docs so that they live under %{contentdir}
271
272* Thu May 31 2001 Nalin Dahyabhai <nalin@redhat.com>
273- update to 2.7.3
274
275* Tue Jan 16 2001 Cristian Gafton <gafton@redhat.com>
276- fix module compilation paths
277- build first package for RHN
Note: See TracBrowser for help on using the repository browser.