source: projects/specs/trunk/m/mod_perl2/mod_perl2-vl.spec @ 5344

Revision 5344, 3.1 KB checked in by iwaim, 12 years ago (diff)

mod_perl2-2.0.5-1

Line 
1Summary: An embedded Perl interpreter for the Apache Web server Version 2
2Summary(ja): Apache2 Web サーバ用 組み込み Perl インタプリタ
3Name: mod_perl2
4Version: 2.0.5
5Release: 1%{?_dist_release}
6URL: http://perl.apache.org/
7Source0: http://perl.apache.org/dist/mod_perl-%{version}.tar.gz
8Source1: perl.conf
9Source2: filter-requires.sh
10Source3: filter-provides.sh
11License:  The Apache Software License, Version 2.0
12Group: System Environment/Daemons
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: apache2-devel >= 2.0.51
15BuildRequires: perl >= 5.6.0
16Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
17
18Vendor: Project Vine
19Distribution: Vine Linux
20
21%if %{?_dist_release} == "vl5" || %{?_dist_release} == "vl4"
22# Provide perl-specific find-{provides,requires}.
23%define __find_requires %{SOURCE2}
24%define __find_provides %{SOURCE3}
25%else
26%define __perl_requires %{SOURCE2}
27%endif
28
29%description
30Mod_perl incorporates a Perl interpreter into the Apache web server,
31so that the Apache web server can directly execute Perl code.
32Mod_perl links the Perl runtime library into the Apache web server and
33provides an object-oriented Perl interface for Apache's C language
34API.  The end result is a quicker CGI script turnaround process, since
35no external Perl interpreter has to be started.
36
37Install mod_perl if you're installing the Apache web server and you'd
38like for it to directly incorporate a Perl interpreter.
39
40
41%prep
42%setup -q -n mod_perl-%{version}
43
44
45%build
46perl Makefile.PL PREFIX=%{buildroot}/usr \
47  MP_APXS=%{_bindir}/apxs \
48  INSTALLDIRS=vendor
49make
50
51
52%install
53rm -rf %{buildroot}
54%makeinstall \
55  MODPERL_AP_INCLUDEDIR=%{buildroot}%{_includedir}/apache2 \
56  MODPERL_AP_LIBEXECDIR=%{buildroot}%{_libdir}/apache2/modules
57
58install -d -m 755 %{buildroot}%{_sysconfdir}/apache2/conf.d
59install -p -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/apache2/conf.d/
60
61find %{buildroot} -type f -name perllocal.pod -exec rm -f {} ';'
62find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
63
64chmod -R u+w %{buildroot}/*
65
66
67%clean
68rm -rf %{buildroot}
69
70
71%files
72%defattr(-,root,root)
73%doc Changes INSTALL LICENSE README* STATUS SVN-MOVE docs
74%config(noreplace) %{_sysconfdir}/apache2/conf.d/*.conf
75%{_bindir}/*
76%{_mandir}/man3/*
77%{_includedir}/apache2/mod_perl*
78%{_includedir}/apache2/modperl*
79%{_libdir}/apache2/modules/mod_perl.so
80%{perl_vendorarch}/*.pm
81%{perl_vendorarch}/APR
82%{perl_vendorarch}/Apache
83%{perl_vendorarch}/Apache2
84%{perl_vendorarch}/Bundle
85%{perl_vendorarch}/ModPerl
86%{perl_vendorarch}/auto
87
88
89%changelog
90* Fri Sep  9 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.5-1
91- new upstream release
92- add Requires: perl:(MODULE_COMPAT_x.y.z)
93- update Requires filter routine
94- add Vendor and Distribution tags
95
96* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.4-2
97- rebuilt with openldap-2.4.16
98
99* Fri Jan 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
100- new upstream release
101- new versioning policy
102- add default config file (SOURCE1) and prov/req filters (SOURCE2/3)
103- install under vendor_perl dir instead of site_perl
104
105* Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 1.99_09-0vl1
106- Initial build.
Note: See TracBrowser for help on using the repository browser.