source: projects/specs/trunk/m/ming/ming-vl.spec @ 9149

Revision 9149, 6.6 KB checked in by inagaki, 9 years ago (diff)

2014-12-12 Ryoichi INAGAKI <ryo1@…>

  • ming: updated


Line 
1Name:    ming
2Summary: A library for generating Macromedia Flash files
3Summary(ja): Macromedia Flash ファイル生成ライブラリ
4Version: 0.4.5
5Release: 1%{?_dist_release}
6
7Group:   System Environment/Libraries
8License: LGPLv2+
9URL:     http://www.libming.org/FrontPage
10
11Source0: http://downloads.sourceforge.net/project/ming/Releases/ming-%{version}.tar.bz2
12# make ming-config multilib-compatible
13Patch0: ming-multilib.patch
14# install perl modules to vendorarch dir and link dynamically with libming.so
15Patch1: ming-perl.patch
16
17# To build with giflib-4.2.x
18Patch100: ming-0.4.5-gif-error.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: bison
22BuildRequires: flex
23BuildRequires: freetype2-devel
24BuildRequires: giflib-devel
25BuildRequires: libpng-devel
26BuildRequires: perl
27BuildRequires: php5-devel
28BuildRequires: python-devel
29BuildRequires: swig
30BuildRequires: tcl
31BuildRequires: zlib-devel
32
33%description
34Ming is a library for generating Macromedia Flash files (.swf), written in C,
35and includes useful utilities for working with .swf files.
36
37%package devel
38Summary:    A library for generating Macromedia Flash files - development files
39Summary(ja): %{name} の開発用ファイル
40Group:      Development/Libraries
41Requires:   %{name} = %{version}-%{release}
42
43%description devel
44The ming-devel package includes the static libraries,
45header files, and developer docs for the ming package.
46
47%package python
48Summary:    Ming Python wrapper
49Group:      Development/Libraries
50Requires:   %{name} = %{version}-%{release}
51
52%description python
53%{summary}
54
55%package tcl
56Summary:    Ming Tcl wrapper
57Group:      Development/Libraries
58Requires:   %{name} = %{version}-%{release}
59Requires:   tcl
60
61%description tcl
62%{summary}
63
64%package perl
65Summary:    Ming Perl wrapper
66Group:      Development/Libraries
67Requires:   perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
68Provides:   perl-SWF = %{version}-%{release}
69
70%description perl
71%{summary}
72
73%package php
74Summary:    Ming PHP wrapper
75Group:      Development/Libraries
76Requires:   %{name} = %{version}-%{release}
77Requires:   php5
78
79%description php
80%{summary}
81
82%prep
83%setup -q
84%patch0 -p1 -b .multilib
85%patch1 -p1 -b .p
86%patch100 -p2 -b .p
87
88pushd src
89chmod -x actioncompiler/{compile,listaction}.* blocks/{matrix,outputblock}.* \
90         displaylist.* position.*
91popd
92iconv -f iso8859-1 -t utf8 -o ChangeLog.utf8 ChangeLog && \
93touch -r ChangeLog ChangeLog.utf8 && \
94mv ChangeLog.utf8 ChangeLog
95
96# force rebuild of python bindings
97rm py_ext/ming_wrap.c
98
99%build
100%configure \
101    --disable-static \
102    --enable-python \
103    --enable-tcl \
104    --enable-php \
105    --enable-perl \
106    --with-pic \
107
108sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
109sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
110make V=1 %{?_smp_mflags}
111
112%install
113[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
114make install DESTDIR=$RPM_BUILD_ROOT \
115        pkgconfigdir=%{_libdir}/pkgconfig \
116        docdir=$RPM_BUILD_ROOT%{_docdir}/%{name}
117
118find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
119find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
120chmod 755 $RPM_BUILD_ROOT%{perl_vendorarch}/auto/SWF/*.so
121make -C ./docs/man mandir=$RPM_BUILD_ROOT%{_mandir} install-man1
122make -C ./docs/man mandir=$RPM_BUILD_ROOT%{_mandir} install-man3
123
124%post -p /sbin/ldconfig
125%post python -p /sbin/ldconfig
126%post tcl -p /sbin/ldconfig
127%post perl -p /sbin/ldconfig
128%post php -p /sbin/ldconfig
129%postun -p /sbin/ldconfig
130%postun python -p /sbin/ldconfig
131%postun tcl -p /sbin/ldconfig
132%postun perl -p /sbin/ldconfig
133%postun php -p /sbin/ldconfig
134
135%clean
136[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
137
138%files
139%defattr(-,root,root)
140%doc README AUTHORS COPYING ChangeLog
141%{_bindir}/*
142%{_libdir}/libming*.so.*
143%{_mandir}/man1/*
144
145%files devel
146%defattr(-, root, root)
147%{_includedir}/*
148%{_libdir}/libming.so
149%{_libdir}/pkgconfig/*.pc
150%{_mandir}/man3/*
151%exclude %{_mandir}/man3/SWF*.3pm*
152%exclude %{_libdir}/*.la
153
154%files python
155%defattr(-, root, root)
156%{python_sitearch}/*.so
157%{python_sitearch}/*.py*
158%{python_sitearch}/mingc-%{version}-py%{pyver}.egg-info
159
160%files tcl
161%defattr(-, root, root)
162%{_libdir}/%{name}/tcl/*.so
163%exclude %{_libdir}/%{name}/tcl/*.la
164
165%files perl
166%defattr(-, root, root)
167%{_libdir}/perl5/*
168%{_mandir}/man3/SWF*.3pm*
169
170%files php
171%defattr(-, root, root)
172%{_libdir}/php5/*
173
174%changelog
175* Fri Dec 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.4.5-1
176- updated to 0.4.5
177- added Patch0, 1 and 100
178- built with libpng 1.6.12, giflib 4.2.3 and perl 5.16.3
179- updated URL
180
181* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.3-2
182- rebuilt with rpm-4.8.1 for pkg-config
183
184* Tue Feb 16 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.3-1
185- updated ming to 0.4.3
186- added %{name}-python, -tcl, -perl, -php sub packages
187- added BR: swig python-devel php-devel
188
189* Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 0.4.2-1vl5
190- updated ming to 0.4.2
191- added tags: BuildRequires Requires
192- added sub package: ming-devel
193- added script at %%clean
194- applied new versioning policy, spec in utf-8
195
196* Wed Sep 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2a-4vl3
197- fixed args type of addString function (Patch1)
198- added Japanese Summary
199
200* Sat May 15 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2a-4vl2
201- removed Vendor: tag
202- fixed post and postun section
203
204* Sat May 15 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2a-4vl1
205- rebuild for Vine Linux
206- based on TLD 10, but removed Serial:
207
208* Thu Apr 24 2003 Noriyuki Suzuki <noriyuki@turbolinux.co.jp>
209- modified spec file for x86_64.
210
211* Thu Feb 28 2002 Kiichiro NAKA <knaka@turbolinux.co.jp>
212- I have gotten SRPM from http://rpms.arvin.dk/ming/source/
213
214* Tue Aug 21 2001 Troels Arvin <troels@arvin.dk>
215  [0.2a-2.arvin]
216- Add Hansuck Jo's listmp3.c patch.
217- Build and include some of the utils.
218
219* Mon Aug 20 2001 Troels Arvin <troels@arvin.dk>
220  [0.2a-1.arvin]
221- Uses new source version.
222
223* Sat Apr 14 2001 Troels Arvin <troels@arvin.dk>
224  [0.1.1-3.arvin]
225- Added distribution to release-tag.
226
227* Sat Apr 14 2001 Troels Arvin <troels@arvin.dk>
228  [0.1.1-2.arvin]
229- Fixed a permission problem for the documentation
230  area.
231* Sat Apr 14 2001 Troels Arvin <troels@arvin.dk>
232  [0.1.1-1.arvin]
233- Rebuilt with new source version.
234* Mon Mar 19 2001 Troels Arvin <troels@arvin.dk>
235  [0.1.0-1.arvin]
236- Rebuilt with new source version. Patches shouldn't be need
237  any more.
238* Mon Jan 29 2001 Troels Arvin <troels@arvin.dk>
239  [0.0.9c-1.arvin]
240- First Ming RPM package. Currently, the RPM doesn't include
241  anyting but the shared library and the C-oriented include
242  file. None of the wrappers for other languages are handled by this
243  RPM, currently. Also, none of the utilities are included in the
244  package yet.
Note: See TracBrowser for help on using the repository browser.