source: projects/specs/trunk/m/migemo/migemo-vl.spec @ 9515

Revision 9515, 4.8 KB checked in by inagaki, 9 years ago (diff)

2015-04-17 Ryoichi INAGAKI <ryo1@…>

  • auto-install, js2-mode, lua-mode, migemo, php-mode, po-mode: updated


Line 
1## -*- coding: utf-8-unix -*-
2%define   _noVersionedDependencies        1
3%define   prereq_ge()   %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
4%define   origname      migemo
5%define   origver       1.9.1
6%define   release       1%{?_dist_release}
7
8Name:     %{origname}
9Version:  %{origver}
10Release:  %{release}
11
12Summary: Japanese incremental search with Romaji on Emacsen
13Summary(ja): Emacsen 上でローマ字を使って日本語インクリメントサーチを行うツール
14License: GPLv2+
15Group: Applications/Editors/Emacs
16URL: http://0xcc.net/migemo/
17
18Source0: https://github.com/emacs-jp/migemo/archive/%{version}.tar.gz
19Source1: migemo-install.sh
20Source2: migemo-remove.sh
21Source3: vine-default-migemo.el
22Source4: migemo-init.el
23
24BuildArch: noarch
25Buildroot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: emacsen
27Requires: cmigemo
28Requires: emacsen
29Requires: apel
30Requires(post): emacsen
31Requires(preun): emacsen
32%prereq_ge emacsen-common
33
34%description
35Japanese incremental search with Romaji on Emacsen
36
37%description -l ja
38Emacsen 上でローマ字を使って日本語インクリメントサーチを行うツールです。
39
40%prep
41%setup -q -n %{origname}-%{origver}
42#patch0 -p 1 -b .debian
43
44%build
45
46%install
47[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
48[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
49
50mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
51mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
52mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
53
54install -m644 migemo.el %{SOURCE3} %{SOURCE4} \
55      $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{origname}
56
57#
58# install  script( bytecompile el and install elc , remove )   
59#
60%_installemacsenscript %{origname} %{SOURCE1}
61
62%_removeemacsenscript  %{origname} %{SOURCE2}
63
64%post
65#
66# bytecompile and install
67#
68
69if [ "$1" = 2 ]; then
70
71%_emacsenPackageRemove %{origname}
72
73fi
74
75%_addemacsenlist %{origname}
76
77%_emacsenPackageInstall %{origname}
78
79
80%preun
81if [ "$1" = 0 ]; then
82
83%_emacsenPackageRemove %{origname}
84
85%_removeemacsenlist %{origname}
86
87fi
88
89%clean
90[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
91
92rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
93
94%files
95%defattr(-,root,root)
96%doc README.md images/migemo.png
97%{_datadir}/emacs/site-lisp/%{origname}
98%{emacsen_pkgdir}/install/%{origname}
99%{emacsen_pkgdir}/remove/%{origname}
100
101%changelog
102* Fri Apr 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.9.1-1
103- updated to 1.9.1
104
105* Fri Dec 14 2012 IWAI, Masaharu <iwai@alib.jp> 0.40-6
106- update migemo-install.sh (Source1)
107
108* Thu Nov 29 2012 IWAI, Masaharu <iwai@alib.jp> 0.40-5
109- using C/Migemo
110  - update Requires and BuildRequires
111  - update migemo-install.sh
112  - update vine-default-migemo.el
113
114* Sun Feb 19 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.40-4
115- updated migemo-init.el
116
117* Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.40-3
118- use %%{emacsen_pkgdir}
119
120* Tue May  5 2009 IWAI, Masaharu <iwai@alib.jp> 0.40-2
121- spec in UTF-8
122- drop Prefix tag
123- fix BuildRequires: emacs to emacsen
124- apply vine-default
125  - update migemo-install.sh (Source1)
126  - update migemo-remove.sh (Source2)
127  - add vine-default-migemo.el (Source3)
128  - add migemo-init.el (Source4)
129- update %%flies section
130  - add %%{_datadir}/emacs/site-lisp/%%{origname} directory
131
132* Tue Sep 16 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.40-1
133- applied new versioning policy
134- updated Source0 URL, URL:
135- updated BuildRequires:
136
137* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.40-0vl9
138- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
139
140* Fri Oct 22 2004 IWAI, Masaharu <iwai@alib.jp> 0.40-0vl7
141- add Japanese summary and description
142
143* Tue Jun 15 2004 IWAI, Masaharu <iwai@alib.jp> 0.40-0vl6
144- update migemo-install.sh (Source1):
145    touch a few files: aclocal.m4 Makefile.in configure
146
147* Sun Dec 28 2003 IWAI, Masaharu <iwai@alib.jp> 0.40-0vl5
148- fix Requires
149
150* Fri Oct 10 2003 IWAI, Masaharu <iwai@alib.jp> 0.40-0vl4
151- update {Build,}Requires: more exact
152
153* Tue Oct  7 2003 IWAI, Masaharu <iwai@alib.jp> 0.40-0vl3
154- build with ruby-1.8.0
155
156* Sun Jun  1 2003 IWAI Masaharu <iwai@alib.jp> 0.40-0vl2
157- fix byte compile routine ([VineSeed-Plus:01695])
158   - cp -ar migemo.rb.in migemo %%{_datadir}/emacs/site-lisp/%%{origname}
159   - update migemo-install.sh (Source1)
160
161* Fri May 30 2003 IWAI Masaharu <iwai@alib.jp> 0.40-0vl1
162- upstream release
163
164* Fri Mar 21 2003 IWAI Masaharu <iwai@alib.jp> 0.32-0vl4
165- rebuild
166
167* Sat Feb 16 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.32-0vl3
168- rebuild with ruby-romkan-0.4-0vl1
169
170* Wed Feb  6 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.32-0vl2
171- moved the directory installed the ruby library
172    - sitelibdir -> rubylibdir
173- added BuildRequires: ruby, rpm >= 3.0.6-0vl16
174
175* Wed Jan  2 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.32-0vl1
176- first release for VIne Linux
177
178* Fri Sep  7 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
179- 0.32-1
180- first release.
Note: See TracBrowser for help on using the repository browser.