source: projects/specs/trunk/m/midori/midori-vl.spec @ 617

Revision 617, 5.7 KB checked in by kudoh, 14 years ago (diff)
Line 
1Summary:        A lightweight GTK+ web browser
2Summary(ja):    軽量な GTK+ ウェブブラウザ
3Name:           midori
4Version:        0.2.4
5Release:        1%{?_dist_release}
6
7Group:          Applications/Internet
8License:        LGPLv2.1+
9URL:            http://software.twotoasts.de/?page=midori
10
11Source0:        http://software.twotoasts.de/media/%{name}/%{name}-%{version}.tar.bz2
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14
15BuildRequires:  desktop-file-utils
16BuildRequires:  gettext
17BuildRequires:  libsexy-devel
18BuildRequires:  libtool
19BuildRequires:  libxml2-devel >= 2.6
20BuildRequires:  perl-XML-Parser
21BuildRequires:  WebKit-gtk-devel >= 1.1.6
22
23## for IDN support
24BuildRequires:  libidn-devel >= 1.0
25## for Single instance
26BuildRequires:  unique-devel >= 0.9
27## for Persistent history
28BuildRequires:  sqlite3-devel >= 3.0
29BuildRequires:  glib2-devel >= 2.16.0
30BuildRequires:  gtk2-devel >= 2.10.0
31BuildRequires:  libsoup-devel >= 2.25.2
32## for Icon optimizations: /usr/bin/rsvg-convert
33BuildRequires:  librsvg2
34## for User documentation
35BuildRequires:  docutils
36## for API documentation
37#BuildRequires:  gtk-doc
38
39Requires:       WebKit-gtk
40
41%description
42Midori is a lightweight web browser, and has many features expected of a
43modern browser, including:
44* Full integration with GTK+2.
45* Fast rendering with WebKit.
46* Tabs, windows and session management.
47* Bookmarks are stored with XBEL.
48* Searchbox based on OpenSearch.
49* Custom context menu actions.
50* User scripts and user styles support.
51* Extensible via Lua scripts.
52
53The project is currently in an early alpha state. The features are still being
54implemented, and some are still quite incomplete.
55
56%description -l ja
57Midori は軽量な Web ブラウザで、多くの機能がモダンブラウザとして期待されています。
58以下の機能が含まれています。:
59* GTK+2 に完全に統合。
60* WebKit で高速なレンダリング。
61* タブ、ウィンドウおよびセッションの管理。
62* ブックマークは XBEL で格納。
63* OpenSearch に基づくサーチボックス。
64* カスタムコンテキストメニューの操作。
65* ユーザースクリプトとユーザースタイルをサポート。
66* Lua スクリプトを介して拡張可能。
67
68プロジェクトは現在初期アルファの状態にあります。
69機能はまだ実装中で、一部はかなり不完全です。
70
71%prep
72%setup -q
73
74
75%build
76export CFLAGS="%{optflags}"
77./waf   --prefix=%{_usr}                        \
78        --docdir=%{_docdir}/%{name}-%{version}  \
79        --libdir=%{_libdir}                     \
80        configure \
81            --disable-hildon
82./waf %{?_smp_mflags} build
83
84
85%install
86rm -rf %{buildroot}
87./waf --destdir=%{buildroot} install
88%find_lang %{name}
89desktop-file-install                                    \
90        --vendor ""                                     \
91        --delete-original                               \
92        --dir %{buildroot}%{_datadir}/applications      \
93        %{buildroot}%{_datadir}/applications/%{name}.desktop
94
95
96%clean
97rm -rf %{buildroot}
98
99%post
100touch --no-create %{_datadir}/icons/hicolor
101if [ -x /usr/bin/gtk-update-icon-cache ]; then
102  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
103fi
104
105%postun
106touch --no-create %{_datadir}/icons/hicolor
107if [ -x /usr/bin/gtk-update-icon-cache ]; then
108  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
109fi
110
111
112%files -f %{name}.lang
113%defattr(-,root,root,-)
114%doc AUTHORS ChangeLog COPYING README TODO
115%dir %{_sysconfdir}/xdg/midori
116%{_sysconfdir}/xdg/midori/*
117#%{_sysconfdir}/%{name}/
118%{_bindir}/midori
119%dir %{_libdir}/midori
120%{_libdir}/midori/*.so
121%{_datadir}/midori/*
122%{_datadir}/applications/%{name}.desktop
123%{_datadir}/icons/hicolor/*/*/*.png
124
125
126%changelog
127* Sat Mar 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.2.4-1
128- new upstream release
129- applied new naming policy to spec
130
131* Thu Feb 25 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.2.3-1
132- new upstream release
133
134* Mon Dec 28 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.2.2-1
135- new upstream release
136
137* Sat Nov 14 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.2.1-1
138- new upstream release
139
140* Fri Oct 16 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.2.0-1
141- new upstream release
142- fixed BuildRequires:  perl-XML-Parser
143
144* Sun Sep 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.1.10-1
145- new upstream release
146
147* Sun Aug 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.1.9-1
148- new upstream release
149
150* Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.1.8-2
151- added Japanese description
152- fixed BuildRequires:  perl(XML::Parser) to perl-XML-Parser
153
154* Sun Jul 26 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.1.8-1
155- new upstream release
156- few changed in %files seciton
157
158* Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.6-1
159- new upstream release
160- add BR: WebKit-gtk-devel >= 1.1.6
161- add --disable-hildon to configure option
162
163* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.4-1
164- new upstream release
165- drop old ja.po
166
167* Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.1-1
168- new upstream release
169
170* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.19-1
171- new upstream release
172- update ja.po
173
174* Fri Jul 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  0.0.18-1
175- initial build for Vine Linux
176- add initial ja.po
177
178* Sat May 24 2008 Peter Gordon <peter@thecodergeek.com> - 0.0.18-1
179- Update to new upstream release (0.0.18), adds some translations and
180  a lot of bug-fixes.
181- Alphabetize dependency list (aesthetic-only change).
182
183* Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> - 0.0.17-3
184- Rebuild for updated WebKit library so-name and include directory.
185
186* Mon Mar 03 2008 Peter Gordon <peter@thecodergeek.com> - 0.0.17-2
187- Cleanups from review (bug 435661):
188  (1) Fix consistency of tabs/spaces usage.
189  (2) Fix source permissions.
190  (3) Add desktop-file-utils build dependency.
191
192* Sun Mar 02 2008 Peter Gordon <peter@thecodergeek.com> - 0.0.17-1
193- Initial packaging for Fedora.
Note: See TracBrowser for help on using the repository browser.