source: projects/specs/trunk/m/mgetty/mgetty-vl.spec @ 521

Revision 521, 15.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _sysconfdir /etc
2%define using_netpbm 1
3%define have_mkdtemp 1
4#%%define have_mkdtemp 0
5
6Summary: A getty replacement for use with data and fax modems.
7Name: mgetty
8Version: 1.1.25
9Release: 5vl4
10Source: ftp://ftp.leo.org/pub/comp/os/unix/networking/mgetty/mgetty%{version}-Feb01.tar.gz
11Source1: logrotate.mgetty
12Source2: logrotate.sendfax
13Source3: logrotate.vgetty
14Source4: logrotate.vm
15Patch0: http://www-internal.alphanet.ch/~schaefer/vgetty/global_patches/CURRENT/mgetty-1.1.25-to-11032001.bz2
16Patch1: mgetty-1.1.22-config.patch
17Patch2: mgetty-1.1.26-policy.patch
18Patch3: mgetty-1.1.25-faxprint.patch
19Patch4: mgetty-1.1.21-giftopnm.patch
20Patch5: mgetty-1.1.25-voiceconfig.patch
21Patch6: mgetty-1.1.25-elsa.patch
22License: GPL
23Group: Applications/Communications
24Prereq: /sbin/install-info
25BuildPrereq: groff, tetex, texinfo
26Buildroot: %{_tmppath}/%{name}-root
27Requires: mktemp
28URL: http://www.leo.org/~doering/mgetty/index.html
29
30%package sendfax
31Summary: Provides support for sending faxes over a modem.
32Requires: mgetty = %{version}
33Group: Applications/Communications
34%if %{using_netpbm}
35Requires: netpbm-progs
36%else
37Requires: libgr-progs
38%endif
39
40%package voice
41Summary: A program for using your modem and mgetty as an answering machine.
42Requires: mgetty = %{version}
43Group: Applications/Communications
44
45%package viewfax
46Summary: An X Window System fax viewer.
47Group: Applications/Communications
48
49%description
50The mgetty package contains a "smart" getty which allows logins over a
51serial line (i.e., through a modem).  If you're using a Class 2 or 2.0
52modem, mgetty can receive faxes.  If you also need to send faxes,
53you'll need to install the sendfax program.
54
55If you'll be dialing in to your system using a modem, you should
56install the mgetty package.  If you'd like to send faxes using mgetty
57and your modem, you'll need to install the mgetty-sendfax program.  If
58you need a viewer for faxes, you'll also need to install the
59mgetty-viewfax package.
60
61%description sendfax
62Sendfax is a standalone backend program for sending fax files.  The
63mgetty program (a getty replacement for handling logins over a serial
64line) plus sendfax will allow you to send faxes through a Class 2
65modem.
66
67If you'd like to send faxes over a Class 2 modem, you'll need to
68install the mgetty-sendfax and the mgetty packages.
69
70%description voice
71The mgetty-voice package contains the vgetty system, which enables
72mgetty and your modem to support voice capabilities.  In simple terms,
73vgetty lets your modem act as an answering machine.  How well the
74system will work depends upon your modem, which may or may not be able
75to handle this kind of implementation.
76
77Install mgetty-voice along with mgetty if you'd like to try having
78your modem act as an answering machine.
79
80%description viewfax
81Viewfax displays the fax files received using mgetty in an X11 window.
82Viewfax is capable of zooming in and out on the displayed fax.
83
84If you're installing the mgetty-viewfax package, you'll also need to
85install mgetty.
86
87%prep
88%setup -q
89%patch0 -p1 -b .vgetty
90%patch1 -p1 -b .config
91%patch2 -p1 -b .policy
92%patch3 -p1 -b .faxprint
93%if %{using_netpbm}
94%patch4 -p1 -b .giftopnm
95%endif
96%patch5 -p1 -b .voiceconfig
97# Should be outdated by the vgetty patch.
98#%patch6 -p1 -b .elsa
99cp policy.h-dist policy.h
100
101%build
102%define makeflags CFLAGS="$RPM_OPT_FLAGS -Wall -DAUTO_PPP"                                        CONFDIR=%{_sysconfdir}/mgetty+sendfax                                           ECHO="'echo -e'" prefix=%{_prefix}
103
104make %{makeflags}
105make -C voice %{makeflags}
106make -C tools %{makeflags}
107
108%if %{have_mkdtemp}
109MKDTEMP_FLAGS=
110%else
111MKDTEMP_FLAGS=-DNEED_MKDTEMP
112%endif
113
114pushd frontends/X11/viewfax-2.5
115xmkmf
116make depend
117make CDEBUGFLAGS="$RPM_OPT_FLAGS $MKDTEMP_FLAGS" CONFDIR=%{_sysconfdir}/mgetty+sendfax
118popd
119
120%install
121rm -rf $RPM_BUILD_ROOT
122
123mkdir -p $RPM_BUILD_ROOT{%{_bindir},%{_infodir},%{_libdir}/mgetty+sendfax}
124mkdir -p $RPM_BUILD_ROOT{%{_mandir},%{_sbindir},/sbin,/var/spool}
125
126%define instflags                                                                       CFLAGS="$RPM_OPT_FLAGS"                                                         prefix=$RPM_BUILD_ROOT%{_prefix}                                                spool=$RPM_BUILD_ROOT%{_var}/spool                                              BINDIR=$RPM_BUILD_ROOT%{_bindir}                                                SBINDIR=$RPM_BUILD_ROOT%{_sbindir}                                              LIBDIR=$RPM_BUILD_ROOT%{_libdir}/mgetty+sendfax                                 HELPDIR=$RPM_BUILD_ROOT%{_libdir}/mgetty+sendfax                                CONFDIR=$RPM_BUILD_ROOT%{_sysconfdir}/mgetty+sendfax                            MANDIR=$RPM_BUILD_ROOT%{_mandir}                                                MAN1DIR=$RPM_BUILD_ROOT%{_mandir}/man1                                          MAN4DIR=$RPM_BUILD_ROOT%{_mandir}/man4                                          MAN5DIR=$RPM_BUILD_ROOT%{_mandir}/man5                                          MAN8DIR=$RPM_BUILD_ROOT%{_mandir}/man8                                          INFODIR=$RPM_BUILD_ROOT%{_infodir}                                              ECHO='echo -e' INSTALL=%{__install}
127make install %instflags
128install -m700 callback/callback $RPM_BUILD_ROOT%{_sbindir}
129install -m4711 callback/ct $RPM_BUILD_ROOT%{_bindir}
130
131gzip -9n $RPM_BUILD_ROOT%{_infodir}/*
132
133mv $RPM_BUILD_ROOT%{_sbindir}/mgetty $RPM_BUILD_ROOT/sbin
134
135# this conflicts with efax
136mv $RPM_BUILD_ROOT%{_mandir}/man1/fax.1 $RPM_BUILD_ROOT%{_mandir}/man1/mgetty_fax.1
137
138# tools
139make -C tools install %instflags
140
141# voice mail extensions
142mkdir -p $RPM_BUILD_ROOT%{_var}/spool/voice/{messages,incoming}
143make -C voice install %instflags
144mv $RPM_BUILD_ROOT%{_sbindir}/vgetty $RPM_BUILD_ROOT/sbin
145install -m 600 -c voice/voice.conf-dist $RPM_BUILD_ROOT%{_sysconfdir}/mgetty+sendfax/voice.conf
146
147# don't ship documentation that is executable...
148find samples -type f -exec chmod 644 {} \;
149
150make -C frontends/X11/viewfax-2.5 install %instflags
151make -C frontends/X11/viewfax-2.5 install.man %instflags MANDIR=$RPM_BUILD_ROOT%{_mandir}/man1
152
153# install logrotate control files
154mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
155install -m 0644 $RPM_SOURCE_DIR/logrotate.mgetty  $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/mgetty
156install -m 0644 $RPM_SOURCE_DIR/logrotate.sendfax $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/sendfax
157install -m 0644 $RPM_SOURCE_DIR/logrotate.vgetty  $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/vgetty
158install -m 0644 $RPM_SOURCE_DIR/logrotate.vm      $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/vm
159
160%clean
161rm -rf $RPM_BUILD_ROOT
162
163%post
164/sbin/install-info %{_infodir}/mgetty.info.gz %{_infodir}/dir --entry="* mgetty: (mgetty).              Package to handle faxes, voicemail and more."
165
166%preun
167if [ $1 = 0 ]; then
168    /sbin/install-info --delete %{_infodir}/mgetty.info.gz %{_infodir}/dir --entry="* mgetty: (mgetty).         Package to handle faxes, voicemail and more."
169fi
170
171%files
172%defattr(-,root,root)
173%doc BUGS ChangeLog README.1st Recommend THANKS doc/modems.db samples
174%doc doc/mgetty.ps doc/*.txt
175/sbin/mgetty
176%{_sbindir}/callback
177%{_mandir}/man4/mgettydefs.4*
178%{_mandir}/man8/mgetty.8*
179%{_mandir}/man8/callback.8*
180%{_infodir}/mgetty.info*
181%dir %{_sysconfdir}/mgetty+sendfax
182%config %{_sysconfdir}/mgetty+sendfax/login.config
183%config %{_sysconfdir}/mgetty+sendfax/mgetty.config
184%config %{_sysconfdir}/mgetty+sendfax/dialin.config
185%config %{_sysconfdir}/logrotate.d/mgetty
186
187%files sendfax
188%defattr(-,root,root)
189%dir %{_var}/spool/fax
190%dir %{_var}/spool/fax/incoming
191%dir %{_var}/spool/fax/outgoing
192%dir %{_var}/spool/fax/outgoing/locks
193%attr(0755,root,root) %{_bindir}/ct
194%{_bindir}/faxq
195%{_bindir}/faxrm
196%{_bindir}/faxrunq
197%{_bindir}/faxspool
198%{_bindir}/g3cat
199%{_bindir}/g32pbm
200%{_bindir}/kvg
201%{_bindir}/newslock
202%{_bindir}/pbm2g3
203%{_sbindir}/faxrunqd
204%{_sbindir}/sendfax
205%dir %{_libdir}/mgetty+sendfax
206%{_libdir}/mgetty+sendfax/cour25.pbm
207%{_libdir}/mgetty+sendfax/cour25n.pbm
208%{_mandir}/man1/g32pbm.1*
209%{_mandir}/man1/pbm2g3.1*
210%{_mandir}/man1/g3cat.1*
211%{_mandir}/man1/mgetty_fax.1*
212%{_mandir}/man1/faxspool.1*
213%{_mandir}/man1/faxrunq.1*
214%{_mandir}/man1/faxq.1*
215%{_mandir}/man1/faxrm.1*
216%{_mandir}/man1/coverpg.1*
217%{_mandir}/man5/faxqueue.5*
218%{_mandir}/man8/faxrunqd.8*
219%{_mandir}/man8/sendfax.8*
220%dir %{_sysconfdir}/mgetty+sendfax
221%config %{_sysconfdir}/mgetty+sendfax/sendfax.config
222%config %{_sysconfdir}/mgetty+sendfax/faxrunq.config
223%config %{_sysconfdir}/mgetty+sendfax/faxspool.rules.sample
224%config %{_sysconfdir}/mgetty+sendfax/faxheader
225%config %{_sysconfdir}/logrotate.d/sendfax
226
227%files voice
228%defattr(-,root,root)
229%doc voice/doc/* voice/Announce voice/ChangeLog voice/Readme
230%dir %{_var}/spool/voice
231%dir %{_var}/spool/voice/incoming
232%dir %{_var}/spool/voice/messages
233/sbin/vgetty
234%{_bindir}/vm
235%{_bindir}/pvfamp
236%{_bindir}/pvfcut
237%{_bindir}/pvfecho
238%{_bindir}/pvffft
239%{_bindir}/pvffile
240%{_bindir}/pvffilter
241%{_bindir}/pvfmix
242%{_bindir}/pvfnoise
243%{_bindir}/pvfreverse
244%{_bindir}/pvfsine
245%{_bindir}/pvfspeed
246%{_bindir}/rmdfile
247%{_bindir}/pvftormd
248%{_bindir}/rmdtopvf
249%{_bindir}/pvftovoc
250%{_bindir}/voctopvf
251%{_bindir}/pvftolin
252%{_bindir}/lintopvf
253%{_bindir}/pvftobasic
254%{_bindir}/basictopvf
255%{_bindir}/pvftoau
256%{_bindir}/autopvf
257%{_bindir}/pvftowav
258%{_bindir}/wavtopvf
259%{_mandir}/man1/zplay.1*
260%{_mandir}/man1/pvf.1*
261%{_mandir}/man1/pvfamp.1*
262%{_mandir}/man1/pvfcut.1*
263%{_mandir}/man1/pvfecho.1*
264%{_mandir}/man1/pvffile.1*
265%{_mandir}/man1/pvffft.1*
266%{_mandir}/man1/pvfmix.1*
267%{_mandir}/man1/pvfreverse.1*
268%{_mandir}/man1/pvfsine.1*
269%{_mandir}/man1/pvfspeed.1*
270%{_mandir}/man1/pvftormd.1*
271%{_mandir}/man1/rmdtopvf.1*
272%{_mandir}/man1/rmdfile.1*
273%{_mandir}/man1/pvftovoc.1*
274%{_mandir}/man1/voctopvf.1*
275%{_mandir}/man1/pvftolin.1*
276%{_mandir}/man1/lintopvf.1*
277%{_mandir}/man1/pvftobasic.1*
278%{_mandir}/man1/basictopvf.1*
279%{_mandir}/man1/pvftoau.1*
280%{_mandir}/man1/autopvf.1*
281%{_mandir}/man1/pvftowav.1*
282%{_mandir}/man1/wavtopvf.1*
283%dir %{_sysconfdir}/mgetty+sendfax
284%config %{_sysconfdir}/mgetty+sendfax/voice.conf
285%config %{_sysconfdir}/logrotate.d/vgetty
286%config %{_sysconfdir}/logrotate.d/vm
287
288%files viewfax
289%defattr(-,root,root)
290%doc frontends/X11/viewfax-2.5/C* frontends/X11/viewfax-2.5/README
291%{_bindir}/viewfax
292%dir %{_libdir}/mgetty+sendfax
293%{_libdir}/mgetty+sendfax/viewfax.tif
294%{_mandir}/man1/viewfax.1x*
295
296%changelog
297* Wed Dec 19 2001 Toru Sagami <sagami@vinelinux.org> 1.1.25-5vl4
298- change %%define mkdtemp 1 in oreder to build on glibc22 system
299
300* Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.25-5vl3
301- BuildPreReq: pTex, pLaTeX2e -> tetex again :)
302- (Machino-san previously put 5vl2, but the src.rpm was gone...)
303
304* Thu May 24 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
305- 1.1.25-5vl1
306- based on 1.1.25-5 from RH 7.1 security update
307- BuildPreReq pTeX and pLaTeX2e instead of tetex and tetex-latex
308- change %%define mkdtemp 0 (current Vine is based on glibc-2.1.3 yet)
309
310* Wed Apr 18 2001 Nalin Dahyabhai <nalin@redhat.com>
311- define _sysconfdir, not sysconfdir
312
313* Mon Apr 16 2001 Nalin Dahyabhai <nalin@redhat.com>
314- add logrotate.vm and logrotate.vgetty (note from Heiner Kordewiner)
315- add voice/{Announce,Changelog,Readme} to documentation set
316
317* Tue Apr 10 2001 Nalin Dahyabhai <nalin@redhat.com>
318- define CNDFILE in policy.h
319
320* Tue Mar 20 2001 Nalin Dahyabhai <nalin@redhat.com>
321- change the default group in the vgetty configuration file from phone to uucp,
322  which matches the settings for faxes
323
324* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
325- update to 1.1.25
326- ditch the elsa patch in favor of the current vgetty patch
327- don't need to strip binaries, buildroot policies do that
328- add docs to the voice subpackage
329
330* Tue Jan 16 2001 Nalin Dahyabhai <nalin@redhat.com>
331- use mkdtemp() when printing faxes
332
333* Mon Jan 15 2001 Preston Brown <pbrown@redhat.com>
334- fix misdetection of USR voice modem detection <cjj@u.washington.edu>
335
336* Mon Jan 08 2001 Preston Brown <pbrown@redhat.com>
337- 1.1.24 includes tmpfile security enhancements, some of our patches
338
339* Tue Sep 19 2000 Nalin Dahyabhai <nalin@redhat.com>
340- back out quoting patch
341- change Copyright: distributable to License: GPL
342- add URL
343- remove logging changes from excl patch, based on input from Gert
344- rework ia64 patch, break out gets/fgets change based on input from Gert
345
346* Thu Sep  7 2000 Nalin Dahyabhai <nalin@redhat.com>
347- make sure all scripts quote variables where possible (#17179)
348- make sure all scripts use mktemp for generating temporary files
349
350* Sat Aug 26 2000 Bill Nottingham <notting@redhat.com>
351- update to 1.1.22; fixes security issues
352
353* Mon Aug  7 2000 Nalin Dahyabhai <nalin@redhat.com>
354- fix excl patch to keep everything from segfaulting all the time (#11523,11590)
355
356* Mon Jul 24 2000 Nalin Dahyabhai <nalin@redhat.com>
357- forcibly strip binaries (#12431)
358- change dependency on libgr-progs (which is gone) to netgr-progs (#10819)
359- change dependency on giftoppm to giftopnm (#8088)
360- attempt to plug some potential security problems (#11874)
361
362* Thu Jul 12 2000 Than Ngo <than@redhat.de>
363- add new V250modem patch from ELSA (thanks to JÓgen Kosel)
364
365* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
366- automatic rebuild
367
368* Fri Jun 23 2000 Than Ngo <than@redhat.de>
369- add support ELSA Microlink 56k
370
371* Sun Jun  4 2000 Nalin Dahyabhai <nalin@redhat.com>
372- Overhaul for FHS fixes.
373- Stop removing logs in postun.
374- Stop stripping everything.
375- ia64 fixes.
376
377* Wed May 17 2000 Ngo Than <than@redhat.de>
378- updated the new vgetty (#bug 10440)
379
380* Sat May  6 2000 Bill Nottingham <notting@redhat.com>
381- fix compilation with new gcc, or ia64, or something...
382
383* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
384- rebuild for sparc baud rates > 38400.
385
386* Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
387- man pages are compressed
388
389* Tue Sep  7 1999 Jeff Johnson <jbj@redhat.com>
390- add fax print command (David Fox).
391
392* Tue Sep 07 1999 Cristian Gafton <gafton@redhat.com>
393- version 1.1.21
394
395* Tue Aug 31 1999 Jeff Johnson <jbj@redhat.com>
396- move callback to base package (#4799).
397
398* Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
399- update to 1.1.20 (#3216).
400
401* Tue Apr  6 1999 Bill Nottingham <notting@redhat.com>
402- strip setuid bit from ct
403
404* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
405- better log handling
406
407* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
408- rebuild for glibc 2.1
409
410* Sat Aug 22 1998 Jos Vos <jos@xos.nl>
411- Use a patch for creating policy.h using policy.h-dist.
412- Add viewfax subpackage (X11 fax viewing program).
413- Add logrotate config files for mgetty and sendfax log files.
414- Properly define ECHO in Makefile for use with bash.
415- Add optional use of dialin.config (for modems supporting this).
416- Change default notification address to "root" (was "faxadmin").
417- Change log file names according to better defaults.
418- Change default notify program to /etc/mgetty+sendfax/new_fax (was
419  /usr/local/bin/new_fax).
420
421* Fri Aug 21 1998 Jeff Johnson <jbj@redhat.com>
422- add faxrunqd man page (problem #850)
423- add missing pbm2g3 (and man page); remove unnecessary "rm -f pbmtog3"
424- delete redundant ( cd tools; make ... )
425
426* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
427- translations modified for de, fr, tr
428
429* Fri Apr 10 1998 Cristian Gafton <gafton@redhat.com>
430- updated to 1.1.14
431- AutoPPP patch
432 
433* Thu Dec 18 1997 Mike Wangsmo <wanger@redhat.com>
434- added more of the documentation files to the rpm
435
436* Wed Oct 29 1997 Otto Hammersmith <otto@redhat.com>
437- added install-info support
438
439* Tue Oct 21 1997 Otto Hammersmith <otto@redhat.com>
440- updated version
441
442* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
443- now requires libgr-progs instead of netpbm
444
445* Mon Aug 25 1997 Erik Troan <ewt@redhat.com>
446- built against glibc
Note: See TracBrowser for help on using the repository browser.