source: projects/specs/trunk/m/metacity/metacity-vl.spec @ 623

Revision 623, 12.7 KB checked in by Takemikaduchi, 14 years ago (diff)

takemikaduchi fix and add spec file

Line 
1%define gettext_package metacity
2
3Summary: Metacity window manager
4Summary(ja): Metacity ウインドウマネージャ
5Name: metacity
6Version: 2.28.1
7Release: 1%{?_dist_release}
8URL: http://ftp.gnome.org/pub/gnome/sources/metacity/
9License: GPL
10Group: User Interface/Desktops
11
12Source0: %{name}-%{version}.tar.bz2
13Source10: metacity-theme-oldvine-2.0.tar.bz2
14Source20: metacity-theme-vine-5.0.tar.bz2
15
16# change default theme to Vine
17Patch0: metacity-2.26.0-default-theme.patch
18# ctrl-alt-del call logout session
19Patch1: metacity-2.26.0-ctrlaltdel.patch
20# change default number of workspace
21Patch2: metacity-2.26.0-num_workspace.patch
22# http://bugzilla.gnome.org/show_bug.cgi?id=558723
23Patch4: stop-spamming-xsession-errors.patch
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: gtk2-devel >= 2.14
27BuildRequires: pango-devel >= 1.22.0
28BuildRequires: GConf2-devel >= 2.24.0
29BuildRequires: desktop-file-utils >= 0.3
30BuildRequires: intltool >= 0.22
31BuildRequires: startup-notification-devel >= 0.7
32BuildRequires: libtool, automake, autoconf
33BuildRequires: xorg-x11-proto-devel
34BuildRequires: libSM-devel, libICE-devel, libX11-devel
35BuildRequires: libXext-devel, libXinerama-devel, libXrandr-devel
36BuildRequires: libXcursor-devel, libXrender-devel
37BuildRequires: libXcomposite-devel, libXdamage-devel
38BuildRequires: zenity
39BuildRequires: libcanberra-devel
40BuildRequires: libgtop2-devel
41BuildRequires: gnome-doc-utils
42Requires(post): GConf2
43
44%description
45Metacity is a simple window manager that integrates nicely with
46the GNOME desktop.
47
48%package devel
49Summary: Development files for metacity
50Group: Development/Libraries
51Requires: gtk2-devel, libX11-devel
52Requires: pkgconfig
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56This package contains the files needed for compiling programs using
57the metacity-private library. Note that you are not supposed to write
58programs using the metacity-private library, since it is a private
59API. This package exists purely for technical reasons.
60
61%prep
62%setup -q
63
64%patch0 -p1 -b .default-theme
65%patch1 -p1 -b .ctrlaltdel
66%patch2 -p1 -b .num_workspace
67%patch4 -p1 -b .stop-spamming-xsession-errors
68
69%build
70intltoolize --copy --force
71libtoolize --copy --force
72autoreconf
73%configure
74%__make %{?_smp_mflags} INTLTOOL_MERGE=/usr/bin/intltool-merge
75
76%install
77rm -rf $RPM_BUILD_ROOT
78
79export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
80make install DESTDIR=$RPM_BUILD_ROOT
81unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
82
83/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
84/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
85
86# install Vine Theme (New default theme)
87tar xzvf %{SOURCE10} -C $RPM_BUILD_ROOT%{_datadir}/themes
88# install NeoVine Theme
89tar xzvf %{SOURCE20} -C $RPM_BUILD_ROOT%{_datadir}/themes
90
91%find_lang %{gettext_package}
92
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%post
97export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
98SCHEMAS="metacity.schemas"
99for S in $SCHEMAS; do
100  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null
101done
102
103%files -f %{gettext_package}.lang
104%defattr(-,root,root)
105%doc README AUTHORS COPYING NEWS HACKING doc/theme-format.txt doc/metacity-theme.dtd
106%{_bindir}/metacity
107%{_bindir}/metacity-message
108#{_libexecdir}/*
109%{_sysconfdir}/gconf/schemas/*.schemas
110%{_datadir}/metacity
111%{_datadir}/themes
112%{_libdir}/lib*.so.*
113%{_mandir}/man1/metacity.1.gz
114%{_mandir}/man1/metacity-message.1.gz
115%{_datadir}/gnome-control-center/keybindings/*
116%{_datadir}/applications/metacity.desktop
117%{_datadir}/gnome/wm-properties/metacity-wm.desktop
118%{_datadir}/gnome/help/creating-metacity-themes
119
120%files devel
121%defattr(-,root,root)
122%{_bindir}/metacity-theme-viewer
123%{_bindir}/metacity-window-demo
124%{_includedir}/*
125%{_libdir}/lib*.so
126%{_libdir}/pkgconfig/*
127%{_mandir}/man1/metacity-theme-viewer.1.gz
128%{_mandir}/man1/metacity-window-demo.1.gz
129
130%changelog
131* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
132- new upstream release
133- add BuildRequires: gnome-doc-utils
134
135* Mon Nov 02 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.28.0-2
136- add BR: libgtop2-devel
137
138* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
139- new upstream release
140- dropped Patch5, 6 and 7 (merged into upstream)
141- removed BR: libglade2-devel
142
143* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.0-4
144- added BuildRequires: zenity, libcanberra-devel
145
146* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
147- Patch4: don't spam .xsession-errors so hard
148- Patch5: use libcanberra to play the alert sound
149- Patch6: don't force bell
150- Patch7: fix interaction with autohide panels
151
152* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
153- update Patch0,1,2
154  - apply patches to ".in.in" insread of ".in"
155
156* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
157- new upstream release
158- split development file to -devel subpackage
159  - remove static libs
160
161* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
162- new upstream release
163
164* Fri May 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-2
165- rebuild to fix strange color problem.
166
167* Tue Mar 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
168- new upstream release
169
170* Wed Dec 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
171- new upstream release
172- added Requires(post): GConf2
173
174* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl1
175- new upstream release
176
177* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.13-0vl1
178- new upstream release
179
180* Mon Jun 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.5-0vl1
181- new upstream release
182
183* Sun Apr 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
184- new upstream release
185- remove Patch20 which is merged in upstream
186- include ClearVine theme as default theme.
187
188* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
189- new upstream release
190
191* Fri Apr 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
192- add Patch20 to make configurable new window focus (bug 326159)
193
194* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
195- new upstream release
196
197* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.144-0vl1
198- new upstream release
199
200* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
201- new upstream release
202
203* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
204- new upstream release
205
206* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
207- new upstream release
208
209* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.2-0vl1
210- new upstream release
211
212* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.1-0vl1
213- new upstream release
214
215* Sun Jul 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
216- new upstream release
217
218* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
219- new upstream version
220- include Vine metacity theme as default theme.
221- update Patch0 to change deafult theme.
222
223* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.0-0vl2
224- update NeoVine metacity theme.
225
226* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.0-0vl1
227- new upstream release
228
229* Wed Nov 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
230- new upstream release
231
232* Sun Jun 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
233- new upstream release
234- add BuildRequires: libtoo,automake14, autoconf
235
236* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.6.3-0vl1
237- new upstream release
238- build with new toolchain
239
240* Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
241- new upstream release
242
243* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
244- new upstream release
245
246* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-0vl2
247- fixed missing locale files
248
249* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-0vl1
250- new upstream release
251
252* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl2
253- add patch10 to increase workspaces (4->6).
254
255* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl1
256- new upstream release
257
258* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.3-0vl1
259- new upstream release
260
261* Mon Jun 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2-0vl2
262- update ja.po
263- update NeoVine theme
264
265* Sat May 31 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2-0vl1
266- new upstream release
267
268* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.34-0vl1
269- fixed typo
270- NeoVine Metatheme moved to gnome-themes package.
271
272* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.34-0vl1
273- new upstream release
274- add patch2 from rawhide.
275- drop patch1, merged in upstream.
276
277* Fri Jan 31 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.21-0vl2
278- add Patch1 to fix hang on all 64-bit platforms
279
280* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.21-0vl1
281- new upstream release
282
283* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.13-0vl3
284- update NeoVine metatheme (use gnome default icons)
285
286* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.13-0vl2
287- update neovine theme
288
289* Sat Jan 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.13-0vl1
290- new upstream release
291
292* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl6
293- drop patch0 to use system fonts.
294
295* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl6
296- update ja.po
297
298* Fri Dec 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl5
299- fixed NeoVine theme
300
301* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl4
302- add NeoVine theme ported from sawfish.
303- use neoVine as default theme. (Patch0)
304
305* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl3
306- change URL
307- add BuildRequires
308
309* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl2
310- add include files
311
312* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
313- build for Vine Linux
314- new upstream release from gnome-2.1.4
315
316* Tue Oct 29 2002 Havoc Pennington <hp@redhat.com>
317- 2.4.3
318- remove patches that have gone upstream
319
320* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
321- fix shaded window decorations in Bluecurve theme
322
323* Sat Aug 24 2002 Havoc Pennington <hp@redhat.com>
324- fix the mplayer-disappears-on-de-fullscreen bug
325
326* Sat Aug 24 2002 Havoc Pennington <hp@redhat.com>
327- add some fixes from CVS for #71163 #72379 #72478 #72513
328
329* Thu Aug 22 2002 Havoc Pennington <hp@redhat.com>
330- patch .schemas.in instead of .schemas so we get right default theme/fonts
331
332* Tue Aug 20 2002 Havoc Pennington <hp@redhat.com>
333- grow size of top resize, and display proper cursor on enter notify
334- require latest intltool to try and fix metacity.schemas by
335  regenerating it in non-UTF-8 locale
336
337* Thu Aug 15 2002 Havoc Pennington <hp@redhat.com>
338- default to Sans Bold font, fixes #70920 and matches graphic design spec
339
340* Thu Aug 15 2002 Havoc Pennington <hp@redhat.com>
341- 2.4.0.91 with raise/lower keybindings for msf, fixes to fullscreen
342- more apps that probably intend to be, fix for changing number of
343  workspaces, fix for moving windows in multihead
344
345* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
346- update build requires
347
348* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
349- upgrade to cvs snap 2.4.0.90 with pile of bugfixes from
350  this weekend
351- change default theme to bluecurve and require new redhat-artwork
352
353* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
354- 2.4.0
355- themes are moved, require appropriate redhat-artwork
356
357* Thu Aug  1 2002 Havoc Pennington <hp@redhat.com>
358- munge the desktop file to be in toplevel menus and
359  not show in KDE
360
361* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
362- don't use system font by default as metacity's
363  font is now in the system font dialog
364
365* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
366- 2.3.987.92 cvs snap
367
368* Fri Jul 12 2002 Havoc Pennington <hp@redhat.com>
369- 2.3.987.91 cvs snap
370
371* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
372- 2.3.987.90 cvs snap
373
374* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
375- automated rebuild
376
377* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
378- rebuild for new libraries
379
380* Mon Jun 10 2002 Havoc Pennington <hp@redhat.com>
381- rebuild in different environment
382
383* Mon Jun 10 2002 Havoc Pennington <hp@redhat.com>
384- 2.3.987
385- default to redhat theme
386
387* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
388- rebuild in different environment
389
390* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
391- 2.3.610.90 cvs snap
392
393* Sun May 26 2002 Tim Powers <timp@redhat.com>
394- automated rebuild
395
396* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
397- rebuild in different environment
398
399* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
400- 2.3.377
401
402* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
403- 2.3.233
404
405* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
406- rebuild in different environment
407- add gconf schemas boilerplate
408
409* Mon Apr 15 2002 Havoc Pennington <hp@pobox.com>
410- 2.3.89
411
412* Tue Oct 30 2001 Havoc Pennington <hp@redhat.com>
413- 2.3.34
414
415* Fri Oct 13 2001 Havoc Pennington <hp@redhat.com>
416- 2.3.21
417
418* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
419- 2.3.8
420- 2.3.13
421
422* Wed Sep  5 2001 Havoc Pennington <hp@redhat.com>
423- Initial build.
424
425
Note: See TracBrowser for help on using the repository browser.