source: projects/specs/trunk/m/metacity/metacity-vl.spec @ 6890

Revision 6890, 15.3 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1%define gettext_package metacity
2
3Summary: Metacity window manager
4Summary(ja): Metacity ウインドウマネージャ
5Name: metacity
6Version: 2.34.8
7Release: 1%{?_dist_release}
8URL: http://ftp.gnome.org/pub/gnome/sources/metacity/
9License: GPL
10Group: User Interface/Desktops
11
12Source0: http://ftp.gnome.org/pub/GNOME/sources/metacity/2.34/%{name}-%{version}.tar.xz
13Source10: metacity-theme-vine-7.tar.xz
14
15# update ja.po from git
16# http://git.gnome.org/browse/metacity/commit/?id=8c407025fb3c83262c17bbb28fe175a416fb29ab
17Source20: metacity-2.34.0-ja.po
18
19# change default theme to Vine
20Patch0: metacity-2.34.0-default-theme.patch
21# ctrl-alt-del call logout session
22Patch1: metacity-2.26.0-ctrlaltdel.patch
23# change default number of workspace
24# Patch2: metacity-2.26.0-num_workspace.patch
25# http://bugzilla.gnome.org/show_bug.cgi?id=558723
26Patch4: stop-spamming-xsession-errors.patch
27# enable compositing_manager
28Patch10: metacity-2.30.3-enable-compositing-manager.patch
29# change deafult (revert to 2.30 default)
30Patch11: metacity-2.34.0-revert-default-setting.patch
31
32# revert patch to work with compiz
33# http://git.gnome.org/browse/metacity/commit/?id=6a52883c2b670ad645257373515d1e704408b93d
34Patch20: metacity-2.34.0-revert-6a5288.patch
35
36BuildRoot: %{_tmppath}/%{name}-%{version}-root
37BuildRequires: gtk2-devel >= 2.20
38BuildRequires: pango-devel >= 1.28.0
39BuildRequires: pangox-compat-devel
40BuildRequires: desktop-file-utils >= 0.3
41BuildRequires: intltool >= 0.22
42BuildRequires: startup-notification-devel >= 0.7
43BuildRequires: libtool, automake, autoconf
44BuildRequires: xorg-x11-proto-devel
45BuildRequires: libSM-devel, libICE-devel, libX11-devel
46BuildRequires: libXext-devel, libXinerama-devel, libXrandr-devel
47BuildRequires: libXcursor-devel, libXrender-devel
48BuildRequires: libXcomposite-devel, libXdamage-devel
49BuildRequires: zenity
50BuildRequires: libcanberra-devel
51BuildRequires: libgtop2-devel
52BuildRequires: gsettings-desktop-schemas-devel >= 3.3.0
53BuildRequires: yelp-tools
54
55Vendor: Project Vine
56Distribution: Vine Linux
57Packager: daisuke
58
59%description
60Metacity is a simple window manager that integrates nicely with
61the GNOME desktop.
62
63%package devel
64Summary: Development files for metacity
65Group: Development/Libraries
66Requires: gtk2-devel, libX11-devel
67Requires: pkgconfig
68Requires: %{name} = %{version}-%{release}
69
70%description devel
71This package contains the files needed for compiling programs using
72the metacity-private library. Note that you are not supposed to write
73programs using the metacity-private library, since it is a private
74API. This package exists purely for technical reasons.
75
76%prep
77%setup -q
78
79# %patch0 -p1 -b .default-theme
80# %patch1 -p1 -b .ctrlaltdel
81# patch2 -p1 -b .num_workspace
82%patch4 -p1 -b .stop-spamming-xsession-errors
83# %patch10 -p1 -b .enable-compositing-manager
84# %patch11 -p1 -b .revert-default-settings
85
86%patch20 -p1 -b .revert-6a5288
87
88cp -a %{SOURCE20} po/ja.po
89
90%build
91intltoolize --copy --force
92libtoolize --copy --force
93autoreconf
94%configure
95%__make %{?_smp_mflags} INTLTOOL_MERGE=/usr/bin/intltool-merge
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
101make install DESTDIR=$RPM_BUILD_ROOT
102unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
103
104/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
105/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
106
107# install Vine Theme (default theme)
108tar xJvf %{SOURCE10} -C $RPM_BUILD_ROOT%{_datadir}/themes
109
110%find_lang %{gettext_package}
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115
116%postun
117if [ $1 -eq 0 ]; then
118  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
119fi
120
121%posttrans
122glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
123
124
125%files -f %{gettext_package}.lang
126%defattr(-,root,root)
127%doc README AUTHORS COPYING NEWS HACKING doc/theme-format.txt doc/metacity-theme.dtd
128%{_bindir}/metacity
129%{_bindir}/metacity-message
130#{_libexecdir}/*
131%{_datadir}/metacity
132%{_datadir}/themes
133%{_libdir}/lib*.so.*
134%{_mandir}/man1/metacity.1.gz
135%{_mandir}/man1/metacity-message.1.gz
136%{_datadir}/GConf/gsettings/metacity-schemas.convert
137%{_datadir}/glib-2.0/schemas/org.gnome.metacity.gschema.xml
138%{_datadir}/gnome-control-center/keybindings/*
139%{_datadir}/applications/metacity.desktop
140%{_datadir}/gnome/wm-properties/metacity-wm.desktop
141%{_datadir}/help/*/*/*
142
143%files devel
144%defattr(-,root,root)
145%{_bindir}/metacity-theme-viewer
146%{_bindir}/metacity-window-demo
147%{_includedir}/*
148%{_libdir}/lib*.so
149%{_libdir}/pkgconfig/*
150%{_mandir}/man1/metacity-theme-viewer.1.gz
151%{_mandir}/man1/metacity-window-demo.1.gz
152
153%changelog
154* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.8-1
155- new upstream release
156- change BuildRequires: yelp-tools instead of gnome-doc-utils
157- add BuildRequires: pangox-compat-devel
158
159* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.5-1
160- new upstream release
161
162* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.3-2
163- update Source10 (metacity-theme-vine-7.tar.xz)
164
165* Sat Apr 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.3-1
166- new upstream release
167- drop Patch0,1,10,11
168- remove BuildRequires: GConf2-devel
169- remove Requires: GConf2
170- BuildRequires: gsettings-desktop-schemas-devel
171
172* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
173- new upstream release
174
175* Tue Aug 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.34.0-5
176- fix Vine theme to use fixed size window buttons.
177  - some fonts breaks window title design..
178
179* Wed Jun 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.34.0-4
180- update metacity theme
181
182* Sun Jun 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.34.0-3
183- add patch20 (revert patch)
184  - this commit breaks compiz window decoration.
185
186* Sun Jun 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.34.0-2
187- update ja.po from git
188
189* Sat Jun 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.34.0-1
190- update to 2.34.0
191- add patch11 to revert default settings
192  - default title font to Sans Bold 10
193  - add icon menu on titlebar
194- disable patch2 to change workspace num to 4 (factory default).
195
196* Sat Jun 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.3-3
197- update metacity theme
198
199* Wed Jun 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.3-2
200- update metacity theme
201- drop old old theme
202- add patch10 to enable compositing_manager by default
203
204* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
205- new upstream release
206
207* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
208- rebuild with rpm-4.8.1 for pkg-config file
209- add BuildRequires: gnome-doc-utils
210
211* Fri Apr 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-1
212- updated metacity to 2.30.1
213  - fixed crash when right-clicking on window frame
214
215* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
216- new upstream release
217
218* Mon Nov 02 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.28.0-2
219- add BR: libgtop2-devel
220
221* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
222- new upstream release
223- dropped Patch5, 6 and 7 (merged into upstream)
224- removed BR: libglade2-devel
225
226* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.0-4
227- added BuildRequires: zenity, libcanberra-devel
228
229* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
230- Patch4: don't spam .xsession-errors so hard
231- Patch5: use libcanberra to play the alert sound
232- Patch6: don't force bell
233- Patch7: fix interaction with autohide panels
234
235* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
236- update Patch0,1,2
237  - apply patches to ".in.in" insread of ".in"
238
239* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
240- new upstream release
241- split development file to -devel subpackage
242  - remove static libs
243
244* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
245- new upstream release
246
247* Fri May 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-2
248- rebuild to fix strange color problem.
249
250* Tue Mar 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
251- new upstream release
252
253* Wed Dec 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
254- new upstream release
255- added Requires(post): GConf2
256
257* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl1
258- new upstream release
259
260* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.13-0vl1
261- new upstream release
262
263* Mon Jun 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.5-0vl1
264- new upstream release
265
266* Sun Apr 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
267- new upstream release
268- remove Patch20 which is merged in upstream
269- include ClearVine theme as default theme.
270
271* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
272- new upstream release
273
274* Fri Apr 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
275- add Patch20 to make configurable new window focus (bug 326159)
276
277* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
278- new upstream release
279
280* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.144-0vl1
281- new upstream release
282
283* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
284- new upstream release
285
286* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
287- new upstream release
288
289* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
290- new upstream release
291
292* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.2-0vl1
293- new upstream release
294
295* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.1-0vl1
296- new upstream release
297
298* Sun Jul 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
299- new upstream release
300
301* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
302- new upstream version
303- include Vine metacity theme as default theme.
304- update Patch0 to change deafult theme.
305
306* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.0-0vl2
307- update NeoVine metacity theme.
308
309* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.0-0vl1
310- new upstream release
311
312* Wed Nov 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
313- new upstream release
314
315* Sun Jun 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
316- new upstream release
317- add BuildRequires: libtoo,automake14, autoconf
318
319* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.6.3-0vl1
320- new upstream release
321- build with new toolchain
322
323* Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
324- new upstream release
325
326* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
327- new upstream release
328
329* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-0vl2
330- fixed missing locale files
331
332* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-0vl1
333- new upstream release
334
335* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl2
336- add patch10 to increase workspaces (4->6).
337
338* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl1
339- new upstream release
340
341* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.3-0vl1
342- new upstream release
343
344* Mon Jun 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2-0vl2
345- update ja.po
346- update NeoVine theme
347
348* Sat May 31 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2-0vl1
349- new upstream release
350
351* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.34-0vl1
352- fixed typo
353- NeoVine Metatheme moved to gnome-themes package.
354
355* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.34-0vl1
356- new upstream release
357- add patch2 from rawhide.
358- drop patch1, merged in upstream.
359
360* Fri Jan 31 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.21-0vl2
361- add Patch1 to fix hang on all 64-bit platforms
362
363* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.21-0vl1
364- new upstream release
365
366* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.13-0vl3
367- update NeoVine metatheme (use gnome default icons)
368
369* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.13-0vl2
370- update neovine theme
371
372* Sat Jan 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.13-0vl1
373- new upstream release
374
375* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl6
376- drop patch0 to use system fonts.
377
378* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl6
379- update ja.po
380
381* Fri Dec 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl5
382- fixed NeoVine theme
383
384* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl4
385- add NeoVine theme ported from sawfish.
386- use neoVine as default theme. (Patch0)
387
388* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl3
389- change URL
390- add BuildRequires
391
392* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl2
393- add include files
394
395* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
396- build for Vine Linux
397- new upstream release from gnome-2.1.4
398
399* Tue Oct 29 2002 Havoc Pennington <hp@redhat.com>
400- 2.4.3
401- remove patches that have gone upstream
402
403* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
404- fix shaded window decorations in Bluecurve theme
405
406* Sat Aug 24 2002 Havoc Pennington <hp@redhat.com>
407- fix the mplayer-disappears-on-de-fullscreen bug
408
409* Sat Aug 24 2002 Havoc Pennington <hp@redhat.com>
410- add some fixes from CVS for #71163 #72379 #72478 #72513
411
412* Thu Aug 22 2002 Havoc Pennington <hp@redhat.com>
413- patch .schemas.in instead of .schemas so we get right default theme/fonts
414
415* Tue Aug 20 2002 Havoc Pennington <hp@redhat.com>
416- grow size of top resize, and display proper cursor on enter notify
417- require latest intltool to try and fix metacity.schemas by
418  regenerating it in non-UTF-8 locale
419
420* Thu Aug 15 2002 Havoc Pennington <hp@redhat.com>
421- default to Sans Bold font, fixes #70920 and matches graphic design spec
422
423* Thu Aug 15 2002 Havoc Pennington <hp@redhat.com>
424- 2.4.0.91 with raise/lower keybindings for msf, fixes to fullscreen
425- more apps that probably intend to be, fix for changing number of
426  workspaces, fix for moving windows in multihead
427
428* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
429- update build requires
430
431* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
432- upgrade to cvs snap 2.4.0.90 with pile of bugfixes from
433  this weekend
434- change default theme to bluecurve and require new redhat-artwork
435
436* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
437- 2.4.0
438- themes are moved, require appropriate redhat-artwork
439
440* Thu Aug  1 2002 Havoc Pennington <hp@redhat.com>
441- munge the desktop file to be in toplevel menus and
442  not show in KDE
443
444* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
445- don't use system font by default as metacity's
446  font is now in the system font dialog
447
448* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
449- 2.3.987.92 cvs snap
450
451* Fri Jul 12 2002 Havoc Pennington <hp@redhat.com>
452- 2.3.987.91 cvs snap
453
454* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
455- 2.3.987.90 cvs snap
456
457* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
458- automated rebuild
459
460* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
461- rebuild for new libraries
462
463* Mon Jun 10 2002 Havoc Pennington <hp@redhat.com>
464- rebuild in different environment
465
466* Mon Jun 10 2002 Havoc Pennington <hp@redhat.com>
467- 2.3.987
468- default to redhat theme
469
470* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
471- rebuild in different environment
472
473* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
474- 2.3.610.90 cvs snap
475
476* Sun May 26 2002 Tim Powers <timp@redhat.com>
477- automated rebuild
478
479* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
480- rebuild in different environment
481
482* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
483- 2.3.377
484
485* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
486- 2.3.233
487
488* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
489- rebuild in different environment
490- add gconf schemas boilerplate
491
492* Mon Apr 15 2002 Havoc Pennington <hp@pobox.com>
493- 2.3.89
494
495* Tue Oct 30 2001 Havoc Pennington <hp@redhat.com>
496- 2.3.34
497
498* Fri Oct 13 2001 Havoc Pennington <hp@redhat.com>
499- 2.3.21
500
501* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
502- 2.3.8
503- 2.3.13
504
505* Wed Sep  5 2001 Havoc Pennington <hp@redhat.com>
506- Initial build.
507
508
Note: See TracBrowser for help on using the repository browser.