source: projects/specs/trunk/m/memtest86+/memtest86+-vl.spec @ 521

Revision 521, 5.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Prevent stripping
2%define __spec_install_post /usr/lib/rpm/brp-compress
3# Turn off debuginfo package
4%define debug_package %{nil}
5
6Summary: Stand-alone memory tester for x86 and x86-64 computers
7Summary(ja): x86 および x86_64 用のスタンドアロンメモリ検査ツール
8Name: memtest86+
9Version: 2.11
10Release: 1%{?_dist_release}
11License: GPL
12ExclusiveArch: %{ix86} x86_64
13Group: System Environment/Base
14Source0: http://www.memtest.org/download/1.20/memtest86+-%{version}.tar.gz
15URL: http://www.memtest.org
16Source1: new-memtest-pkg
17Source2: memtest-setup
18Requires(preun): coreutils
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
20Obsoletes: memtest86
21
22
23%description
24Memtest86+ is a thorough stand-alone memory test for x86 and x86-64
25architecture computers. BIOS based memory tests are only a quick
26check and often miss many of the failures that are detected by
27Memtest86+.
28
29Run 'memtest-setup' to add to your GRUB or lilo boot menu.
30
31%prep
32%setup -q
33
34%build
35# Regular build flags not wanted for this binary
36# Note: i486 minimum runtime arch
37make
38
39%install
40rm -rf $RPM_BUILD_ROOT
41mkdir -p $RPM_BUILD_ROOT/boot
42mkdir -p $RPM_BUILD_ROOT/sbin
43mkdir -p $RPM_BUILD_ROOT%{_sbindir}
44
45install -m644 memtest.bin $RPM_BUILD_ROOT/boot/memtest86+-%{version}
46install -m755 %{SOURCE1} $RPM_BUILD_ROOT/sbin/new-memtest-pkg
47install -m755 %{SOURCE2} $RPM_BUILD_ROOT%{_sbindir}/memtest-setup
48
49%clean
50rm -rf $RPM_BUILD_ROOT
51
52%files
53%defattr(-,root,root,-)
54%doc README
55/boot/memtest86+-%{version}
56/sbin/new-memtest-pkg
57%{_sbindir}/memtest-setup
58
59%preun
60/sbin/new-memtest-pkg --remove %{version}
61
62%changelog
63* Sat May 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11-1
64- new upstream release
65
66* Mon Sep 08 2008 Shu KONNO <owa@bg.wakwak.com> 1.65-1vl5
67- applied new versioning policy, spec in utf-8
68
69* Fri Aug 18 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.65-0vl1
70- initial build for Vine Linux
71
72* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.65-4.1
73- rebuild
74
75* Tue Jun 27 2006 Florian La Roche <laroche@redhat.com> - 1.65-4
76- make sure coreutils is installed for the preun script
77
78* Thu Jun 08 2006 Jesse Keating <jkeating@redhat.com> - 1.65-3
79- rebuilt for new buildsystem
80
81* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.65-2.2
82- rebuilt for new gcc4.1 snapshot and glibc changes
83
84* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
85- rebuilt
86
87* Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
88- make sure 32bit glibc-devel is installed (#170614)
89
90* Sat Oct 01 2005 Warren Togami <wtogami@redhat.com> - 1.65-1
91- 1.65
92
93* Wed Jun 29 2005 Warren Togami <wtogami@redhat.com> - 1.60-1
94- 1.60
95
96* Mon Mar 28 2005 Warren Togami <wtogami@redhat.com> - 1.55.1-1
97- 1.55.1 fixes K8
98
99* Sun Mar 27 2005 Warren Togami <wtogami@redhat.com> - 1.55-1
100- 1.55
101
102* Wed Mar 16 2005 Elliot Lee <sopwith@redhat.com>
103- rebuilt
104
105* Sat Feb 19 2005 Warren Togami <wtogami@redhat.com> - 1.51-1
106- 1.51
107
108* Fri Jan 21 2005 Warren Togami <wtogami@redhat.com> - 1.50-1
109- 1.50
110
111* Sun Nov 28 2004 Warren Togami <wtogami@redhat.com> - 1.40-1
112- 1.40
113- remove arch patch, now upstream
114
115* Tue Oct 26 2004 Warren Togami <wtogami@redhat.com> - 1.27-1
116- 1.27
117
118* Mon Oct 25 2004 Jeremy Katz <katzj@redhat.com> - 1.26-3
119- allow building on all x86 arches
120- pass appropriate compiler options to build on x86_64 as well (#136939)
121
122* Wed Sep 02 2004 Warren Togami <wtogami@redhat.com> 1.26-1
123- update to 1.26
124
125* Sat Aug 28 2004 Warren Togami <wtogami@redhat.com> 1.25-1
126- update to 1.25
127
128* Mon Jun 28 2004 Warren Togami <wtogami@redhat.com>
129- update to 1.20
130
131* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
132- rebuilt
133
134* Sun May 16 2004 Warren Togami <wtogami@redhat.com> 1.15-1
135- update to 1.15
136
137* Sun Feb 29 2004 Warren Togami <wtogami@redhat.com> 1.11-2
138- switch to memtest86+ 1.11
139- add boot loader setup script
140
141* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
142- rebuilt
143
144* Tue Oct 21 2003 Mike A. Harris <mharris@redhat.com> 3.0-3
145- Pedantic spec file cleanups - s/Copyright/License/ and use _libdir instead of
146  /usr/lib everywhere (even though it's currently x86 only)
147
148* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 3.0-2
149- fix perms (#107610)
150- doesn't really require dev86 to build
151
152* Thu Jul 21 2003 Michael Fulbright <msf@redhat.com>
153- initial integration into distribution. Removed the scripts to install a
154  entry in the boot loader for memtest for the moment, and relocated to under
155  /usr/lib.
156
157* Thu Apr 17 2003 Joe Szep <jszep@bu.edu>
158- rebuilt for Doolittle final
159
160* Mon Feb  3 2003 Matthew Miller <mattdm@bu.edu>
161- rebuild for doolittle
162- patches to make build -- new gcc growing pains, I guess
163
164* Tue Jul 30 2002 Matthew Miller <mattdm@bu.edu>
165- added grubby stuff
166
167* Tue Jul 30 2002 Dave Heistand <davidbh@bu.edu>
168- updated source to v 3
169
170* Thu Mar 7 2002 Dave Heistand <davidbh@bu.edu>
171- updated source to 2.9, also changed setup -n
172- to use %{version}.
173
174* Thu Nov  1 2001 Matthew Miller <mattdm@bu.edu>
175- v 2.8a
176- removed lilo-configuring scripts. need to figure out the best way to
177  work with grub and RH 7.2 / BU Linux 2.5
178- group -> System Environment/Base
179
180* Mon Aug 20 2001 Matthew Miller <mattdm@bu.edu>
181- v 2.7
182
183* Wed Feb 14 2001 Matthew Miller <mattdm@bu.edu>
184- v 2.5
185
186* Fri Oct 06 2000 Matthew Miller <mattdm@bu.edu>
187- v 2.4
188
189* Thu Mar 23 2000 Matthew Miller <mattdm@bu.edu>
190- changed so that lilo.conf isn't written if it already exists. This is
191  important if you're including memtest86 in a distribution
192- GPG key available from http://www.bu.edu/dsgsupport/linux/BULinux-GPG-KEY 
193- changed name of lilo.conf backup file to something less likely to conflict
194  with other backups
195
196* Wed Mar 01 2000 Matthew Miller <mattdm@bu.edu>
197- Updated to version 2.2
198- Cosmetic changes to spec file
199- updated Source: to reflect actual author's url
200
201* Fri Dec 25 1998 Peter Soos <sp@osb.hu>
202
203- Corrected the file attributes
204
205* Mon Aug 17 1998 Peter Soos <sp@osb.hu>
206
207- Moved to 1.4a
208
209* Mon Jun 22 1998 Peter Soos <sp@osb.hu>
210
211- Moved to 1.4
212
213* Wed Dec 31 1997 Peter Soos <sp@osb.hu>
214
215- Initial version
Note: See TracBrowser for help on using the repository browser.