source: projects/specs/trunk/m/mcomix/mcomix-vl.spec @ 5408

Revision 5408, 3.8 KB checked in by kudoh, 12 years ago (diff)

mcomix-vl.spec

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Summary:        customizable image viewer that specifically designed to handle comic books
4Summary(ja):    漫画向けに特化してデザインされたカスタム可能なイメージビューワ
5Name:           mcomix
6Version:        0.96
7Release:        2%{?_dist_release}
8Source0:        mcomix-%{version}.tar.bz2
9Source1:        mcomix_ja.po
10
11License:        GPLv2
12Group:          Applications/Graphics
13URL:            http://mcomix.sourceforge.net/
14
15Requires:       pygtk2 >= 2.12, python-imaging >= 1.1.5, libjpeg-turbo
16Requires:       python >= 2.5
17Requires:       python-chardet
18Requires:       python-setuptools
19
20BuildRequires:  python  >= 2.5
21BuildRequires:  python-devel
22BuildRequires:  python-setuptools
23BuildRequires:  pygtk2-devel python-imaging
24BuildRequires:  gettext
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildArch: noarch
27
28Vendor: Project Vine
29Distribution: Vine Linux
30Packager: kudoh
31
32%description
33MComix is a user-friendly, customizable image viewer. It is specifically
34designed to handle comic books, but also serves as a generic viewer. It
35reads images in ZIP, RAR or tar archives as well as plain image files.
36It is written in Python and uses GTK+ through the PyGTK bindings.
37
38%description -l ja
39MComix はユーザーフレンドリでカスタマイズ可能なイメージビューワです。
40このビューワは漫画を読むのに特化してデザインされていますが、一般的な画像
41ビューワとしても利用できます。
42通常のイメージファイルと同様に、ZIP、RAR または tar (gzip 及び bzip2 で圧縮
43されたものも含む) アーカイブ中のイメージも読み込めます。
44Python で書かれており、PyGTK バインディングを通じて GTK+ を使用しています。
45
46%prep
47
48%setup -qn mcomix-%{version}
49%{__cp} -f %{SOURCE1} mcomix/messages/ja/LC_MESSAGES/mcomix.po
50msgfmt -o mcomix/messages/ja/LC_MESSAGES/mcomix.mo mcomix/messages/ja/LC_MESSAGES/mcomix.po
51
52%install
53%{__rm} -rf ${RPM_BUILD_ROOT}
54
55%{__python} setup.py install --single-version-externally-managed --root=$RPM_BUILD_ROOT
56
57%clean
58%{__rm} -rf ${RPM_BUILD_ROOT}
59
60%post
61touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
62
63
64%postun
65if [ $1 -eq 0 ] ; then
66        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
67        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
68fi
69
70%posttrans
71gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
72
73
74%files
75%defattr(-,root,root)
76%doc ChangeLog README
77%{_bindir}/%{name}
78%{_datadir}/applications/%{name}.desktop
79%{_datadir}/icons/hicolor/
80%{_datadir}/mime/packages/%{name}.xml
81%{_mandir}/man1/*.1.gz
82%{python_sitelib}/*
83
84%changelog
85* Sat Jan 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.96-2
86- rebuilt
87  - forgot using newer spec..
88
89* Wed Jan 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.96-1
90- new upstream release
91- added BuildRequires: python-devel
92- updated source1
93
94* Wed Sep 28 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.94-1
95- new upstream release
96
97* Sat Sep 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.93-1
98- new upstream release
99- added Requires: python-chardet, python-setuptools
100- added Vendor/Distribution/Packager tag
101
102* Sun Jul 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.92-2
103- updated source1
104
105* Sat Jul 09 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.92-1
106- new upstream release
107- replaced source1
108
109* Sun May 22 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.91-2
110- added BuildRequires:  python-setuptools
111
112* Wed May 11 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.91-1
113- new upstream release
114- changed Lisence tag
115  - applied to GPLv2
116- changed URL
117- changed BuildArch to noarch
118
119* Sun Nov 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.90.2-2
120- updated source1
121- probed %%post and %%postun
122  - added %%posttrans
123
124* Sat Oct 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.90.2-1
125- initial build for VineSeed
Note: See TracBrowser for help on using the repository browser.