source: projects/specs/trunk/m/mcomix/mcomix-vl.spec @ 4746

Revision 4746, 3.5 KB checked in by kudoh, 13 years ago (diff)

%{!?python_sitelib: %define python_sitelib %(%{python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}

Summary: customizable image viewer that specifically designed to handle comic books
Summary(ja): 漫画向けに特化してデザインされたカスタム可能なイメージビューワ
Name: mcomix
Version: 0.93
Release: 1%{?_dist_release}
Source0: mcomix-%{version}.tar.bz2
Source1: mcomix_ja.po

License: GPLv2
Group: Applications/Graphics?
URL:  http://mcomix.sourceforge.net/

Requires: pygtk2 >= 2.12, python-imaging >= 1.1.5, libjpeg-turbo
Requires: python >= 2.5
Requires: python-chardet
Requires: python-setuptools

BuildRequires?: python >= 2.5
BuildRequires?: python-setuptools
BuildRequires?: pygtk2-devel python-imaging
BuildRequires?: gettext
BuildRoot?: %{_tmppath}/%{name}-%{version}-root
BuildArch?: noarch

Vendor: Project Vine
Distribution: Vine Linux
Packager: kudoh

%description
MComix is a user-friendly, customizable image viewer. It is specifically
designed to handle comic books, but also serves as a generic viewer. It
reads images in ZIP, RAR or tar archives as well as plain image files.
It is written in Python and uses GTK+ through the PyGTK bindings.

%description -l ja
MComix はユーザーフレンドリでカスタマイズ可能なイメージビューワです。
このビューワは漫画を読むのに特化してデザインされていますが、一般的な画像
ビューワとしても利用できます。
通常のイメージファイルと同様に、ZIP、RAR または tar (gzip 及び bzip2 で圧縮
されたものも含む) アーカイブ中のイメージも読み込めます。
Python で書かれており、PyGTK バインディングを通じて GTK+ を使用しています。

%prep

%setup -qn mcomix-%{version}
%{cp} -f %{SOURCE1} mcomix/messages/ja/LC_MESSAGES/mcomix.po
msgfmt -o mcomix/messages/ja/LC_MESSAGES/mcomix.mo mcomix/messages/ja/LC_MESSAGES/mcomix.po

%install
%{rm} -rf ${RPM_BUILD_ROOT}

%{python} setup.py install --single-version-externally-managed --root=$RPM_BUILD_ROOT

%clean
%{rm} -rf ${RPM_BUILD_ROOT}

%post

touch --no-create %{_datadir}/icons/hicolor &>/dev/null
:

%postun
if [ $1 -eq 0 ] ; then

touch --no-create %{_datadir}/icons/hicolor &>/dev/null

gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null
:

fi

%posttrans

gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null
:

%files
%defattr(-,root,root)
%doc ChangeLog? README
%{_bindir}/%{name}
%{_datadir}/applications/%{name}.desktop
%{_datadir}/icons/hicolor/
%{_datadir}/mime/packages/%{name}.xml
%{_mandir}/man1/*.1.gz
%{python_sitelib}/*

%changelog

  • Sat Sep 10 2011 Toshiharu Kudoh <toshi.kd2@…> 0.93-1
  • new upstream release
  • added Requires: python-chardet, python-setuptools
  • added Vendor/Distribution/Packager? tag
  • Sun Jul 10 2011 Toshiharu Kudoh <toshi.kd2@…> 0.92-2
  • updated source1
  • Sat Jul 09 2011 Toshiharu Kudoh <toshi.kd2@…> 0.92-1
  • new upstream release
  • replaced source1
  • Sun May 22 2011 Toshiharu Kudoh <toshi.kd2@…> 0.91-2
  • added BuildRequires?: python-setuptools
  • Wed May 11 2011 Toshiharu Kudoh <toshi.kd2@…> 0.91-1
  • new upstream release
  • changed Lisence tag
    • applied to GPLv2
  • changed URL
  • changed BuildArch? to noarch
  • Sun Nov 14 2010 Toshiharu Kudoh <toshi.kd2@…> 0.90.2-2
  • updated source1
  • probed %%post and %%postun
    • added %%posttrans
  • Sat Oct 30 2010 Toshiharu Kudoh <toshi.kd2@…> 0.90.2-1
  • initial build for VineSeed
Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Summary:        customizable image viewer that specifically designed to handle comic books
4Summary(ja):    漫画向けに特化してデザインされたカスタム可能なイメージビューワ
5Name:           mcomix
6Version:        0.93
7Release:        1%{?_dist_release}
8Source0:        mcomix-%{version}.tar.bz2
9Source1:        mcomix_ja.po
10
11License:        GPLv2
12Group:          Applications/Graphics
13URL:            http://mcomix.sourceforge.net/
14
15Requires:       pygtk2 >= 2.12, python-imaging >= 1.1.5, libjpeg-turbo
16Requires:       python >= 2.5
17Requires:       python-chardet
18Requires:       python-setuptools
19
20BuildRequires:  python  >= 2.5
21BuildRequires:  python-setuptools
22BuildRequires:  pygtk2-devel python-imaging
23BuildRequires:  gettext
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25BuildArch: noarch
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: kudoh
30
31%description
32MComix is a user-friendly, customizable image viewer. It is specifically
33designed to handle comic books, but also serves as a generic viewer. It
34reads images in ZIP, RAR or tar archives as well as plain image files.
35It is written in Python and uses GTK+ through the PyGTK bindings.
36
37%description -l ja
38MComix はユーザーフレンドリでカスタマイズ可能なイメージビューワです。
39このビューワは漫画を読むのに特化してデザインされていますが、一般的な画像
40ビューワとしても利用できます。
41通常のイメージファイルと同様に、ZIP、RAR または tar (gzip 及び bzip2 で圧縮
42されたものも含む) アーカイブ中のイメージも読み込めます。
43Python で書かれており、PyGTK バインディングを通じて GTK+ を使用しています。
44
45%prep
46
47%setup -qn mcomix-%{version}
48%{__cp} -f %{SOURCE1} mcomix/messages/ja/LC_MESSAGES/mcomix.po
49msgfmt -o mcomix/messages/ja/LC_MESSAGES/mcomix.mo mcomix/messages/ja/LC_MESSAGES/mcomix.po
50
51%install
52%{__rm} -rf ${RPM_BUILD_ROOT}
53
54%{__python} setup.py install --single-version-externally-managed --root=$RPM_BUILD_ROOT
55
56%clean
57%{__rm} -rf ${RPM_BUILD_ROOT}
58
59%post
60touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
61
62
63%postun
64if [ $1 -eq 0 ] ; then
65        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
66        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
67fi
68
69%posttrans
70gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
71
72
73%files
74%defattr(-,root,root)
75%doc ChangeLog README
76%{_bindir}/%{name}
77%{_datadir}/applications/%{name}.desktop
78%{_datadir}/icons/hicolor/
79%{_datadir}/mime/packages/%{name}.xml
80%{_mandir}/man1/*.1.gz
81%{python_sitelib}/*
82
83%changelog
84* Sat Sep 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.93-1
85- new upstream release
86- added Requires: python-chardet, python-setuptools
87- added Vendor/Distribution/Packager tag
88
89* Sun Jul 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.92-2
90- updated source1
91
92* Sat Jul 09 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.92-1
93- new upstream release
94- replaced source1
95
96* Sun May 22 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.91-2
97- added BuildRequires:  python-setuptools
98
99* Wed May 11 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.91-1
100- new upstream release
101- changed Lisence tag
102  - applied to GPLv2
103- changed URL
104- changed BuildArch to noarch
105
106* Sun Nov 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.90.2-2
107- updated source1
108- probed %%post and %%postun
109  - added %%posttrans
110
111* Sat Oct 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.90.2-1
112- initial build for VineSeed
Note: See TracBrowser for help on using the repository browser.