source: projects/specs/trunk/m/mcomix/mcomix-vl.spec @ 3838

Revision 3838, 2.9 KB checked in by kudoh, 13 years ago (diff)
Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Summary:        customizable image viewer that specifically designed to handle comic books
4Summary(ja):    漫画向けに特化してデザインされたカスタム可能なイメージビューワ
5Name:           mcomix
6Version:        0.91
7Release:        1%{?_dist_release}
8Source0:        mcomix-%{version}.tar.bz2
9Source1:        mcomix_ja.po
10
11License:        GPLv2
12Group:          Applications/Graphics
13URL:            http://mcomix.sourceforge.net/
14
15Requires:       pygtk2 >= 2.12, python-imaging >= 1.1.5, libjpeg-turbo
16Requires:       python >= 2.5
17
18BuildRequires:  python  >= 2.5
19BuildRequires:  pygtk2-devel python-imaging
20BuildRequires:  gettext
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildArch: noarch
23
24%description
25MComix is a user-friendly, customizable image viewer. It is specifically
26designed to handle comic books, but also serves as a generic viewer. It
27reads images in ZIP, RAR or tar archives as well as plain image files.
28It is written in Python and uses GTK+ through the PyGTK bindings.
29
30%description -l ja
31MComix はユーザーフレンドリでカスタマイズ可能なイメージビューワです。
32このビューワは漫画を読むのに特化してデザインされていますが、一般的な画像
33ビューワとしても利用できます。
34通常のイメージファイルと同様に、ZIP、RAR または tar (gzip 及び bzip2 で圧縮
35されたものも含む) アーカイブ中のイメージも読み込めます。
36Python で書かれており、PyGTK バインディングを通じて GTK+ を使用しています。
37
38%prep
39
40%setup -qn mcomix-%{version}
41%{__cp} -f %{SOURCE1} mcomix/messages/ja/LC_MESSAGES/mcomix.po
42msgfmt -o mcomix/messages/ja/LC_MESSAGES/mcomix.mo mcomix/messages/ja/LC_MESSAGES/mcomix.po
43
44%install
45%{__rm} -rf ${RPM_BUILD_ROOT}
46
47%{__python} setup.py install --single-version-externally-managed --root=$RPM_BUILD_ROOT
48
49%clean
50%{__rm} -rf ${RPM_BUILD_ROOT}
51
52%post
53touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
54
55
56%postun
57if [ $1 -eq 0 ] ; then
58        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
59        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
60fi
61
62%posttrans
63gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
64
65
66%files
67%defattr(-,root,root)
68%doc ChangeLog README
69%{_bindir}/%{name}
70%{_datadir}/applications/%{name}.desktop
71%{_datadir}/icons/hicolor/
72%{_datadir}/mime/packages/%{name}.xml
73%{_mandir}/man1/*.1.gz
74%{python_sitelib}/*
75
76%changelog
77* Wed May 11 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.91-1
78- new upstream release
79- changed Lisence tag
80  - applied to GPLv2
81- changed URL
82- changed BuildArch to noarch
83
84* Sun Nov 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.90.2-2
85- updated source1
86- probed %%post and %%postun
87  - added %%posttrans
88
89* Sat Oct 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.90.2-1
90- initial build for VineSeed
Note: See TracBrowser for help on using the repository browser.